Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/12/2020, à 15:28

tortuegonzo

[Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Bonjour smile

Je viens d'acquérir un portable CLEVO NL41LU.

Celui-ci contient déjà un windows 10 préinstallé et je souhaite supprimer complètement ce windows 10 afin d'y installer un ubuntu (20.04 dans l'idéal).

Je suis malheureusement bloqué car je n'arrive pas à démarrer sur la clé USB bootable que j'ai crée depuis un ISO (avec l'outil creator disk d'un autre ordi sur ubuntu 18.04).

J'utilise cette méthode depuis windows 10 afin de tenter un démarrage sur la clé USB : https://www.clubic.com/tutoriels/articl … e-usb.html

Au redémarrage, j'ai le message d'erreur : "system doesn't have any usb boot option"

Ce que j'ai tenté pour le moment :

- désactiver le fast boot de windows 10
- désactiver le fast boot dans le bios
- essayer de trouver comment passer en mode legacy : je ne trouve nulle part cette option
- ajouter un mot de passe super utilisateur dans le BIOS pour voir si ça change quelque chose : je n'ai rien vu


Je suis un peu perdu alors toute aide sera la bienvenue.


Merci d'avance

Dernière modification par tortuegonzo (Le 12/12/2020, à 12:59)

Hors ligne

#2 Le 11/12/2020, à 19:44

lucmars

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Ton w10 est surement en uefi, ne passe pas de suite en legacy meme si tu ne veux plus de win.

Là semble que le bios Clevo ne saurait booter sur une clef usb, mais p'tete sur un lecteur cd/dvd usb.

Cerise sur le gateau, je parie que le Clevo n'as pas de lecteur cd/dvd intégré ! Je me trompe ? Si non, passes par là.


Gaulois Matter !

Hors ligne

#3 Le 11/12/2020, à 20:21

geole

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

tortuegonzo a écrit :

Bonjour smile

Je viens d'acquérir un portable CLEVO NL41LU.
Celui-ci contient déjà un windows 10 préinstallé et je souhaite supprimer complètement ce windows 10 afin d'y installer un ubuntu (20.04 dans l'idéal).
Je suis malheureusement bloqué car je n'arrive pas à démarrer sur la clé USB bootable que j'ai crée depuis un ISO (avec l'outil creator disk d'un autre ordi sur ubuntu 18.04).

Merci d'avance

Je ne suis pas convaincu que cet outil soit parfait
Utilise un peu ton windows  pour fabriquer une clé USB à la norme EFI   en suivant cette documentation

Hors ligne

#4 Le 11/12/2020, à 20:22

DRbuntu91

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

@tortuegonzo.
Tu sembles suivre une procédure W10, ce n'est peut-être pas le plus judicieux...
Moi j'ai un CLEVO que j'ai installé moi-même en "legacy" mais il était venu sans OS
Quand j’utilise F7 avant POST j'entre dans le "boot manager" du CLEVO ou je peux définir sur quel périphérique booter.
Avec ta clef Ubuntu bootable en place au moment du boot, tu vois quoi dans le "boot manager"?


Portable CLEVO W55SU1, Intel i5-4200M, RAM=8Go, DD=500Go mSATA, BIOS 4.6.5 AMI, Ubuntu 16.04 LTS a jour
Puis pour bidouiller un vieux portable Dell Precision M4600 avec W10 + DEBIAN-Buster
Utilisateur Ubuntu depuis Janvier 2017

Hors ligne

#5 Le 12/12/2020, à 12:57

tortuegonzo

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Bonjour et merci à tous d'avoir pris le temps de répondre

geole a écrit :

Je ne suis pas convaincu que cet outil soit parfait
Utilise un peu ton windows  pour fabriquer une clé USB à la norme EFI   en suivant cette documentation

Le problème était effectivement du côté de ma clé bootable : soit l'image ISO que j'avais téléchargé n'était pas correcte (je n'avais pas validé avec un checksum...), soit le "disk creator" n'a pas donné le résultat que j'attendais.

Au final, j'ai recrée une clé bootable (UEFI) sous un windows avec Rufus.

La clé est alors apparue sans problème dans les options "Boot Loader EFI".

Voilà, désolé pour le dérangement.

J'espère que ça pourra servir à d'autres smile

Dernière modification par tortuegonzo (Le 12/12/2020, à 13:03)

Hors ligne

#6 Le 12/12/2020, à 16:17

malbo

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Bonjour,
Je ne sais pas si c'est déjà fait ou si ça reste à faire mais quand tu auras installé Ubuntu, je te prie de le signaler dans la présente discussion. Cela me permettra d'ajouter ton modèle CLEVO NL41LU dans la Liste des portables « Clevo »

Hors ligne

#7 Le 12/12/2020, à 18:22

tortuegonzo

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

malbo a écrit :

Bonjour,
Je ne sais pas si c'est déjà fait ou si ça reste à faire mais quand tu auras installé Ubuntu, je te prie de le signaler dans la présente discussion. Cela me permettra d'ajouter ton modèle CLEVO NL41LU dans la Liste des portables « Clevo »

Bonjour,

Oui, je viens d'installer la 20.04.1 (finalement : en dual boot avec un windows 10 pour infos).

Je n'ai bien sûr pas assez de recul pour voir si tout fonctionne bien mais ça a l'air.

J'ai juste eu un souci au 1er redémarrage après l'installation : je restais bloqué sur l'écran avec le loader qui tourne et le logo Ubuntu en bas. J'ai modifié Grub pour enlever le "quiet splash" comme indiqué ici et ça démarre bien maintenant.

Hors ligne

#8 Le 12/12/2020, à 18:29

malbo

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Puisque tu as conservé Windows 10, je souhaiterais voir ton dual-boot. Pour cela, je te prie de faire un Boot-info depuis une session de ton Ubuntu installé et de donner l'URL de ce Boot-info dans ta réponse.

Hors ligne

#9 Le 13/12/2020, à 13:04

tortuegonzo

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

malbo a écrit :

Puisque tu as conservé Windows 10, je souhaiterais voir ton dual-boot. Pour cela, je te prie de faire un Boot-info depuis une session de ton Ubuntu installé et de donner l'URL de ce Boot-info dans ta réponse.

Voici ; https://paste.ubuntu.com/p/cDDsz4QWrn/

Merci

Hors ligne

#10 Le 13/12/2020, à 16:07

malbo

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Bonjour,
Je colle ci-dessous le contenu du Boot-info dont tu as donné le lien dans ton dernier post :

boot-info-4ppa125                                              [20201213_1157]

============================== Boot Info Summary ===============================

 => No boot loader is installed in the MBR of /dev/nvme0n1.

nvme0n1p1: _____________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/Boot/bootx64.efi /efi/Boot/fbx64.efi 
                       /efi/Boot/mmx64.efi /efi/ubuntu/grubx64.efi 
                       /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                       /efi/ubuntu/grub.cfg /efi/Microsoft/Boot/bootmgfw.efi 
                       /efi/Microsoft/Boot/bootmgr.efi 
                       /efi/Microsoft/Boot/memtest.efi

nvme0n1p2: _____________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 

nvme0n1p3: _____________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

nvme0n1p4: _____________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 8 or 10
    Boot files:        /Windows/System32/winload.exe

nvme0n1p5: _____________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

nvme0n1p6: _____________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.1 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub


================================ 2 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession on nvme0n1p6
OS#2:   Windows 8 or 10 on nvme0n1p4

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.4.0-58-generic root=UUID=0aab568a-a3fc-4650-b180-9398d6253cde ro


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 0004,0002,2002,2003,2001
Boot0000* EFI PXE 0 for IPv4 (80-FA-5B-85-D1-ED) 	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x1)/MAC(80fa5b85d1ed,0)/IPv4(0.0.0.00.0.0.0,0,0)RC
Boot0001* EFI PXE 0 for IPv6 (80-FA-5B-85-D1-ED) 	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x1)/MAC(80fa5b85d1ed,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0002* Windows Boot Manager	HD(1,GPT,dbd14282-a209-4f9b-b4b5-47491cec247c,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0004* ubuntu	HD(1,GPT,dbd14282-a209-4f9b-b4b5-47491cec247c,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

78415fb8fb9b909f8029858113f1335f   nvme0n1p1/Boot/bootx64.efi
2895d47544fd587b26c7e29be1295c27   nvme0n1p1/Boot/fbx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   nvme0n1p1/Boot/mmx64.efi
8ed07d5ee4e5e1534bcf64037b7589ff   nvme0n1p1/ubuntu/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   nvme0n1p1/ubuntu/mmx64.efi
78415fb8fb9b909f8029858113f1335f   nvme0n1p1/ubuntu/shimx64.efi
4f0248591a11d5432380ba65f683879b   nvme0n1p1/Microsoft/Boot/bootmgfw.efi
1feb5f9427494e6f598603caa3af7d99   nvme0n1p1/Microsoft/Boot/bootmgr.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

nvme0n1	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

nvme0n1p6	: is-os,	64, apt-get,	signed grub-pc grub-efi ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
nvme0n1p1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
nvme0n1p3	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
nvme0n1p4	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
nvme0n1p5	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

nvme0n1p6	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p3	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot
nvme0n1p4	: isnotESP,	part-has-no-fstab,	no-nt,	haswinload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p5	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

nvme0n1p6	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	nvme0n1
nvme0n1p1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p3	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p4	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p5	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1

fdisk -l (filtered): ___________________________________________________________

Disk nvme0n1: 238.49 GiB, 256060514304 bytes, 500118192 sectors
Disk identifier: FBD2F876-2377-4BE1-AA92-35A3D1B5438E
              Start       End   Sectors   Size Type
nvme0n1p1      2048    534527    532480   260M EFI System
nvme0n1p2    534528    796671    262144   128M Microsoft reserved
nvme0n1p3    796672   1820671   1024000   500M Windows recovery environment
nvme0n1p4   1820672 294214656 292393985 139.4G Microsoft basic data
nvme0n1p5 294215680 295315455   1099776   537M Windows recovery environment
nvme0n1p6 295317504 500117503 204800000  97.7G Linux filesystem

parted -lm (filtered): _________________________________________________________

nvme0n1:256GB:nvme:512:512:gpt:256GB PCS PCIe M.2 SSD:;
1:1049kB:274MB:273MB:fat32:EFI system partition:boot, esp;
2:274MB:408MB:134MB::Microsoft reserved partition:msftres;
3:408MB:932MB:524MB:ntfs:Basic data partition:hidden, diag;
4:932MB:151GB:150GB:ntfs:Basic data partition:msftdata;
5:151GB:151GB:563MB:ntfs::hidden, diag;
6:151GB:256GB:105GB:ext4::;

blkid (filtered): ______________________________________________________________

NAME        FSTYPE   UUID                                 PARTUUID                             LABEL    PARTLABEL
nvme0n1                                                                                                 
├─nvme0n1p1 vfat     5AD7-5E42                            dbd14282-a209-4f9b-b4b5-47491cec247c SYSTEM   EFI system partition
├─nvme0n1p2                                               34c6bc09-fc9a-469f-86fa-d710e145b17e          Microsoft reserved partition
├─nvme0n1p3 ntfs     E414D7D814D7AC34                     d112c745-7aa2-496b-ad11-68736f415593 Recovery Basic data partition
├─nvme0n1p4 ntfs     90E6D9EDE6D9D396                     ce6efb08-e1bc-4326-a2e8-68656a84fbee Windows  Basic data partition
├─nvme0n1p5 ntfs     4612C04A12C040A3                     b028ef6a-ffd0-47b6-b43c-8b27be863172          
└─nvme0n1p6 ext4     0aab568a-a3fc-4650-b180-9398d6253cde e39015d5-8125-4ee3-b44b-2e65ca7115f3          

df (filtered): _________________________________________________________________

           Avail Use% Mounted on
nvme0n1p3  91.2M  82% /mnt/boot-sav/nvme0n1p3
nvme0n1p4  80.9G  42% /mnt/boot-sav/nvme0n1p4
nvme0n1p5  88.5M  84% /mnt/boot-sav/nvme0n1p5
nvme0n1p6  82.6G   8% /

Mount options: __________________________________________________________________

nvme0n1p3 rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
nvme0n1p4 rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
nvme0n1p5 rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
nvme0n1p6 rw,relatime,errors=remount-ro

=================== nvme0n1p1/efi/ubuntu/grub.cfg (filtered) ===================

search.fs_uuid 0aab568a-a3fc-4650-b180-9398d6253cde root 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

=================== nvme0n1p6/boot/grub/grub.cfg (filtered) ====================

Ubuntu   0aab568a-a3fc-4650-b180-9398d6253cde
Ubuntu, avec Linux 5.4.0-58-generic   0aab568a-a3fc-4650-b180-9398d6253cde
Ubuntu, avec Linux 5.4.0-42-generic   0aab568a-a3fc-4650-b180-9398d6253cde
Windows Boot Manager (sur nvme0n1p1)   osprober-efi-5AD7-5E42
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

======================== nvme0n1p6/etc/fstab (filtered) ========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=0aab568a-a3fc-4650-b180-9398d6253cde /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=5AD7-5E42  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

==================== nvme0n1p6/etc/default/grub (filtered) =====================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

================= nvme0n1p6: Location of files loaded by Grub ==================

           GiB - GB             File                                 Fragment(s)
 233,122119904 = 250,312970240  boot/grub/grub.cfg                             1
 234,243301392 = 251,516829696  boot/vmlinuz                                   1
 144,998043060 = 155,690463232  boot/vmlinuz-5.4.0-42-generic                  2
 234,243301392 = 251,516829696  boot/vmlinuz-5.4.0-58-generic                  1
 144,998043060 = 155,690463232  boot/vmlinuz.old                               2
 144,896804810 = 155,581759488  boot/initrd.img                                2
 235,739913940 = 253,123805184  boot/initrd.img-5.4.0-42-generic               2
 144,896804810 = 155,581759488  boot/initrd.img-5.4.0-58-generic               2
 235,739913940 = 253,123805184  boot/initrd.img.old                            2

=================== nvme0n1p6: ls -l /etc/grub.d/ (filtered) ===================

-rwxr-xr-x 1 root root 17622 nov.  13 00:15 10_linux
-rwxr-xr-x 1 root root 42359 nov.  13 00:15 10_linux_zfs
-rwxr-xr-x 1 root root 12894 juil. 31 02:34 20_linux_xen
-rwxr-xr-x 1 root root 12059 juil. 31 02:34 30_os-prober
-rwxr-xr-x 1 root root  1424 juil. 31 02:34 30_uefi-firmware
-rwxr-xr-x 1 root root   214 juil. 31 02:34 40_custom
-rwxr-xr-x 1 root root   216 juil. 31 02:34 41_custom


======================== Unknown MBRs/Boot Sectors/etc =========================


/dev/nvme0n1p5: unknown GPT attributes
8000000000000001

Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
nvme0n1p6,
using the following options:        nvme0n1p1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s win-legacy-basic-fix use-standard-efi-file    

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession entry (nvme0n1p1/efi/****/shim****.efi (**** will be updated in the final message) file) !
If your computer reboots directly into Windows, try to change the boot order in your UEFI firmware.

If your UEFI firmware does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI\****\shim****.efi (**** will be updated in the final message)

A mon avis, le dual-boot est parfaitement installé.
Comme prévu, je viens d'ajouter une ligne pour ton modèle NL41LU dans la Liste des portables « Clevo »
Merci d'avoir pris le temps de donner ces infos complémentaires.
EDIT : on voit bien dans ce Boot-info que tu as enlevé les paramètres de noyau "quiet splash" comme tu l'as signalé dans ton post #7

Dernière modification par malbo (Le 13/12/2020, à 16:15)

Hors ligne

#11 Le 13/12/2020, à 18:05

freechelmi

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Au passage ces 2  options grub pour NL41LU pourrait corriger quelques problèmes :

https://github.com/ekimiateam/ubuntupos … l.cfg#L171

Tu as payé une licence windows dont tu n avais pas besoin ?

Hors ligne

#12 Le 13/12/2020, à 19:16

malbo

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

@freechelmi : pourrais-tu préciser les 2 options en question ?

Hors ligne

#13 Le 29/01/2021, à 09:33

freechelmi

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

- i8042.reset est en fait très utilisé sur beaucoup de portables ( pas clevo uniquement ) pour atténuer ( mais pas éradiquer pour l'instant ) le bug du clavier inopérant en sortie de veille.

- pci=nocrs est necessaire pour que le touchpad soit bien detecté sur NL41LU/NL51LU

Hors ligne

#14 Le 26/02/2021, à 15:06

freechelmi

Re : [Résolu] CLEVO NL41LU : system doesn't have any usb boot option

Pour info , avec le kernel 5.8 qui est maintenant celui par défaut d'Ubuntu 20.04  pci=nocrs n'est plus necessaire

Hors ligne