Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/12/2020, à 16:34

Karpon

[Résolu] Choix de l'OS au départ

Bonjour,

Un portable acheté d'occasion, avec W$. J'ai installé xubuntu à côté, histoire d'avoir les deux OS, en cas de revente.
L'installation s'est bien passée, et à chaque mise en marche, j'avais le menu qui me permettait de choisir l'OS, avec xubuntu en priorité (donc "Entrée" suffisait).
Et un jour, plus rien d'affiché, et au bout d'un "certain temps", assez long du reste, xubuntu se lance, et fonctionne d'ailleurs normalement.
J'aimerais bien retrouver la configuration d'avant, ou, mieux, la possibilité de la faire apparaître au besoin, par exemple, comme en tapant F11, comme sur ma machine de bureau.
J'ai lancé boot-info, mais je n'ai pas la formation pour interpréter, encore moins pour savoir quelle modification  apporter, et où l'apporter !
Merci de votre aide !


boot-info-4ppa125                                              [20201213_1146]

============================== Boot Info Summary ===============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda2: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/Boot/bootx64.efi /efi/Boot/fbx64.efi 
                       /efi/Boot/mmx64.efi /efi/ubuntu/grubx64.efi 
                       /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                       /efi/ubuntu/grub.cfg /efi/Microsoft/Boot/bootmgfw.efi 
                       /efi/Microsoft/Boot/bootmgr.efi 
                       /efi/Microsoft/Boot/memtest.efi 
                       /efi/OEM/Boot/bootmgfw.efi /efi/OEM/Boot/bootmgr.efi 
                       /efi/OEM/Boot/memtest.efi

sda3: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 

sda4: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 8 or 10
    Boot files:        /Windows/System32/winload.exe

sda5: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda6: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.1 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub


================================ 2 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession on sda7
OS#2:   Windows 8 or 10 on sda4

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.4.0-58-generic root=UUID=2bcd6808-1eb4-4704-9c6a-00838894c1ee ro quiet splash vt.handoff=7


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0003,0001,0002
Boot0001* HDD0: 	HD(2,GPT,1970563a-82cf-4edc-929b-77758270413c,0xc8800,0x96000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0002* Windows Boot Manager	HD(2,GPT,1970563a-82cf-4edc-929b-77758270413c,0xc8800,0x96000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...e................
Boot0003* ubuntu	HD(2,GPT,1970563a-82cf-4edc-929b-77758270413c,0xc8800,0x96000)/File(\EFI\ubuntu\shimx64.efi)

78415fb8fb9b909f8029858113f1335f   sda2/Boot/bootx64.efi
2895d47544fd587b26c7e29be1295c27   sda2/Boot/fbx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   sda2/Boot/mmx64.efi
8ed07d5ee4e5e1534bcf64037b7589ff   sda2/ubuntu/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   sda2/ubuntu/mmx64.efi
78415fb8fb9b909f8029858113f1335f   sda2/ubuntu/shimx64.efi
e646918649032d6cb9e42b7b61649829   sda2/Microsoft/Boot/bootmgfw.efi
6aff955147b6a9367762704407fc6e31   sda2/Microsoft/Boot/bootmgr.efi
87b6d22295a16073d8d456fc574441a8   sda2/OEM/Boot/bootmgfw.efi
bb971a4a02185961543c7903473a6680   sda2/OEM/Boot/bootmgr.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda7	: is-os,	64, apt-get,	signed grub-pc grub-efi ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
sda1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
sda2	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
sda4	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
sda5	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
sda6	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

sda7	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda1	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot
sda2	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda4	: isnotESP,	part-has-no-fstab,	no-nt,	haswinload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda5	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot
sda6	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

sda7	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	sda
sda1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda
sda2	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda
sda4	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda
sda5	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda
sda6	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 465.78 GiB, 500107862016 bytes, 976773168 sectors
Disk identifier: 55E7A2E1-4823-4E70-97D9-5D942E6C0800
          Start       End   Sectors   Size Type
sda1       2048    821247    819200   400M Windows recovery environment
sda2     821248   1435647    614400   300M EFI System
sda3    1435648   1697791    262144   128M Microsoft reserved
sda4    1697792 273124296 271426505 129.4G Microsoft basic data
sda5  939024384 941119487   2095104  1023M Windows recovery environment
sda6  941119488 976773119  35653632    17G Windows recovery environment
sda7  273125376 939024383 665899008 317.5G Linux filesystem
Partition table entries are not in disk order.

parted -lm (filtered): _________________________________________________________

sda:500GB:scsi:512:4096:gpt:ATA ST500LT012-9WS14:;
1:1049kB:420MB:419MB:ntfs:Basic data partition:hidden, diag;
2:420MB:735MB:315MB:fat32:EFI system partition:boot, esp;
3:735MB:869MB:134MB::Microsoft reserved partition:msftres;
4:869MB:140GB:139GB:ntfs:Basic data partition:msftdata;
7:140GB:481GB:341GB:ext4::;
5:481GB:482GB:1073MB:ntfs::hidden, diag;
6:482GB:500GB:18.3GB:ntfs:Basic data partition:hidden, diag;

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL             PARTLABEL
sda                                                                                                         
├─sda1 ntfs     6AA098ADA09880ED                     d4b0bab7-606f-4e29-b972-27eabe4f1308 Recovery          Basic data partition
├─sda2 vfat     0E9B-1E84                            1970563a-82cf-4edc-929b-77758270413c ESP               EFI system partition
├─sda3                                               5cf8a1c6-7409-4cdb-8af4-caa430d73c22                   Microsoft reserved partition
├─sda4 ntfs     46829D69829D5DED                     94fd3a76-aa86-484a-90cc-4b8c968edaa8 Packard Bell      Basic data partition
├─sda5 ntfs     A0266BD7266BACCA                     4cbf7aa0-60ad-4ab0-99b5-63c0239e0bca                   
├─sda6 ntfs     DCCC9FE7CC9FB9EA                     696ef9d2-ad02-4e10-b7ce-73a08e9507f6 Push Button Reset Basic data partition
└─sda7 ext4     2bcd6808-1eb4-4704-9c6a-00838894c1ee c1913861-3776-4175-a93a-c498576c6908                   

df (filtered): _________________________________________________________________

       Avail Use% Mounted on
sda1     144M  64% /mnt/boot-sav/sda1
sda4   101.8G  21% /mnt/boot-sav/sda4
sda5   347.9M  66% /mnt/boot-sav/sda5
sda6     5.4G  69% /mnt/boot-sav/sda6
sda7   280.4G   5% /

Mount options: __________________________________________________________________

sda1   rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda4   rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda5   rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda6   rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda7   rw,relatime,errors=remount-ro

===================== sda2/efi/ubuntu/grub.cfg (filtered) ======================

search.fs_uuid 2bcd6808-1eb4-4704-9c6a-00838894c1ee root hd0,gpt7 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

====================== sda7/boot/grub/grub.cfg (filtered) ======================

Ubuntu   2bcd6808-1eb4-4704-9c6a-00838894c1ee
Ubuntu, avec Linux 5.4.0-58-generic   2bcd6808-1eb4-4704-9c6a-00838894c1ee
Ubuntu, avec Linux 5.4.0-56-generic   2bcd6808-1eb4-4704-9c6a-00838894c1ee
Ubuntu, avec Linux 5.4.0-54-generic   2bcd6808-1eb4-4704-9c6a-00838894c1ee
Windows Boot Manager (sur sda2)   osprober-efi-0E9B-1E84
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

========================== sda7/etc/fstab (filtered) ===========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=2bcd6808-1eb4-4704-9c6a-00838894c1ee /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=0E9B-1E84  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

======================= sda7/etc/default/grub (filtered) =======================

GRUB_DEFAULT=0
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

==================== sda7: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
 204,729694366 = 219,826835456  boot/grub/grub.cfg                             1
 140,661270142 = 151,033888768  boot/vmlinuz                                   1
 137,895641327 = 148,064317440  boot/vmlinuz-5.4.0-54-generic                  1
 137,559707642 = 147,703611392  boot/vmlinuz-5.4.0-56-generic                  1
 140,661270142 = 151,033888768  boot/vmlinuz-5.4.0-58-generic                  1
 137,559707642 = 147,703611392  boot/vmlinuz.old                               1
 140,993862152 = 151,391006720  boot/initrd.img                                2
 140,907913208 = 151,298719744  boot/initrd.img-5.4.0-54-generic               2
 140,868862152 = 151,256788992  boot/initrd.img-5.4.0-56-generic               2
 140,993862152 = 151,391006720  boot/initrd.img-5.4.0-58-generic               2
 140,868862152 = 151,256788992  boot/initrd.img.old                            2

===================== sda7: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 17622 sept.  8 12:24 10_linux
-rwxr-xr-x 1 root root 42359 sept.  8 12:24 10_linux_zfs
-rwxr-xr-x 1 root root 12894 avril 15  2020 20_linux_xen
-rwxr-xr-x 1 root root 12059 avril 15  2020 30_os-prober
-rwxr-xr-x 1 root root  1424 avril 15  2020 30_uefi-firmware
-rwxr-xr-x 1 root root   214 avril 15  2020 40_custom
-rwxr-xr-x 1 root root   216 avril 15  2020 41_custom


Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
sda7,
using the following options:        sda2/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s win-legacy-basic-fix use-standard-efi-file    

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession entry (sda2/efi/****/shim****.efi (**** will be updated in the final message) file) !
If your computer reboots directly into Windows, try to change the boot order in your UEFI firmware.

If your UEFI firmware does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI\****\shim****.efi (**** will be updated in the final message)

Edit : Solution trouvée, à force de tatônnements : Il faut intervenir dans le BIOS.

Dernière modification par Karpon (Le 26/01/2021, à 18:36)


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#2 Le 13/12/2020, à 18:21

noje

Re : [Résolu] Choix de l'OS au départ

Le menu qui permet de choisir l'OS tu dois parler de GRUB très certainement, est-ce qu'il était gris le menu non ?).
Tu vois encore un fond gris avant de démarrer, si oui tu peux appuyer sur «Esc» et le menu doit normalement apparaître.
Montre le contenu de ton fichier /etc/default/grub STP.


- LTS 18.04 - jwm -
Les seules vraies erreurs sont celles que nous commettons à répétition.
Les autres sont des occasions d'apprentissage. (Dalaï Lama)

Hors ligne

#3 Le 13/12/2020, à 20:04

Karpon

Re : [Résolu] Choix de l'OS au départ

Bonjour,

Merci de prendre en compte ma demande.
Oui, je suppose que c'est le grub, et qu'il n'apparaît pas. Arès, le grisé ou pas, je ne sais pas. Disons que, quand j'allume la machine, l'écran s'illumine et n'affiche qu'un modeste tiret, en haut, à gauche, c'est tout.
Quand ça fonctionnait, j'avais un menu en .. (oublié le nom), càd en mode texte comme en console.
Du jour où ça ne s'est plus affiché comme ça - en fait, plus d'affichage du tout, j'ai tenté de frapper un peu toutes les touches, sans succès.

Pour le fichier grub :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
# GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Voilà !


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#4 Le 13/12/2020, à 20:53

noje

Re : [Résolu] Choix de l'OS au départ

change : 

# GRUB_TIMEOUT_STYLE=hidden

pour :

GRUB_TIMEOUT_STYLE=countdown

ps : l'editeur de texte doit être lancer avec sudo dans un terminal par exemple.

sudo nom_editeur /etc/default/grub

puis tape ceci :

sudo update-grub

Dernière modification par noje (Le 13/12/2020, à 20:54)


- LTS 18.04 - jwm -
Les seules vraies erreurs sont celles que nous commettons à répétition.
Les autres sont des occasions d'apprentissage. (Dalaï Lama)

Hors ligne

#5 Le 13/12/2020, à 21:12

bluc

Re : [Résolu] Choix de l'OS au départ

Bonjour

noje a écrit :

ps : l'editeur de texte doit être lancer avec sudo dans un terminal par exemple.

Non gedit doit etre lancé
avec admin:// si Ubuntu

gedit admin:///etc/default/grub

avec pkexec pour xubuntu

pkexec mousepad /etc/default/grub

Ou utiliser nano

sudo nano /etc/default/grub

Dernière modification par bluc (Le 13/12/2020, à 21:17)


Clevo :  Ubuntu 22.10   ❖  Deepin 20.5 ❖  Zorin OS 16.2  ❖  Kubuntu 20.04  ❖ Ubuntu 22.04
                                           avec partition data commune

Hors ligne

#6 Le 13/12/2020, à 21:30

Karpon

Re : [Résolu] Choix de l'OS au départ

Je viens de faire la manip, rien de nouveau...
J'ai éteint, puis démarré une seconde fois, pareil.

Pour info : comme j'utilise gedit, systématiquement, en console, je fais toujours gedit admin:///monfichier.
En général, ça se passe bien !

Finalement, j'ai oublié de vérifier, après changement, que la modif a bien été prise en compte dans le fichier grub : je verrai ça demain, c'est une autre machine.


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#7 Le 13/12/2020, à 21:34

noje

Re : [Résolu] Choix de l'OS au départ

bluc a écrit :

Bonjour

noje a écrit :

ps : l'editeur de texte doit être lancer avec sudo dans un terminal par exemple.

Non gedit doit etre lancé
avec admin:// si Ubuntu

gedit admin:///etc/default/grub

avec pkexec pour xubuntu

pkexec mousepad /etc/default/grub

Ou utiliser nano

sudo nano /etc/default/grub

Ça va rentrer pour pkexec perso j’utilise vim en ligne de commande.


- LTS 18.04 - jwm -
Les seules vraies erreurs sont celles que nous commettons à répétition.
Les autres sont des occasions d'apprentissage. (Dalaï Lama)

Hors ligne

#8 Le 14/12/2020, à 00:19

noje

Re : [Résolu] Choix de l'OS au départ

Tente encore ceci pour voir si tu vois au moins la séquence de boot et des messages d’erreurs pendant le démarrage et voir aussi si le souci ne viens pas de la carte graphique.

Remplace ceci par ça :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
sudo update-grub

Reboot

Regarde après si ça ne marche pas, bootrepair suggère une réinstallation de grub sur sda7.


- LTS 18.04 - jwm -
Les seules vraies erreurs sont celles que nous commettons à répétition.
Les autres sont des occasions d'apprentissage. (Dalaï Lama)

Hors ligne

#9 Le 14/12/2020, à 12:02

Karpon

Re : [Résolu] Choix de l'OS au départ

noje a écrit :

... après si ça ne marche pas, bootrepair suggère une réinstallation de grub sur sda7.

Bonjour,

Effectivement, ça ne marche pas. Après la modif, j'ai, au départ, une liste impressionnante de contrôles, et vu la vitesse d'affichage, impossible de tout lire. Mais tous semblent afficher [OK], sauf un [failed] mais qui concernerait le brightness, à première vue, pas de rapport avec le souci.
Comme le laisse penser ma citation, utiliser bootrepair, je ne sais pas faire, mais ça ne doit pas être si compliqué, non ?
On verra par la suite à éliminer l'affichage du journal au départ ET à la sortie !


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#10 Le 14/12/2020, à 12:41

noje

Re : [Résolu] Choix de l'OS au départ

Est-ce que tu avais aussi ces messages texte de boot avant ou juste un écran noir avant d'avoir l'invite de login de ta version d'Ubuntu ?
Après c’est soit un souci avec la carte graphique (changement de pilote selon la version, une mauvaise installation de grub en lien avec EFI UEFI ou Secure Boot ».

Tu peux tenter de réinstaller grub comme le suggère bootrepair pour voir.

ggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
sda7,
using the following options:        sda2/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s win-legacy-basic-fix use-standard-efi-file    

Final advice in case of suggested repair: ______________________________________

Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession entry (sda2/efi/****/shim****.efi (**** will be updated in the final message) file) !
If your computer reboots directly into Windows, try to change the boot order in your UEFI firmware.

If your UEFI firmware does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI\****\shim****.efi (**** will be updated in the final message)

Pour plus de détails sur ton hardware peux-tu installer «  inxi » et envoyer le retour de la commande suivante :

inxi -F

Tu peux aussi donner des détails sur ton pc le modèle et les informations sur la carte graphique.


- LTS 18.04 - jwm -
Les seules vraies erreurs sont celles que nous commettons à répétition.
Les autres sont des occasions d'apprentissage. (Dalaï Lama)

Hors ligne

#11 Le 14/12/2020, à 12:58

Karpon

Re : [Résolu] Choix de l'OS au départ

A ma connaissance, ou plutôt souvenir, je n'ai jamais eu ce genre de texte, ou alors, c'était au tout début du journal qui s'affiche maintenant au démarrage, mais je ne crois pas.
Je peux effectivement choisir mon OS au démarrage, mais il me faut passer par le BIOS et changer la place du premier, de celui donc que je souhaite lancer, ce qui n'est quand même par très pratique.
Lors d'une manipulation parmi celles qui m'ont été suggérées ici, je crois me souvenir qu'à plusieurs reprises, il y a eu reconctruction du grub, comme de celles que l'on voit quand il est proposé un nouveau noyau. Après, que la carte graphique ait un problème, pourquoi pas, seulement, ça marchait avant (anomalie apparue probablement suite à des mises à jour - à moins que ce ne soit une mauvaise manip dans le BIOS, mais en général, je fais attention, je ne bricole pas trop ce que je ne connais pas ou mal), et par ailleurs, le graphisme actuel est tout à fait correct, je suppose qu'en cas d'avarie, j'aurais certainement des lacunes dans l'affichage, ce qui n'est pas le cas.
Je veux bien tenter "inxi" et exécuter la commande idoine. Je vais essayer de voir ça dans l'après-midi.


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#12 Le 14/12/2020, à 15:02

bluc

Re : [Résolu] Choix de l'OS au départ

Tu peux si tu ne l'as pas deja fait installer synaptic recercher grub-pc → clic droit et choisir Désinstallation complète → Appliquer
Fermer synaptic → le relancer rechercher grub-pc → clic droit Sélectionner pour installationAppliquer
A un moment il te sera demander ou installer grub → choisis sda
Redémarre

Dernière modification par bluc (Le 14/12/2020, à 15:13)


Clevo :  Ubuntu 22.10   ❖  Deepin 20.5 ❖  Zorin OS 16.2  ❖  Kubuntu 20.04  ❖ Ubuntu 22.04
                                           avec partition data commune

Hors ligne

#13 Le 14/12/2020, à 15:56

Karpon

Re : [Résolu] Choix de l'OS au départ

Oui, j'utilise assez souvent Synaptic, et j'aime bien, par contre, je ne sais plus si il est installé sur le portable concerné, auquel cas je le mettrai.
Suite à un nouveau démarrage, j'ai vu passer, entre autres choses, un "boot failed" ou quelque chose du genre, ce qui m'a paru logique.
inxi était déjà en place, je l'ai lancé :

.....-ENLE11BZ:~$ inxi -F
System:
  Host: firmin-ENLE11BZ Kernel: 5.4.0-58-generic x86_64 bits: 64 
  Desktop: Xfce 4.14.2 Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:
  Type: Laptop System: Packard Bell product: ENLE11BZ v: V2.10 
  serial: <superuser/root required> 
  Mobo: Packard Bell model: EG70_BZ serial: <superuser/root required> 
  UEFI: Insyde v: 2.10 date: 11/13/2012 
Battery:
  ID-1: BAT0 charge: 0 Wh condition: 17.1/48.4 Wh (35%) 
CPU:
  Topology: Dual Core model: AMD E1-1200 APU with Radeon HD Graphics 
  bits: 64 type: MCP L2 cache: 512 KiB 
  Speed: 780 MHz min/max: 777/1400 MHz Core speeds (MHz): 1: 779 2: 779 
Graphics:
  Device-1: AMD Wrestler [Radeon HD 7310] driver: radeon v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz 
  OpenGL: renderer: AMD PALM (DRM 2.50.0 / 5.4.0-58-generic LLVM 10.0.0) 
  v: 3.3 Mesa 20.0.8 
Audio:
  Device-1: AMD Wrestler HDMI Audio driver: snd_hda_intel 
  Device-2: AMD FCH Azalia driver: snd_hda_intel 
  Sound Server: ALSA v: k5.4.0-58-generic 
Network:
  Device-1: Intel Centrino Wireless-N 105 driver: iwlwifi 
  IF: wlp3s0 state: down mac: 80:9b:20:4c:0d:84 
  Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c 
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 70:54:d2:3f:a7:08 
Drives:
  Local Storage: total: 473.23 GiB used: 15.37 GiB (3.2%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-9WS142 size: 465.76 GiB 
  ID-2: /dev/sdb type: USB vendor: Lexar model: USB Flash Drive 
  size: 7.47 GiB 
Partition:
  ID-1: / size: 311.54 GiB used: 15.31 GiB (4.9%) fs: ext4 dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 55.5 C mobo: N/A gpu: radeon temp: 56 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 172 Uptime: 3m Memory: 3.42 GiB used: 540.8 MiB (15.4%) 
  Shell: bash inxi: 3.0.38 
....-ENLE11BZ:~$ 

Pas vu grand chose d'intéressant, mais n'étant pas spécialiste....

Désinstaller grup (avec Synaptic) me fait un peu peur.
Réinstaller sur sda ne m'inspire pas trop, simplement parce qu'il y a plusieurs partitions en sda, et il me semble que le boot était sur la sda7 (W$ sur sda4). Et je ne vois pas de sda tout seul !


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#14 Le 14/12/2020, à 16:28

bluc

Re : [Résolu] Choix de l'OS au départ

Quand on installe grub sur sda ,ce n'est qu'une partie de grub, en fait c'est dans le secteur désamorçage du disque, l'autre  partie, avec les fichiers de config sont sur le système linux
par exemple chez moi 3 os :un sur sda1, un autre sur sda2 et un autre sur sda5 et grub est installé sur sda
Pour l'instant c'est le systeme qui est sur sda5 qui a installé grub sur sda

Peu importe le système qui as le grub actif
Si je fais l’opération que je t'ai proposé depuis un autre de mes systèmes , c'est ce dernier qui aura la main sur le démarrage
ils ont tous grub installé sur le système, mais une autre partie est en début de disque et c'est le dernier os installé qui a le grub actif

Mais bon , je viens de voir que ton système est en UEFI , alors , je ne sais pas ce qui te serait proposé comme choix du grub, est ce sda ?...est ce la partition boot ?..., (je pense qu'il te serait proposé la partition boot, j'en suis presque sûr )
comme je ne suis pas vraiment sûr , jamais eu a faire cette opération sur ce type d'installation
Donc je te conseillerais de réinstallé grub depuis boot-repair

Dernière modification par bluc (Le 14/12/2020, à 16:54)


Clevo :  Ubuntu 22.10   ❖  Deepin 20.5 ❖  Zorin OS 16.2  ❖  Kubuntu 20.04  ❖ Ubuntu 22.04
                                           avec partition data commune

Hors ligne

#15 Le 14/12/2020, à 18:07

Karpon

Re : [Résolu] Choix de l'OS au départ

OK.
Bon, comment je fais pour utiliser boot-repair ?
Simplement en console, genre :

boot-repair

ou c'est un peu plus compliqué ?...


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#16 Le 14/12/2020, à 18:42

bluc

Re : [Résolu] Choix de l'OS au départ

https://doc.ubuntu-fr.org/boot-repair

Dernière modification par bluc (Le 14/12/2020, à 18:42)


Clevo :  Ubuntu 22.10   ❖  Deepin 20.5 ❖  Zorin OS 16.2  ❖  Kubuntu 20.04  ❖ Ubuntu 22.04
                                           avec partition data commune

Hors ligne

#17 Le 14/12/2020, à 20:02

Karpon

Re : [Résolu] Choix de l'OS au départ

Merci, je vois ça...


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#18 Le 14/12/2020, à 21:44

noje

Re : [Résolu] Choix de l'OS au départ

Karpon a écrit :

Pas vu grand chose d'intéressant, mais n'étant pas spécialiste....

Juste pour voir quels sont les informations sur ta machine et voir si des bugs similaire sont présents ou connus.

Dernière modification par noje (Le 14/12/2020, à 21:44)


- LTS 18.04 - jwm -
Les seules vraies erreurs sont celles que nous commettons à répétition.
Les autres sont des occasions d'apprentissage. (Dalaï Lama)

Hors ligne

#19 Le 15/12/2020, à 12:00

Karpon

Re : [Résolu] Choix de l'OS au départ

Bonjour,

Voilà, j'ai donc installé et fait tourner boot-repair.
J'ai pu constater qu'il faisait beaucoup de choses, des analyses et probablement plein de trucs. Le souci est que, au final,  je suis toujours dans la même situation, disons que, peut-être, ça traîne juste un peu moins pour démarrer, et sur Linux, obligatoirement.
Je suis passé dans le BIOS, histoire de mettre W$ en première place, et là, il a démarré immédiatement, en clair, l'appareil a été programmé pour tourner sous W$, et l'installation de Linux avait bien proposé le choix, lequel choix a disparu, je ne sais pas pourquoi.
Comme tel, je peux utiliser la machine, puisque je ne me sers que de xubuntu, mais si je veux revendre cet appareil avec une valorisation de double boot, c'est sérieusement compromis !
Boot-repair me propose d'envoyer le rapport à une adresse mail, ça ne me coûtera rien d'accepter cette invitation.
Pour l'heure, j'aimerais bien aussi me débarrasser de la litanie affichée au départ, elle se justifiait pour ma demande d'aide, elle n'est donc plus utile, je suppose qu'il me faudra remettre les deux lignes comme au départ.
Donc, et pour l'heure : sans changement...
Et j'en suis bien désolé, un instant, j'y ai cru...
Merci pour l'aide, bien qu'elle n'ait pas abouti pour l'instant.


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#20 Le 15/12/2020, à 15:03

bluc

Re : [Résolu] Choix de l'OS au départ

Tu as réinstallé grub depuis boot-repair ?....


Clevo :  Ubuntu 22.10   ❖  Deepin 20.5 ❖  Zorin OS 16.2  ❖  Kubuntu 20.04  ❖ Ubuntu 22.04
                                           avec partition data commune

Hors ligne

#21 Le 15/12/2020, à 16:47

Karpon

Re : [Résolu] Choix de l'OS au départ

bluc a écrit :

Tu as réinstallé grub depuis boot-repair ?....

En fait, je ne sais pas trop...
Comme ce logiciel propose, d'emblée, deux options, j'ai pris la première qui prétend être suffisante pour résoudre les problèmes dans la majorité des cas.
Comme ça n'a rien donné une première fois, j'ai relancé l'application pour effectuer une autre réparation, avec, cette fois, un regard dans les paramètres, ce que je n'avais pas fait la première fois. De mémoire, je n'ai pas dû changer grand chose...
Arrivé à ce stade, je me demande si le plus simple ne serait pas de réinstaller xubuntu, purement et simplement, ça m'ennuie un peu, d'autant que je ne suis pas du tout sûr du résultat. En effet, si ça a coincé suite à une MàJ, il est probable que la réinstallation remettra l'OS à la dernière mouture, et je risque donc de retrouver le souci.
Manifestement, j'eusse espéré une solution plus simple...


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#22 Le 15/12/2020, à 20:06

bluc

Re : [Résolu] Choix de l'OS au départ

Du fait d'avoir installé sur une seule partition il faudra sauvegarder les données sur un autre support
quand on installe avec home séparé sur une autre partition, c'est une opération que l'on a pas besoin de faire

Dernière modification par bluc (Le 15/12/2020, à 20:07)


Clevo :  Ubuntu 22.10   ❖  Deepin 20.5 ❖  Zorin OS 16.2  ❖  Kubuntu 20.04  ❖ Ubuntu 22.04
                                           avec partition data commune

Hors ligne

#23 Le 15/12/2020, à 20:49

Karpon

Re : [Résolu] Choix de l'OS au départ

En général, je fais toujours des partitions séparées dans mes intallations (/, /home, /swap, /autre). Je n'ai pas en tête ce que j'ai fait sur ce portable car W$ occupe déjà 3 ou 4 partitions à lui tout seul. J'en ai donc réduit une pour en créer une supplémentaire, ce qui explique pourquoi j'ai procédé ainsi. De toute façon, à chaque installation ou remise à niveau, je formate systématiquement mes partitions, histoire de faire du propre, ça ne changera donc pas grand chose même si j'avais eu un /home séparé.
Bon, n'ayant pas de solution viable,  je vais tenter de remettre le fichier à l'origine de manière à ne plus avoir le défilé au départ.
Disons que cette machine n'est pas terrible, j'envisageais donc une revente possible, je crois que c'est compromis. Je vais utiliser comme telle, éventuellement en dépannage, voire la brader à 100 € éventuellement...
Merci pour l'aide mais il faut être un peu philosophe, et ça ne marche pas à tous les coups.
Mais j'ai grandement apprécié qu'on s'intéresse à mon problème !
Merci encore !


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne

#24 Le 15/12/2020, à 21:55

bluc

Re : [Résolu] Choix de l'OS au départ

Oui... mais Ubuntu est installé sur environ 320 Go
Ubuntu peut tenir sur une partition de 25 minimum a 40 Go pour être a l'aise
donc il serait possible de faire sur ces 320 Go
Supprimer la partition sda7, après sauvegarde des données présentes, sur un dd-usb ou autres supports

et créer
_une partition de 40 Go pour Ubuntu
_une autre pour /home (ou /data) sur le reste donc 280 Go (ou seraient les données)

Je propose ça, mais une installation comme tu as fait , ça fonctionne bien , le seul probleme c'est en cas de réinstallation a cause des données

Vu que tu as 7 partitions, tu as une table de partition GPT qui peut donc en accueillir une 8ème

Dernière modification par bluc (Le 15/12/2020, à 22:28)


Clevo :  Ubuntu 22.10   ❖  Deepin 20.5 ❖  Zorin OS 16.2  ❖  Kubuntu 20.04  ❖ Ubuntu 22.04
                                           avec partition data commune

Hors ligne

#25 Le 17/12/2020, à 20:51

Karpon

Re : [Résolu] Choix de l'OS au départ

Bonjour,

      A tout hasard, et sans conviction, j'ai réinstallé xubuntu20. Comme on pouvait s'y attendre, aucun changement.
Boot-repair ne donne pas vraiment de solution, j'ai vu, me souvient-il, que "dans certains cas",  il fallait passer par W$ et lancer je ne sais plus quoi, je n'ai pas retenu.
Bon, ça marche comme avant, càd, difficulté à démarrer sous xubuntu, démarrage rapide sous W$, dans la mesure où l'on intervient dans l'ordre du Bios, ce qui n'est pas  une solution. Mon idée était qu'il doit bien y avoir un touche (ou combinaison de touches) à frapper juste au départ, de manière à afficher le grub.
Maintenant, c'est en mode EUFI, peut-être est-ce indispensable pour avoir W$. Le mode Legacy marchait très bien. Je ne sais pas si le mode EUFI est vraiment adéquat pour xubuntu, j'ai quand même des drôles de choses, outre le fait qu'il est très long à démarrer, il arrive parfois que la case de saisie du passe ne reconnaisse pas le clavier, dans ce cas, redémarrer ne donne rien, il faut obligatoirement éteindre (voire débrancher l'alimentation), et rallumer.
Heureusement que ce n'est pas une machine que j'utilise au quotidien, car elle irait direct à la poubelle...
Je ne vois pas trop ce que je pourrais faire d'autre, j'ai bien peur de rester avec un souci jamais solutionné.


Machine assemblée perso - xubuntu 20.04 -  Xfce 4.14
Carte-mère : MSI H110 PRO D - Ram DDR3 16 G° - CPU Intel S1151
Carte graphique : NVIDIA Corporation - GeForce 210/PCIe/SSE2 - Vers 3.3.3 NVIDIA 340.108

Hors ligne