Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/12/2020, à 14:46

Rafbor

[Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Bonjour,
acquis chez Dell, livré avec Ubuntu 16.04 préinstallé, DD Toshiba de 1To. La date de fin du support de cette LTS approchant, j'ai pensé le mettre à niveau. J'avais un peu peur de tout casser après avoir lu que des problèmes de compatibilité matérielle étaient possibles avec du Dell, qu'en live USB tout semble bien fonctionner mais qu'après l'install ça ne va plus, ou qu'après migration vers la LTS suivante, sur d'autres laptop Dell ça n'est pas concluant.
De plus sur le site linux-hardware les retours sur ce modèle ne sont pas très rassurants, beaucoup de problèmes signalés et la page Canonical de certification des modèles liste des problèmes mineurs mais je comprends que cela correspond à la version installée par Dell, pas la version standard d'Ubuntu...

J'ai quand même trouvé un topic rassurant ici et j''ai donc décidé d'installer la 20.04.1, qui fonctionne nickel en live USB. Par sécurité, j'ai sauvegardé mes données et l'image de récupération fournie par Dell, avec l'outil dell-recovery (déjà installé) au cas ou je doive revenir en arrière.
Lors de l'installation je n'ai pas touché aux 2 premières partitions (/boot-efi et la partition qui contient l'image de récupération)
J'ai supprimé la partition de swap qui n'est plus utile et j'ai créé une partition de 100Go pour la racine et avec le reste, une partition pour le /home.

L'installation s'est déroulée sans problèmes et tout fonctionne correctement (wifi, bluetooth, webcam, sortie de veille...). Seul pb avec le pavé tactile, comme mentionné dans la certification Canonical, qui ne prend pas le scrolling de page avec un doigt (fonctionne à 2 doigts), mais pas grave, je l'utilise pas j'ai une souris.

Voilà, mon expérience pourra servir à d'autres, dites moi s'il faut d'autres infos et si quelqu'un se charge d'ajouter ce modèle sur la page de doc des portables Dell.

Edit: voici le boot-info:

boot-info-4ppa125                                              [20201216_1438]

============================== Boot Info Summary ===============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/Boot/fbx64.efi /efi/Boot/mmx64.efi 
                       /efi/Boot/shimx64.efi /efi/ubuntu/fwupx64.efi 
                       /efi/ubuntu/grubx64.efi /efi/ubuntu/mmx64.efi 
                       /efi/ubuntu/shimx64.efi /efi/ubuntu/grub.cfg

sda2: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /boot/grub/grub.cfg

sda3: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.1 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub

sda4: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        


================================ 1 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession on sda3

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.4.0-58-generic root=UUID=12084b67-4a45-49fb-91eb-70e4fb55e9a9 ro quiet splash vt.handoff=7


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot enabled.

efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,0002,0003,0004
Boot0000* ubuntu	HD(1,GPT,15874540-f2a8-4591-a764-20880fbb94bd,0x800,0x177000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* UEFI: SanDisk Cruzer 8.02, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x56f48570,0x4c8f30,0x1f00)..BO
Boot0002* UEFI:CD/DVD Drive	BBS(129,,0x0)
Boot0003* UEFI:Removable Device	BBS(130,,0x0)
Boot0004* UEFI:Network Device	BBS(131,,0x0)
Boot0005* Onboard NIC	BBS(Network,Realtek PXE B02 D00,0x0)..BO
Boot0006* UEFI: TOSHIBA MQ04ABF100, Partition 1	HD(1,GPT,15874540-f2a8-4591-a764-20880fbb94bd,0x800,0x177000)/File(EFI\boot\bootx64.efi)..BO

2895d47544fd587b26c7e29be1295c27   sda1/Boot/fbx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   sda1/Boot/mmx64.efi
ded965934506efb38a6dcb9ac5b2b79e   sda1/Boot/shimx64.efi
82894bcbe4f010664226ba7591372538   sda1/ubuntu/fwupx64.efi
8ed07d5ee4e5e1534bcf64037b7589ff   sda1/ubuntu/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84   sda1/ubuntu/mmx64.efi
78415fb8fb9b909f8029858113f1335f   sda1/ubuntu/shimx64.efi
78415fb8fb9b909f8029858113f1335f   sda1/Boot/BOOTX64.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda3	: is-os,	64, apt-get,	signed grub-pc grub-efi ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
sda1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
sda2	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
sda4	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

sda3	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda2	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda4	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

sda3	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	sda
sda1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda
sda2	: not-sepboot,	no-kernel,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda
sda4	: maybesepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk identifier: 15268504-A16E-431E-8815-A3E5697864D1
          Start        End    Sectors   Size Type
sda1       2048    1538047    1536000   750M EFI System
sda2    1538048   12023807   10485760     5G Microsoft basic data
sda3   12023808  207335423  195311616  93.1G Linux filesystem
sda4  207335424 1953523711 1746188288 832.7G Linux filesystem

parted -lm (filtered): _________________________________________________________

sda:1000GB:scsi:512:4096:gpt:ATA TOSHIBA MQ04ABF1:;
1:1049kB:787MB:786MB:fat32:EFI system partition:boot, esp;
2:787MB:6156MB:5369MB:fat32:Basic data partition:msftdata;
3:6156MB:106GB:100GB:ext4::;
4:106GB:1000GB:894GB:ext4::;

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL PARTLABEL
sda                                                                                             
├─sda1 vfat     C472-F111                            15874540-f2a8-4591-a764-20880fbb94bd ESP   EFI system partition
├─sda2 vfat     EC15-2993                            9066b54b-5a0a-4f37-9616-5ac1fa1d49c3 OS    Basic data partition
├─sda3 ext4     12084b67-4a45-49fb-91eb-70e4fb55e9a9 ebe94cc7-3b31-47d1-8a2a-d4b8eec52c23       
└─sda4 ext4     736a7100-d788-4cd3-9564-0d51dc2a2485 22e45e09-f3d7-46b6-a3dc-87c61172b620       

df (filtered): _________________________________________________________________

                   Avail Use% Mounted on
sda2                2.2G  56% /mnt/boot-sav/sda2
sda3               78.3G   9% /
sda4              772.3G   1% /home

Mount options: __________________________________________________________________

sda2              rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro
sda3              rw,relatime,errors=remount-ro
sda4              rw,relatime

===================== sda1/efi/ubuntu/grub.cfg (filtered) ======================

search.fs_uuid 12084b67-4a45-49fb-91eb-70e4fb55e9a9 root hd0,gpt3 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

====================== sda2/boot/grub/grub.cfg (filtered) ======================

Install Complete, remove media and reboot.
Dell Recovery
Dell Recovery (safe graphics mode)

==================== sda2: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             boot/grub/grub.cfg                             1

====================== sda3/boot/grub/grub.cfg (filtered) ======================

Ubuntu   12084b67-4a45-49fb-91eb-70e4fb55e9a9
Ubuntu, avec Linux 5.4.0-58-generic   12084b67-4a45-49fb-91eb-70e4fb55e9a9
Ubuntu, avec Linux 5.4.0-42-generic   12084b67-4a45-49fb-91eb-70e4fb55e9a9
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

========================== sda3/etc/fstab (filtered) ===========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=12084b67-4a45-49fb-91eb-70e4fb55e9a9 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=C472-F111  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sda4 during installation
UUID=736a7100-d788-4cd3-9564-0d51dc2a2485 /home           ext4    defaults        0       2
/swapfile                                 none            swap    sw              0       0

======================= sda3/etc/default/grub (filtered) =======================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

==================== sda3: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
  52,580696106 = 56,458092544   boot/grub/grub.cfg                             2
  62,392715454 = 66,993668096   boot/vmlinuz                                   1
  10,127071381 = 10,873860096   boot/vmlinuz-5.4.0-42-generic                  1
  62,392715454 = 66,993668096   boot/vmlinuz-5.4.0-58-generic                  1
  10,127071381 = 10,873860096   boot/vmlinuz.old                               1
   8,194053650 = 8,798298112    boot/initrd.img                                4
  64,897140503 = 69,682774016   boot/initrd.img-5.4.0-42-generic               2
   8,194053650 = 8,798298112    boot/initrd.img-5.4.0-58-generic               4
  64,897140503 = 69,682774016   boot/initrd.img.old                            2

===================== sda3: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 17622 nov.  13 00:15 10_linux
-rwxr-xr-x 1 root root 42359 nov.  13 00:15 10_linux_zfs
-rwxr-xr-x 1 root root 12894 juil. 31 02:34 20_linux_xen
-rwxr-xr-x 1 root root 12059 juil. 31 02:34 30_os-prober
-rwxr-xr-x 1 root root  1424 juil. 31 02:34 30_uefi-firmware
-rwxr-xr-x 1 root root   214 juil. 31 02:34 40_custom
-rwxr-xr-x 1 root root   216 juil. 31 02:34 41_custom


Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
sda3,
using the following options:        sda1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s  use-standard-efi-file    

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession entry (sda1/efi/****/shim****.efi (**** will be updated in the final message) file) !

Une question quand même: puisque tout fonctionne, je n'ai plus besoin des 2 partitions créées par Dell, je pourrais donc reformater entièrement le disque et réinstaller ?

Dernière modification par Rafbor (Le 17/12/2020, à 08:24)


Ubuntu 20.04 - RafCalc

Hors ligne

#2 Le 16/12/2020, à 19:44

malbo

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Bonjour,
Moi je ne vois qu'une partition créée par Dell qui pourrait éventuellement être supprimée : c'est la partition sda2. Si tu en vois une autre qui pourrait être supprimée, je te prie de préciser laquelle.

Hors ligne

#3 Le 16/12/2020, à 20:31

Rafbor

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Merci @malbo, je suis pas très à l'aise avec ces histoires de boot, je crois que le PC pourrait démarrer en mode classique, non efi, faut que je vérifie dans le bios, et dans ce cas plus besoin de la partition de boot. Bon je me pencherai dessus si j'ai des soucis, pour le moment il va tourner comme ça smile


Ubuntu 20.04 - RafCalc

Hors ligne

#4 Le 16/12/2020, à 20:47

geole

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Rafbor a écrit :

je crois que le PC pourrait démarrer en mode classique:)

Bonjour
Je ne pense pas que booter en mode légacy au lieu du mode EFI sécurisé soit une bonne idée. En revanche la partition SDA1 qui fait 750 Mo pourrait ne faire que 36 Mo. Mais je ne sais pas si gparted sait rétrécir si finement.
Comme a dit Malbo, SDA2 n'a pas lieu d'exister

disk -l (filtered): ___________________________________________________________
Disk sda: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk identifier: 15268504-A16E-431E-8815-A3E5697864D1
          Start        End    Sectors   Size Type
sda1       2048    1538047    1536000   750M EFI System
sda2    1538048   12023807   10485760     5G Microsoft basic data

Hors ligne

#5 Le 16/12/2020, à 20:49

lucmars

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Non, t'as installé en efi, ça ne boot donc qu'en efi, point barre.

D'ailleurs y-a rien dans ton installe pour un boot "classique" (non-efi) !


Gaulois Matter !

Hors ligne

#6 Le 16/12/2020, à 21:17

Rafbor

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

@geole: bien noté pour la taille, dans la doc il est écrit

doc a écrit :

Taille : entre 35 Mo et 250 Mo mais une taille de 5 Mo est suffisante si vous n'installez pas Windows mais impossible à faire accepter par gparted.

@lucmars: j'ai vérifié dans le bios, je peux activer le mode Legacy après avoir désactivé le Secure Boot. Dans ce cas, je pourrai réinstaller sans la partition de boot.
Mais comme dit @geole, c'est peut être pas une bonne idée. Je vais laisser comme ça, c'est pas la place de stockage qui manque, je reconfigurerai lors d'une prochaine install.

Vous savez pourquoi j'ai le message "Booting in insecure mode" au boot, alors que Secure boot est activé ?


Ubuntu 20.04 - RafCalc

Hors ligne

#7 Le 16/12/2020, à 21:44

malbo

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Je viens de créer une ligne Inspiron 15-3567 dans la Liste des portables « Dell » pour mentionner ta réussite.

Rafbor a écrit :

Vous savez pourquoi j'ai le message "Booting in insecure mode" au boot, alors que Secure boot est activé ?

Moi je ne sais pas.

Dernière modification par malbo (Le 16/12/2020, à 21:46)

Hors ligne

#8 Le 16/12/2020, à 21:56

Rafbor

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Merci @malbo.

Pour le message "Booting in insecure mode", @agn01 avait le même problème dans le topic que j'ai cité plus haut ( ici ):

agn01 a écrit :

1- Dans le bios (accès par F2) : Secure boot disabled
Il était "enabled" à l'origine mais quand je lançais l'Ubuntu installé par Dell je voyais toujours "booting in unsecure mode" donc j'ai pensé qu'il fallait le faire.


Ubuntu 20.04 - RafCalc

Hors ligne

#9 Le 16/12/2020, à 22:13

ikewdu

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Salut,

N'aurais-tu pas activé involontairement le secure-boot intégré de shim-signed ? J'ai eu il y a deux mois une bizarrerie de ce genre  qui s'est imposée à moi lors d'une mise à niveau de Mint, sur un PC qu'on m'avait confié. J'avoue avoir oublié si j'obtenais ce message, mais je me souviens que j'ai dû désactiver mokutil, ce que j'ai réussi à faire en suivant ce tuto :

https://wiki.ubuntu.com/UEFI/SecureBoot/DKMS

C'est peut-être cette piste qu'il faut suivre.

Hors ligne

#10 Le 16/12/2020, à 22:26

Rafbor

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

@ikewdu merci, j'ai eu cet écran bleu une fois au 1er démarrage après l'install, je l'avais jamais vu avant.
Bonne piste en effet, je testerai ça.


Ubuntu 20.04 - RafCalc

Hors ligne

#11 Le 17/12/2020, à 00:00

ikewdu

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

Re,

Donc, c'est ça. Fais attention car le processus te demandera un nouveau mot de passe à 8 caractères. Au redémarrage, il peut te demander de taper uniquement certains caractères de ce mot de passe, selon leur place.

Dernière modification par ikewdu (Le 17/12/2020, à 00:00)

Hors ligne

#12 Le 17/12/2020, à 08:24

Rafbor

Re : [Résolu] Ubuntu 20.04 sur Dell Inspiron 15-3567

C'était bien ça, j'ai activé le Secure boot avec

sudo mokutil --enable-validation

et je n'ai plus de message au boot. Pour le mot de passe, c'est vrai qu'il te demande plusieurs fois de saisir un caractère en position x, c'est plus sage de faire comme dans le wiki et mettre 12345678.
Je passe en résolu, merci à tous.


Ubuntu 20.04 - RafCalc

Hors ligne