Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/02/2021, à 13:49

xianbroc

[Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Bonjour,
Je viens d'acheter une imprimante HP DeskJet 2722 pour imprimer et scanner. Mon ordi est en ubuntu 20.04
hplip 3.20.3 n'a pas reconnu l'imprimante.
J'ai lu qu'il fallait au moins hplip 3.20.5 pour la série 2700 mais que ça ne fonctionnait pas parfaitement bien avec ubuntu 20.04
J'ai essayé d'installer hplip 3.20.11 qui est donné pour supporter ubuntu 20.10
L'installation a planté avec
error : command failed with error 100
sudo apt-get install --assume-yes python-pyqt5

Et puis ensuite  avec python-dbus.mainloop.pyqt5 et avec python-notify et avec python-reportlab

Que faire ?
. reprendre avec hplip 3.20.5 ?
. installer pyqt5 avant hplip 3.20.11 ?

Mon installation :

xianne@xianne-G5429fr:~$ cat /etc/lsb-release && uname -i && groups && lsusb
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.1 LTS"
x86_64
sudo adm dialout fax cdrom floppy tape audio dip video plugdev netdev lpadmin scanner sambashare
Bus 002 Device 003: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0461:4d0f Primax Electronics, Ltd HP Optical Mouse
Bus 001 Device 003: ID 0461:0010 Primax Electronics, Ltd HP PR1101U / Primax PMX-KPR1101U Keyboard
Bus 001 Device 005: ID 03f0:1853 HP, Inc 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
xianne@xianne-G5429fr:~$ 
xianne@xianne-G5429fr:~$ dpkg -l | grep hplip
rc  hplip                                         3.20.3+dfsg0-2                      amd64        HP Linux Printing and Imaging System (HPLIP)
ii  hplip-data                                    3.20.3+dfsg0-2                      all          HP Linux Printing and Imaging - data files
rc  hplip-gui                                     3.20.3+dfsg0-2                      all          HP Linux Printing and Imaging - GUI utilities (Qt-based)
xianne@xianne-G5429fr:~$ 
xianne@xianne-G5429fr:~$ hp-check

La commande « hp-check » n'a pas été trouvée, mais peut être installée avec :

sudo apt install hplip

xianne@xianne-G5429fr:~$ 
xianne@xianne-G5429fr:~$ dpkg -l | grep cups
ii  bluez-cups                                    5.53-0ubuntu3                       amd64        Bluetooth printer driver for CUPS
ii  cups                                          2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  cups-browsed                                  1.27.4-1                            amd64        OpenPrinting CUPS Filters - cups-browsed
ii  cups-bsd                                      2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - BSD commands
ii  cups-client                                   2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - client programs (SysV)
ii  cups-common                                   2.3.1-9ubuntu1.1                    all          Common UNIX Printing System(tm) - common files
ii  cups-core-drivers                             2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - driverless printing
ii  cups-daemon                                   2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters                                  1.27.4-1                            amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers                     1.27.4-1                            amd64        OpenPrinting CUPS Filters - Driverless printing
ii  cups-ipp-utils                                2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - IPP developer/admin utilities
ii  cups-pk-helper                                0.2.6-1ubuntu3                      amd64        PolicyKit helper to configure cups with fine-grained privileges
ii  cups-ppdc                                     2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
ii  cups-server-common                            2.3.1-9ubuntu1.1                    all          Common UNIX Printing System(tm) - server common files
ii  libcups2:amd64                                2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - Core library
ii  libcups2-dev:amd64                            2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - Development files CUPS library
ii  libcupsfilters-dev:amd64                      1.27.4-1                            amd64        OpenPrinting CUPS Filters - Development files for the library
ii  libcupsfilters1:amd64                         1.27.4-1                            amd64        OpenPrinting CUPS Filters - Shared library
ii  libcupsimage2:amd64                           2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - Raster image library
ii  libcupsimage2-dev:amd64                       2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - Development files CUPS image library
ii  python3-cups                                  1.9.73-3build1                      amd64        Python3 bindings for CUPS
ii  python3-cupshelpers                           1.5.12-0ubuntu1.1                   all          Python utility modules around the CUPS printing system
xianne@xianne-G5429fr:~$ 
xianne@xianne-G5429fr:~$ lpstat -t
scheduler is running
no system default destination
lpstat: Aucune destination ajoutée.
lpstat: Aucune destination ajoutée.
lpstat: Aucune destination ajoutée.
lpstat: Aucune destination ajoutée.
xianne@xianne-G5429fr:~$ 
xianne@xianne-G5429fr:~$ /usr/sbin/lpinfo -v
network https
network beh
network http
network lpd
network ipps
network socket
file cups-brf:/
network ipp
network dnssd://HP%20DeskJet%202700%20series%20%5BE14CD8%5D._ipp._tcp.local/?uuid=0a6c157a-3fcb-7db9-bbf6-ea3c2ee15f7e
network socket://192.168.1.14:9100
network ipp://HP%20DeskJet%202700%20series%20%5BE14CD8%5D._ipp._tcp.local/
xianne@xianne-G5429fr:~$ 
xianne@xianne-G5429fr:~$ cat /var/log/cups/error_log
xianne@xianne-G5429fr:~$ 
xianne@xianne-G5429fr:~$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                           Version                             Architecture Description
+++-=============================================-===================================-============-======================================================================================================
rc  hplip                                         3.20.3+dfsg0-2                      amd64        HP Linux Printing and Imaging System (HPLIP)
rc  hplip-gui                                     3.20.3+dfsg0-2                      all          HP Linux Printing and Imaging - GUI utilities (Qt-based)
rc  libkf5contacts-data                           5:5.68.0-0ubuntu1                   all          data files for kcontacts
rc  libkf5people-data                             5.68.0-0ubuntu1                     all          data files for kpeople
rc  libsane-hpaio:amd64                           3.20.3+dfsg0-2                      amd64        HP SANE backend for multi-function peripherals
rc  linux-image-5.4.0-56-generic                  5.4.0-56.62                         amd64        Signed kernel image generic
rc  linux-image-5.4.0-58-generic                  5.4.0-58.64                         amd64        Signed kernel image generic
rc  linux-image-5.4.0-59-generic                  5.4.0-59.65                         amd64        Signed kernel image generic
rc  linux-image-5.4.0-60-generic                  5.4.0-60.67                         amd64        Signed kernel image generic
rc  linux-image-5.4.0-62-generic                  5.4.0-62.70                         amd64        Signed kernel image generic
rc  linux-modules-5.4.0-56-generic                5.4.0-56.62                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-58-generic                5.4.0-58.64                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-59-generic                5.4.0-59.65                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-60-generic                5.4.0-60.67                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-62-generic                5.4.0-62.70                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-56-generic          5.4.0-56.62                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-58-generic          5.4.0-58.64                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-59-generic          5.4.0-59.65                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-60-generic          5.4.0-60.67                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-62-generic          5.4.0-62.70                         amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP


Résumé de la résolution du problème :
---------------------------------------------------

J'ai téléchargé hplip-3.20.11.run depuis le site

https://developers.hp.com/hp-linux-imaging-and-printing

Et j'ai choisi le mode d'installation conseillé dans la doc : hplip
. en mode "custom"
. avec l'option sans support graphique (sans GUI)
. sans fax
. en mode interactif au moment d'installer l'imprimante

L'installateur est lancé par la commande :

sh hplip-3.20.11.run

Pour éviter toutes les "required dependencies" manquantes qui empêchent l'installateur de fonctionner, j'ai dû installer par apt-get :
. python3-pip
. python3-pyqt5
. python3-pil
. python-pil

Et puis, pour pip2, j'ai téléchargé une version inférieure à celle des paquets depuis :
bootstrap get-pip

J'ai soumis les commandes :

sudo python2 get-pip.py
sudo pip install --upgrade pip

Au final, j'ai lancé l'installateur de hplip par la commande :

sh hplip-3.20.11.run

J'ai ensuite contourné le problème de liaison USB proposé par le §9.1 de la doc hplip :
$ hp-setup -ir
$ sudo apt-get remove ippusbxd
arrêter et relancer l'imprimante et le PC,
$ hp-setup

L'icône "imprimante" fait maintenant fonctionner l'impression dans de nombreux logiciels comme Editeur de texte, LibreOffice Writer, Visionneur de documents, etc...

J'ai enfin permis à la numérisation de fonctionner en installant le hp-plugin.

Dernière modification par xianbroc (Le 03/03/2021, à 01:28)

Hors ligne

#2 Le 14/02/2021, à 14:18

abelthorne

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

J'ai essayé d'installer hplip 3.20.11 qui est donné pour supporter ubuntu 20.10

Qu'est-ce que tu as installé exactement et comment ?

Hors ligne

#3 Le 14/02/2021, à 19:03

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

J'ai téléchargé hplip-3.20.11.run depuis le site

https://sourceforge.net/projects/hplip/files/hplip/3.20.11/hplip-3.20.11.run/download?use_mirror=nchc

ou depuis le site

https://developers.hp.com/hp-linux-imaging-and-printing

J'ai lancé la commande

sh hplip-3.20.11.run

Et j'ai choisi le mode d'installation "automatique".

Dernière modification par xianbroc (Le 17/02/2021, à 11:31)

Hors ligne

#4 Le 14/02/2021, à 19:16

grigouille

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Pour ubuntu 20.10, la version d'hplip est 3.20.5 et ton imprimante a besoin d'hplip >= 3.20.5.

Pouquoi veux-tu installer hplip 3.20.11 alors ?


Xubuntu 20.04
HP LaserJet M1132 MFP

Hors ligne

#5 Le 14/02/2021, à 19:24

abelthorne

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Il est en 20.04 (HPLIP 3.20.3).

xianbroc : Ce n'est pas du tout une bonne idée de mélanger l'installation par paquets (utilisée par Ubuntu) avec une installation par script (qui fait on ne sait quoi) pour les mêmes éléments. Les chances de tout casser sont d'environ 100 %, à moins que ton script génère et installe un paquet deb (format de paquet utilisé sur Ubuntu).

Là, il faudrait idéalement désinstaller la version .run (la façon de le faire dépend entièrement de celle-ci, il n'y a aucune standardisation sur ce genre de méthode), réinstaller HPLIP depuis les dépôts, puis trouver un moyen de le mettre à jour en deb. Ça peut être via un PPA s'il en existe un, via des paquets à installer manuellement (peut-être que HP en fournit), ou éventuellement en voyant s'il est possible de récupérer les paquets des dépôts 20.10 pour les installer (en fonction des dépendances, ça peut être possible ou non).

Dernière modification par abelthorne (Le 14/02/2021, à 19:24)

Hors ligne

#6 Le 14/02/2021, à 22:06

grigouille

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Ubuntu 20.04 : la doc hplip te suggère de faire une installation "custom".


Xubuntu 20.04
HP LaserJet M1132 MFP

Hors ligne

#7 Le 14/02/2021, à 23:18

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

grigouille a écrit :

Pouquoi veux-tu installer hplip 3.20.11 alors ?

En défaveur de la 3.20.5 je lis dans la doc
https://sourceforge.net/p/hplip/news/20 … ase-notes/
que

USB print and scan will not work on Vasari and Taccola on Ubuntu 20.04, please refer to link below
http://manpages.ubuntu.com/manpages/cosmic/man8/ippusbxd.8.html

En faveur de la 3.20.11 il est écrit que

The Automatic Installer is known to work on the following Linux Distributions:

    SUSE Linux (...)
    Ubuntu (12.04, 14.04, 15.10, 16.04, 16.10, 17.04,17.10,18.04,18.10,19.04,19.10,20.04,20.10)
    (...) 

Je n'y connais guère en installation de drivers. Je lis d'un côté "will not work" et de l'autre "is known to work". C'est la raison de mon choix.
Mais maintenant que des personnes compétentes sont prêtes à m'épauler, je choisis de suivre leurs conseils et de réparer mes errements ou mes erreurs.
Je pars donc vers la 3.20.5

Hors ligne

#8 Le 14/02/2021, à 23:36

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

abelthorne a écrit :

Ce n'est pas du tout une bonne idée de mélanger l'installation par paquets (utilisée par Ubuntu) avec une installation par script

Merci pour ce conseil d'ordre général. Je m'en souviendrai et veillerai à l'appliquer.

abelthorne a écrit :

il faudrait idéalement désinstaller la version .run

J'ai lancé la commande suivante :

sudo python3 ./uninstall.py

qui a répondu

error: HPLIP is not installed.

Alors j'espère que l'épisode 3.20.11 n'aura pas laissé de traces indélébiles.
Et je m'apprête à rm le hplip-3.20.11.run ainsi que le sous-répertoire qui a été généré. Correct ?

Ensuite, pour suivre le conseil de grigouille, je me lancerai dans l'installation "custom" du paquet hplip-3.20.5

Hors ligne

#9 Le 14/02/2021, à 23:47

abelthorne

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Concernant la désinstallation, je ne saurais pas te dire si tu as tapé la commande correcte. Ça me semble un peu bizarre qu'il ne trouve pas  HPLIP alors qu'il est censé avoir été installé par le .run. Pas sûr que ce soit la bonne commande.

L'installation custom de la 3.20.5, ça va être kif-kif, ça reste une installation manuelle.

Personnellement, je tenterais plutôt une installation des paquets en version groovy (20.10) si c'est possible depuis packages.ubuntu.com, il faudrait voir les dépendances (il y a au moins 5 paquets concernés).

Dernière modification par abelthorne (Le 14/02/2021, à 23:47)

Hors ligne

#10 Le 14/02/2021, à 23:58

grigouille

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Installe la dernière version d'hplip en mode custom. Lis la doc hplip.


Xubuntu 20.04
HP LaserJet M1132 MFP

Hors ligne

#11 Le 15/02/2021, à 00:37

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

abelthorne a écrit :

Ça me semble un peu bizarre qu'il ne trouve pas  HPLIP alors qu'il est censé avoir été installé par le .run.

L'installation n'a pas été jusqu'au bout : le code est sorti en erreur. Les dernières lignes étaient :

RE-CHECKING DEPENDENCIES
------------------------
error: A required dependency 'pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without this dependency.
error: Please manually install this dependency and re-run this installer.

J'ai l'impression qu'il n'y a donc rien à désinstaller. Vrai ?

Hors ligne

#12 Le 15/02/2021, à 00:40

abelthorne

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Effectivement. Il faudrait installer python3-pyqt5.

Après, c'est toi qui vois mais si tu veux faire une installation manuelle, il faudrait supprimer les paquets HPLIP d'abord. Il reste hplip-data, tandis que hplip et hplip-gui ont des restes de fichiers de config.

Hors ligne

#13 Le 15/02/2021, à 03:19

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Selon grigouille, la 3.20.5 pourrait suffire. Alors j'ai téléchargé hplip-3.20.5.run
Et je l'ai lancé. Résultat : beaucoup de "failed to install" et au final un "error hp-systray"
Alors j'ai suivi le dernier post de grigouille

grigouille a écrit :

Installe la dernière version d'hplip en mode custom

OK. Je clique, je tombe sur la 3.20.11
Et je l'installe.

xianne@xianne-G5429fr:~$ sh hplip-3.20.11.run
Creating directory hplip-3.20.11
Verifying archive integrity... All good.
Uncompressing HPLIP 3.20.11 Self Extracting Archive...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.20.11)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Mon-15-Feb-2021_01:58:21.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
 

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : c


INTRODUCTION
------------
This installer will install HPLIP version 3.20.11 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Ubuntu 20.04.

Is "Ubuntu 20.04" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


DRIVER OPTIONS
--------------
Would you like to install Custom Discrete Drivers or Class Drivers ( 'd'= Discrete Drivers*,'c'= Class Drivers,'q'= Quit)?   : d

Initializing. Please wait...


SELECT HPLIP OPTIONS
--------------------
You can select which HPLIP options to enable. Some options require extra dependencies.

Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ? y
Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? y
Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ? y


ENTER USER PASSWORD
-------------------
Please enter the sudoer (xianne)'s password: 
 

INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information.  Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit: 


SECURITY PACKAGES
-----------------
AppArmor is installed. 
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? y


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


RUNNING HPLIP LIBS REMOVE COMMANDS
----------------------------------
sudo apt-get remove libhpmud0 libsane-hpaio
sudo apt-get remove libhpmud0 libsane-hpaio ( hp_libs_remove step 1)
OK


MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
pil                  scan                 OPTIONAL            
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? y


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.


INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing OPTIONAL dependency for option 'scan': pil (PIL - Python Imaging Library (required for commandline scanning with hp-scan))
warning: This installer cannot install 'pil' for your distro/OS and/or version.


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
warning: An error occurred running 'sudo apt-get update'
sudo apt-get update (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
HPLIP-3.20.5 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install*, 'q'= Quit)?    :i
Starting uninstallation...
HPLIP uninstallation is completed


RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK


RE-CHECKING DEPENDENCIES
------------------------
warning: An optional dependency 'pil (PIL - Python Imaging Library (required for commandline scanning with hp-scan))' is still missing.
warning: Some features may not function as expected.


RUNNING SCANJET DEPENDENCY COMMANDS
-----------------------------------
sudo apt-get install --assume-yes python-pip (Scanjet-depend step 1)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo pip2 install --upgrade pip (Scanjet-depend step 2)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo apt-get install --assume-yes libleptonica-dev (Scanjet-depend step 3)
sudo apt-get install --assume-yes tesseract-ocr (Scanjet-depend step 4)
sudo apt-get install --assume-yes libtesseract-dev (Scanjet-depend step 5)
sudo -H pip2 install tesserocr (Scanjet-depend step 6)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo apt-get install --assume-yes tesseract-ocr-all (Scanjet-depend step 7)
sudo apt-get install --assume-yes libzbar-dev (Scanjet-depend step 8)
sudo apt-get install --assume-yes python-zbar (Scanjet-depend step 9)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install opencv-python (Scanjet-depend step 10)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install PyPDF2 (Scanjet-depend step 11)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install imutils (Scanjet-depend step 12)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install pypdfocr (Scanjet-depend step 13)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install scikit-image (Scanjet-depend step 14)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install scipy (Scanjet-depend step 15)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
OK


READY TO BUILD AND INSTALL
--------------------------
Ready to perform build and install. Press <enter> to continue or 'q' to quit: 


PRE-BUILD COMMANDS
------------------
OK


BUILD AND INSTALL
-----------------
Running './configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib --prefix=/usr --disable-qt4 --disable-qt5 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-libusb01_build --disable-foomatic-ppd-install --disable-hpijs-install --disable-class-driver --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --disable-fax-build --enable-apparmor_build'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make clean'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make'
Please wait, this may take several minutes...
Command completed successfully.

Running 'sudo make install'
Please wait, this may take several minutes...
Command completed successfully.


Build complete.



POST-BUILD COMMANDS
-------------------
 

CLOSE HP_SYSTRAY
----------------
Sending close message to hp-systray (if it is currently running)...
OK


HPLIP UPDATE NOTIFICATION
-------------------------
Do you want to check for HPLIP updates?. (y=yes*, n=no) : y


RESTART OR RE-PLUG IS REQUIRED
------------------------------
If you are installing a USB connected printer, and the printer was plugged in when you started this installer, you will need to either restart your PC or unplug and re-plug in your printer (USB cable    
only). If you choose to restart, run this command after restarting: hp-setup (Note: If you are using a parallel connection, you will have to restart your PC. If you are using network/wireless, you can   
ignore and continue).                                                                                                                                                                                      

Restart or re-plug in your printer (r=restart, p=re-plug in*, i=ignore/continue, q=quit) : p
Please unplug and re-plugin your printer now.  Press <enter> to continue or 'q' to quit: 


PRINTER SETUP
-------------
Would you like to setup a printer now (y=yes*, n=no, q=quit) ? y
Please make sure your printer is connected and powered on at this time.
Do you want to setup printer in GUI mode? (u=GUI mode*, i=Interactive mode) : i
Running 'hp-setup  -i' command....

HP Linux Imaging and Printing System (ver. 3.20.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                               
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)

Enter number 0...1 for connection type (q=quit, enter=usb*) ? 0

Using connection type: usb

 
Setting up device: hp:/usb/DeskJet_2700_series?serial=CN0CR5W5FK



---------------------
| PRINT QUEUE SETUP |
---------------------

warning: One or more print queues already exist for this device: DeskJet_2700.

Would you like to install another print queue for this device (y=yes, n=no*, q=quit) ? n


Done.


RE-STARTING HP_SYSTRAY
----------------------

HP Linux Imaging and Printing System (ver. 3.20.11)
System Tray Status Service ver. 2.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: GUI Modules PyQt4 and PyQt5 are not installed
error: hp-systray requires Qt4 GUI and DBus support. Exiting.

Beaucoup de "failed to install" et au final un "error hp-systray". Je suis un peu perdu...

Hors ligne

#14 Le 15/02/2021, à 09:37

abelthorne

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Manifestement, tous les "failed to install" viennent d'éléments qu'il essaie d'installer via pip2. Est-ce que ce dernier est installé ? Cela dit, ce sont peut-être des fonctionnalités optionnelles qui n'empêchent pas l'installation du bouzin.

À la fin, il te dit qu'il n'arrive pas à lancer hp-systray (vraisemblablement le soft qui affiche l'icône dans le systray, la zone de notification) parce qu'il manque les (ou un ?) module(s) PyQt4 et PyQt5. Tout ce qui est Qt4 a été supprimé des dépôts Ubuntu 20.04 mais est-ce que tu as installé python3-pyqt5 comme indiqué dans mon précédent message ?

Hors ligne

#15 Le 15/02/2021, à 12:09

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

abelthorne a écrit :

Est-ce que ce dernier est installé

J'installe par apt-get :
. python3-pip
. python3-pyqt5
. python3-pil
. python-pil
Et je recommence. A suivre...

Hors ligne

#16 Le 15/02/2021, à 12:20

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

J'ai moins d'erreurs, mais ça n'est pas encore ça...

$ sh hplip-3.20.11.run
Creating directory hplip-3.20.11
Verifying archive integrity... All good.
Uncompressing HPLIP 3.20.11 Self Extracting Archive...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.20.11)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Mon-15-Feb-2021_11:12:02.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
 

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : c


INTRODUCTION
------------
This installer will install HPLIP version 3.20.11 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Ubuntu 20.04.

Is "Ubuntu 20.04" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


DRIVER OPTIONS
--------------
Would you like to install Custom Discrete Drivers or Class Drivers ( 'd'= Discrete Drivers*,'c'= Class Drivers,'q'= Quit)?   : d

Initializing. Please wait...


SELECT HPLIP OPTIONS
--------------------
You can select which HPLIP options to enable. Some options require extra dependencies.

Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ? y
Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? y
Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ? y


ENTER USER PASSWORD
-------------------
Please enter the sudoer (xianne)'s password: 
 

INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information.  Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit: 


SECURITY PACKAGES
-----------------
AppArmor is installed. 
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? 


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


RUNNING HPLIP LIBS REMOVE COMMANDS
----------------------------------
sudo apt-get remove libhpmud0 libsane-hpaio
sudo apt-get remove libhpmud0 libsane-hpaio ( hp_libs_remove step 1)
OK


MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? 


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.


RUNNING SCANJET DEPENDENCY COMMANDS
-----------------------------------
sudo apt-get install --assume-yes python-pip (Scanjet-depend step 1)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo pip2 install --upgrade pip (Scanjet-depend step 2)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo apt-get install --assume-yes libleptonica-dev (Scanjet-depend step 3)
sudo apt-get install --assume-yes tesseract-ocr (Scanjet-depend step 4)
sudo apt-get install --assume-yes libtesseract-dev (Scanjet-depend step 5)
sudo -H pip2 install tesserocr (Scanjet-depend step 6)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo apt-get install --assume-yes tesseract-ocr-all (Scanjet-depend step 7)
sudo apt-get install --assume-yes libzbar-dev (Scanjet-depend step 8)
sudo apt-get install --assume-yes python-zbar (Scanjet-depend step 9)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install opencv-python (Scanjet-depend step 10)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install PyPDF2 (Scanjet-depend step 11)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install imutils (Scanjet-depend step 12)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install pypdfocr (Scanjet-depend step 13)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install scikit-image (Scanjet-depend step 14)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install scipy (Scanjet-depend step 15)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
OK


READY TO BUILD AND INSTALL
--------------------------
Ready to perform build and install. Press <enter> to continue or 'q' to quit: 


PRE-BUILD COMMANDS
------------------
OK


BUILD AND INSTALL
-----------------
Running './configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib --prefix=/usr --disable-qt4 --disable-qt5 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-libusb01_build --disable-foomatic-ppd-install --disable-hpijs-install --disable-class-driver --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --disable-fax-build --enable-apparmor_build'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make clean'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make'
Please wait, this may take several minutes...
Command completed successfully.

Running 'sudo make install'
Please wait, this may take several minutes...
Command completed successfully.


Build complete.



POST-BUILD COMMANDS
-------------------
OK


HPLIP UPDATE NOTIFICATION
-------------------------
Do you want to check for HPLIP updates?. (y=yes*, n=no) : 


RESTART OR RE-PLUG IS REQUIRED
------------------------------
If you are installing a USB connected printer, and the printer was plugged in when you started this installer, you will need to either restart your PC or unplug  
and re-plug in your printer (USB cable only). If you choose to restart, run this command after restarting: hp-setup (Note: If you are using a parallel connection,
you will have to restart your PC. If you are using network/wireless, you can ignore and continue).                                                                

Restart or re-plug in your printer (r=restart, p=re-plug in*, i=ignore/continue, q=quit) : 
Please unplug and re-plugin your printer now.  Press <enter> to continue or 'q' to quit: 


PRINTER SETUP
-------------
Would you like to setup a printer now (y=yes*, n=no, q=quit) ? 
Please make sure your printer is connected and powered on at this time.
Do you want to setup printer in GUI mode? (u=GUI mode*, i=Interactive mode) : i
Running 'hp-setup  -i' command....

HP Linux Imaging and Printing System (ver. 3.20.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                               
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)

Enter number 0...1 for connection type (q=quit, enter=usb*) ? 0

Using connection type: usb

 
Setting up device: hp:/usb/DeskJet_2700_series?serial=CN0CR5W5FK



---------------------
| PRINT QUEUE SETUP |
---------------------

warning: One or more print queues already exist for this device: DeskJet_2700.

Would you like to install another print queue for this device (y=yes, n=no*, q=quit) ? y

Please enter a name for this print queue (m=use model name:'DeskJet_2700_2'*, q=quit) ?
Using queue name: DeskJet_2700_2
Locating PPD file... Please wait.

Found PPD file: drv:///hp/hpcups.drv/hp-deskjet_2700_series.ppd
Description: 

Note: The model number may vary slightly from the actual model number on the device.

Does this PPD file appear to be the correct one (y=yes*, n=no, q=quit) ? 
Enter a location description for this printer (q=quit) ?Bureau
Enter additonal information or notes for this printer (q=quit) ?hplip 3.20.11 cyd

Adding print queue to CUPS:
Device URI: hp:/usb/DeskJet_2700_series?serial=CN0CR5W5FK
Queue name: DeskJet_2700_2
PPD file: drv:///hp/hpcups.drv/hp-deskjet_2700_series.ppd
Location: Bureau
Information: hplip 3.20.11 cyd


---------------------
| PRINTER TEST PAGE |
---------------------


Would you like to print a test page (y=yes*, n=no, q=quit) ? 

HP Linux Imaging and Printing System (ver. 3.20.11)
Testpage Print Utility ver. 6.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Unable to connect to dbus. Is hp-systray running?
error: Unable to communicate with device (code=12): hp:/usb/DeskJet_2700_series?serial=CN0CR5W5FK
error: Unable to print to printer. Please check device and try again.

note: If an error occured, or the test page failed to print, refer to the HPLIP website
note: at: http://hplip.sourceforge.net for troubleshooting and support.


Done.


RE-STARTING HP_SYSTRAY
----------------------

HP Linux Imaging and Printing System (ver. 3.20.11)
System Tray Status Service ver. 2.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: GUI Modules PyQt4 and PyQt5 are not installed
error: hp-systray requires Qt4 GUI and DBus support. Exiting.

Hors ligne

#17 Le 15/02/2021, à 13:13

abelthorne

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Attention à un détail : il essaie d'installer les éléments avec pip2, le paquet python3-pip concerne a priori pip tout court. Pas sûr que pip2 soit dans les dépôts Ubuntu, il va peut-être falloir l'installer autrement (PPA, installation manuelle...).

Concernant hp-systray, soit il manque d'autres paquets en plus de python3-pyqt5 en rapport avec, soit il veut aussi PyQt4. Ce serait étonnant : comme il parle des deux, je suppose qu'il se contente de l'un ou l'autre, mais si il veut forcément avoir PyQt4 installé, ça va être problématique : il n'y a plus du tout de Qt4 dans les dépôts Ubuntu.

Hors ligne

#18 Le 15/02/2021, à 16:28

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

J'ai téléchargé une version inférieure depuis :
https://bootstrap.pypa.io/2.6/get-pip.py.

J'ai soumis la commande :
sudo python2 get-pip.py

Et puis :
sudo pip install --upgrade pip

Au final, ça donne du mieux et du moins bien

$ sh hplip-3.20.11.run
Creating directory hplip-3.20.11
Verifying archive integrity... All good.
Uncompressing HPLIP 3.20.11 Self Extracting Archive...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.20.11)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Mon-15-Feb-2021_14:56:21.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
 

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : c


INTRODUCTION
------------
This installer will install HPLIP version 3.20.11 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Ubuntu 20.04.

Is "Ubuntu 20.04" your correct distro/OS and version (y=yes*, n=no, q=quit) ? 


DRIVER OPTIONS
--------------
Would you like to install Custom Discrete Drivers or Class Drivers ( 'd'= Discrete Drivers*,'c'= Class Drivers,'q'= Quit)?   : 

Initializing. Please wait...


SELECT HPLIP OPTIONS
--------------------
You can select which HPLIP options to enable. Some options require extra dependencies.

Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ? 
Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? 
Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ? 


ENTER USER PASSWORD
-------------------
Please enter the sudoer (xianne)'s password: 
 

INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information.  Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit: 


SECURITY PACKAGES
-----------------
AppArmor is installed. 
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? 


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


RUNNING HPLIP LIBS REMOVE COMMANDS
----------------------------------
sudo apt-get remove libhpmud0 libsane-hpaio
sudo apt-get remove libhpmud0 libsane-hpaio ( hp_libs_remove step 1)
OK


MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? 


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.


RUNNING SCANJET DEPENDENCY COMMANDS
-----------------------------------
sudo apt-get install --assume-yes python-pip (Scanjet-depend step 1)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo pip2 install --upgrade pip (Scanjet-depend step 2)
sudo apt-get install --assume-yes libleptonica-dev (Scanjet-depend step 3)
sudo apt-get install --assume-yes tesseract-ocr (Scanjet-depend step 4)
sudo apt-get install --assume-yes libtesseract-dev (Scanjet-depend step 5)
sudo -H pip2 install tesserocr (Scanjet-depend step 6)
sudo apt-get install --assume-yes tesseract-ocr-all (Scanjet-depend step 7)
sudo apt-get install --assume-yes libzbar-dev (Scanjet-depend step 8)
sudo apt-get install --assume-yes python-zbar (Scanjet-depend step 9)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install opencv-python (Scanjet-depend step 10)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install PyPDF2 (Scanjet-depend step 11)
sudo -H pip2 install imutils (Scanjet-depend step 12)
sudo -H pip2 install pypdfocr (Scanjet-depend step 13)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install scikit-image (Scanjet-depend step 14)
sudo -H pip2 install scipy (Scanjet-depend step 15)
OK


READY TO BUILD AND INSTALL
--------------------------
Ready to perform build and install. Press <enter> to continue or 'q' to quit: 


PRE-BUILD COMMANDS
------------------
OK


BUILD AND INSTALL
-----------------
Running './configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib --prefix=/usr --disable-qt4 --disable-qt5 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-libusb01_build --disable-foomatic-ppd-install --disable-hpijs-install --disable-class-driver --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --disable-fax-build --enable-apparmor_build'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make clean'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make'
Please wait, this may take several minutes...
Command completed successfully.

Running 'sudo make install'
Please wait, this may take several minutes...
Command completed successfully.


Build complete.



POST-BUILD COMMANDS
-------------------
OK


HPLIP UPDATE NOTIFICATION
-------------------------
Do you want to check for HPLIP updates?. (y=yes*, n=no) : 


RESTART OR RE-PLUG IS REQUIRED
------------------------------
If you are installing a USB connected printer, and the printer was plugged in when you started this installer, you will need to either restart your PC or unplug  
and re-plug in your printer (USB cable only). If you choose to restart, run this command after restarting: hp-setup (Note: If you are using a parallel connection,
you will have to restart your PC. If you are using network/wireless, you can ignore and continue).                                                                

Restart or re-plug in your printer (r=restart, p=re-plug in*, i=ignore/continue, q=quit) : 
Please unplug and re-plugin your printer now.  Press <enter> to continue or 'q' to quit: 


PRINTER SETUP
-------------
Would you like to setup a printer now (y=yes*, n=no, q=quit) ? 
Please make sure your printer is connected and powered on at this time.
Do you want to setup printer in GUI mode? (u=GUI mode*, i=Interactive mode) : i
Running 'hp-setup  -i' command....

HP Linux Imaging and Printing System (ver. 3.20.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                               
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)

Enter number 0...1 for connection type (q=quit, enter=usb*) ? 

Using connection type: usb

error: No device selected/specified or that supports this functionality.
error: hp-setup failed. Please run hp-setup manually.


RE-STARTING HP_SYSTRAY
----------------------

HP Linux Imaging and Printing System (ver. 3.20.11)
System Tray Status Service ver. 2.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: GUI Modules PyQt4 and PyQt5 are not installed
error: hp-systray requires Qt4 GUI and DBus support. Exiting.

Hors ligne

#19 Le 15/02/2021, à 22:07

grigouille

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Laisse râler l'installateur. As-tu essayé de faire fonctionner ton imprimante/scanner ?

Sinon, j'ai vu ceci durant l'installation :

xianbroc a écrit :
warning: An error occurred running 'sudo apt-get update'

Donne

sudo apt-get update

Tu es sur une installation fraîche d'Ubuntu 20.04 bien sûr.


Xubuntu 20.04
HP LaserJet M1132 MFP

Hors ligne

#20 Le 15/02/2021, à 23:03

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Focal Fossa : j'ai mis à jour Ubuntu le 06/10/2020

Réponse de apt-get update :

sudo apt-get update
[sudo] Mot de passe de xianne : 
Atteint :1 http://ppa.launchpad.net/costales/yaru-colors-folder-color/ubuntu focal InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal InRelease        
Réception de :3 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Réception de :4 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Atteint :5 http://ppa.launchpad.net/micahflee/ppa/ubuntu focal InRelease       
Réception de :6 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Ign :7 http://ppa.launchpad.net/vikoadi/ppa/ubuntu focal InRelease    
Err :8 http://ppa.launchpad.net/vikoadi/ppa/ubuntu focal Release      
  404  Not Found [IP : 2001:67c:1560:8008::19 80]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [421 kB]
Réception de :10 http://security.ubuntu.com/ubuntu focal-security/main i386 Packages [183 kB]
Réception de :11 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [807 kB]
Réception de :12 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [489 kB]
Réception de :13 http://fr.archive.ubuntu.com/ubuntu focal-updates/main Translation-en [195 kB]
Réception de :14 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [264 kB]
Réception de :15 http://security.ubuntu.com/ubuntu focal-security/main Translation-en [107 kB]
Réception de :16 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24,2 kB]
Réception de :17 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [57,5 kB]
Réception de :18 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [11,8 kB]
Réception de :19 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [549 kB]
Réception de :20 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [740 kB]
Réception de :21 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [301 kB]
Réception de :22 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe DEP-11 64x64 Icons [347 kB]
Réception de :23 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata [15,6 kB]
Réception de :24 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2464 B]
Réception de :25 http://fr.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1764 B]
Lecture des listes de paquets... Fait                            
E: Le dépôt http://ppa.launchpad.net/vikoadi/ppa/ubuntu focal Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

Hors ligne

#21 Le 15/02/2021, à 23:41

ylag

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Bonsoir,

Pour cette erreur:

E: Le dépôt http://ppa.launchpad.net/vikoadi/ppa/ubuntu focal Release n'a pas de fichier Release.

Ce ppa n'as pas de section pour Focal 20.04, il faut le supprimer des sources:

sudo add-apt-repository --remove ppa:vikoadi/ppa



abelthorne au #9 a écrit :

Concernant la désinstallation, je ne saurais pas te dire si tu as tapé la commande correcte. Ça me semble un peu bizarre qu'il ne trouve pas  HPLIP alors qu'il est censé avoir été installé par le .run. Pas sûr que ce soit la bonne commande.

Pour désinstaller le hplip-*.run, il faut se placer dans le dossier d'extraction de l'archive et passer la commande:

sudo make uninstall

Par exemple, si on a téléchargé hplip-3.20.11.run dans son ~/Téléchargements et qu'on en a lancé l'installation à partir de là, un dossier d'extraction nommé
hplip-3.20.11 devrait avoir été créé à ~/Téléchargements/hplip-3.20.11

Pour désinstaller hplip-3.20.11, on ferait:

cd ~/Téléchargements/hplip-3.20.11 ; sudo make uninstall

...je ne sais pas si le script effectue un désinstallation «propre», ou s'il resterait des résidus...?

Le script python uninstall.py mentionné au commentaire #8 est utilisé par l'installation de hplip-*.run pour supprimer une éventuelle version de hplip déjà présente, qui aurait été installée via les dépôts réguliers.

A+

Dernière modification par ylag (Le 16/02/2021, à 00:01)

Hors ligne

#22 Le 16/02/2021, à 00:14

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

grigouille a écrit :

As-tu essayé de faire fonctionner ton imprimante/scanner ?

En voilà une bonne idée !

Je sélectionne un fichier txt de 4 lignes. Je l'ouvre avec "Editeur de texte". Je clique l'icône "imprimante". Un fenêtre intitulée "Imprimer" s'ouvre avec une liste de 5 imprimantes correspondant peu ou prou à mes différentes tentatives d'installation. Il semble que seule la dernière fonctionne ; car elle fonctionne !!!

Fonctionne aussi avec "LibreOffice Writer".
Fonctionne aussi avec "Visionneur de documents" pour un pdf.

Si je scanne avec "Numériseur de documents" j'obtiens une image à enregistrer.
Je découvre une appli hp-uiscan qui ne fonctionne pas : aucune fenêtre de dialogue ne s'ouvre.
Je découvre une appli "xsane 0.999" qui semble prête à numériser dans le cas où j'utilise la dernière des 4 imprimantes proposées.

Question : comment de la liste des imprimantes, supprimer celles qui ne fonctionnent pas pour ne garder que celle qui fonctionne (la dernière) ?

Hors ligne

#23 Le 16/02/2021, à 00:18

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

ylag a écrit :

Ce ppa n'as pas de section pour Focal 20.04, il faut le supprimer des sources:

OK. C'est fait. Réponse de apt-get update :

$ sudo apt-get update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://ppa.launchpad.net/costales/yaru-colors-folder-color/ubuntu focal InRelease
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease 
Atteint :4 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease                       
Atteint :5 http://ppa.launchpad.net/micahflee/ppa/ubuntu focal InRelease                       
Réception de :6 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]            
Réception de :7 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24,3 kB]
Réception de :8 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [57,5 kB]
191 ko réceptionnés en 1s (130 ko/s)         
Lecture des listes de paquets... Fait

Nickel

Hors ligne

#24 Le 16/02/2021, à 00:58

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

ylag a écrit :

Pour désinstaller le hplip-*.run, il faut

Je viens de le faire pour la hplip-20.3.5. Ça a bien commencé et ça s'est arrêté sur un

/bin/bash: ligne 4 : cd: /usr/share/doc/hplip-3.20.5: Aucun fichier ou dossier de ce type
make: *** [Makefile:8965 : uninstall-dist_www0DATA] Erreur 1

Peut-être parce que lors d'un ménage précédent je l'ai détruit "a la mano"...

Pour la 20.3.11, lors de chaque run, l'installeur a demandé à désinstaller la version déjà installée même si c'était aussi une 20.3.11 (pour éviter les conflits je suppose). Et j'ai accepté à chaque fois. Donc je pense que la désinstallation a été effectuée proprement.

Dernière modification par xianbroc (Le 16/02/2021, à 01:49)

Hors ligne

#25 Le 16/02/2021, à 01:59

xianbroc

Re : [Résolu] hplip et ubuntu 20.04 pour une HP DeskJet 2722

Et au final, un run donne :

$ sh hplip-3.20.11.run
Creating directory hplip-3.20.11
Verifying archive integrity... All good.
Uncompressing HPLIP 3.20.11 Self Extracting Archive...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.20.11)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Mon-15-Feb-2021_23:32:45.log

\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
 

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : c


INTRODUCTION
------------
This installer will install HPLIP version 3.20.11 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Ubuntu 20.04.

Is "Ubuntu 20.04" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


DRIVER OPTIONS
--------------
Would you like to install Custom Discrete Drivers or Class Drivers ( 'd'= Discrete Drivers*,'c'= Class Drivers,'q'= Quit)?   : d

Initializing. Please wait...


SELECT HPLIP OPTIONS
--------------------
You can select which HPLIP options to enable. Some options require extra dependencies.

Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ? y
Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? n
Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? y
Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ? y


ENTER USER PASSWORD
-------------------
Please enter the sudoer (xianne)'s password: 
 

INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information.  Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit: 


SECURITY PACKAGES
-----------------
AppArmor is installed. 
AppArmor protects the application from external intrusion attempts making the application secure

Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? y


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


RUNNING HPLIP LIBS REMOVE COMMANDS
----------------------------------
sudo apt-get remove libhpmud0 libsane-hpaio
sudo apt-get remove libhpmud0 libsane-hpaio ( hp_libs_remove step 1)
OK


MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? 


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo apt-get update (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
HPLIP-3.20.11 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install*, 'q'= Quit)?    :i
Starting uninstallation...
HPLIP uninstallation is completed


RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK


RE-CHECKING DEPENDENCIES
------------------------
OK


RUNNING SCANJET DEPENDENCY COMMANDS
-----------------------------------
sudo apt-get install --assume-yes python-pip (Scanjet-depend step 1)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo pip2 install --upgrade pip (Scanjet-depend step 2)
sudo apt-get install --assume-yes libleptonica-dev (Scanjet-depend step 3)
sudo apt-get install --assume-yes tesseract-ocr (Scanjet-depend step 4)
sudo apt-get install --assume-yes libtesseract-dev (Scanjet-depend step 5)
sudo -H pip2 install tesserocr (Scanjet-depend step 6)
sudo apt-get install --assume-yes tesseract-ocr-all (Scanjet-depend step 7)
sudo apt-get install --assume-yes libzbar-dev (Scanjet-depend step 8)
sudo apt-get install --assume-yes python-zbar (Scanjet-depend step 9)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install opencv-python (Scanjet-depend step 10)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install PyPDF2 (Scanjet-depend step 11)
sudo -H pip2 install imutils (Scanjet-depend step 12)
sudo -H pip2 install pypdfocr (Scanjet-depend step 13)
warning: Failed to install this Scanjet dependency package. Some Scanjet features will not work.
sudo -H pip2 install scikit-image (Scanjet-depend step 14)
sudo -H pip2 install scipy (Scanjet-depend step 15)
OK


READY TO BUILD AND INSTALL
--------------------------
Ready to perform build and install. Press <enter> to continue or 'q' to quit: 


PRE-BUILD COMMANDS
------------------
OK


BUILD AND INSTALL
-----------------
Running './configure --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib --prefix=/usr --disable-qt4 --disable-qt5 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-libusb01_build --disable-foomatic-ppd-install --disable-hpijs-install --disable-class-driver --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --disable-fax-build --enable-apparmor_build'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make clean'
Please wait, this may take several minutes...
Command completed successfully.

Running 'make'
Please wait, this may take several minutes...
Command completed successfully.

Running 'sudo make install'
Please wait, this may take several minutes...
Command completed successfully.


Build complete.



POST-BUILD COMMANDS
-------------------
 

CLOSE HP_SYSTRAY
----------------
Sending close message to hp-systray (if it is currently running)...
OK


HPLIP UPDATE NOTIFICATION
-------------------------
Do you want to check for HPLIP updates?. (y=yes*, n=no) : 


RESTART OR RE-PLUG IS REQUIRED
------------------------------
If you are installing a USB connected printer, and the printer was plugged in when you started this installer, you will need to either restart your 
PC or unplug and re-plug in your printer (USB cable only). If you choose to restart, run this command after restarting: hp-setup (Note: If you are  
using a parallel connection, you will have to restart your PC. If you are using network/wireless, you can ignore and continue).                     

Restart or re-plug in your printer (r=restart, p=re-plug in*, i=ignore/continue, q=quit) : 
Please unplug and re-plugin your printer now.  Press <enter> to continue or 'q' to quit: 


PRINTER SETUP
-------------
Would you like to setup a printer now (y=yes*, n=no, q=quit) ? 
Please make sure your printer is connected and powered on at this time.
Do you want to setup printer in GUI mode? (u=GUI mode*, i=Interactive mode) : i
Running 'hp-setup  -i' command....

HP Linux Imaging and Printing System (ver. 3.20.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)


--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                               
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)

Enter number 0...1 for connection type (q=quit, enter=usb*) ? 0

Using connection type: usb

 
Setting up device: hp:/usb/DeskJet_2700_series?serial=CN0CR5W5FK



---------------------
| PRINT QUEUE SETUP |
---------------------

warning: One or more print queues already exist for this device: DeskJet_2700, DeskJet_2700_2.

Would you like to install another print queue for this device (y=yes, n=no*, q=quit) ? y

Please enter a name for this print queue (m=use model name:'DeskJet_2700_3'*, q=quit) ?
Using queue name: DeskJet_2700_3
Locating PPD file... Please wait.

Found PPD file: drv:///hp/hpcups.drv/hp-deskjet_2700_series.ppd
Description: 

Note: The model number may vary slightly from the actual model number on the device.

Does this PPD file appear to be the correct one (y=yes*, n=no, q=quit) ? 
Enter a location description for this printer (q=quit) ?Bureau
Enter additonal information or notes for this printer (q=quit) ?hplip-20.3.11

Adding print queue to CUPS:
Device URI: hp:/usb/DeskJet_2700_series?serial=CN0CR5W5FK
Queue name: DeskJet_2700_3
PPD file: drv:///hp/hpcups.drv/hp-deskjet_2700_series.ppd
Location: Bureau
Information: hplip-20.3.11


---------------------
| PRINTER TEST PAGE |
---------------------


Would you like to print a test page (y=yes*, n=no, q=quit) ? 

HP Linux Imaging and Printing System (ver. 3.20.11)
Testpage Print Utility ver. 6.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Unable to connect to dbus. Is hp-systray running?
error: Unable to communicate with device (code=12): hp:/usb/DeskJet_2700_series?serial=CN0CR5W5FK
error: Unable to print to printer. Please check device and try again.

note: If an error occured, or the test page failed to print, refer to the HPLIP website
note: at: http://hplip.sourceforge.net for troubleshooting and support.


Done.


RE-STARTING HP_SYSTRAY
----------------------

HP Linux Imaging and Printing System (ver. 3.20.11)
System Tray Status Service ver. 2.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: GUI Modules PyQt4 and PyQt5 are not installed
error: hp-systray requires Qt4 GUI and DBus support. Exiting.

Restent quelques warnings dans les ScanJet Dependency Commands et une erreur hp-systray

Hors ligne