Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/06/2021, à 16:33

stephdz

Mon CPU décolle en visio

Bonjour,

Je suis l'heureux possesseur d'un Lenovo T590 sous Ubuntu 20.04 dont voici la configuration provenant d'inxi :

System:    Kernel: 5.8.0-53-generic x86_64 bits: 64 compiler: N/A Desktop: Gnome 3.36.7 
           Distro: Ubuntu 20.04.2 LTS (Focal Fossa) 
Machine:   Type: Laptop System: LENOVO product: 20N4000BFR v: ThinkPad T590 serial: <filter> 
           Mobo: LENOVO model: 20N4000BFR v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N2IET94W (1.72 ) date: 02/18/2021 
Battery:   ID-1: BAT0 charge: 58.1 Wh condition: 58.1/57.0 Wh (102%) model: LGC 5B10W13913 status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake rev: C L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999 
           Speed: 1620 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 1620 2: 1553 3: 1807 4: 2012 5: 1950 6: 1916 7: 1963 
           8: 1720 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.9 driver: i915 resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.2.6 direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Device-2: Logitech H600 [Wireless Headset] type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-3:3 
           Sound Server: ALSA v: k5.8.0-53-generic 
Network:   Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter> 
           IF-ID-2: vethd2634b9 state: up speed: 10000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 68.44 GiB (14.3%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBQNTY-512G-1001 size: 476.94 GiB 
Partition: ID-1: / size: 466.30 GiB used: 68.22 GiB (14.6%) fs: ext4 dev: /dev/dm-1 
           ID-2: /boot size: 704.5 MiB used: 209.7 MiB (29.8%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-3: swap-1 size: 980.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2 
Sensors:   System Temperatures: cpu: 91.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3509 
Info:      Processes: 453 Uptime: 8h 32m Memory: 15.30 GiB used: 9.22 GiB (60.2%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.3.0 Shell: zsh v: 5.8 inxi: 3.0.38

Tout fonctionnait très bien jusqu'à ce que je fasse une mise à jour le 1er Juin à mon retour au boulot après 3 mois d'absence. Depuis, dès qu'une visio Google Meet dure un peu longtemps, le CPU s'emballe régulièrement que ce soit sous Firefox ou Chrome.

J'ai mis à jour les firmwares proposés par Ubuntu Software sans que cela ne corrige rien.
Ça ressemble à un problème de drivers, mais je ne sais pas trop où chercher pour régler le problème.

Merci d'avance pour votre aide !

Hors ligne

#2 Le 03/06/2021, à 16:52

Vobul

Re : Mon CPU décolle en visio

Alors quand tu dis : "le CPU s'emballe", tu parles de l'utilisation effective du CPU par l'OS ? Visible avec "htop". Ou tu parles du ventilo de l'ordi qui ramp up, ce qui génère du bruit et te fait penser que le cpu s'emballe alors que c'est juste une question de chauffe du chassis ?

Note: un ordi ça se nettoie wink

Dernière modification par Vobul (Le 03/06/2021, à 16:52)


Vobul

Utilisez le retour utilisable de commandes !!!
J'aime la langue française, mais je parle franglais, deal with it.

Hors ligne

#3 Le 03/06/2021, à 16:59

stephdz

Re : Mon CPU décolle en visio

Pardon, je n'ai pas été assez précis dans ma description roll
Mon CPU passe à 100% d'utilisation pendant 10/20 secondes (ce qui fait que je n'entends presque plus rien de la visio) et c'est le process de rendu de Chrome ou de Firefox qui le charge à fond.
Donc non, ce n'est pas une question de poussière, le PC est récent et bien entretenu, mais bien un problème de soft wink

Hors ligne

#4 Le 03/06/2021, à 17:03

Vobul

Re : Mon CPU décolle en visio

Et toujours Google Meet ? Pas Teams ou Zoom ou Skype ou que sais-je ?


Vobul

Utilisez le retour utilisable de commandes !!!
J'aime la langue française, mais je parle franglais, deal with it.

Hors ligne

#5 Le 03/06/2021, à 17:26

stephdz

Re : Mon CPU décolle en visio

Je n'ai pas eu l'occasion d'utiliser autre chose que Meet.
Je précise que ça ne se produit que lorsque la visio est un peu longue (30 minutes) et ça se répète alors très fréquemment m'obligeant à quitter le navigateur sans garantie que ça ne se reproduise pas après reconnexion à la visio. Vraiment gênant pour un dev qui fait souvent du pair programming ou du code mob à distance...

Hors ligne

#6 Le 03/06/2021, à 19:39

iznobe

Re : Mon CPU décolle en visio

Bonsoir le probleme apparrait avec differents navigateurs ?
essaye zoom a la place de meet .
essaie d' enlever les plugins ou autre joyeuseté qui pourrait interferer avec .


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#7 Le 11/06/2021, à 13:37

stephdz

Re : Mon CPU décolle en visio

Après un monitoring poussé de mon CPU, je me suis aperçu que :
- sa température montait à des niveaux extrêmes (entre 80 et 100°C)
- lors des pics d'utilisation CPU, c'était en fait la fréquence du CPU qui passait de 2GHz à 200MHz => throttling pour faire baisser la température
- ces pics étaient déclenchés par la visio que ce soit avec Meet sur n'importe quel navigateur ou même n'importe quel outil l'utilisant : j'ai supposé que vu que je n'ai qu'un chipset graphique intégré, le CPU était un peu plus fortement sollicité

En faisant plusieurs essais au niveau des réglages du CPU, je pense avoir trouvé le fautif : intel_pstate
Je l'ai désactivé dans GRUB comme décrit ici : https://askubuntu.com/a/1064534
Et depuis, mon CPU est à une 50aine de degrés au repos et environ 70 avec une visio.

J'espère que ça va fonctionner sur le long terme et je vais en parallèle chercher si d'autres personnes ont eu ce soucis avec pstate ces 3 derniers mois.

PS : pour ceux que ça intéresse, pour le monitoring, j'ai utilisé les commandes suivantes :

$ watch -n1 sensors
$ watch -n1 'cat /proc/cpuinfo | grep MHz'

Dernière modification par stephdz (Le 11/06/2021, à 13:38)

Hors ligne

#8 Le 11/06/2021, à 18:42

iznobe

Re : Mon CPU décolle en visio

j ' avais deja vu des posts parlant de ce bug , mais je pensais que c' etait definitivement resolu ...

Bref , bravo tu as fini par trouver la solution , je pense que ca va persister , et si j' ai bonne memoire c ' est lié a un serie specifique de processeurs de chez intel .


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#9 Le 11/06/2021, à 19:38

FrancisFDZ

Re : Mon CPU décolle en visio

Bonjour,
Alors "[Résolu]" ?


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#10 Le 11/06/2021, à 21:04

stephdz

Re : Mon CPU décolle en visio

Je ne voudrais pas vendre la peau de l'ours avant de l'avoir tué...

Le problème étant assez aléatoire quoique de plus en plus fréquent ces derniers jours avant que je ne trouve une "solution", je préfère attendre de voir ce que ça donne sur une semaine complète.

Je viendrai mettre le flag [Résolu] vendredi prochain si tout va bien wink

Hors ligne

#11 Le 12/06/2021, à 08:12

FrancisFDZ

Re : Mon CPU décolle en visio

stephdz a écrit :

Je ne voudrais pas vendre la peau de l'ours avant de l'avoir tué...

Le problème étant assez aléatoire quoique de plus en plus fréquent ces derniers jours avant que je ne trouve une "solution", je préfère attendre de voir ce que ça donne sur une semaine complète.

Je viendrai mettre le flag [Résolu] vendredi prochain si tout va bien wink

Donc pas encore de certitude pour "[Résolu]" .Sage décision. smile


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne