Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/08/2021, à 13:32

PaniPwoBlem

Steam ne se lance pas :(

Bonjour,

Je viens d'installer Steam sauf que celui ci ne se lance pas quand je tape "steam" dans la console.

J'ai ça en retour :

Running Steam on ubuntu 20.04 64-bit
STEAM_RUNTIME is enabled automatically
Steam runtime environment up-to-date!
Steam client's requirements are satisfied
WARNING: Using default/fallback debugger launch
/home/lours/.steam/debian-installation/ubuntu12_32/steam -nominidumps -nobreakpad
[2021-08-06 13:29:37] Startup - updater built Jul 20 2021 22:25:51
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  152 (GLX)
Minor opcode of failed request:  3 (X_GLXCreateContext)
Value in failed request:  0x0
Serial number of failed request:  50
xerror_handler: X failed, continuing
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2021-08-06 13:29:37] Failed to load cached hosts file (File 'update_hosts_cached.vdf' not found), using defaults
[2021-08-06 13:29:37] Using the following download hosts for Public, Realm steamglobal
[2021-08-06 13:29:37] 1. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2021-08-06 13:29:37] Checking for update on startup
[2021-08-06 13:29:37] Checking for available updates...
[2021-08-06 13:29:37] Downloading manifest: http://media.steampowered.com/client/steam_client_ubuntu12
[2021-08-06 13:29:38] Download skipped: /client/steam_client_ubuntu12 version 1626824053, installed version 1626824053, existing pending version 0
[2021-08-06 13:29:38] Nothing to do
[2021-08-06 13:29:38] Verifying installation...
[2021-08-06 13:29:38] Performing checksum verification of executable files
[2021-08-06 13:29:38] Verification complete

Est ce que quelqu'un a déjà eu ce problème?

Merci d'avance pour votre aide smile.

Hors ligne

#2 Le 06/08/2021, à 13:45

abelthorne

Re : Steam ne se lance pas :(

1) Qu'est-ce que tu as comme GPU et quel pilote est utilisé ?

lspci | grep VGA
glxinfo | grep OpenGL

2) Steam est installé depuis les dépôts Ubuntu, depuis le deb de Valve ou en flatpak ?

Sachant que j'ai vu passer des problèmes similaires récemment, que j'en ai moi-même eu (mais dans mon cas, il se lance quand même) et que s'il n'y a pas de problèmes au niveau des pilotes, une solution va peut-être être de l'installer en flatpak (avec quelques limitations à la clé mais rien de très grave).

Hors ligne

#3 Le 06/08/2021, à 13:57

PaniPwoBlem

Re : Steam ne se lance pas :(

Alors, une chose que j'ai oublié de préciser (je ne sais pas si ça peut influer) j'ai 2 cartes graphiques (Intel et Nvidia)

1)

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
glxinfo | grep OpenGL

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  71
  Current serial number in output stream:  72

2) Je l'ai installé depuis la "Boutique des snap". Je suis sur Xubuntu.

Hors ligne

#4 Le 06/08/2021, à 14:16

abelthorne

Re : Steam ne se lance pas :(

Là, on ne voit qu'un GPU détecté. Redonne le retour de lspci tout court pour voir si le nvidia est listé.
Au niveau pilote, y a rien qui est utilisé, swrast c'est du rendu software pour l'accélération 3D.

D'autre part, si tu vas dans Logiciels & mises à jour → Pilotes additionnels, qu'est-ce qui est listé (idéalement, poste une capture de la fenêtre) et qu'est-ce qui est actuellement sélectionné ?

Est-ce que par hasard tu as des fichiers de config de X (au cas où ce ne soit pas une installation d'Ubuntu récente et que tu aies bidouillé des trucs) ?

cat /etc/X11/xorg.conf
ls /etc/X11/xorg.conf.d

Hors ligne

#5 Le 06/08/2021, à 14:32

PaniPwoBlem

Re : Steam ne se lance pas :(

lspci

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 05)
00:14.0 USB controller: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Thermal Subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Serial IO I2C Controller #0 (rev 31)
00:16.0 Communication controller: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 (rev 31)
00:17.0 SATA controller: Intel Corporation HM170/QM170 Chipset SATA Controller [AHCI Mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #1 (rev f1)
00:1c.4 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #6 (rev f1)
00:1c.6 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #7 (rev f1)
00:1f.0 ISA bridge: Intel Corporation HM175 Chipset LPC/eSPI Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller (rev 31)
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation 100 Series/C230 Series Chipset Family SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev ff)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
04:00.0 Network controller: Intel Corporation Wireless 7265 (rev 61)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Piltoes additionnels : https://imgur.com/Q3pFAQU
En sachant que je ne peux rien choisir d'autre, c'est grisé.

cat /etc/X11/xorg.conf

cat: /etc/X11/xorg.conf: Aucun fichier ou dossier de ce type

ls /etc/X11/xorg.conf.d

ls: impossible d'accéder à '/etc/X11/xorg.conf.d': Aucun fichier ou dossier de ce type

Hors ligne

#6 Le 06/08/2021, à 14:48

abelthorne

Re : Steam ne se lance pas :(

Pas de fichiers de config de X, ce qui est normal, et donc pas d'anomalie qui pourrait venir de ce côté.

Le GPU nvidia est bien reconnu (simplement y a pas "VGA" dans la ligne, c'est pour ça que la première commande ne le listait pas).

En revanche, du côté des pilotes, c'est pas normal du tout que tu ne puisses pas en sélectionner et c'est un peu bizarre qu'il indique que tu utilises un pilote installé manuellement. Question suivante : est-ce que tu as installé (ou tenté de le faire) un pilote manuellement ?
Au cas où, donne le retour de :

dpkg -l | grep nvidia
apt list | grep "installé, local"

Accessoirement, tu es sur quelle version de Xubuntu ? 20.04 ? 21.04 ? autre ?

Dans tous les cas, le problème ne vient pas de Steam, il est plus général. Il faudra peut-être rouvrir un sujet dédié dans Affichage et cartes graphiques, je ne suis pas vraiment compétent sur ce genre de cas.

Hors ligne

#7 Le 06/08/2021, à 15:01

PaniPwoBlem

Re : Steam ne se lance pas :(

Je n'ai pas tenté d'installer un pilote manuellement.

dpkg -l | grep nvidia

ii  libnvidia-cfg1-470:amd64                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-390                       390.144-0ubuntu0.20.04.1              all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-470:amd64                470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA libcompute package
ii  libnvidia-decode-470:amd64                 470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-470:amd64                 470.57.02-0ubuntu0.20.04.1            amd64        NVENC Video Encoding runtime library
ii  libnvidia-extra-470:amd64                  470.57.02-0ubuntu0.20.04.1            amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-470:amd64                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-390:i386                      390.144-0ubuntu0.20.04.1              i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  linux-modules-nvidia-470-5.11.0-25-generic 5.11.0-25.27~20.04.1+3                amd64        Linux kernel nvidia modules for version 5.11.0-25
ii  linux-modules-nvidia-470-generic-hwe-20.04 5.11.0-25.27~20.04.1+3                amd64        Extra drivers for nvidia-470 for the generic-hwe-20.04 flavour
ii  linux-objects-nvidia-470-5.11.0-25-generic 5.11.0-25.27~20.04.1+3                amd64        Linux kernel nvidia modules for version 5.11.0-25 (objects)
ii  linux-signatures-nvidia-5.11.0-25-generic  5.11.0-25.27~20.04.1+3                amd64        Linux kernel signatures for nvidia modules for version 5.11.0-25-generic
ii  nvidia-compute-utils-470                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA compute utilities
ii  nvidia-kernel-common-470                   470.57.02-0ubuntu0.20.04.1            amd64        Shared files used with the kernel module
ii  nvidia-prime                               0.8.16~0.20.04.1                      all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                            470.57.01-0ubuntu0.20.04.1            amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-470                           470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                    0.18build1                            all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-470              470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA binary Xorg driver
apt list | grep "installé, local"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

L'ISO que j'ai utilisé est Xubuntu 20.04.2.0 LTS

J'avais déjà ouvert un sujet sur ce problème dans les pilotes additionnels

https://forum.ubuntu-fr.org/viewtopic.p … #p22477889

Hors ligne

#8 Le 06/08/2021, à 15:26

ylag

Re : Steam ne se lance pas :(

Bonjour,

Est-ce que les erreurs au message #3 concernant la commande glxinfo | grep OpenGL pourraient venir du fait que ces deux bibliothèques (390) ne sont pas à la même version que le pilote (470) ?

...
ii  libnvidia-common-390                       390.144-0ubuntu0.20.04.1              all          Shared files used by the NVIDIA libraries
...
ii  libnvidia-gl-390:i386                      390.144-0ubuntu0.20.04.1              i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD

Ces deux biblothèques existent en version 470 dans les dépôts...

Aussi, le pilote ne me semble pas correctement installé, manquerait au moins le méta-paquet nvidia-driver-470 ?

A+

Dernière modification par ylag (Le 06/08/2021, à 15:30)

Hors ligne

#9 Le 06/08/2021, à 15:31

abelthorne

Re : Steam ne se lance pas :(

Au vu de la liste des paquets, j'ai l'impression que le pilote 470 est installé mais il y a des morceaux du 390 qui traînent avec et je ne sais pas si c'est très normal... Et les paquets ne sont pas ceux qu'on a habituellement quand on passe par Logiciels & mises à jour.

Est-ce que tu saurais d'où vient ce pilote ? Notamment, dans l'autre sujet, alius te demandait si tu avais coché la case "installer des logiciels tiers" pendant l'installation d'Ubuntu mais tu n'as pas répondu.

Là, tout ce que je peux dire c'est que le pilote n'est probablement pas installé correctement au vu du retour de glxinfo.

EDIT : donne aussi le retour de la commande suivante :

ubuntu-drivers devices

EDIT 2 : ylag : c'est ce que je me dis par rapport aux versions 390 et 470 qui cohabitent. Et l'absence du méta-paquet nvidia-driver-470 me fait penser que le pilote est installé d'une manière alternative (je ne suis pas sûr qu'avec une installation standard il y a les paquets de modules du noyau ?).

Dernière modification par abelthorne (Le 06/08/2021, à 15:36)

Hors ligne

#10 Le 06/08/2021, à 15:34

xubu1957

Re : Steam ne se lance pas :(

Bonjour,

@ylag

Pour i386

Je crois que pour ces architectures, c'est un peu à l'abandon > packages.ubuntu.com/fr/focal/libnvidia-gl-390


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#11 Le 06/08/2021, à 15:40

ylag

Re : Steam ne se lance pas :(

Re,

Pour fin de vérification, peut-être tenter de simuler l'installation du paquet nvidia-driver-470, histoire de voir ce qui serait ajouté et/ou supprimé :

sudo apt -s install nvidia-driver-470

Ajout : «(je ne suis pas sûr qu'avec une installation standard il y a les paquets de modules du noyau ?).»
Ces paquets n'apparaîssent pas comme dépendances de nvidia-driver-470,

A+

Dernière modification par ylag (Le 06/08/2021, à 15:47)

Hors ligne

#12 Le 06/08/2021, à 15:42

PaniPwoBlem

Re : Steam ne se lance pas :(

abelthorne a écrit :

Au vu de la liste des paquets, j'ai l'impression que le pilote 470 est installé mais il y a des morceaux du 390 qui traînent avec et je ne sais pas si c'est très normal... Et les paquets ne sont pas ceux qu'on a habituellement quand on passe par Logiciels & mises à jour.

Est-ce que tu saurais d'où vient ce pilote ? Notamment, dans l'autre sujet, alius te demandait si tu avais coché la case "installer des logiciels tiers" pendant l'installation d'Ubuntu mais tu n'as pas répondu.

Là, tout ce que je peux dire c'est que le pilote n'est probablement pas installé correctement au vu du retour de glxinfo.

EDIT : donne aussi le retour de la commande suivante :

ubuntu-drivers devices

EDIT 2 : ylag : c'est ce que je me dis par rapport aux versions 390 et 470 qui cohabitent. Et l'absence du méta-paquet nvidia-driver-470 me fait penser que le pilote est installé d'une manière alternative (je ne suis pas sûr qu'avec une installation standard il y a les paquets de modules du noyau ?).

Ah mince, j'avais pas fait gaffe. Oui la case "installer des logiciels tiers" était coché.

ubuntu-drivers devices

WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C8Dsv0000103Csd0000825Dbc03sc02i00
vendor   : NVIDIA Corporation
model    : GP107M [GeForce GTX 1050 Mobile]
manual_install: True
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-470 - distro non-free recommended
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-460-server - distro non-free
driver   : nvidia-driver-418-server - distro non-free
driver   : nvidia-driver-460 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

Est ce qu'il ne faudrait pas que je réinstalle Ubuntu mais en ne cochant pas cette case "installer des logiciels tiers" ?

Hors ligne

#13 Le 06/08/2021, à 15:49

ylag

Re : Steam ne se lance pas :(

@PaniPwoBlem :

Bonjour,

Tente la suggestion du commentaire #11 ?
Ce n'est qu'à titre indicatif, aucune modif ne sera effectuée sur ton installation.

A+

Hors ligne

#14 Le 06/08/2021, à 15:50

abelthorne

Re : Steam ne se lance pas :(

Si tu peux te permettre de réinstaller Ubuntu, ça pourrait être une chose à tester. On peut aussi essayer d'autres choses avant en espérant que tu ne te retrouves pas sans affichage au prochain boot.
Notamment ça :

sudo ubuntu-drivers autoinstall

en rebootant après.

Idéalement, prévois d'avoir un livCD/liveUSB sous la main au cas où (si plus rien ne marche, ça te permettra d'avoir une session pour revenir dire "y a plus rien qui marche").

Hors ligne

#15 Le 06/08/2021, à 16:38

PaniPwoBlem

Re : Steam ne se lance pas :(

Dans tout les pilotes additionnels proposé, lequel faudra t il que je prenne svp?

Hors ligne

#16 Le 06/08/2021, à 16:41

abelthorne

Re : Steam ne se lance pas :(

Déjà, fais un point sur ce que tu as fait, parce qu'il y aura plusieurs étapes si tout se passe bien. Est-ce que tu as lancé ma commande, redémarré et tu peux maintenant sélectionner un pilote dans Logiciels et mises à jour ?

Hors ligne

#17 Le 06/08/2021, à 16:53

ylag

Re : Steam ne se lance pas :(

La commande suggérée au #14 tentera l'installation de ce pilote :

driver   : nvidia-driver-470 - distro non-free recommended

A+

Hors ligne

#18 Le 06/08/2021, à 17:04

PaniPwoBlem

Re : Steam ne se lance pas :(

abelthorne a écrit :

Déjà, fais un point sur ce que tu as fait, parce qu'il y aura plusieurs étapes si tout se passe bien. Est-ce que tu as lancé ma commande, redémarré et tu peux maintenant sélectionner un pilote dans Logiciels et mises à jour ?

Toujours pareil dans les pilotes additionnels. Impossible d'en choisir un autre.

Dernière modification par PaniPwoBlem (Le 06/08/2021, à 17:05)

Hors ligne

#19 Le 06/08/2021, à 17:07

abelthorne

Re : Steam ne se lance pas :(

Tu as bien lancé la commande sudo ubuntu-drivers autoinstall puis redémarré après ?

EDIT : concernant la commande en #11, est-ce que tu pourrais donner le retour complet ? Normalement, elle devrait lister les paquets qui vont être installés.

Dernière modification par abelthorne (Le 06/08/2021, à 17:15)

Hors ligne

#20 Le 06/08/2021, à 17:24

PaniPwoBlem

Re : Steam ne se lance pas :(

sudo apt -s install nvidia-driver-470

[sudo] Mot de passe de lours : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra gnome-software-common gstreamer1.0-vaapi
  libappstream-glib8 libgspell-1-2 libgspell-1-common libllvm11 libva-wayland2
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libnvidia-common-470 libnvidia-compute-470:i386 libnvidia-decode-470:i386
  libnvidia-encode-470:i386 libnvidia-fbc1-470:i386 libnvidia-gl-470
  libnvidia-gl-470:i386 libnvidia-ifr1-470 libnvidia-ifr1-470:i386
  nvidia-kernel-source-470
Les paquets suivants seront ENLEVÉS :
  libnvidia-common-390 libnvidia-gl-390:i386
Les NOUVEAUX paquets suivants seront installés :
  libnvidia-common-470 libnvidia-compute-470:i386 libnvidia-decode-470:i386
  libnvidia-encode-470:i386 libnvidia-fbc1-470:i386 libnvidia-gl-470
  libnvidia-gl-470:i386 libnvidia-ifr1-470 libnvidia-ifr1-470:i386
  nvidia-driver-470 nvidia-kernel-source-470
0 mis à jour, 11 nouvellement installés, 2 à enlever et 0 non mis à jour.
Remv libnvidia-gl-390:i386 [390.144-0ubuntu0.20.04.1]
Remv libnvidia-common-390 [390.144-0ubuntu0.20.04.1]
Inst libnvidia-common-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [all])
Inst libnvidia-compute-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst libnvidia-decode-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst libnvidia-encode-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst libnvidia-fbc1-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst libnvidia-gl-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-gl-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst libnvidia-ifr1-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst libnvidia-ifr1-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Inst nvidia-kernel-source-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Inst nvidia-driver-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-common-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [all])
Conf libnvidia-compute-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf libnvidia-decode-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf libnvidia-encode-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf libnvidia-fbc1-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf libnvidia-gl-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-gl-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf libnvidia-ifr1-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf libnvidia-ifr1-470:i386 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [i386])
Conf nvidia-kernel-source-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])
Conf nvidia-driver-470 (470.57.02-0ubuntu0.20.04.1 Ubuntu:20.04/focal-updates, Ubuntu:20.04/focal-security [amd64])

Après avoir fait sudo ubuntu-drivers autoinstall, je peux choisir le pilote. J'ai rien touché, c'était comme ça par défaut.

6yIuTKv.png

Hors ligne

#21 Le 06/08/2021, à 17:28

abelthorne

Re : Steam ne se lance pas :(

Tu as redémarré ? Si oui, redonne le retour de :

glxinfo | grep OpenGL

(Si tu n'as pas redémarré, redémarre et donne la commande ensuite.)

Hors ligne

#22 Le 06/08/2021, à 18:52

PaniPwoBlem

Re : Steam ne se lance pas :(

abelthorne a écrit :

Tu as redémarré ? Si oui, redonne le retour de :

glxinfo | grep OpenGL

(Si tu n'as pas redémarré, redémarre et donne la commande ensuite.)

Après redémarrage j'ai ça :

glxinfo | grep OpenGL

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce GTX 1050/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 470.57.02
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 470.57.02
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 470.57.02
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

Hors ligne

#23 Le 06/08/2021, à 18:54

abelthorne

Re : Steam ne se lance pas :(

Il y a du mieux, tu n'es plus en rendu software. Essaie de lancer Steam, de préférence en ligne de commande pour avoir des infos.

Redonne aussi le retour de :

dpkg -l | grep nvidia
dpkg -l | grep vulkan

Hors ligne

#24 Le 06/08/2021, à 19:19

PaniPwoBlem

Re : Steam ne se lance pas :(

Steam fonctionne nickel. J'ai pu me connecter. Je ne touche à rien dedans pr le moment.

dpkg -l | grep nvidia

ii  libnvidia-cfg1-470:amd64                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-470                       470.57.02-0ubuntu0.20.04.1            all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-470:amd64                470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA libcompute package
ii  libnvidia-compute-470:i386                 470.57.02-0ubuntu0.20.04.1            i386         NVIDIA libcompute package
ii  libnvidia-decode-470:amd64                 470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-470:i386                  470.57.02-0ubuntu0.20.04.1            i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-470:amd64                 470.57.02-0ubuntu0.20.04.1            amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-470:i386                  470.57.02-0ubuntu0.20.04.1            i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-470:amd64                  470.57.02-0ubuntu0.20.04.1            amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-470:amd64                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-470:i386                    470.57.02-0ubuntu0.20.04.1            i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-470:amd64                     470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-470:i386                      470.57.02-0ubuntu0.20.04.1            i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-470:amd64                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-470:i386                    470.57.02-0ubuntu0.20.04.1            i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  linux-modules-nvidia-470-5.11.0-25-generic 5.11.0-25.27~20.04.1+3                amd64        Linux kernel nvidia modules for version 5.11.0-25
ii  linux-modules-nvidia-470-generic-hwe-20.04 5.11.0-25.27~20.04.1+3                amd64        Extra drivers for nvidia-470 for the generic-hwe-20.04 flavour
ii  linux-objects-nvidia-470-5.11.0-25-generic 5.11.0-25.27~20.04.1+3                amd64        Linux kernel nvidia modules for version 5.11.0-25 (objects)
ii  linux-signatures-nvidia-5.11.0-25-generic  5.11.0-25.27~20.04.1+3                amd64        Linux kernel signatures for nvidia modules for version 5.11.0-25-generic
ii  nvidia-compute-utils-470                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA compute utilities
ii  nvidia-driver-470                          470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-470                   470.57.02-0ubuntu0.20.04.1            amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-470                   470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA kernel source package
ii  nvidia-prime                               0.8.16~0.20.04.1                      all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                            470.57.01-0ubuntu0.20.04.1            amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-470                           470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                    0.18build1                            all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-470              470.57.02-0ubuntu0.20.04.1            amd64        NVIDIA binary Xorg driver
dpkg -l | grep vulkan

ii  libvulkan1:amd64                           1.2.131.2-1                           amd64        Vulkan loader library
ii  libvulkan1:i386                            1.2.131.2-1                           i386         Vulkan loader library
ii  mesa-vulkan-drivers:amd64                  21.0.3-0ubuntu0.2~20.04.1             amd64        Mesa Vulkan graphics drivers
ii  mesa-vulkan-drivers:i386                   21.0.3-0ubuntu0.2~20.04.1             i386         Mesa Vulkan graphics drivers

Hors ligne

#25 Le 06/08/2021, à 19:28

abelthorne

Re : Steam ne se lance pas :(

Je ne connais pas assez les paquets des pilotes nvidia pour être sûr que toutes les biblis 32 bits nécessaires pour les jeux soient installées mais on peut supposer que c'est le cas. Idem pour les modules du noyau : je ne suis pas sûr que leur présence soit normale ou nécessaire mais j'imagine qu'ils ne poseront pas de problème si ce n'est pas le cas.

Essaie de lancer des jeux pour voir s'ils fonctionnent. Si tu es nouveau sur Linux et que tu veux lancer des jeux Windows (note que la compatibilité n'est pas assurée mais ce n'est pas lié à ta config), va dans les paramètres de Steam → Steam Play et coche "Activer Steam Play pour les jeux compatibles". Si tu veux pouvoir tester tous tes jeux Windows et pas seulement ceux whitelistés par Valve, coche aussi "Activer Steam Play pour tous les autres titres" et sélectionne la dernière version de Proton dans la liste en-dessous s'il y en a plusieurs.

Hors ligne