Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/09/2021, à 11:28

remi44

[Résolu] Nginx reverseproxy

Bonjour,

J'essaie de configurer nginx en reverse proxy. J'ai suivi plusieurs tutos, mais je rencontre toujours la même erreur au moment du redémarrage :

failed (40: Too many levels of symbolic links) in /etc/nginx/nginx.conf:62

J'ai donc installé nginx : apt-get install nginx.
Je n'ai pas modifié la conf de nginx

Dans sites-available, j'ai créé mon fichier de conf : site.conf

upstream site { 
	server 192.168.1.1; 
} 

server { 
	listen 80; 
	server_name mon.domaine.fr; 
	
	location / { 
		include proxy_params; 
		proxy_pass http://site; 
	} 
}

Quand je fais nginx -t
j'ai le message d'erreur suivant :


nginx: [emerg] open() "/etc/nginx/sites-enabled/site.conf" failed (40: Too many levels of symbolic links) in /etc/nginx/nginx.conf:62
nginx: configuration file /etc/nginx/nginx.conf test failed

Merci pour votre aide

Dernière modification par remi44 (Le 14/09/2021, à 09:10)

Hors ligne

#2 Le 13/09/2021, à 16:17

soshy

Re : [Résolu] Nginx reverseproxy

Salut,
tu peux donner le retour de la commande suivante ?

ls -la /etc/nginx/sites-enabled

ainsi que le contenu de proxy_params qui j'imagine se trouve dans /etc/nginx ?

Dernière modification par soshy (Le 13/09/2021, à 16:19)

Hors ligne

#3 Le 13/09/2021, à 16:34

bruno

Re : [Résolu] Nginx reverseproxy

Bonjour,

Il manque probablement une directive root

root /var/www/html

Le mensonge et la crédulité s'accouplent et engendrent l'opinion.

En ligne

#4 Le 13/09/2021, à 17:19

remi44

Re : [Résolu] Nginx reverseproxy

Bonjour,

Pour info, quand je supprime mon fichier de conf dans site_available, la commande

 service nging configtest 

me retourne OK.

La commande ls -la /etc/nginx/sites-enabled me retourne

lrwxrwxrwx 1 0 0 34 sept. 13 14:54 default -> /etc/nginx/sites-available/default

Le fichier proxy_params est celui par défaut :

proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;

Merci

Hors ligne

#5 Le 13/09/2021, à 17:29

remi44

Re : [Résolu] Nginx reverseproxy

On activant mon fichier de conf et via ta commande ln -la, je viens de voir que mon lien n'était  pas bon.
Je recommence et vous tiens au courant.

Merci

Hors ligne

#6 Le 13/09/2021, à 17:38

remi44

Re : [Résolu] Nginx reverseproxy

Je n'ai plus d'erreur, mais ça ne fonctionne pas.

J'ai deux fichiers de confs dans sites_available
Un qui redirige vers 192.168.1.1:80, l'autre vers 192.168.1.1:20000
Le premier fichier a en server_name : server_name mon.domaine.fr;
Le second server_name mon2.domaine.fr;

Quand je teste la config, il me dit OK, mais ça ne fonctionne pas.
Je vous remercie

Hors ligne

#7 Le 13/09/2021, à 22:07

remi44

Re : [Résolu] Nginx reverseproxy

J'ai refait la conf. Et étrangement, ça fonctionne.

Merci à vous deux pour votre aide.
Rémi

Hors ligne

#8 Le 13/09/2021, à 22:13

soshy

Re : [Résolu] Nginx reverseproxy

Bien, donc le problème initial, c'était ton lien qui était mauvais. A priori, rien à voir avec le contenu du/des fichier(s) dans sites-available

Maintenant, il faut un peu plus de détail...
Depuis ton serveur tu as bien accès aux 2 destinations ?
Montre :

curl -i 192.168.1.1:80

et

curl -i 192.168.1.1:20000

Ensuite, est ce que le proxy nginx fonctionne ? Modifie le fichier host du serveur pour que serveur puisse résoudre tes domaines à coup sûr en ajoutant au fichier /etc/hosts les 2 lignes suivantes

127.0.0.1  mon.domaine.fr
127.0.0.1  mon2.domaine.fr

Maintenant, toujours depuis le serveur, curl les noms de domaine pour voir si on a bien la réponse escompté comme au début

curl -i mon.domaine.fr

et

curl -i mon2.domaine.fr

Si la première étape était bonne, celle ci devrait l'être aussi. Et si c'est le cas, ça veut dire que ton serveur est bien configuré et que c'est ton client qui ne résout pas le domaine correctement.

Et juste au cas où, il faut bien penser à reload nginx pour qu'il prenne en compte tes modifications de config avec par exemple

sudo systemctl reload nginx

Voir carrément de le redémarrer.


Edit, bon bah puisque c'est réparé, c'est parfait alors smile

Dernière modification par soshy (Le 13/09/2021, à 22:14)

Hors ligne

#9 Le 14/09/2021, à 09:10

remi44

Re : [Résolu] Nginx reverseproxy

Bonjour Soshy,

Merci pour ton aide.

Hors ligne