Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/09/2021, à 10:19

Arbiel

[Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour à tous

Pour moi, la solution a été de désinstaller ma version de VirtualBox et 
d'installer celle qui est disponible ici : https://www.virtualbox.org/wiki/Testbuilds
avec
sudo bash <adresse du fichier téléchargé> (il s'agit d'un fichier .run)

J'utilise VirtualBox pour faire mes comptes avec Money, et cela depuis de nombreuses années. Je n'envisage absolument pas de migrer vers quelque autre logiciel car une telle migration dégraderait trop profondément mes données pour que je m'y résolve.

J'utilise Money par le biais de VirtualBox. Chaque fois que je veux faire mes comptes après redémarrage de mon PC, qu'il s'agisse d'un redémarrage après extinction complète ou simplement par le choix de cette option dans le dialogue d'arrêt, je reçois le message d'erreur ci-dessous :

VBoxManager a écrit :

VBoxManage: error: The virtual machine 'Comptes CF' has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

accompagné d'un second message qui me conseille d'exécuter /sbin/vboxconfig en tant qu'administrateur.

L'exécution de cette procédure résout le problème, mais elle n'est efficace qu'aussi longtemps que je ne redémarrage pas mon PC. Je souhaite pouvoir arrêter mon PC sans avoir à l'exécuter encore et encore.

Merci à qui pourra m'indiquer comment faire.

Arbiel

Dernière modification par Arbiel (Le 04/10/2021, à 20:28)


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#2 Le 27/09/2021, à 10:31

xubu1957

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour,

Vu la Doc > § 7.7.7 virtualbox#ns_error_failure_0x80004005

Le paquet virtualbox-dkms est-il installé ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 27/09/2021, à 11:15

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour xubu1957

Merci de m'apporter ton aide.

virtualbox-dkms n'est pas installé, mais je n'ai pas réussi à l'installer, comme le montre le résultat des commandes que j'ai exécutées, et que j'ai fractionné pour y faciliter la recherche des informations

arbiel@arbiel-NK3S-8-S4:~$ sudo dpkg -V virtualbox-dkms
dpkg: paquet « virtualbox-dkms » n'est pas installé
arbiel@arbiel-NK3S-8-S4:~$ sudo apt-get install virtualbox-dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib libsdl-ttf2.0-0
  linux-image-5.8.0-63-generic linux-modules-5.8.0-63-generic
  linux-modules-extra-5.8.0-63-generic python-is-python2 python2
  python2-minimal python2.7 python2.7-minimal
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox
  virtualbox-qt
Paquets suggérés :
  debtags menu vde2 virtualbox-guest-additions-iso
Les paquets suivants seront ENLEVÉS :
  virtualbox-6.1
Les NOUVEAUX paquets suivants seront installés :
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox
  virtualbox-dkms virtualbox-qt
0 mis à jour, 8 nouvellement installés, 1 à enlever et 17 non mis à jour.
Il est nécessaire de prendre 43,9 Mo/44,4 Mo dans les archives.
Après cette opération, 11,6 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Err :1 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-dkms amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
Err :2 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
Err :3 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-qt amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-dkms_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-qt_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?
arbiel@arbiel-NK3S-8-S4:~$ sudo apt-get update
Ign :1 https://brave-browser-apt-release.s3.brave5t5rjjg3s6k.onion stable InRelease
Err :2 https://brave-browser-apt-release.s3.brave5t5rjjg3s6k.onion stable Release
  La connexion directe vers les domaines .onion est bloquée par défaut.
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Réception de :4 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Atteint :5 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal InRelease
Réception de :6 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [282 kB]
Réception de :8 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [354 kB]
Réception de :10 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [944 B]
Réception de :11 http://fr.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [10,4 kB]
Lecture des listes de paquets... Fait                                        
E: Le dépôt https://brave-browser-apt-release.s3.brave5t5rjjg3s6k.onion stable Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
arbiel@arbiel-NK3S-8-S4:~$ 

sudo apt-get update --fix-missing me donne le même résultat.

Et après tout cela, comme tu peux t'en douter :

arbiel@arbiel-NK3S-8-S4:~$ sudo sudo dpkg -V virtualbox-dkms
dpkg: paquet « virtualbox-dkms » n'est pas installé
arbiel@arbiel-NK3S-8-S4:~$ 

Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#4 Le 27/09/2021, à 11:21

xubu1957

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Il faut attendre des aidants plus dégourdis que moi, vu les messages concernant brave.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 27/09/2021, à 11:28

cqfd93

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour,

Avant d'installer quoi que ce soit, il est bon de faire les mises à jour (17 paquets non mis à jour !)

Apt sembles avoir un problème avec l'ipv6, je te propose de le forcer à utiliser ipv4 avec :

sudo sed -i '/precedence \:\:ffff\:0\:0\/96  100/s/#//' /etc/gai.conf

suivi de :

sudo apt update
sudo apt full-upgrade

(donne tous les retours)

Il y a aussi un problème avec https://brave-browser-apt-release.s3.br … 3s6k.onion qui est inaccessible, donc tu ferais bien de désactiver ce dépôt avant de lancer tes mises à jour.


cqfd93

Hors ligne

#6 Le 27/09/2021, à 22:37

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonsoir cqfd93

J'ai réussi à forcer l'utilisation d'ipv4, sans résultat.

Par contre je ne trouve pas quel paquet je dois désactiver pour le problème relatif à brave :

arbiel@arbiel-NK3S-8-S4:~$ apt-cache search brave
python-psycopg2-doc - Module Python pour PostgreSQL (paquet de documentation)
python3-psycopg2 - module Python 3 pour PostgreSQL
claws-mail-themes - thèmes d'icône pixmap pour « Claws Mail »
gnome-brave-icon-theme - variante bleue du thème d'icônes GNOME-Colors
gnome-colors - ensemble de thèmes d'icônes GNOME
libraven0 - Raven library for budgie-desktop
shiki-brave-theme - Variation bleue du thème Shiki-Colors
shiki-colors - ensemble de thèmes de Metacity/GTK-2+
wesnoth-1.14-dw - "Dead Water" official campaign for Wesnoth (branch 1.14)
astromenace - Jeu de tir complexe dans l'espace en 3D avec la possibilité d'améliorer le vaisseau spatial
astromenace-data-src - Fichiers de données pour le jeu AstroMenace
arbiel@arbiel-NK3S-8-S4:~$ apt-cache search onion
onioncircuits - application GTK+ pour afficher les circuits et connexions Tor
python-txtorcon-doc - Twisted-based asynchronous Tor control protocol implementation (Documentation)
python3-txtorcon - Twisted-based asynchronous Tor control protocol implementation (Python 3)
tupi - outil de conception et création d’animation en 2D
tupi-data - Fichiers de données pour tupi (outil de création et conception d'animations 2D)
youtube-dl - téléchargeur de vidéos depuis YouTube et d'autres sites
coyim - safe and secure XMPP chat client
libconfig-onion-perl - layered configuration
onionbalance - Tor hidden service load balancer
prosody-modules - Selection of community modules for Prosody
vanguards - Additional protections for Tor Onion Services
onionshare - Share a file over Tor Hidden Services anonymously and securely
arbiel@arbiel-NK3S-8-S4:~$ 

Pour le reste :

arbiel@arbiel-NK3S-8-S4:~$ sudo apt update
Ign :1 https://brave-browser-apt-release.s3.brave5t5rjjg3s6k.onion stable InRelease
Err :2 https://brave-browser-apt-release.s3.brave5t5rjjg3s6k.onion stable Release
  La connexion directe vers les domaines .onion est bloquée par défaut.
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :4 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal InRelease     
Atteint :5 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                
Atteint :6 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease              
Réception de :7 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Réception de :8 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [892 kB]
Réception de :9 http://security.ubuntu.com/ubuntu focal-security/main i386 Packages [287 kB]
Réception de :10 http://security.ubuntu.com/ubuntu focal-security/main Translation-en [170 kB]
Réception de :11 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [27,6 kB]
Réception de :12 http://security.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [8716 B]
Réception de :13 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [427 kB]
Réception de :14 http://security.ubuntu.com/ubuntu focal-security/restricted Translation-en [61,3 kB]
Réception de :15 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [61,1 kB]
Réception de :16 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2468 B]
Lecture des listes de paquets... Fait                                      
E: Le dépôt https://brave-browser-apt-release.s3.brave5t5rjjg3s6k.onion stable Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
arbiel@arbiel-NK3S-8-S4:~$ 
arbiel@arbiel-NK3S-8-S4:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  libdrm-amdgpu1 libdrm-common libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libegl-mesa0 libegl1-mesa libgbm1 libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libglx-mesa0 libxatracker2 linux-firmware linux-libc-dev mesa-va-drivers mesa-vdpau-drivers
  mesa-vulkan-drivers
19 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 standard security update
Il est nécessaire de prendre 134 Mo dans les archives.
Après cette opération, 147 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de :1 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libdrm-common all 2.4.105-3~20.04.2 [5552 B]
Réception de :2 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libdrm2 amd64 2.4.105-3~20.04.2 [32,3 kB]
Réception de :3 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libdrm-amdgpu1 amd64 2.4.105-3~20.04.2 [18,4 kB]
Réception de :4 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libdrm-intel1 amd64 2.4.105-3~20.04.2 [60,7 kB]
Réception de :5 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libdrm-nouveau2 amd64 2.4.105-3~20.04.2 [16,4 kB]
Réception de :6 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libdrm-radeon1 amd64 2.4.105-3~20.04.2 [19,7 kB]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libegl-mesa0 amd64 21.0.3-0ubuntu0.3~20.04.2 [96,4 kB]
Réception de :8 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgbm1 amd64 21.0.3-0ubuntu0.3~20.04.2 [28,9 kB]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgl1-mesa-dri amd64 21.0.3-0ubuntu0.3~20.04.2 [10,5 MB]
Réception de :10 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libglx-mesa0 amd64 21.0.3-0ubuntu0.3~20.04.2 [137 kB]       
Réception de :11 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libglapi-mesa amd64 21.0.3-0ubuntu0.3~20.04.2 [26,8 kB]     
Réception de :12 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 libegl1-mesa amd64 21.0.3-0ubuntu0.3~20.04.2 [6480 B]  
Réception de :13 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgl1-mesa-glx amd64 21.0.3-0ubuntu0.3~20.04.2 [5540 B]   
Réception de :14 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 libxatracker2 amd64 21.0.3-0ubuntu0.3~20.04.2 [1716 kB]    
Réception de :15 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-firmware all 1.187.17 [110 MB]                        
Réception de :16 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-libc-dev amd64 5.4.0-88.99 [1116 kB]                                        
Réception de :17 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 mesa-va-drivers amd64 21.0.3-0ubuntu0.3~20.04.2 [2825 kB]                     
Réception de :18 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 mesa-vdpau-drivers amd64 21.0.3-0ubuntu0.3~20.04.2 [2944 kB]                      
Réception de :19 http://fr.archive.ubuntu.com/ubuntu focal-updates/main amd64 mesa-vulkan-drivers amd64 21.0.3-0ubuntu0.3~20.04.2 [4733 kB]                     
134 Mo réceptionnés en 1min 18s (1717 ko/s)                                                                                                                     
(Lecture de la base de données... 263325 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-libdrm-common_2.4.105-3~20.04.2_all.deb ...
Dépaquetage de libdrm-common (2.4.105-3~20.04.2) sur (2.4.105-3~20.04.1) ...
Préparation du dépaquetage de .../01-libdrm2_2.4.105-3~20.04.2_amd64.deb ...
Dépaquetage de libdrm2:amd64 (2.4.105-3~20.04.2) sur (2.4.105-3~20.04.1) ...
Préparation du dépaquetage de .../02-libdrm-amdgpu1_2.4.105-3~20.04.2_amd64.deb ...
Dépaquetage de libdrm-amdgpu1:amd64 (2.4.105-3~20.04.2) sur (2.4.105-3~20.04.1) ...
Préparation du dépaquetage de .../03-libdrm-intel1_2.4.105-3~20.04.2_amd64.deb ...
Dépaquetage de libdrm-intel1:amd64 (2.4.105-3~20.04.2) sur (2.4.105-3~20.04.1) ...
Préparation du dépaquetage de .../04-libdrm-nouveau2_2.4.105-3~20.04.2_amd64.deb ...
Dépaquetage de libdrm-nouveau2:amd64 (2.4.105-3~20.04.2) sur (2.4.105-3~20.04.1) ...
Préparation du dépaquetage de .../05-libdrm-radeon1_2.4.105-3~20.04.2_amd64.deb ...
Dépaquetage de libdrm-radeon1:amd64 (2.4.105-3~20.04.2) sur (2.4.105-3~20.04.1) ...
Préparation du dépaquetage de .../06-libegl-mesa0_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libegl-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../07-libgbm1_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libgbm1:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../08-libgl1-mesa-dri_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libgl1-mesa-dri:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../09-libglx-mesa0_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libglx-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../10-libglapi-mesa_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libglapi-mesa:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../11-libegl1-mesa_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libegl1-mesa:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../12-libgl1-mesa-glx_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libgl1-mesa-glx:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../13-libxatracker2_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de libxatracker2:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../14-linux-firmware_1.187.17_all.deb ...
Dépaquetage de linux-firmware (1.187.17) sur (1.187.16) ...
Préparation du dépaquetage de .../15-linux-libc-dev_5.4.0-88.99_amd64.deb ...
Dépaquetage de linux-libc-dev:amd64 (5.4.0-88.99) sur (5.4.0-86.97) ...
Préparation du dépaquetage de .../16-mesa-va-drivers_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de mesa-va-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../17-mesa-vdpau-drivers_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de mesa-vdpau-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Préparation du dépaquetage de .../18-mesa-vulkan-drivers_21.0.3-0ubuntu0.3~20.04.2_amd64.deb ...
Dépaquetage de mesa-vulkan-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.2) sur (21.0.3-0ubuntu0.3~20.04.1) ...
Paramétrage de linux-firmware (1.187.17) ...
update-initramfs: Generating /boot/initrd.img-5.11.0-36-generic
W: Possible missing firmware /lib/firmware/i915/skl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/cml_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/ehl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/ehl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_huc_7.5.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_huc_7.5.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/dg1_dmc_ver2_02.bin for module i915
update-initramfs: Generating /boot/initrd.img-5.11.0-34-generic
W: Possible missing firmware /lib/firmware/i915/skl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/cml_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/ehl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/ehl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_huc_7.5.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_huc_7.5.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_49.0.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/dg1_dmc_ver2_02.bin for module i915
update-initramfs: Generating /boot/initrd.img-5.8.0-63-generic
Paramétrage de linux-libc-dev:amd64 (5.4.0-88.99) ...
Paramétrage de libegl1-mesa:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libglapi-mesa:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libdrm-common (2.4.105-3~20.04.2) ...
Paramétrage de libdrm2:amd64 (2.4.105-3~20.04.2) ...
Paramétrage de libdrm-amdgpu1:amd64 (2.4.105-3~20.04.2) ...
Paramétrage de mesa-vulkan-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libdrm-nouveau2:amd64 (2.4.105-3~20.04.2) ...
Paramétrage de libgbm1:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libdrm-radeon1:amd64 (2.4.105-3~20.04.2) ...
Paramétrage de libdrm-intel1:amd64 (2.4.105-3~20.04.2) ...
Paramétrage de libgl1-mesa-dri:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libxatracker2:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libegl-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de mesa-va-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de mesa-vdpau-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libglx-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Paramétrage de libgl1-mesa-glx:amd64 (21.0.3-0ubuntu0.3~20.04.2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9.2) ...
arbiel@arbiel-NK3S-8-S4:~$ 
arbiel@arbiel-NK3S-8-S4:~$ sudo apt-get install virtualbox-dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib libsdl-ttf2.0-0 linux-image-5.8.0-63-generic linux-modules-5.8.0-63-generic python-is-python2
  python2 python2-minimal python2.7 python2.7-minimal
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox virtualbox-qt
Paquets suggérés :
  debtags menu vde2 virtualbox-guest-additions-iso
Les paquets suivants seront ENLEVÉS :
  virtualbox-6.1
Les NOUVEAUX paquets suivants seront installés :
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox virtualbox-dkms virtualbox-qt
0 mis à jour, 8 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 43,9 Mo/44,4 Mo dans les archives.
Après cette opération, 11,6 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Err :1 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-dkms amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 194.158.119.186 80]
Err :2 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 194.158.119.186 80]
Err :3 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-qt amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-dkms_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-qt_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?
arbiel@arbiel-NK3S-8-S4:~$ 

Arbiel

Dernière modification par Arbiel (Le 27/09/2021, à 22:48)


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#7 Le 28/09/2021, à 00:13

alv37

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Pour brave c'est le dépôt à désactiver et pas le logiciel, pour désactiver le dépôt tu édite le fichier dédié:

sudo nano /etc/apt/sources.list.d/brave-browser-release.list

et tu ajoute un dièse (#) avant la/les ligne(s) puis tu sauvegarde la modification et normalement quand tu fera les commandes de mises à jour tu aura plus d'erreur (du moins plus à cause de brave ^^).

Dernière modification par alv37 (Le 28/09/2021, à 00:13)

Hors ligne

#8 Le 28/09/2021, à 09:25

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour

En ipv4 ou ipv6, en inhibant ou en laissait actif le dépôt brave, "sudo apt-get install virtualbox-dkms"  ne fonctionne pas.

Je vais essayer avec le gestionnaire de paquets qui remplace synaptic et sur lequel je dois d'abord rechercher des informations.

Je reviens aux fichiers originaux (ipv6 et dépôt brave actif).

Je vous remercie tous les trois pour l'aide que vous m'avez apportée et je vous tiens informés du résultat que j'obtiendrai.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#9 Le 28/09/2021, à 09:41

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

L'installation de virtualbox-dkms ne fonctionne pas non plus avec l'outil graphique.

Je suppose qu'il s'agit d'une incohérence entre ma version de virtualbox, que j'ai vraisemblablement installée à partir du site Oracle, et la version proposée avec le 20.04.

J'abandonne, et le vais me contenter de réinstaller le noyau de virtualbox en tant que de besoin.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#10 Le 28/09/2021, à 10:31

airvb

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour ,
En désinstallant/purgeant la version installée actuellement, ajouter les dépôts oracle , puis réinstaller ça devrait le faire !

Tu peux regarder là
https://www.numetopia.fr/installer-virt … inux-mint/


@+

Hors ligne

#11 Le 28/09/2021, à 21:51

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonsoir airvb

Merci pour le lien que tu m'as indiqué et qui m'a été bien utile, et qui le sera encore à l'avenir.

Après installation du dépôt Oracle,

arbiel@arbiel-NK3S-8-S4:~$ cat /etc/apt/sources.list.d/virtualbox.list
deb [arch=amd64] http://download.virtualbox.org/virtualbox/debian focal contrib
arbiel@arbiel-NK3S-8-S4

mise à jour de la liste des paquets,

arbiel@arbiel-NK3S-8-S4:~$ sudo apt update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                                     
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease                                   
Atteint :4 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal InRelease                          
Atteint :5 http://download.virtualbox.org/virtualbox/debian focal InRelease                                
Réception de :6 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]        
114 ko réceptionnés en 1s (172 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.
arbiel@arbiel-NK3S-8-S4:~$

suppression de ma version de VirtualBox (6.1)

arbiel@arbiel-NK3S-8-S4:~$ sudo apt remove virtualbox-6.1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib libsdl-ttf2.0-0
  libsdl1.2debian linux-headers-5.11.0-34-generic
  linux-headers-5.8.0-63-generic linux-hwe-5.11-headers-5.11.0-34
  linux-hwe-5.8-headers-5.8.0-63 linux-image-5.11.0-34-generic
  linux-image-5.8.0-63-generic linux-modules-5.11.0-34-generic
  linux-modules-5.8.0-63-generic linux-modules-extra-5.11.0-34-generic
  python-is-python2 python2 python2-minimal python2.7 python2.7-minimal
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  virtualbox-6.1
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 192 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 301757 fichiers et répertoires déjà installés.
)
Suppression de virtualbox-6.1 (6.1.26-145957~Ubuntu~eoan) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) 
...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2)
 ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu
1) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.15-1) .
..
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1u
buntu3) ...

réinstallation de la version 6.1,

arbiel@arbiel-NK3S-8-S4:~$ sudo apt install virtualbox-6.1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-5.11.0-34-generic linux-hwe-5.11-headers-5.11.0-34
  linux-image-5.11.0-34-generic linux-modules-5.11.0-34-generic
  linux-modules-extra-5.11.0-34-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  virtualbox-6.1
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 90,7 Mo dans les archives.
Après cette opération, 192 Mo d'espace disque supplémentaires seront utilisés.
Réception de :1 http://download.virtualbox.org/virtualbox/debian focal/contrib amd64 virtualbox-6.1 amd64 6.1.26-145957~Ubuntu~eoan [90,7 MB]
90,7 Mo réceptionnés en 54s (1686 ko/s)                                       
Préconfiguration des paquets...
Sélection du paquet virtualbox-6.1 précédemment désélectionné.
(Lecture de la base de données... 301009 fichiers et répertoires déjà installés.
)
Préparation du dépaquetage de .../virtualbox-6.1_6.1.26-145957~Ubuntu~eoan_amd64
.deb ...
Dépaquetage de virtualbox-6.1 (6.1.26-145957~Ubuntu~eoan) ...
Paramétrage de virtualbox-6.1 (6.1.26-145957~Ubuntu~eoan) ...
addgroup: Le groupe « vboxusers » existe déjà en tant que groupe système. Fin de
 la procédure.
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) 
...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2)
 ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu
1) ...
Traitement des actions différées (« triggers ») pour systemd (245.4-4ubuntu3.13)
 ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.15-1) .
..
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1u
buntu3) ...
arbiel@arbiel-NK3S-8-S4:~$ sudo dpkg -V virtualbox-dkms
dpkg: paquet « virtualbox-dkms » n'est pas installé
arbiel@arbiel-NK3S-8-S4:~$

je n'arrive toujours pas à installer virtualbox-dkms

arbiel@arbiel-NK3S-8-S4:~$ sudo apt-get install virtualbox-dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib libsdl-ttf2.0-0
  linux-headers-5.11.0-34-generic linux-hwe-5.11-headers-5.11.0-34
  linux-image-5.11.0-34-generic linux-image-5.8.0-63-generic
  linux-modules-5.11.0-34-generic linux-modules-5.8.0-63-generic
  linux-modules-extra-5.11.0-34-generic python-is-python2 python2
  python2-minimal python2.7 python2.7-minimal
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox
  virtualbox-qt
Paquets suggérés :
  debtags menu vde2 virtualbox-guest-additions-iso
Les paquets suivants seront ENLEVÉS :
  virtualbox-6.1
Les NOUVEAUX paquets suivants seront installés :
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox
  virtualbox-dkms virtualbox-qt
0 mis à jour, 8 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 43,9 Mo/44,4 Mo dans les archives.
Après cette opération, 11,6 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Err :1 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-dkms amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
Err :2 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
Err :3 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-qt amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-dkms_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-qt_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?

et j'ai toujours le même problème au lancement de VirtualBox

Arbiel

Dernière modification par Arbiel (Le 28/09/2021, à 21:52)


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#12 Le 28/09/2021, à 23:41

alv37

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Vu que la commande fini en erreur et ne te télécharge/installe pas les paquets, peut-être essayer de les récupérer et installer à la main.

Téléchargement du paquet:

wget https://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-dkms_6.1.26-dfsg-3~ubuntu1.20.04.2_amd64.deb

Installation du paquet:

sudo dpkg -i virtualbox-dkms_6.1.26-dfsg-3~ubuntu1.20.04.2_amd64.deb

PS: je vois que ta des paquets qui sont plus utile, pense à les supprimer:

sudo apt autoremove

Hors ligne

#13 Le 29/09/2021, à 08:24

cqfd93

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour,

Dans ton dernier retour :

Err :1 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-dkms amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
Err :2 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
Err :3 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-qt amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-dkms_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-qt_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 2001:860:f70a::2 80]
E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?

Retour de ce dépôt inaccessible en ipv6, il l'est peut-être en ipv4 ?


cqfd93

Hors ligne

#14 Le 29/09/2021, à 09:45

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour

@cqfd93
Le passage en ipv4 ne résout pas le problème

arbiel@arbiel-NK3S-8-S4:~$ grep -v "^#" /etc/gai.conf
precedence ::ffff:0:0/96  100

arbiel@arbiel-NK3S-8-S4:~$ sudo apt-get install virtualbox-dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib libsdl-ttf2.0-0
  linux-headers-5.11.0-34-generic linux-hwe-5.11-headers-5.11.0-34
  linux-image-5.11.0-34-generic linux-image-5.8.0-63-generic
  linux-modules-5.11.0-34-generic linux-modules-5.8.0-63-generic
  linux-modules-extra-5.11.0-34-generic python-is-python2 python2
  python2-minimal python2.7 python2.7-minimal
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox
  virtualbox-qt
Paquets suggérés :
  debtags menu vde2 virtualbox-guest-additions-iso
Les paquets suivants seront ENLEVÉS :
  virtualbox-6.1
Les NOUVEAUX paquets suivants seront installés :
  dctrl-tools dkms libgsoap-2.8.91 liblzf1 libvncserver1 virtualbox
  virtualbox-dkms virtualbox-qt
0 mis à jour, 8 nouvellement installés, 1 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 43,9 Mo/44,4 Mo dans les archives.
Après cette opération, 11,6 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Err :1 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-dkms amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 194.158.119.186 80]
Err :2 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 194.158.119.186 80]
Err :3 http://fr.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 virtualbox-qt amd64 6.1.22-dfsg-2~ubuntu1.20.04.1
  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-dkms_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-qt_6.1.22-dfsg-2~ubuntu1.20.04.1_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?
arbiel@arbiel-NK3S-8-S4:~$ 

@alv37
Je vais exécuter tes instructions.
Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#15 Le 29/09/2021, à 09:56

cqfd93

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

C'est bizarre, parce que ton système essaye d'installer la version 6.1.22. Je suis aussi sous focal et j'ai la version 6.1.26 (pas installée mais disponible).

On peut voir ta version du système et tes sources ?

cat /etc/issue
uname -a
echo "${XDG_CURRENT_DESKTOP}"
find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

cqfd93

Hors ligne

#16 Le 29/09/2021, à 10:00

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

@alv37
L'installation à la main m'a permis de constater l'absence du paquet dkms dont dépend virtualbox-dkms

arbiel@arbiel-NK3S-8-S4:~$ sudo dpkg -i virtualbox-dkms_6.1.26-dfsg-3~ubuntu1.20.04.2_amd64.deb
Sélection du paquet virtualbox-dkms précédemment désélectionné.
(Lecture de la base de données... 301757 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de virtualbox-dkms_6.1.26-dfsg-3~ubuntu1.20.04.2_amd64.deb ...
/var/lib/dpkg/tmp.ci/preinst: 11: dkms: not found
/var/lib/dpkg/tmp.ci/preinst: 11: dkms: not found
/var/lib/dpkg/tmp.ci/preinst: 11: dkms: not found
Dépaquetage de virtualbox-dkms (6.1.26-dfsg-3~ubuntu1.20.04.2) ...
dpkg: des problèmes de dépendances empêchent la configuration de virtualbox-dkms :
 virtualbox-dkms dépend de dkms (>= 2.1.0.0) ; cependant :
  Le paquet dkms n'est pas installé.

dpkg: erreur de traitement du paquet virtualbox-dkms (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 virtualbox-dkms
arbiel@arbiel-NK3S-8-S4:~$

que j'ai été conduit à résoudre par

arbiel@arbiel-NK3S-8-S4:~$ sudo apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-5.11.0-34-generic linux-hwe-5.11-headers-5.11.0-34
  linux-image-5.11.0-34-generic linux-modules-5.11.0-34-generic
  linux-modules-extra-5.11.0-34-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  dctrl-tools dkms
Paquets suggérés :
  debtags menu
Les NOUVEAUX paquets suivants seront installés :
  dctrl-tools dkms
0 mis à jour, 2 nouvellement installés, 0 à enlever et 1 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/128 ko dans les archives.
Après cette opération, 599 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Sélection du paquet dctrl-tools précédemment désélectionné.
(Lecture de la base de données... 302032 fichiers et répertoires déjà installés.
)
Préparation du dépaquetage de .../dctrl-tools_2.24-3_amd64.deb ...
Dépaquetage de dctrl-tools (2.24-3) ...
Sélection du paquet dkms précédemment désélectionné.
Préparation du dépaquetage de .../dkms_2.8.1-5ubuntu2_all.deb ...
Dépaquetage de dkms (2.8.1-5ubuntu2) ...
Paramétrage de dctrl-tools (2.24-3) ...
Paramétrage de dkms (2.8.1-5ubuntu2) ...
Paramétrage de virtualbox-dkms (6.1.26-dfsg-3~ubuntu1.20.04.2) ...
Loading new virtualbox-6.1.26 DKMS files...
Building for 5.11.0-37-generic
Building initial module for 5.11.0-37-generic
Can't load /var/lib/shim-signed/mok/.rnd into RNG
139862699992384:error:2406F079:random number generator:RAND_load_file:Cannot ope
n file:../crypto/rand/randfile.c:98:Filename=/var/lib/shim-signed/mok/.rnd
Generating a RSA private key
..........+++++
..............................................................................++
+++
writing new private key to '/var/lib/shim-signed/mok/MOK.priv'
-----
Secure Boot not enabled on this system.
Done.

vboxdrv.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.11.0-37-generic/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.11.0-37-generic/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.11.0-37-generic/updates/dkms/

depmod...

DKMS: install completed.
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...

puis

arbiel@arbiel-NK3S-8-S4:~$ sudo dpkg -i virtualbox-dkms_6.1.26-dfsg-3~ubuntu1.20.04.2_amd64.deb
(Lecture de la base de données... 302084 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de virtualbox-dkms_6.1.26-dfsg-3~ubuntu1.20.04.2_amd64.deb ...

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 6.1.26
Kernel:  5.11.0-37-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/5.11.0-37-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/5.11.0-37-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/5.11.0-37-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...

DKMS: uninstall completed.

------------------------------
Deleting module version: 6.1.26
completely from the DKMS tree.
------------------------------
Done.
Dépaquetage de virtualbox-dkms (6.1.26-dfsg-3~ubuntu1.20.04.2) sur (6.1.26-dfsg-3~ubuntu1.20.04.2) ...
Paramétrage de virtualbox-dkms (6.1.26-dfsg-3~ubuntu1.20.04.2) ...
Loading new virtualbox-6.1.26 DKMS files...
Building for 5.11.0-37-generic
Building initial module for 5.11.0-37-generic
Secure Boot not enabled on this system.
Done.

vboxdrv.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.11.0-37-generic/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.11.0-37-generic/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/5.11.0-37-generic/updates/dkms/

depmod...

DKMS: install completed.
arbiel@arbiel-NK3S-8-S4:~$ sudo dpkg -V virtualbox-dkms
arbiel@arbiel-NK3S-8-S4:~$ 

Il me reste maintenant à vérifier que le problème original était effectivement l'absence de virtualbox-dkms.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#17 Le 29/09/2021, à 22:26

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonsoir

Pour répondre à l'interrogation de cqfd93 que je n'avais pas vue :

arbiel@arbiel-NK3S-8-S4:~$ cat /etc/issue
Ubuntu 20.04.3 LTS \n \l

arbiel@arbiel-NK3S-8-S4:~$ uname -a
Linux arbiel-NK3S-8-S4 5.11.0-37-generic #41~20.04.2-Ubuntu SMP Fri Sep 24 09:06:38 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
arbiel@arbiel-NK3S-8-S4:~$ e XDG_CURRENT_DESKTOP
declare -x XDG_CURRENT_DESKTOP="ubuntu:GNOME"
arbiel@arbiel-NK3S-8-S4:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list

     1	# deb cdrom:[Ubuntu 20.04.2.0 LTS _Focal Fossa_ - Release amd64 (20210209.1)]/ focal main restricted
     2	
     3	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4	# newer versions of the distribution.
     5	deb http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
     6	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
     7	
     8	## Major bug fix updates produced after the final release of the
     9	## distribution.
    10	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    11	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    12	
    13	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14	## team. Also, please note that software in universe WILL NOT receive any
    15	## review or updates from the Ubuntu security team.
    16	deb http://fr.archive.ubuntu.com/ubuntu/ focal universe
    17	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal universe
    18	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
    19	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
    20	
    21	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22	## team, and may not be under a free licence. Please satisfy yourself as to 
    23	## your rights to use the software. Also, please note that software in 
    24	## multiverse WILL NOT receive any review or updates from the Ubuntu
    25	## security team.
    26	deb http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
    27	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
    28	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    29	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    30	
    31	## N.B. software from this repository may not have been tested as
    32	## extensively as that contained in the main release, although it includes
    33	## newer versions of some applications which may provide useful features.
    34	## Also, please note that software in backports WILL NOT receive any review
    35	## or updates from the Ubuntu security team.
    36	deb http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    37	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    38	
    39	## Uncomment the following two lines to add software from Canonical's
    40	## 'partner' repository.
    41	## This software is not part of Ubuntu, but is offered by Canonical and the
    42	## respective vendors as a service to Ubuntu users.
    43	# deb http://archive.canonical.com/ubuntu focal partner
    44	# deb-src http://archive.canonical.com/ubuntu focal partner
    45	
    46	deb http://security.ubuntu.com/ubuntu focal-security main restricted
    47	# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
    48	deb http://security.ubuntu.com/ubuntu focal-security universe
    49	# deb-src http://security.ubuntu.com/ubuntu focal-security universe
    50	deb http://security.ubuntu.com/ubuntu focal-security multiverse
    51	# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse
    52	
    53	# This system was installed using small removable media
    54	# (e.g. netinst, live or single CD). The matching "deb cdrom"
    55	# entries were disabled at the end of the installation process.
    56	# For information about how to configure apt package sources,
    57	# see the sources.list(5) manual.

/etc/apt/sources.list.d/virtualbox.list

     1	deb [arch=amd64] http://download.virtualbox.org/virtualbox/debian focal contrib

/etc/apt/sources.list.d/brave-browser-release.list

     1	#deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg arch=amd64] https://brave-browser-apt-release.s3.brave5t5rjjg3s6k.onion/ stable main

/etc/apt/sources.list.d/yannubuntu-ubuntu-boot-repair-focal.list

     1	deb http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal main
     2	# deb-src http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal main
arbiel@arbiel-NK3S-8-S4:~$ 

Mais le problème n'est plus l'installation de virtualbox-dkms, maintenant résolue, mais le fait que cette installation ne donne rien.

À la première exécution d'une machine virtuelle après démarrage du PC survient encore l'erreur qui m'a fait ouvrir cette discussion. Son intitulé indique

"VirtualBox - Error in suplibOsInit" 

et son contenu

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing

'/sbin/vboxconfig'

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

Apparemment l'arrêt ou le démarrage du PC dégrade ou efface le noyau linux de VirtualBox. Je dois maintenant reprendre quelques tests pour essayer d'obtenir de nouvelles informations sur ce qui se passe.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#18 Le 29/09/2021, à 23:35

cqfd93

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Je ne vois rien d'anormal dans tes sources.

Arbiel a écrit :

Mais le problème n'est plus l'installation de virtualbox-dkms, maintenant résolue, mais le fait que cette installation ne donne rien.

Peut-être parce que tes versions de virtualbox et virtualbox-dkms installées ne correspondent pas ?


cqfd93

Hors ligne

#19 Le 30/09/2021, à 06:10

bruno

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour,

Il aurait mieux valu ne pas chercher à installer le paquet virtualbox-dkms.
Dés le message #3 on voit que ce paquet est en conflit avec la version installée de virtualbox : paquet virtualbox-6.1 issu des dépôts Oracle.

Il y a effectivement sans doute un conflit de version entre le module vbxodrv présent  sur le système et la version de virtualbox installée.

Il faut montrer les retour de :

modinfo vboxdrv
virtualbox --help

Une purge complète des paquets virtualbox puis une réinstallation de la version d'Oracke ou celle de Debian (mais pas les deux en même temps), pourrait résoudre le problème.

Autre problème : apparemment la mise à jour des dépôts ne se fait pas correctement en #14

Hors ligne

#20 Le 30/09/2021, à 20:06

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonsoir

@Bruno,cqfd93
vboxdrv et virtualbox me semblent compatibles, tous deux à la version 6.1.26

arbiel@arbiel-NK3S-8-S4:~$ modinfo vboxdrv
filename:       /lib/modules/5.11.0-37-generic/updates/dkms/vboxdrv.ko
version:        6.1.26_Ubuntu r145957 (0x00300000)
license:        GPL
description:    Oracle VM VirtualBox Support Driver
author:         Oracle Corporation
srcversion:     384D5079D63E907132614A5
depends:        
retpoline:      Y
name:           vboxdrv
vermagic:       5.11.0-37-generic SMP mod_unload modversions 
sig_id:         PKCS#7
signer:         arbiel-NK3S-8-S4 Secure Boot Module Signature key
sig_key:        6A:D0:8D:92:7D:CE:14:51:72:D7:C8:85:96:77:04:3C:18:48:4C:E9
sig_hashalgo:   sha512
signature:      57:E0:5A:06:13:66:2A:2A:36:EC:63:84:69:DD:46:4A:16:99:8B:B4:
		FF:A8:24:DD:5A:6C:E9:33:5C:87:EB:94:E0:53:E2:91:01:CB:1A:1D:
		FF:08:7A:1E:82:6C:4E:3F:F2:3C:3B:06:89:0E:15:8E:89:C2:C6:F4:
		B8:A9:DB:E8:3C:F7:67:36:ED:DC:82:4B:71:46:BA:AA:DF:13:7A:05:
		44:18:04:ED:92:F2:06:43:EC:3A:2C:CE:7D:5E:BB:9E:78:10:E8:1F:
		34:7E:62:84:8D:FB:C5:CD:B8:F6:24:67:DE:E7:CD:9D:92:A8:CE:B9:
		07:6E:E9:2F:82:A8:61:D8:39:F9:B2:2A:79:9A:E6:6F:47:A8:32:FB:
		BF:5D:A4:92:B0:23:C6:A2:6E:EA:B1:4C:03:7E:5D:EB:5F:43:E4:28:
		01:15:FB:AF:42:D0:98:C5:EE:09:5B:04:8C:9E:CA:4E:C0:1F:0F:8B:
		51:2F:E9:DA:1A:3C:E6:BC:2B:02:DB:76:63:EA:F0:A6:39:74:EA:A0:
		B9:EF:9E:82:A5:DE:A1:07:C2:AB:87:94:6A:FC:7B:4E:BB:C5:10:9D:
		B0:9C:6F:E1:B2:2B:63:7B:30:89:1F:96:8E:38:62:36:F7:32:97:67:
		8B:B0:F3:07:37:88:D2:6B:5A:D2:1B:BE:63:CF:85:95
parm:           force_async_tsc:force the asynchronous TSC mode (int)
arbiel@arbiel-NK3S-8-S4:~$
arbiel@arbiel-NK3S-8-S4:~$ virtualbox --help
Oracle VM VirtualBox VM Selector v6.1.26
(C) 2005-2021 Oracle Corporation
All rights reserved.

No special options.

If you are looking for --startvm and related options, you need to use VirtualBoxVM.
arbiel@arbiel-NK3S-8-S4:~$

Pour ce qui est de la disinstallation et réinstallation de virtualbox, n'est-ce pas ce que j'ai fait à partir du #11 en suivant les conseils d'airvb au #10 ?


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#21 Le 01/10/2021, à 07:05

airvb

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bjr ,
je retenterai l'expérience en PURGEANT lors de la désinstallation (apt purge
Et je purgerai tous les paquets lié à virtualbox
Attention, il est possible que les fichiers .vbox de config de tes VM soit aussi effacés. Juste prendre les caractéristiques pour reproduire à l'identique
Je viens de taper sur le mien, juste le kernel qui < , suis sous focal

modinfo vboxdrv 
filename:       /lib/modules/5.4.0-86-generic/misc/vboxdrv.ko
version:        6.1.26 r145957 (0x00300000)
license:        GPL
description:    Oracle VM VirtualBox Support Driver
author:         Oracle Corporation
srcversion:     C028F8DFFEE6F572A26DC87
depends:        
retpoline:      Y
name:           vboxdrv
vermagic:       5.4.0-86-generic SMP mod_unload modversions 
parm:           force_async_tsc:force the asynchronous TSC mode (int)

Mais je viens de lire que le 5.11 est ok pour la 6.26 !

N'aurais tu pas 2 versions d'installées sur ton pc , un 6.0 et 6.1 ?

Hors ligne

#22 Le 01/10/2021, à 07:40

bruno

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bon cela à l'air correct pour les versions utilisées.
Mais en relisant le fil j'ai l'impression que tu as un problème de signature des modules avec le « secure boot ».
Voir ce ticket : https://www.virtualbox.org/ticket/11577?cversion=3

Pour une désinstallation complète je ferais :

sudo apt autoremove --purge ~nvirtualbox*

Puis installation de la version des dépôts Oracle :

sudo apt install virtualbox-6.1

Hors ligne

#23 Le 02/10/2021, à 09:31

Arbiel

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

Bonjour

Le so-called secure boot est désactivé

arbiel@arbiel-NK3S-8-S4:~$ /usr/bin/mokutil --sb-state
SecureBoot disabled
Platform is in Setup Mode
arbiel@arbiel-NK3S-8-S4:~$ 

Pour des raisons historiques, je lance mes machines virtuelles par VBoxManage. J'ai voulu m'assurer que le problème ne venait pas de ce mode opératoire. Le message d'erreur alors affiché lors du lancement de VirtualBox apporte une information supplémentaire :

arbiel@arbiel-NK3S-8-S4:~$ VirtualBox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (5.11.0-37-generic) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.
arbiel@arbiel-NK3S-8-S4:~$ sudo /sbin/vboxconfig
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
arbiel@arbiel-NK3S-8-S4:~$ VirtualBox
arbiel@arbiel-NK3S-8-S4:~$ VirtualBox
arbiel@arbiel-NK3S-8-S4:~$ 

J'ai exécuté les instructions proposées par bruno pour désinstaller complètement VirtualBox et la réinstaller. Le problème n'en a pas été résolu pour autant. Je suppose l'existence d'une incompatibilité entre la distributon Ubuntu 20.04.3 LTS que j'utilise et la dernière version d'Oracle. Je vais donc réinstaller depuis la logithèque après avoir cependant essayé de créer un alias matériel du noyau, si je le trouve, que je nommerai 5.11.0-37-generic puisque

airvb a écrit :

Mais je viens de lire que le 5.11 est ok pour la 6.26 !

Arbiel

Dernière modification par Arbiel (Le 02/10/2021, à 09:40)


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#24 Le 02/10/2021, à 11:57

bruno

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

C'est quand même curieux ce problème…
Sur ma machine ou UEFI et secure boot sont désactivés, Virtualbox 6.1 fonctionne parfaitement avec la même version d'Ubuntu et du noyau que toi.

Je persiste à croire que le souci est lié à la signature du module (en #20 on voit bien que le module est signé) et à cette daube de secure boot.

Hors ligne

#25 Le 03/10/2021, à 07:57

airvb

Re : [Résolu]VirtualBox : récurrence du message Kernel driver not installed

bruno a écrit :

Je persiste à croire que le souci est lié à la signature du module (en #20 on voit bien que le module est signé) et à cette daube de secure boot.

Lo,
Cela ne va pas aider, j'ai 2 machines sur lesquelles VB est installé.
La première n'est pas signée ,( voir #21 )et la deuxième l'est et les 2 fonctionnent !

La 2ième :

modinfo vboxdrv 
filename:       /lib/modules/5.4.0-81-generic/misc/vboxdrv.ko
version:        6.1.26 r145957 (0x00300000)
license:        GPL
description:    Oracle VM VirtualBox Support Driver
author:         Oracle Corporation
srcversion:     C028F8DFFEE6F572A26DC87
depends:        
retpoline:      Y
name:           vboxdrv
vermagic:       5.4.0-81-generic SMP mod_unload modversions 
sig_id:         PKCS#7
signer:         airvb-serveur Secure Boot Module Signature key
sig_key:        4E:7F:AA:D9:30:C4:39:36:DE:64:0A:35:7B:E1:EE:DD:0C:FD:8A:97
sig_hashalgo:   sha512
signature:      BB:A4:C9:5D:6C:51:AE:19:A2:81:78:09:B8:2D:B0:0C:05:AA:BE:3C:
		13:07:70:2E:1B:ED:20:C3:56:CF:05:10:DA:F7:0E:97:71:B5:CC:8F:
		9E:19:65:BB:CD:F9:3B:A9:AB:9C:B4:9C:F2:A8:6E:0E:F2:BB:C2:2C:
		7B:7D:4C:3C:9E:B5:CF:86:81:B0:37:4B:FE:67:0C:3E:1B:E1:32:5F:
		39:9E:84:2B:04:05:2C:EC:6D:96:58:E0:9D:85:19:CE:BD:05:5B:5E:
		CF:7C:2C:6C:AF:38:D9:C6:AF:70:D8:EE:CE:89:68:86:43:A2:85:35:
		7C:F8:AC:89:9C:26:0C:1F:7B:C4:EC:7F:33:D1:0D:9F:24:14:C3:8F:
		00:28:6B:E0:90:E2:75:10:1E:FC:F7:F5:E8:C8:01:6C:30:20:7E:DF:
		7E:75:14:26:DB:F4:2C:F1:28:69:29:A3:81:79:B6:C2:83:6C:E1:B6:
		15:E1:B2:5F:DA:71:DD:7E:EF:8F:4A:E9:18:CF:86:A6:85:2C:ED:8D:
		37:82:AA:2C:8D:E1:3C:2C:66:68:66:4A:71:83:E6:71:E4:64:D8:EC:
		AF:15:FF:CA:7F:67:92:CB:9E:4A:89:98:07:2A:0B:C2:C9:3A:83:71:
		1A:1E:F6:A7:A6:17:79:D7:6D:32:90:38:37:2E:D5:E4
parm:           force_async_tsc:force the asynchronous TSC mode (int)

Hors ligne