Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/05/2022, à 15:08

vgr

[RESOLU] phpmyadmin ne fonctionne pas (ubuntu 20.04)

Bonjour.

Je viens d'installer un nouveau serveurs de zéro en ubuntu 20.04
J'ai suivi ce tutoriel

Quand j'accède à la page phpmyadmin, j’obtiens une  page avec le code suivant :

get(Response::class); /** @var DatabaseInterface $dbi */ $dbi = $containerBuilder->get(DatabaseInterface::class); /** @var HomeController $controller */ $controller = $containerBuilder->get(HomeController::class); if (isset($_REQUEST['ajax_request']) && ! empty($_REQUEST['access_time'])) { exit; } if (isset($_POST['set_theme'])) { $controller->setTheme([ 'set_theme' => $_POST['set_theme'], ]); header('Location: index.php' . Url::getCommonRaw()); } elseif (isset($_POST['collation_connection'])) { $controller->setCollationConnection([ 'collation_connection' => $_POST['collation_connection'], ]); header('Location: index.php' . Url::getCommonRaw()); } elseif (! empty($_REQUEST['db'])) { // See FAQ 1.34 $page = null; if (! empty($_REQUEST['table'])) { $page = Util::getScriptNameForOption( $GLOBALS['cfg']['DefaultTabTable'], 'table' ); } else { $page = Util::getScriptNameForOption( $GLOBALS['cfg']['DefaultTabDatabase'], 'database' ); } include ROOT_PATH . $page; } elseif ($response->isAjax() && ! empty($_REQUEST['recent_table'])) { $response->addJSON($controller->reloadRecentTablesList()); } elseif ($GLOBALS['PMA_Config']->isGitRevision() && isset($_REQUEST['git_revision']) && $response->isAjax() ) { $response->addHTML($controller->gitRevision()); } else { // Handles some variables that may have been sent by the calling script $GLOBALS['db'] = ''; $GLOBALS['table'] = ''; $show_query = '1'; if ($server > 0) { include ROOT_PATH . 'libraries/server_common.inc.php'; } $response->addHTML($controller->index()); } 

Je ne trouve pas de problème similaires sur le web.
Merci de votre aide.

VGR.

Dernière modification par vgr (Le 06/05/2022, à 13:21)

Hors ligne

#2 Le 05/05/2022, à 22:15

vgr

Re : [RESOLU] phpmyadmin ne fonctionne pas (ubuntu 20.04)

Bonsoir

Alors en fait c'est plus fin que ça...
Le site fonctionne, sauf que
Sur FIREFOX
==> sous linux (ubuntu 18.04.6 LTS)
=====> http://monServer_1/phpmyadmin ==> Donne la page blanche avec le texte donné dans le premier post
=====> http://monServer_1/phpmyadmin/index.php ==> fonctionne bien
==> sous Windows
=====> http://monServer_1/phpmyadmin ==> fonctionne bien
=====> http://monServer_1/phpmyadmin/index.php ==> fonctionne bien

Sur GOOGLE CHROME
toutes les combinaisons fonctionnent

Et j'ai un monServer_2 pour lequel je n'ai pas ce comportement (avec phpmyadmin également)
Mon firefox sous linux semble ne pas chercher la page index.php
Une idée du pourquoi ?

VGR

Hors ligne

#3 Le 05/05/2022, à 22:29

alex2423

Re : [RESOLU] phpmyadmin ne fonctionne pas (ubuntu 20.04)

Il faut que tu regardes sur ton serveur Web, la configuration de ton site, si tu as bien précisé comme index,
index.php

Si tu créé par exemple une page index.php à la racine de ton site, avec du contenu bidon, par exemple

<?php echo "toto"; ?> 

Et si tu appelles juste la page suivante, est ce que cela fonctionne ?
http://monServer_1/
Ou est ce que tu dois appeler obligatoirement
http://monServer_1/index.php

EDIT : oups, j'avais lu, le comportement diffère en fonction du navigateur. C'est vraiment bizzare ton histoire, c

Hors ligne

#4 Le 06/05/2022, à 12:15

vgr

Re : [RESOLU] phpmyadmin ne fonctionne pas (ubuntu 20.04)

Et si tu appelles juste la page suivante, est ce que cela fonctionne ?
http://monServer_1/
Ou est ce que tu dois appeler obligatoirement
http://monServer_1/index.php

EDIT : oups, j'avais lu, le comportement diffère en fonction du navigateur. C'est vraiment bizzare ton histoire, c

Oui en précisant 'index.php' cela fonctionne, mais juste sur firefox sous linux (ubuntu desktop...)
Oui je suis bien d'accord...

Hors ligne

#5 Le 06/05/2022, à 12:39

bruno

Re : [RESOLU] phpmyadmin ne fonctionne pas (ubuntu 20.04)

Bonjour,
Le problème a certainement été corrigé sur le serveur mais la page est toujours dans le cache de Firefox.
Recommence le test en vidant le cache de Firefox.

Hors ligne

#6 Le 06/05/2022, à 13:21

vgr

Re : [RESOLU] phpmyadmin ne fonctionne pas (ubuntu 20.04)

C'est exact. Merci.
VGR

Hors ligne