Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/05/2022, à 22:39

T00rk

Ubuntu 22.04 / Radeon RX570

Bonjour,

Je viens de migrer mon PC sur la version 22.04.
Tout se passait bien quand malheureusement il a fallu installer les pilotes graphiques.

J'ai d'abord essayé le fameux amdgpu des familles qui vient du site officiel AMD.
Aucune surprise, ça n'a pas fonctionné.
J'ai eu des erreurs au niveau de amdgpu-dkms et d'autres paquets qui ne s'installaient pas.

J'ai donc ajouté le dépôt ppa:oibaf/graphics-drivers.

apt list | grep mesa
libd3dadapter9-mesa-dev/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libd3dadapter9-mesa-dev/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libd3dadapter9-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libd3dadapter9-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libegl-mesa0/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
libegl-mesa0/jammy,now 22.2~git2205100600.768ebf~oibaf~j i386  [installé]
libegl1-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 amd64
libegl1-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 i386
libegl1-amdgpu-mesa-drivers/focal 1:22.0.0.50002-1384495 amd64
libegl1-amdgpu-mesa-drivers/focal 1:22.0.0.50002-1384495 i386
libegl1-amdgpu-mesa/focal 1:22.0.0.50002-1384495 amd64
libegl1-amdgpu-mesa/focal 1:22.0.0.50002-1384495 i386
libegl1-mesa-dev/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
libegl1-mesa-dev/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libegl1-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libegl1-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libgl1-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 amd64
libgl1-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 i386
libgl1-amdgpu-mesa-dri/focal 1:22.0.0.50002-1384495 amd64
libgl1-amdgpu-mesa-dri/focal 1:22.0.0.50002-1384495 i386
libgl1-amdgpu-mesa-glx/focal 1:22.0.0.50002-1384495 amd64
libgl1-amdgpu-mesa-glx/focal 1:22.0.0.50002-1384495 i386
libgl1-mesa-dev/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
libgl1-mesa-dev/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libgl1-mesa-dri/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
libgl1-mesa-dri/jammy,now 22.2~git2205100600.768ebf~oibaf~j i386  [installé]
libgl1-mesa-glx/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
libgl1-mesa-glx/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libglapi-amdgpu-mesa/focal 1:22.0.0.50002-1384495 amd64
libglapi-amdgpu-mesa/focal 1:22.0.0.50002-1384495 i386
libglapi-mesa/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
libglapi-mesa/jammy,now 22.2~git2205100600.768ebf~oibaf~j i386  [installé]
libgles1-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 amd64
libgles1-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 i386
libgles1-amdgpu-mesa/focal 1:22.0.0.50002-1384495 amd64
libgles1-amdgpu-mesa/focal 1:22.0.0.50002-1384495 i386
libgles2-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 amd64
libgles2-amdgpu-mesa-dev/focal 1:22.0.0.50002-1384495 i386
libgles2-amdgpu-mesa/focal 1:22.0.0.50002-1384495 amd64
libgles2-amdgpu-mesa/focal 1:22.0.0.50002-1384495 i386
libgles2-mesa-dev/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libgles2-mesa-dev/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libgles2-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libgles2-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libglu1-mesa-dev/jammy,now 9.0.2-1 amd64  [installé]
libglu1-mesa-dev/jammy 9.0.2-1 i386
libglu1-mesa/jammy,now 9.0.2-1 amd64  [installé, automatique]
libglu1-mesa/jammy 9.0.2-1 i386
libglw1-mesa-dev/jammy 8.0.0-1.1build1 amd64
libglw1-mesa/jammy 8.0.0-1.1build1 amd64
libglx-mesa0/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
libglx-mesa0/jammy,now 22.2~git2205100600.768ebf~oibaf~j i386  [installé]
libosmesa6-dev/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libosmesa6-dev/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libosmesa6/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libosmesa6/jammy 22.2~git2205100600.768ebf~oibaf~j i386
libwayland-egl1-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
libwayland-egl1-mesa/jammy 22.2~git2205100600.768ebf~oibaf~j i386
mesa-amdgpu-common-dev/focal 1:22.0.0.50002-1384495 amd64
mesa-amdgpu-common-dev/focal 1:22.0.0.50002-1384495 i386
mesa-amdgpu-omx-drivers/focal 1:22.0.0.50002-1384495 amd64
mesa-amdgpu-omx-drivers/focal 1:22.0.0.50002-1384495 i386
mesa-amdgpu-va-drivers/focal 1:22.0.0.50002-1384495 amd64
mesa-amdgpu-va-drivers/focal 1:22.0.0.50002-1384495 i386
mesa-amdgpu-vdpau-drivers/focal 1:22.0.0.50002-1384495 amd64
mesa-amdgpu-vdpau-drivers/focal 1:22.0.0.50002-1384495 i386
mesa-common-dev/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
mesa-common-dev/jammy 22.2~git2205100600.768ebf~oibaf~j i386
mesa-opencl-icd/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64 [configuration restante]
mesa-opencl-icd/jammy 22.2~git2205100600.768ebf~oibaf~j i386
mesa-utils-bin/jammy,now 8.4.0-1ubuntu1 amd64  [installé, automatique]
mesa-utils/jammy,now 8.4.0-1ubuntu1 amd64  [installé]
mesa-va-drivers/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
mesa-va-drivers/jammy,now 22.2~git2205100600.768ebf~oibaf~j i386  [installé]
mesa-vdpau-drivers/jammy,now 22.2~git2205100600.768ebf~oibaf~j amd64  [installé]
mesa-vdpau-drivers/jammy 22.2~git2205100600.768ebf~oibaf~j i386
mesa-vulkan-drivers/jammy 22.2~git2205100600.768ebf~oibaf~j amd64
mesa-vulkan-drivers/jammy,now 22.2~git2205100600.768ebf~oibaf~j i386  [installé]
mesaflash/jammy 3.4.2-1 amd64

Le problème, c'est que j'ai quelques applications qui ne comprennent pas que j'utilise ces drivers là.
Par exemple, Plex Media Player me renvoie l'erreur suivante :

Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory

J'ai donc cherché à savoir quel driver vdpau était utilisé.

vdpauinfo
display: :0   screen: 0
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
sudo lshw -c video
  *-display                 
       description: VGA compatible controller
       produit: Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
       fabricant: Advanced Micro Devices, Inc. [AMD/ATI]
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       nom logique: /dev/fb0
       version: ef
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm pciexpress msi vga_controller bus_master cap_list rom fb
       configuration : depth=32 driver=amdgpu latency=0 resolution=1920,1080
       ressources : irq:137 mémoire:90000000-9fffffff mémoire:a0000000-a01fffff portE/S:3000(taille=256) mémoire:a0400000-a043ffff mémoire:c0000-dffff

Pourriez-vous m'aider svp ?

Merci d'avance.

Hors ligne

#2 Le 10/05/2022, à 22:42

xubu1957

Re : Ubuntu 22.04 / Radeon RX570

Bonjour,

Pour info > des remarques d'abelthorne.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 10/05/2022, à 22:50

T00rk

Re : Ubuntu 22.04 / Radeon RX570

Le problème c'est que je ne connais pas vraiment d'autres alternatives.

Hors ligne

#4 Le 10/05/2022, à 22:51

xubu1957

Re : Ubuntu 22.04 / Radeon RX570

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 10/05/2022, à 22:55

T00rk

Re : Ubuntu 22.04 / Radeon RX570

dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                                       Architecture Description
+++-==========================================-=============================================-============-================================================================================
rc  ca-certificates-java                       20190909                                      all          Common CA certificates (JKS keystore)
rc  java-common                                0.72build2                                    all          Base package for Java runtimes
rc  javascript-common                          11+nmu1                                       all          Base support for JavaScript library packages
rc  libjs-jquery                               3.6.0+dfsg+~3.5.13-1                          all          JavaScript library for dynamic web applications
rc  libvdpau1:i386                             1.5-1~oibaf~j                                 i386         Video Decode and Presentation API for Unix (libraries)
rc  mesa-opencl-icd:amd64                      22.2~git2205100600.768ebf~oibaf~j             amd64        free implementation of the OpenCL API -- ICD runtime
rc  openjdk-8-jre-headless:amd64               8u312-b07-0ubuntu1                            amd64        OpenJDK Java runtime, using Hotspot JIT (headless)

Hors ligne

#6 Le 10/05/2022, à 23:01

xubu1957

Re : Ubuntu 22.04 / Radeon RX570

Il faut attendre des aidants connaisseurs.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 28/05/2022, à 10:12

T00rk

Re : Ubuntu 22.04 / Radeon RX570

up

Hors ligne