Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/05/2022, à 20:21

L'Africain

(Résolu) Connexion https avec nextcloud

Bonjour,
Je viens d'installer un serveur nextcloud. Je voudrais le rendre accessible en https. J'ai suivi la procédure (peut-être mal) pour générer un certificat ssl. Ça fonctionne en local avec l'alerte dans Firefox, j'accepte le risque et je me connecte. Par contre en internet ça ne fonctionne pas tout est redirigé sur ma box proximus avec un nom de domaine ovh.
j'ai du utiliser le port 444 car le 443 est bloqué par Proximus en Belgique.
Ça c'est mon premier problème à savoir me connecter à mon serveur en internet, sur le port 444. Je précise qu'en http tout fonctionne avec le port 90 le 80 étant aussi vérouillé comme le 443.
Après cela j'ai tenté d'utiliser certbot pour éviter l'alerte mais il semble que cela ne fonctionne pas avec le port 444.
Voici le contenu de mes fichiers:

  GNU nano 4.8                                      /etc/apache2/sites-available/nextcloud.conf                                                
  </IfModule>
</Directory>

<VirtualHost *:80>
   ServerName intra.monsite.net/
   Redirect permanent / https://intra.monsite.net/
</VirtualHost>

<VirtualHost *:90>
   ServerName intra.monsite.net/
   Redirect permanent / https://intra.monsite.net/
</VirtualHost>

<VirtualHost *:443>
   ServerName intra.monsite.net/
   Redirect permanent / https://intra.monsite.net/
   SSLEngine on
   SSLCertificateFile /etc/ssl/certs/apache-selfsigned.crt
   SSLCertificateKeyFile /etc/ssl/private/apache-selfsigned.key
</VirtualHost>

<VirtualHost *:444>
   ServerName intra.monsite.net/
   Redirect permanent / https://intra.monsite.net/
   SSLEngine on
   SSLCertificateFile /etc/ssl/certs/apache-selfsigned.crt
   SSLCertificateKeyFile /etc/ssl/private/apache-selfsigned.key
</VirtualHost>

et le conf de nextcloud:

  GNU nano 4.8                                          /var/www/nextcloud/config/config.php                                                   
<?php
$CONFIG = array (
  'instanceid' => '*****************',
  'passwordsalt' => '************************************',
  'secret' => '****************************************************',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '192.168.0.50',
    2 => 'xx.xx.xxx.xxx',
    3 => 'intra.monsite.net',
    4 => 'intra.monsite.net:90',
    5 => 'intra.monsite.net:444',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '22.2.7.1',
  'overwrite.cli.url' => 'http://localhost/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxxxx',
  'dbpassword' => 'xxxxxxxxxxxxxxxxxxx',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'maintenance' => false,
  'updater.secret' => '*********************************************************.',
  'theme' => '',
  'loglevel' => 2,
);

merci d'avance

Modération : masquage d'informations potentiellement sensibles.

Dernière modification par L'Africain (Le 04/06/2022, à 10:46)


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#2 Le 01/06/2022, à 12:36

bruno

Re : (Résolu) Connexion https avec nextcloud

Bonjour,

Est-ce que tu as réservé un nom de domaine auprès d'un prestataire (OVH ?) ?

Si oui est-ce que tu as créé les enregistrements DNS nécessaires pour faire pointer ton nom de domaine vers ton IP publique ?
En espérant que ton FAI te fournisse une IP fixe, sinon il faudra utiliser un truc du type dynDNS, ou si tu es chez OVH leur interface spécifique DynHost.

Es-tu bien sûr que ton FAI bloque les ports 80 ett 443 en entrée (personnellement je n'ai jamais vu cela même chez les pires) ?
Ne seraient-ils pas plutôt déjà utilisés  pour l'accès distant à ta box ? Et dans ce cas c'est peut-être configurable su l'interface de la box.

Je ne pense pas que tu arriveras à faire fonctionner certbot de manière simple avec un serveur web sur des ports non standards. Si tu ne peux pas utiliser les ports standards il va falloir utiliser le challenge DNS, ce qui est un peu plus complexe.

Hors ligne

#3 Le 03/06/2022, à 12:52

alex2423

Re : (Résolu) Connexion https avec nextcloud

Je suis de l'avis de Bruno, dans un premier temps, je revérifierai la configuration NAT sur la box de l'ensemble des redirections de ports. Je suis très supris que cela ne fonctionne pas.

Puis dans un premier temps, je te suggère de faire un test avec ton adresse IP public.
Même si ton ip est dynamique, et risque de changer, ce n'est pas grave, c'est juste pour faire un test sans prendre en considération un nom de domaine, ou un dyndns, ...
Par contre il faudra que tu refasses un certificat en précisant ton ip public.

Bien penser à faire le test depuis l'extérieur de ton réseau, par exemple en te connectant à ton serveur depuis ton téléphone. Avant de passer l'étape nom de domaine, il faut t'assurer que tout est okay via l'ip public. Mon crédo, chaque chose en son temps.

Pour connaitre ton IP public, tu devrais la trouver sur l'interface de ta box ou via un site. Tu tapes sur ton moteur de rechercher préféré "What is my ip"

Dernière modification par alex2423 (Le 03/06/2022, à 13:00)

Hors ligne

#4 Le 03/06/2022, à 13:10

L'Africain

Re : (Résolu) Connexion https avec nextcloud

Bonjour les amis,
et Merci de vos réponses.

bruno a écrit :

Est-ce que tu as réservé un nom de domaine auprès d'un prestataire (OVH ?) ?

Oui ça c'est bon.

bruno a écrit :

...as créé les enregistrements DNS nécessaires pour faire pointer ton nom de domaine vers ton IP publique

Oui c'est bon aussi.

bruno a écrit :

ton FAI bloque les ports 80 ett 443

Oui certain, j'ai un ami à Proximus qui me l'a redit, mais il y a une option pour le désactiver.

bruno a écrit :

faire fonctionner certbot de manière simple avec un serveur web sur des ports non standards

Finalement nous avons réussi! Mais j'attends toujours que mon frère m'explique comment il a fait. Si j'ai bien compris il y a une bizarrerie avec le port 80 qu'il faut ouvrir momentanément.

Donc au final mon frère à force de chipoté à réussi, mais j'attends qu'il vienne expliquer comment. Du coup ça vaudrait la peine de mettre à jour les pages de la doc sur apache et le https et sur certbot.
Merci en tout cas d'avoir pris le temps.
l'Africain

Dernière modification par L'Africain (Le 03/06/2022, à 13:30)


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#5 Le 03/06/2022, à 13:50

bruno

Re : (Résolu) Connexion https avec nextcloud

Du coup ça vaudrait la peine de mettre à jour les pages de la doc sur apache et le https et sur certbot.

Non, il ne vaut mieux pas encombrer la doc avec des cas d'usage très particuliers.

Hors ligne

#6 Le 03/06/2022, à 14:25

L'Africain

Re : (Résolu) Connexion https avec nextcloud

Je pensais pas à de nouvelle page mais à celle qui existe déjà:
https://doc.ubuntu-fr.org/tutoriel/secu … 2_avec_ssl la partie du point 2.1 me semble incomplète.


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne

#7 Le 03/06/2022, à 15:07

bruno

Re : (Résolu) Connexion https avec nextcloud

Je ne vois rien qui manque dans cette doc. J'ai juste fait une petite mise à jour sur l'installation de certbot (inutile de maintenir des instructions pour des distributions en fin de vie).

Dernière modification par bruno (Le 03/06/2022, à 15:16)

Hors ligne

#8 Le 04/06/2022, à 10:46

L'Africain

Re : (Résolu) Connexion https avec nextcloud

Tu as peut-être raison, dès que j'ai le temps je vais revoir ce qui m'apparaissait manquant. Je me demande si ce n'est pas une histoire de fichier à modifier.


Ubuntu-Unity 18.04 LDLC (clevo) X/Lubuntu-Mate
"Donne à celui qui te demande…" Mt 5,42

Hors ligne