Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/02/2023, à 14:20

Hourra!

[Résolu] MariaDB

Bonjour à tous,

Je suis paasé à Ubuntu 22.04 la semaine dernière, et j'essaie, depuis lors, d'installer MariaDB.

Après plusieurs tentatives personnelles avortées, je me suis rendu ici :

https://www.makeuseof.com/install-set-u … on-ubuntu/

Et je suis scrupuleusement les directives, mais je reviens toujours au même point :

sudo apt install mariadb-server mariadb-client
 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Aucune version du paquet mariadb-server n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source


Aucune version du paquet mariadb-client n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « mariadb-server » n'a pas de version susceptible d'être installée
E: Le paquet « mariadb-client » n'a pas de version susceptible d'être installée

Impossible donc d'installer MariaDB sur Ubuntu 22.04.

Est-ce que quelqu'un aurait une petite idée ?

Merci.

Geoffroy, Ubuntu 22.04

Dernière modification par Hourra! (Le 25/02/2023, à 18:00)

Hors ligne

#2 Le 24/02/2023, à 14:28

ylag

Re : [Résolu] MariaDB

Bonjour,

Il faut activer la section universe des dépôts dans les sources pour accéder aux paquets de mariadb.

A+

Dernière modification par ylag (Le 24/02/2023, à 14:29)

Hors ligne

#3 Le 24/02/2023, à 14:30

xubu1957

Re : [Résolu] MariaDB

Bonjour,

Pour ajouter toi-même les balises code à ton précédent message #1 :                Merci                     wink

  • Cliquer sur le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

1642675956.jpg

comme indiqué dans le : Retour utilisable de commande

Dernière modification par xubu1957 (Le 24/02/2023, à 14:51)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#4 Le 24/02/2023, à 14:48

Hourra!

Re : [Résolu] MariaDB

Bonjour,

Il faut activer la section universe des dépôts dans les sources pour accéder aux paquets de mariadb.

A+

Juste ! Comme je viens de 20.04, en update, et q'il était sélectionné dans le 20.04, je n'ai pas penser à aller voir...

Mais il me reste quand même une erreur :

sudo apt install mariadb-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  android-libbacktrace android-libf2fs-utils android-libutils gcc-10-base gcc-10-base:i386 i965-va-driver:i386 intel-media-va-driver:i386 libaio1 libaom0:i386
  libavcodec58:i386 libavutil56:i386 libcairo-gobject2:i386 libcdio18 libcodec2-0.9:i386 libdrm-intel1:i386 libevent-core-2.1-7 libevent-pthreads-2.1-7
  libf2fs-format4 libf2fs5 libffi7:i386 libfluidsynth2 libflxmlrpc1 libgavl1 libgdk-pixbuf-2.0-0:i386 libgl1-mesa-dev libglew2.1 libgomp1:i386 libgupnp-1.2-0
  libhamlib2 libidn11 libigdgmm11 libigdgmm11:i386 libigdgmm12:i386 libilmbase24 libisl22 libllvm12 libllvm12:i386 libmbedcrypto3 libmbedtls12 libmbedx509-0 libmecab2
  libmms0 libmp3lame0:i386 libnettle7 libnuma1:i386 libofa0 libopenexr24 libopenjp2-7:i386 libpciaccess0:i386 libpgm-5.2-0 libprotobuf-lite23 libqt5script5
  libreadline5 librpm8 librpmio8 librsvg2-2:i386 librsvg2-common:i386 libshine3:i386 libsnappy1v5:i386 libsoxr0:i386 libspeex1:i386 libswresample3:i386
  libtwolame0:i386 libusrsctp1 libva-drm2:i386 libva-x11-2:i386 libva2:i386 libvdpau1:i386 libvpx6:i386 libwavpack1:i386 libwebp6:i386 libwebpmux3:i386
  libx264-155:i386 libx265-179:i386 libxvidcore4:i386 libzip5 libzvbi0:i386 mecab-ipadic mecab-ipadic-utf8 mecab-utils mesa-va-drivers:i386 mesa-vdpau-drivers:i386
  ocaml-base-nox ocaml-nox python-pip-whl va-driver-all:i386 vdpau-driver-all:i386 vlc-l10n vlc-plugin-samba vlc-plugin-video-splitter vlc-plugin-visualization
  wordpress-theme-twentynineteen
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  galera-4 libdaxctl1 libdbd-mysql-perl libmariadb3 libndctl6 libpmem1 liburing2 mariadb-client-10.6 mariadb-client-core-10.6 mariadb-server-10.6
  mariadb-server-core-10.6
Paquets suggérés :
  mariadb-test
Les paquets suivants seront ENLEVÉS :
  mysql-client-8.0 mysql-client-core-8.0 mysql-server-8.0 mysql-server-core-8.0
Les NOUVEAUX paquets suivants seront installés :
  galera-4 libdaxctl1 libdbd-mysql-perl libmariadb3 libndctl6 libpmem1 liburing2 mariadb-client-10.6 mariadb-client-core-10.6 mariadb-server mariadb-server-10.6
  mariadb-server-core-10.6
0 mis à jour, 12 nouvellement installés, 4 à enlever et 196 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/15,4 Mo dans les archives.
Après cette opération, 32,4 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Préconfiguration des paquets...
(Lecture de la base de données... 278232 fichiers et répertoires déjà installés.)
Suppression de mysql-server-8.0 (8.0.32-0ubuntu0.22.04.2) ...
Failed to stop mysql.service: Unit mysql.service not loaded.
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg: erreur de traitement du paquet mysql-server-8.0 (--remove) :
 le sous-processus paquet mysql-server-8.0 script pre-removal installé a renvoyé un état de sortie d'erreur 1
dpkg: trop d'erreurs, arrêt
Failed to stop mysql.service: Unit mysql.service not loaded.
invoke-rc.d: initscript mysql, action "stop" failed.
Failed to preset unit: File mysql.service: Link has been severed
/usr/bin/deb-systemd-helper: error: systemctl preset failed on mysql.service: No such file or directory
Failed to start mysql.service: Unit mysql.service not found.
invoke-rc.d: initscript mysql, action "start" failed.
Unit mysql.service could not be found.
dpkg: erreur lors du nettoyage:
 le sous-processus paquet mysql-server-8.0 script post-installation installé a renvoyé un état de sortie d'erreur 1
Des erreurs ont été rencontrées pendant l'exécution :
 mysql-server-8.0
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#5 Le 24/02/2023, à 14:52

xubu1957

Re : [Résolu] MariaDB

Donne le retour de :

sudo apt update

et d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#6 Le 24/02/2023, à 14:57

Hourra!

Re : [Résolu] MariaDB

sudo apt update
Atteint :1 http://ftp.belnet.be/ubuntu jammy InRelease
Atteint :2 http://ftp.belnet.be/ubuntu jammy-updates InRelease 
Atteint :3 http://ftp.belnet.be/ubuntu jammy-backports InRelease
Atteint :4 http://ftp.belnet.be/ubuntu jammy-security InRelease
Atteint :5 https://ppa.launchpadcontent.net/graphics-drivers/ppa/ubuntu jammy InRelease
Lecture des listes de paquets... Fait                          
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
192 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                            Version                                              Architecture Description
+++-==============================================-====================================================-============-====================================================================================================================================================
rc  adwaita-icon-theme-full                        3.36.1-2ubuntu0.20.04.2                              all          default icon theme of GNOME
rc  avrdude                                        6.3-20171130+svn1429-2                               amd64        software for programming Atmel AVR microcontrollers
rc  bsdmainutils                                   11.1.2ubuntu3                                        amd64        collection of more utilities from FreeBSD
rc  ca-certificates-mono                           6.8.0.105+dfsg-2                                     all          Common CA certificates (Mono keystore)
rc  cqrlog                                         2.5.2-1~focal                                        amd64        Advanced logging program for hamradio operators
rc  crda                                           3.18-1build1                                         amd64        wireless Central Regulatory Domain Agent
rc  dvdauthor                                      0.7.2-1build1                                        amd64        create DVD-Video file system
rc  fuse                                           2.9.9-3                                              amd64        Filesystem in Userspace
rc  gimp-data                                      2.10.18-1                                            all          Data files for GIMP
rc  gnubg                                          1.06.002-4build1                                     amd64        graphical or console backgammon program with analysis
rc  gsfonts-x11                                    0.27                                                 all          Make Ghostscript fonts available to X11
rc  homebank                                       5.6.2-0~97~ubuntu20.04.1                             amd64        Manage your personal accounts at home
rc  ippusbxd                                       1.34-2ubuntu1                                        amd64        Daemon for IPP USB printer support
rc  kaccounts-providers                            4:19.12.3-0ubuntu1                                   amd64        KDE providers for accounts sign-on
rc  kdeconnect                                     1.4-0ubuntu5                                         amd64        connect smartphones to your desktop devices.
rc  kded5                                          5.68.0-0ubuntu1                                      amd64        Extensible daemon for providing session services
rc  kdenlive-data                                  4:19.12.3-0ubuntu1                                   all          non-linear video editor (data files)
rc  kinit                                          5.68.0-0ubuntu1                                      amd64        process launcher to speed up launching KDE applications
rc  libapache2-mod-php7.4                          7.4.3-4ubuntu2.17                                    amd64        server-side, HTML-embedded scripting language (Apache 2 module)
rc  libfm-data                                     1.3.1-1                                              all          file management support (common data)
rc  libfm4:amd64                                   1.3.1-1                                              amd64        file management support (core library)
rc  libgdk-pixbuf-2.0-0:i386                       2.42.8+dfsg-1ubuntu0.2                               i386         GDK Pixbuf library
rc  libgdk-pixbuf2.0-0:amd64                       2.40.0+dfsg-3ubuntu0.4                               amd64        GDK Pixbuf library
rc  libgdk-pixbuf2.0-0:i386                        2.40.0+dfsg-3ubuntu0.4                               i386         GDK Pixbuf library
rc  libimage-magick-perl                           8:6.9.10.23+dfsg-2.1ubuntu11.4                       all          Perl interface to the ImageMagick graphics routines
rc  libkf5akonadicontact-data                      4:19.12.3-0ubuntu1                                   all          akonadi-contacts - data files
rc  libkf5bluezqt-data                             5.68.0-0ubuntu1                                      all          data files for bluez-qt
rc  libkf5calendarcore5abi2:amd64                  5:5.68.0-0ubuntu1                                    amd64        calendar access framework
rc  libkf5contacts-data                            5:5.68.0-0ubuntu1                                    all          data files for kcontacts
rc  libkf5itemmodels5:amd64                        5.68.0-0ubuntu1                                      amd64        additional item/view models for Qt Itemview
rc  libkf5people-data                              5.68.0-0ubuntu1                                      all          data files for kpeople
rc  libkf5prison5:amd64                            5.68.0-0ubuntu1                                      amd64        barcode API for Qt
rc  libkf5purpose-bin:amd64                        5.68.0-0ubuntu1                                      amd64        abstraction to provide and leverage actions of a specific kind, runtime
rc  libnvidia-compute-470:amd64                    470.161.03-0ubuntu0.20.04.1                          amd64        NVIDIA libcompute package
rc  libpython2.7-minimal:amd64                     2.7.18-1~20.04.3                                     amd64        Minimal subset of the Python language (version 2.7)
rc  libreoffice-style-tango                        1:7.3.7-0ubuntu0.22.04.1                             all          transitional package for Tango symbol style
rc  libssl1.1:i386                                 1.1.1f-1ubuntu2.17                                   i386         Secure Sockets Layer toolkit - shared libraries
rc  libvdpau1:i386                                 1.4-3build2                                          i386         Video Decode and Presentation API for Unix (libraries)
rc  libwrap0:i386                                  7.6.q-31build2                                       i386         Wietse Venema's TCP wrappers library
rc  linux-image-5.15.0-53-generic                  5.15.0-53.59~20.04.1                                 amd64        Signed kernel image generic
rc  linux-image-5.15.0-56-generic                  5.15.0-56.62~20.04.1                                 amd64        Signed kernel image generic
rc  linux-image-5.15.0-57-generic                  5.15.0-57.63~20.04.1                                 amd64        Signed kernel image generic
rc  linux-modules-5.15.0-53-generic                5.15.0-53.59~20.04.1                                 amd64        Linux kernel extra modules for version 5.15.0 on 64 bit x86 SMP
rc  linux-modules-5.15.0-56-generic                5.15.0-56.62~20.04.1                                 amd64        Linux kernel extra modules for version 5.15.0 on 64 bit x86 SMP
rc  linux-modules-5.15.0-57-generic                5.15.0-57.63~20.04.1                                 amd64        Linux kernel extra modules for version 5.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.15.0-53-generic          5.15.0-53.59~20.04.1                                 amd64        Linux kernel extra modules for version 5.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.15.0-56-generic          5.15.0-56.62~20.04.1                                 amd64        Linux kernel extra modules for version 5.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.15.0-57-generic          5.15.0-57.63~20.04.1                                 amd64        Linux kernel extra modules for version 5.15.0 on 64 bit x86 SMP
rc  ltrace                                         0.7.3-6.1ubuntu1                                     amd64        Tracks runtime library calls in dynamically linked programs
rc  lxmenu-data                                    0.1.5-2                                              all          LXDE freedesktop.org menu specification
rc  mariadb-client-10.3                            1:10.3.37-0ubuntu0.20.04.1                           amd64        MariaDB database client binaries
rc  mariadb-common                                 1:10.6.12-0ubuntu0.22.04.1                           all          MariaDB common configuration files
rc  mariadb-server-10.3                            1:10.3.37-0ubuntu0.20.04.1                           amd64        MariaDB database server binaries
rc  mono-runtime-common                            6.8.0.105+dfsg-2                                     amd64        Mono runtime - common files
iF  mysql-server-8.0                               8.0.32-0ubuntu0.22.04.2                              amd64        MySQL database server binaries and system database setup
rc  odbcinst                                       2.3.6-0.1build1                                      amd64        Helper program for accessing odbc ini files
rc  oxygen-icon-theme                              5:5.68.0-0ubuntu1                                    all          Oxygen icon theme
rc  pcmanfm                                        1.3.1-1                                              amd64        extremely fast and lightweight file manager
rc  perlmagick                                     8:6.9.10.23+dfsg-2.1ubuntu11.4                       all          Perl interface to ImageMagick -- dummy package
rc  php7.4-cli                                     7.4.3-4ubuntu2.17                                    amd64        command-line interpreter for the PHP scripting language
rc  php7.4-common                                  7.4.3-4ubuntu2.17                                    amd64        documentation, examples and common module for PHP
rc  php7.4-gd                                      7.4.3-4ubuntu2.17                                    amd64        GD module for PHP
rc  php7.4-json                                    7.4.3-4ubuntu2.17                                    amd64        JSON module for PHP
rc  php7.4-mysql                                   7.4.3-4ubuntu2.17                                    amd64        MySQL module for PHP
rc  php7.4-opcache                                 7.4.3-4ubuntu2.17                                    amd64        Zend OpCache module for PHP
rc  php7.4-readline                                7.4.3-4ubuntu2.17                                    amd64        readline module for PHP
rc  popularity-contest                             1.69ubuntu1                                          all          Vote for your favourite packages automatically
rc  python2.7-minimal                              2.7.18-1~20.04.3                                     amd64        Minimal subset of the Python language (version 2.7)
rc  rpm                                            4.14.2.1+dfsg1-1build2                               amd64        package manager for RPM
rc  synaptic                                       0.84.6ubuntu5                                        amd64        Graphical package manager

Il reste les paquets mariadb client et server de la version 20.04...

Hors ligne

#7 Le 24/02/2023, à 14:59

xubu1957

Re : [Résolu] MariaDB

iF  mysql-server-8.0                               8.0.32-0ubuntu0.22.04.2                              amd64        MySQL database server binaries and system database setup

Ce paquet est en anomalie.

Je ne sais pas répondre pour le domaine des serveurs.


Pour nettoyer partiellement :    voir le message suivant

Le 22/07/2020, nany a écrit :
dpkg -l | awk '/^rc/ && !/sql/{print $2}' | xargs -r sudo dpkg -P

Pour info, les précisions de nany, pour la commande de nettoyage.

Dernière modification par xubu1957 (Le 24/02/2023, à 16:22)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#8 Le 24/02/2023, à 16:04

bruno

Re : [Résolu] MariaDB

Bonjour,

D'abord d faire le ménage :

- dans les paquets devenus inutiles :

sudo apt autopurge

- dans les résidus de configuration (paquets marqués rc) :

sudo apt purge ~c

- faire les mises à jour (192 paquets) :

sudo apt full-upgrade

Puis suivre le point 7 (Réinstallation complète) de la doc mysql que je recopie ici :

sudo apt autoremove --purge ~n^mysql-server ~n^mariadb-server

suivi de :

sudo mv /var/lib/mysql /var/lib/mysql.bak
sudo mv /etc/mysql /etc/mysql.bak
sudo mkdir -p /etc/mysql/conf.d

et enfin :

sudo apt install mariadb-server

Dernière modification par bruno (Le 24/02/2023, à 16:06)

#9 Le 25/02/2023, à 18:00

Hourra!

Re : [Résolu] MariaDB

Salut Bruno,

En effet, Mariadb est bien installé !

Merci pour tes précieux conseils !

Geoffroy

Hors ligne