Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/04/2008, à 22:44

Linux-Noobie

[resolu] [problème] emask error

Bonsoir à tous.

J'ai récemment acheté un pc avec ces composants :

-Intel core2duo E8200
-Asus P5K 
-Samsung SpinPoint P, HD321KJ, 320Go SATA II 16Mo
-Samsung SH-S203A 20x SATA
-MSI GeForce 8500GT-TD 256EH

Mais j'ai quelques problèmes avec ce pc ::(

Dans les terminaux textes (tty), ce message revient en boucle


 [xxx.xxx] ata7: exception Emask 0x10 SAct 0x0 SErr 0x4060000 action 0x2 frozen
 [xxx.xxx] ata7: (irq_stat 0x00000040, connection status changed)

avec xxx des nombres de plus en plus grands

D'après ce que j'ai compris c'est un problème de disque dur/carte mère.

Cela cause des problème lors de l'installation/mise à jour de paquets en me donnant des messages d'erreur du style " il y a eu un problème lors de l'installation ... il y a peut être eu une erreur lors du téléchargement ... le paquet est peut être corrompu..." .

Cela m'arrive de manière assez aléatoire mais souvent sur la 1ere mise à jour, quel que soit la version (Kubuntu, Kubuntu 64bit, Ubuntu) et quel que soit le gestionnaire de  paquets (apt-get , adept) .

Voila le lspci :

luca@luca-desktop:/var/log$ lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IB (ICH9) 2 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8500 GT (rev a1)
02:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
03:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 03)
03:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 03)
05:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)

voilà les messages d'érreur de syslog:

Apr 19 23:39:48 luca-desktop kernel: [ 2365.197823] ata7: (irq_stat 0x00000040, connection status changed)
Apr 19 23:39:48 luca-desktop kernel: [ 2366.136062] ata7: soft resetting port
Apr 19 23:39:48 luca-desktop kernel: [ 2366.136071] ata7: SATA link down (SStatus 0 SControl 300)
Apr 19 23:39:48 luca-desktop kernel: [ 2366.136079] ata7: EH complete
Apr 19 23:39:48 luca-desktop kernel: [ 2366.171801] ata7: exception Emask 0x10 SAct 0x0 SErr 0x4060000 action 0x2 frozen
Apr 19 23:39:48 luca-desktop kernel: [ 2366.171805] ata7: (irq_stat 0x00000040, connection status changed)
Apr 19 23:39:51 luca-desktop kernel: [ 2368.418278] ata7: failed to resume link for reset (errno=-16)
Apr 19 23:39:51 luca-desktop kernel: [ 2368.418282] ata7: soft resetting port
Apr 19 23:39:51 luca-desktop kernel: [ 2368.418291] ata7: SATA link down (SStatus 1 SControl 300)
Apr 19 23:39:51 luca-desktop kernel: [ 2368.418298] ata7: EH complete
Apr 19 23:39:51 luca-desktop kernel: [ 2368.419152] ata7: exception Emask 0x10 SAct 0x0 SErr 0x4060000 action 0x2 frozen
Apr 19 23:39:51 luca-desktop kernel: [ 2368.419155] ata7: (irq_stat 0x00000040, connection status changed)
Apr 19 23:39:53 luca-desktop kernel: [ 2370.668514] ata7: failed to resume link for reset (errno=-16)
Apr 19 23:39:53 luca-desktop kernel: [ 2370.668518] ata7: soft resetting port
Apr 19 23:39:53 luca-desktop kernel: [ 2370.668526] ata7: SATA link down (SStatus 1 SControl 300)
Apr 19 23:39:53 luca-desktop kernel: [ 2370.668534] ata7: EH complete
Apr 19 23:39:53 luca-desktop kernel: [ 2370.691289] ata7: exception Emask 0x10 SAct 0x0 SErr 0x4060000 action 0x2 frozen
Apr 19 23:39:53 luca-desktop kernel: [ 2370.691293] ata7: (irq_stat 0x00000040, connection status changed)
Apr 19 23:39:55 luca-desktop kernel: [ 2372.942732] ata7: failed to resume link for reset (errno=-16)
Apr 19 23:39:55 luca-desktop kernel: [ 2372.942736] ata7: soft resetting port
Apr 19 23:39:55 luca-desktop kernel: [ 2372.942744] ata7: SATA link down (SStatus 0 SControl 300)
Apr 19 23:39:55 luca-desktop kernel: [ 2372.942751] ata7: EH complete
Apr 19 23:39:55 luca-desktop kernel: [ 2372.943613] ata7: exception Emask 0x10 SAct 0x0 SErr 0x4060000 action 0x2 frozen
Apr 19 23:39:55 luca-desktop kernel: [ 2372.943617] ata7: (irq_stat 0x00000040, connection status changed)
Apr 19 23:39:57 luca-desktop kernel: [ 2375.160993] ata7: failed to resume link for reset (errno=-16)
Apr 19 23:39:57 luca-desktop kernel: [ 2375.160997] ata7: soft resetting port
Apr 19 23:39:57 luca-desktop kernel: [ 2375.161004] ata7: SATA link down

Il n'y a apparament pas de problèmes sous Windows XP yikes (selon l'assembleur chez qui j'ai fait l'achat).

Je ne sais donc pas quoi faire (à part peut être attendre kubuntu 8.04 (:/ ou 8.10))

C'est pourquoi, je vosu remerci par avance de votre aide.

Linux-Noobie

Dernière modification par Linux-Noobie (Le 20/04/2008, à 11:51)

Hors ligne

#2 Le 19/04/2008, à 23:34

Linux-Noobie

Re : [resolu] [problème] emask error

EDIT

J'ai 2Go de DDR3 Corsaire

Bonne nuit

Hors ligne

#3 Le 19/04/2008, à 23:43

cyberdanycool

Re : [resolu] [problème] emask error

Je n'ai jamais expérimenté ce problème, mais je te donne quelques pistes possibles.

Je te recommande de vérifier que le BIOS de la carte mère est à jour. Le cas échéant, faire une mise à jour.

Essaye de désactiver le PATA dans le BIOS, sous la gestion des disques IDE. Il faudrait laisser uniquement SATA.

Sinon, tu peux aussi essayer de démarrer le système d'exploitation avec l'option supplémentaire "all_generic_ide". Ca a donné de bons résultats chez moi sur un disque SATA de 500 Go que Ubuntu ne voyait pas et après, ça fonctionnait parfaitement.

Je ne sais pas pourquoi le support des disques SATA/PATA sous Linux est encore si problématique.


L'intelligence artificielle se définit comme le contraire de la bêtise naturelle. - Woody Allen

Hors ligne

#4 Le 20/04/2008, à 11:25

Linux-Noobie

Re : [resolu] [problème] emask error

ok merci,

le bios avait déjà été flashé.
Je vais chercher pour le PATA et pour le  "all_generic_ide"

Bonne après midi.

Hors ligne

#5 Le 20/04/2008, à 11:32

Linux-Noobie

Re : [resolu] [problème] emask error

Alors j'ai un :

JMICRON eSATA/PATA Controller [enable]

faut - il que je le mette en "disable" ?

Sinon je signal que j'ai des problèmes d'affichage seulement sur les version 64bit  : je ne voit pas l'écran de chargement/fermeture de Kubuntu (pas celui de KDE), mon écran n'a plus de signal video pendants ces passages.
Mais je ne pense pas que c'est lié.

Merci

Linux-Noobie

Hors ligne

#6 Le 20/04/2008, à 11:50

Linux-Noobie

Re : [resolu] [problème] emask error

Ok après avoir changé ce paramettre, plus de problèmes!!!:):D

Je vais quand même voir si, mon disque dur fonctionne sur des caractéristiques correctes.

Merci encore.

Linux-Noobie

Hors ligne

#7 Le 20/04/2008, à 15:17

cyberdanycool

Re : [resolu] [problème] emask error

Hello, super. En fait, j'ai constaté que quand tu utilises le contrôleur en mode PATA, Ubuntu est tout perdu. Il suffit de le mettre en mode SATA et ça marche. Au niveau performance, ça ne change rien.

Pour le problème d'affichage de la barre de chargement, il te faut regarder ici :

http://doc.ubuntu-fr.org/problemes_usplash

Tu peux suivre la méthode n° 2 qui est en bas et tu mets comme résolution par exemple xres=1024
yres=768
à la place de ce que tu as, ça devrait fonctionner.


L'intelligence artificielle se définit comme le contraire de la bêtise naturelle. - Woody Allen

Hors ligne

#8 Le 11/11/2008, à 13:36

Hélios

Re : [resolu] [problème] emask error

Linux-Noobie a écrit :

Ok après avoir changé ce paramettre, plus de problèmes!!!:):D

Je vais quand même voir si, mon disque dur fonctionne sur des caractéristiques correctes.

Merci encore.

Linux-Noobie

Bonjour,

J'ai le meme probleme que toi avec un disque dur SATA Samsung.

C'est SEULEMENT en modifiant ce parametre JMICRON que cela fonctionne ?
Ou peut on effectuer ce changement dans le Bios ?

Merci

Hors ligne

#9 Le 11/11/2008, à 13:45

Hélios

Re : [resolu] [problème] emask error

C'est  bon, j'ai trouvé (Gestion des périph).
Mais je peux le laisser desactiver quand je vais sous Windows par exemple ?
A quoi sert il exactement ?

Merci

Hors ligne

#10 Le 11/02/2009, à 12:44

Teedee

Re : [resolu] [problème] emask error

Hello, merci pour ce thread qui m'a permis de résoudre mon problème de démarrage d'ubuntu.

+1 pour le paramètre JMicron à mettre à [disabled]

Hors ligne

#11 Le 14/06/2009, à 16:06

Krrf

Re : [resolu] [problème] emask error

Merci aussi pour ce thread qui m'a sauvé. Plus moyen d'arriver au prompt de login.
J'ai aussi une carte Asus P5K et le problème n'est apparu que depuis Kubuntu Jaunty Jackalope (sous Intrepid Ibex & Hardy heron, no problemo).

Hors ligne

#12 Le 21/11/2022, à 13:42

Djee7469

Re : [resolu] [problème] emask error

J’ai un problème similaire avec un pc équipé d’une carte ASRock H410M/ac, un Intel Core i3 et un SSD 440 Go.

Il a très bien marché sur Ubuntu 20.04 puis 22.04 et il s’est réçemment mis à Freezer. L’accès disque est permanent et le système est presque paralyser au bout de quelques seconde de connexion.
Lorsque j’essaie d’éteindre proprement l’ordinateur, le fameux message s’affiche en boucle.

Je ne trouve pas ce paramètre JMICRON. Surtout que je n’arrive pas accéder aux paramètres en mode graphique.
Comment faire en mode texte ou depuis un démarrage USB?

Je suis retourner en Ubuntu 20.04 mais le problème reste.

Mon interface Bios est en UEFI.

Hors ligne