Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/02/2006, à 23:14

Bobbybionic

(XFCE) Les touches de volumes ne fonctionnent plus ?

Bonsoir à tous

Je me suis laissé tenté et j'ai installé XFCE cette après-midi... sympa !
Par contre mes touches de volumes (avec la touche "Fn") ne fonctionnent plus.
Celles du contraste oui, alors comment configurer les autres ?

Merci !

(Packarde Bell Easynote C3300)


Non à la vente liée. Non au monopole Windows.
Tous ensemble, refusons les logiciels préinstallés et tournons nous vers le libre.

http://bobbybionic.wordpress.com

Hors ligne

#2 Le 22/02/2006, à 13:13

Bobbybionic

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Pour l'instant je me débrouille avec l'icone volume sur le tableau de bord mais ça me manque wink


Non à la vente liée. Non au monopole Windows.
Tous ensemble, refusons les logiciels préinstallés et tournons nous vers le libre.

http://bobbybionic.wordpress.com

Hors ligne

#3 Le 22/02/2006, à 14:56

wam

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

j´imagine. Bienvenue dans la section xfce wink
tu peux tenter de paramétrer les racourcis clavier peut être, voir si il reconnait tes touches

Hors ligne

#4 Le 22/02/2006, à 15:00

Bobbybionic

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Lol je trouve ça super sympa pourtant xfce !
Mais c'est vrai que je lutte un peu !
Je retrouve comment paramétrer les touches et j'essaye, mais comment ça marche ? Il faut que je trouve la commande pour monter le son non ?
hmm

XFCE quand tu nous tiens !

Hors sujet : j'ai pas cherché mais tu le prononce comment toi XFCE, tu l'épelles ?


Non à la vente liée. Non au monopole Windows.
Tous ensemble, refusons les logiciels préinstallés et tournons nous vers le libre.

http://bobbybionic.wordpress.com

Hors ligne

#5 Le 22/02/2006, à 15:39

wam

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

oui, je l'épelle, à la française, je devrais paue être le faire à l'anglais genre "exèfsi" wink
Je me comprends en l'épellant, alors je continue comme ça, c'est plus simple.

pour les racourcis, c'est dans settings->window manager settings, mais ça ne reconnait pas quand je tape Fn qqch. Faudra peut être créer tes propres racourcis.
j'ai regardé le man de alsamixer, mais il ne semble pas y avoir de commande pour le controler à distance

Hors ligne

#6 Le 26/06/2008, à 17:14

FreelY

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

up

Vous avez trouvé une solution?
Je suis passé d'Ubuntu à Xfce et j'ai la même chose: plus de contrôle du volume avec la molette (sur un Toshiba A210-1BH) sad

Hors ligne

#7 Le 26/06/2008, à 17:56

valAa

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

chez moi ça marche big_smile

blague à part, sous dapper et edgy ça ne marchait pas, j'avais donc fait des ptits scripts attachés à des raccourcis clavier. Je n'ai malheureusement plus ces scripts (je vais me faire frapper aujourd'hui je sens) mais je me souviens que la solution c'était pas alsamixer, mais amixer.
je pense qu'un ptit

man amixer

devrait en éclairer plus d'un (sauf si pulse audio a changé la donne depuis...)

Hors ligne

#8 Le 28/06/2008, à 14:13

The_Tito

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Bonjour,


Tien moi j'ai ca dans mes notes, si ca peut aider quelqu'un:

Pour augmenter le volume: amixer -c 0 sset "PCM,0" 5%+
Pour diminuer le volume: amixer -c 0 sset "PCM,0" 5%-

! "PCM,0" = La sortie sonore

Et pour mettre en sourdine, j'ai le script de xlolo, merci à lui d'ailleur

#! /bin/bash
#
#mute.sh written by : xlolo <xlolo@free.fr>
#this script is free software according to the GNU General Public License (see http://www.gnu.org/licenses/gpl.html)
#
########## Made by xlolo@free.fr ##########


a=$(aumix -q | head -1 | awk {'printf $2'})
b=${a%,*}


if [ "$b" == "0" ]; then
   aumix -L > /dev/null
else
   aumix -q > ~/.aumixrc
   aumix -v0
fi

A rendre executable. --> chmod +x lefichier.sh

Il faut bien sur qu'amixer soit installé au préalable. --> sudo apt-get install amixer

Hors ligne

#9 Le 28/06/2008, à 14:25

Emralegna

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Bonjour,

Connaissez vous une solution lorsqu'on est obligé d'utiliser les pilotes OSS4 ?

Merci smile

Hors ligne

#10 Le 29/06/2008, à 14:09

pmd

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

D'après ici : http://forum.ubuntu-fr.org/viewtopic.php?pid=1802030#p1802030
On a :

monter le son : amixer sset PCM 1+ unmute
baisser le son : amixer sset PCM 1- unmute
muet on : amixer sset PCM mute
muet off : amixer sset PCM unmute

Tu devras peut-être changer PCM, à voir smile

Ensuite, dans le menu XFCE, tu vas dans Paramètres >> Paramètres du clavier >> Raccourcis
Tu n'as plus qu'à ajouter les raccourcis que tu veux smile

Hors ligne

#11 Le 29/06/2008, à 14:49

Emralegna

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Merci pour la réponse. smile

Ceci dit, je n'utilise pas amixer car c'est un mixer pour Alsa et j'utilise les pilotes OSS car j'ai malheureusement aquis une Creative X-Fi avant mon passage sous Linux. Il me faut donc utiliser ossxmix pour l'utiliser si je ne me trompe pas, mais aucune ligne de commande n'a l'air disponible dans la doc (man ossxmix) ni dans l'aide (ossxmix -h) pour augmenter ou diminuer le volume du son. Pourtant, mes touches fonctionnent sous Gnome et KDE et je ne sais pas du tout comment. Dans les options de son, il n'y a rien d'indiqué, aucun périphérique ni mixer, mais le son fonctionne.

En revanche, j'ai découvert que sous Xfce avec ces pilotes, il ne m'est pas possible d'utiliser deux sources sonores en même temps, ce dont j'ai généralement besoin car j'ai l'habitude de jouer aux FPS avec ma musique. wink je pense que c'est parce qu'il n'utilise pas de serveur son (comme ESD que j'utilise avec Gnome) mais je peux me tromper.

Hors ligne

#12 Le 18/07/2008, à 20:27

technojoly

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

bonjour

en fait une solution est de rajouter dans la barre des applications, à coté de l'horloge une applet permettant grâce à la souris de régler le volume sonore.

C'est expliqué ici : http://ubuntuforums.org/archive/index.php/t-112248.html

Dernière modification par technojoly (Le 18/07/2008, à 20:27)

Hors ligne

#13 Le 26/07/2008, à 14:18

craksus

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

bonjour à tous

je suis sur XFCE en dual-boot avec XP  sur mon vieux portable médion.
Je suis débutant et je n'arrive pas à accéder à mes partitions C (windows) et F(musique....) depuis xubuntu.Surtout F musique et films
J'ai lu sur le net et dans certains tutos qu'il fallait passer par des points de montage...
J'en appelle à toutes les forces mystiques qui pourraient me venir en aide
merci

Dernière modification par craksus (Le 26/07/2008, à 19:07)

Hors ligne

#14 Le 02/09/2008, à 23:11

freecds

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

craksus a écrit :

bonjour à tous

je suis sur XFCE en dual-boot avec XP  sur mon vieux portable médion.
Je suis débutant et je n'arrive pas à accéder à mes partitions C (windows) et F(musique....) depuis xubuntu.Surtout F musique et films
J'ai lu sur le net et dans certains tutos qu'il fallait passer par des points de montage...
J'en appelle à toutes les forces mystiques qui pourraient me venir en aide
merci

la solution drevrait se trouver ici http://doc.ubuntu-fr.org/tutoriel/comme … ns_windows

Hors ligne

#15 Le 14/01/2009, à 23:56

Myddrin

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Je suis tombé sur ce post en ayant le même problème sous gentoo.

amixer fonctionne très bien en racourcis, et j'ai fait le même genre de petit script que précédent. Il regarde simplement si le mute est activé pour le désactiver et vise versa.

Enjoy

#!/bin/sh

# written by Thomas Richard: richthomas@hotmail.fr
# this script is free software according to the GNU General Public License (see http://www.gnu.org/licenses/gpl.html)

amixer -c 0 sget "Master" | grep "\[on\]" # check if the Master is "on" or "off"

if [ $? -eq 0 ] # if on
then
	# mute Master
	amixer -q -c 0 sset "Master" mute
else
	# unmute Master
	amixer -q -c 0 sset "Master" unmute
fi

exit 0

Pour l'utiliser copiez le dans /usr/bin (avec les droit super utilisateur) et tapez simplement "mute" dans la console. Soyez également sur qu'il a les droits d'exécutions (chmod +x /usr/bin/mute tjr en mode super utilisateur).

J'ai rencontré un problème lors de son utilisation depuis le panneau de raccourcis, invoquez le simplement avec son chemin complet (/usr/bin/mute).


Join us now and share the software;
You'll be free, hackers, you'll be free.

écoutez la sur http://www.gnu.org/music/free-software-song.au

Hors ligne

#16 Le 15/01/2009, à 14:32

freecds

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Myddrin a écrit :

Je suis tombé sur ce post en ayant le même problème sous gentoo.

amixer fonctionne très bien en racourcis, et j'ai fait le même genre de petit script que précédent. Il regarde simplement si le mute est activé pour le désactiver et vise versa.

Enjoy

#!/bin/sh

# written by Thomas Richard: richthomas@hotmail.fr
# this script is free software according to the GNU General Public License (see http://www.gnu.org/licenses/gpl.html)

amixer -c 0 sget "Master" | grep "\[on\]" # check if the Master is "on" or "off"

if [ $? -eq 0 ] # if on
then
	# mute Master
	amixer -q -c 0 sset "Master" mute
else
	# unmute Master
	amixer -q -c 0 sset "Master" unmute
fi

exit 0

Pour l'utiliser copiez le dans /usr/bin (avec les droit super utilisateur) et tapez simplement "mute" dans la console. Soyez également sur qu'il a les droits d'exécutions (chmod +x /usr/bin/mute tjr en mode super utilisateur).

J'ai rencontré un problème lors de son utilisation depuis le panneau de raccourcis, invoquez le simplement avec son chemin complet (/usr/bin/mute).

Merci Myddrin, je n'avais pas trouvé les commandes pour 'unmuter' le son... ton script me facilite la vie !

Hors ligne

#17 Le 15/03/2009, à 00:06

broussaille

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

pour couper le son et le remettre, la commande

mute

toute simple suffit chez moi, sans avoir besoin d'un script (sous xfce 4.6 en tout cas).

Je n'ai pas trouvé mieux pour faire varier le volume par contre...:)

Hors ligne

#18 Le 09/08/2011, à 13:43

louis3d

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Pour info et même si le message est vieux, voici mon script pour la touche mute :

#! /bin/bash
#
# On test si le son est coupé. Si oui on le restaure. Si non on le coupe
amixer get Master|grep off && amixer sset Master unmute || amixer sset Master mute

Edit : Ou plus simplement  :

#! /bin/bash
amixer sset Master toggle

Dernière modification par louis3d (Le 09/08/2011, à 19:13)

Hors ligne

#19 Le 14/09/2011, à 19:11

presque anonyme

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

bonjour,


bon OK c'est du déterrage de post, mais si la touche "NumLK" (pour activer le pavé numérique) est active, appui dessus pour désactiver le pavé numérique. peut-être que les touches raccourcies seront actives comme ça...en tout cas chez moi ca marche nickel.

Hors ligne

#20 Le 16/11/2011, à 22:26

jcnouveau

Re : (XFCE) Les touches de volumes ne fonctionnent plus ?

Salut,
J'ai eu juste a installer xfce4-volumed pour que gérer le volume avec le clavier. Je suis sous Debian mais le paquet semble dispo sous Ubuntu aussi.

Hors ligne