Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/05/2009, à 10:58

STR_Locke

Perte connexion rt2500 usb après mise en veille

Bonjour à tous smile

Voilà, je suis nouveau sur Ubuntu (la 9.04 Gnome), mais pas vraiment ,nouveau sur GNU/linux puisqu'auparavant j'utilisais Mandriva One (depuis la version 2008.1 jusqu'à la dernière version 2009.0). Cela dit, je ne suis pas un expert en GNU/Linux, et encore moins un informaticien (considérez moi comme un débutant).
J'ai changé suite à des problèmes de connexion avec cette distribution, et aussi de performances (boot trop long).

J'ai donc installé hier soir Ubuntu 9.04 (Gnome), j'ai fait les mises à jour et installé les pilotes proprio (nvidia) et tout marche plutôt bien pour l'instant, avec en prime un boot très rapide (entre 30 et 40 secondes).

Néanmoins, je rencontre un problème assez gênant : comme l'indique le titre du sujet, je perds ma connexion en WiFi dès que je met en veille le PC sous Ubuntu (je n'ai pas encore testé ce que faisais l'hibernation) : mon WiFi se déconnecte, mais en plus il ne veut plus se connecter : un reboot corrige le problème.
Je rencontrais exactement le même problème avec Mandriva : le seul moyen de le corriger était à chaque fois de créer une nouvelle connexion à place de l'ancienne, et ca marchait bien (mais c'est aussi embêtant qu'un reboot obligatoire)
Je n'ai pas ce problème avec Windows XP (SP3) installé sur la même machine (OEM).

Je me connecte en WiFi avec un dongle WiFi Ovislink"Wireless G USB Dongle" en USB qui se connecte grâçe au WiFi de ma Livebox, celui -ci nécessite le pilote Ratlink Ratlink 2500 en usb, aussi bien sous Windows que GNU/Linux. Je ne peux pas me connecter d'une autre façon ethernet impossible pour des raisons physiques).
Sous Ubuntu, je n'ai rien touché au driver du Wifi, ca marchais directe dés le début (juste à rentrer ma clé WEP, le réseau étant reconnu directement)
J'aimerais donc savoir comment faire pour corriger ce problème, de façon à ce que la mise en veille n'affecte plus ma connexion et ce de manière définitive.

Voilà, je peux vous donner d'autres info si nécessaire qui pourraient vous aider à corriger mon problème.

Merci d'avance de vos réponses. smile

A+.

EDIT 22/05 : Voilà les résultats des commandes demandées dans l'épinglé du sous-forum, si ça peut vous être utile (moi pas trop, je n'y comprends pour ainsi dire rien tongue)

cat /etc/lsb-release

johnlocke@johnlocke-desktop:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

lsusb

johnlocke@johnlocke-desktop:~$ lsusb
Bus 002 Device 003: ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 046d:c001 Logitech, Inc. N48/M-BB48 [FirstMouse Plus]
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 148f:2570 Ralink Technology, Corp. 802.11g WiFi
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

sudo lshw -C network

johnlocke@johnlocke-desktop:~$ sudo lshw -C network
[sudo] password for johnlocke: 
  *-network               
       description: Ethernet interface
       product: 88E8056 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 12
       serial: 00:15:58:53:6a:43
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.22 firmware=N/A latency=0 link=no module=sky2 multicast=yes port=twisted pair
  *-network:0
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:08:a1:a2:d9:89
       capabilities: ethernet physical wireless
       configuration: broadcast=yes ip=192.168.1.13 multicast=yes wireless=IEEE 802.11bg
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: pan0
       serial: d2:9d:22:55:0e:e0
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

lsmod

johnlocke@johnlocke-desktop:~$ lsmod
Module                  Size  Used by
binfmt_misc            16776  1 
bridge                 56340  0 
stp                    10500  1 bridge
bnep                   20224  2 
input_polldev          11912  0 
video                  25360  0 
output                 11008  1 video
lp                     17156  0 
ppdev                  15620  0 
arc4                    9856  2 
ecb                    10752  2 
rt2500usb              27904  0 
rt2x00usb              18688  1 rt2500usb
rt2x00lib              37888  2 rt2500usb,rt2x00usb
pcspkr                 10496  0 
led_class              12036  1 rt2x00lib
mac80211              217208  2 rt2x00usb,rt2x00lib
iTCO_wdt               19108  0 
iTCO_vendor_support    11652  1 iTCO_wdt
usbhid                 42336  0 
snd_hda_intel         435636  3 
snd_pcm_oss            46336  0 
snd_mixer_oss          22656  1 snd_pcm_oss
snd_pcm                82948  2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy          10756  0 
snd_seq_oss            37760  0 
snd_seq_midi           14336  0 
snd_rawmidi            29696  1 snd_seq_midi
snd_seq_midi_event     15104  2 snd_seq_oss,snd_seq_midi
snd_seq                56880  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              29704  2 snd_pcm,snd_seq
snd_seq_device         14988  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    62628  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              15200  1 snd
snd_page_alloc         16904  2 snd_hda_intel,snd_pcm
cfg80211               38032  2 rt2x00lib,mac80211
nvidia               7233756  36 
parport_pc             40100  1 
parport                42220  3 lp,ppdev,parport_pc
intel_agp              34108  0 
agpgart                42696  2 nvidia,intel_agp
usb_storage            82880  0 
ohci1394               38576  0 
ieee1394               94660  1 ohci1394
sky2                   54916  0 
floppy                 64324  0 
vesafb                 13828  1 
fbcon                  46112  72 
tileblit               10752  1 fbcon
font                   16384  1 fbcon
bitblit                13824  1 fbcon
softcursor              9984  1 bitblit
johnlocke@johnlocke-desktop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"Wanadoo_8379"  
          Mode:Managed  Frequency:2.457 GHz  Access Point: 00:16:41:0C:5A:22   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality=61/100  Signal level:-54 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

ifconfig

johnlocke@johnlocke-desktop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:15:58:53:6a:43  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:17 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:08:a1:a2:d9:89  
          inet adr:192.168.1.13  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::208:a1ff:fea2:d989/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:280 erreurs:0 :0 overruns:0 frame:0
          TX packets:317 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:260186 (260.1 KB) Octets transmis:49941 (49.9 KB)

wmaster0  Link encap:UNSPEC  HWaddr 00-08-A1-A2-D9-89-39-38-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

sudo iwlist scan

johnlocke@johnlocke-desktop:~$ sudo iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:16:41:0C:5A:22
                    ESSID:"Wanadoo_8379"
                    Mode:Master
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=51/100  Signal level:-52 dBm  
                    Encryption key:on
                    IE: Unknown: 000C57616E61646F6F5F38333739
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010A
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD060010180200F0
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=0000029b02bdc7e8
                    Extra: Last beacon: 740ms ago

pan0      Interface doesn't support scanning.

cat  /etc/network/interfaces

johnlocke@johnlocke-desktop:~$ cat  /etc/network/interfaces
auto lo
iface lo inet loopback

nm-tool

johnlocke@johnlocke-desktop:~$ nm-tool

NetworkManager Tool

State: connected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            sky2
  State:             unavailable
  Default:           no
  HW Address:        00:15:58:53:6A:43

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0  [Auto Wanadoo_8379] -------------------------------------------
  Type:              802.11 WiFi
  Driver:            rt2500usb
  State:             connected
  Default:           yes
  HW Address:        00:08:A1:A2:D9:89

  Capabilities:
    Speed:           54 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *Wanadoo_8379:   Infra, 00:16:41:0C:5A:22, Freq 2457 MHz, Rate 54 Mb/s, Strength 41 WEP

  IPv4 Settings:
    Address:         192.168.1.13
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1


uname -r -m

johnlocke@johnlocke-desktop:~$ uname -r -m
2.6.28-11-generic i686

Dernière modification par STR_Locke (Le 23/05/2009, à 10:55)


Avec l'iNukes, atomisez une pomme.

Hors ligne

#2 Le 21/05/2009, à 19:44

richardsantoro

Re : Perte connexion rt2500 usb après mise en veille

Ce problème est récurent et concerne beaucoup de carte wifi. As tu essayé de relancer la connexion avec

sudo /etc/init.d/networking restart

Logiciels incontournables => Terminator : terminal divisible; GNS3 : Simulation de réseau avec IOS Cisco; DIA : Editeur de diagrammes pour réseaux et autres; VirtualBox : Emulateur d'ordinateur

Hors ligne

#3 Le 21/05/2009, à 20:28

STR_Locke

Re : Perte connexion rt2500 usb après mise en veille

J'ai essayé, ça ne marche pas (ca me met OK cependant dans le résultat de la commande) : ma connexion n'est pas rétablie et je ne peux pas rétablir moi même ma connexion après ça.

Une autre idée ?


Avec l'iNukes, atomisez une pomme.

Hors ligne

#4 Le 22/05/2009, à 20:38

STR_Locke

Re : Perte connexion rt2500 usb après mise en veille

J'ai essayé avec l'hibernation, pareil c'est déconnecté aussi.

Toujours pas d'idée ?

Sachant que je met très souvent mon Pc en veille, ce serait dommage que je doivent booter sur Windows juste pour profiter de cette "fonctionnalitée".


Avec l'iNukes, atomisez une pomme.

Hors ligne

#5 Le 23/05/2009, à 11:33

tux4fun

Re : Perte connexion rt2500 usb après mise en veille

Sans garanti de succès pour la sortie d'hibernation:

nano /etc/acpi/suspend.d/60-generate-modules-list.sh

à la fin du fichier dans mon cas:

# Add iwl3945
MODULES="$MODULES iwl3945"

Dans le tiens:

MODULES="$MODULES rt2500usb"

Bon courage.

Dernière modification par tux4fun (Le 23/05/2009, à 11:34)


tux4fun
http://linuxcounter.net/ - http://frederick.varin.free.fr
Linux Registered User     #363458
Machine Registered     #261921

Hors ligne

#6 Le 30/05/2009, à 21:32

STR_Locke

Re : Perte connexion rt2500 usb après mise en veille

J'ai éssayé, ça ne marche pas non plus.

J'ai également éssayé de modifier le fichier /etc/default/acpi-support en mettant :


MODULES_WHITELIST="rt 2500usb"

Mais sans succès sad


Avec l'iNukes, atomisez une pomme.

Hors ligne

#7 Le 10/06/2009, à 10:09

loliv

Re : Perte connexion rt2500 usb après mise en veille

Même problème... et aussi intéressé par une solution.

J'ai trouvé une solution de contournement : je débranche et je rebranche ma connexion USB Wifi... et elle se réactive correctement...

Hors ligne

#8 Le 11/07/2009, à 21:58

Pierre09

Re : Perte connexion rt2500 usb après mise en veille

En ce qui me concerne j'ai édité le fichier : /etc/pm/config.d/reloaded_modules en y ajoutant :

 SUSPEND_MODULES=\"rt2500usb\

And it just works wink

#9 Le 20/07/2009, à 10:43

seb31

Re : Perte connexion rt2500 usb après mise en veille

Sous Ubuntu avec un netbook eCafé et une carte rt2860 j'ai le même problème, sauf que la solution indiquée ci-dessus (adaptée à ma carte) empêche tout simplement le netbook de se mettre en veille ou d'hiberner, ce qui est embêtant pour ce genre d'appareil ultranomade !

Hors ligne

#10 Le 22/07/2009, à 11:33

loliv

Re : Perte connexion rt2500 usb après mise en veille

J'ai appliqué la modification proposée par Pierre09 et ça ne marche pas : je suis contraint de débrancher / rebrancher ma clé USB pour que le réseau sans fil se réactive après réveil de la marmotte (= retour d'hibernation)

(je rappelle un petit piège : si la talle de la partition de swap n'est pas au moins 2x plus grande que la RAM, l'hibernation ne fonctionne pas)

Dernière modification par loliv (Le 22/07/2009, à 14:18)

Hors ligne

#11 Le 22/07/2009, à 12:38

seb31

Re : Perte connexion rt2500 usb après mise en veille

Si la mise en veille ne fonctionne pas correctement sur mon netbook, elle ne fonctionnait pas non plus sous mon portable Dell Inspiron 6400. Or, je suis passé sous Kubuntu avec ce dernier, et aussi bien la mise en veille que l'hibernation fonctionnent à merveille...

Hors ligne

#12 Le 22/07/2009, à 14:20

loliv

Re : Perte connexion rt2500 usb après mise en veille

Il me semble qu'il faudrait forcer la réactivation du sans fil au retour d'hibernation. Mais n'étant plus dans le système depuis des années, je ne sais pas où le faire.

Hors ligne

#13 Le 18/08/2009, à 10:18

fabux

Re : Perte connexion rt2500 usb après mise en veille

Salut,

à tout hasard, si vous utilisez gnome, vous avez essayé de passer dans gconf-editor la clef /apps/gnome-power-manager/general/network-sleep à true?

Hors ligne

#14 Le 24/02/2010, à 11:43

Jeanmarc05

Re : Perte connexion rt2500 usb après mise en veille

Bonjour,
je rencontrais le même problème avec mon pc de bureau, avec Freebox par câble usb.
La solution de Fabux m'a sorti d'affaire.
Merci

Hors ligne

#15 Le 24/02/2010, à 13:27

Jeanmarc05

Re : Perte connexion rt2500 usb après mise en veille

Le hic : ça marche pour l'hibernation, pas pour la veille o_O

Bon, finalement ça marche très bien après un reboot.

Dernière modification par Jeanmarc05 (Le 25/02/2010, à 11:19)

Hors ligne