Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 04/04/2006, à 20:58

leseb

Ouverture de session redémarre à la saisie du mot de passe

Bonsoir,

(je ne sais pas si je poste ce message sur le bon forum)
Gros gros problème sur mon Ubuntu. J'essais vainement d'ouvrir ma session depuis une heure et rien. Je n'ai pas trouvé de solution sur le forum ou le site.
Voila ce qui m'arrive. Le PC démarre, puis à la fenêtre d'ouverture de session j'entre mon login, "entrer", mon mot de passe est demandé, je tape à peine la première lettre que l'écran devient noir avec la ligne "seb login:" puis revient sur l'écran d'ouverture de session.
Au bout d'un certains nombres d'essais, une fenêtre m'indique

"Le programme de la bannière d'accueil semble être défaillant, je vais essayer d'en utiliser un autre."
"OK"

De nouveau une fenêtre d'ouverture de session avec l'icône Gnome. Puis au bout d'autres tentatives, un écran bleu, comme windows qui me dit:

"Le serveur de visuels à été arrêté près de 6 fois dans les 90 dernières secondes, il y a quelque chose de mauvais qui se passe. Je vais attendre 2 minutes avant d'essayer sur le visuel :0."

Un écran noir m'invite à entrer mon login et mon mot de passe, ça marche et je me retrouve avec une espèce de terminal. Et là, je sais pas quoi faire, pas moyen pour moi de démarrer ma session en mode graphique, car le mode console, je n'y parviens pas (mes connaissances sont limitées)

Je ne sais pas quoi faire? J'envisage presque de faire une nouvelle install au risque de perdre toutes mes données...
Merci d'avance pour les réponses que vous pourrez m'apporter, je continue aussi mes recherches sur mon autre pc.

PS: ma config portable compaq présario Céléron 700, 320 ram, DD10Go. Si ça peut aider.

Hors ligne

#2 Le 04/04/2006, à 21:39

hello_world

Re : Ouverture de session redémarre à la saisie du mot de passe

leseb a écrit :

Un écran noir m'invite à entrer mon login et mon mot de passe, ça marche et je me retrouve avec une espèce de terminal. Et là, je sais pas quoi faire, pas moyen pour moi de démarrer ma session en mode graphique, car le mode console, je n'y parviens pas (mes connaissances sont limitées)

allons, ce n'est pas si terrible un ecran noir, avec emacs et quelques petite extension (w3m, latex... etc) tu peux déjà ecouter des mpa, faire du traitement de texte, naviguer sur internet, jouer à des jeux débiles, et même compiler ton dernier programme ;-) Que demander de plus?

Serieusement, tu as essayé de taper startx depuis ta session en mode terminal?

et a tout hasard, tu peux noter ce que te renvoie un df .

++

Dernière modification par hello_world (Le 04/04/2006, à 21:40)

Hors ligne

#3 Le 04/04/2006, à 22:35

leseb

Re : Ouverture de session redémarre à la saisie du mot de passe

@ hello_world: Je viens de faire un startx en passant par le recovery mode du kernel (en passant par Grub).
Ubuntu s'est bien lancé, en anglais..? Une fenêtre est apparu au lancement:

"Internal error
failed to initialized HAL!"

J'ai cliqué sur CLOSE (pas d'autre choix)

Le système semble tenir, mais je ne trouve pas mes documents... Que puis-je faire de plus pour revenir à une situation normale?

Hors ligne

#4 Le 04/04/2006, à 22:52

leseb

Re : Ouverture de session redémarre à la saisie du mot de passe

en faisant la commande df dans la console, j'ai:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1              9234688   6570204   2195388  75% /
tmpfs                   156836         0    156836   0% /dev/shm
tmpfs                   156836     12588    144248   9% /lib/modules/2.6.12-10-386/volatile

Hors ligne

#5 Le 05/04/2006, à 14:04

hello_world

Re : Ouverture de session redémarre à la saisie du mot de passe

Salut

Apres quelques recherches sur internet j´ai trouvehttp://ubuntuforums.org/archive/index.php/t-75328.html. Apparement il s´agit d´un peripherique qui n´est pas reconnu. Es-ce que tu as du materiel branche sur tes prises USB. Si c´est le cas essaye sans les brancher au demarrage.

Autrement il y a un tuto sur la page sus-mentionnee pour resoudre le probleme. Je ne sais pas si ca marche puisque je n´ai pas ce probleme, mais apparament, Ca a marche pour certaine personne.

Bonne chance




++

ps: la session x ne demarre pas si on a un disque trop plein, ca m´est encore arrive hier soir, et c´est pourquoi je t´ai demande ce que te repondait la commande df qui signifie disk free. Mais apparament tu as bien assez de place, donc inutile de chercher dans cette direction

pps: il y a aussi ici: http://forum.ubuntu-fr.org/viewtopic.php?pid=41879

Dernière modification par hello_world (Le 05/04/2006, à 15:21)

Hors ligne

#6 Le 05/04/2006, à 15:58

leseb

Re : Ouverture de session redémarre à la saisie du mot de passe

@ hello_world: Merci pour ces infos, je les compulserai ce soir. Cela dit, aucun périphérique usb n'était branché lors de mes essais, et j'avais même retiré ma carte reseau wifi. Je ne sais pas d'où ça peut bien venir, je vais voir si les liens que tu me proposes peuvent m'aider auquel cas je te tiens au courant. Au pire, je ferai une install toute propre (à deux mois de dapper, c'est dommage) en ayant pris soin de récupérer mes documents.
J'ai vu que startx permet de se connecter en root, ce qui ne devrait pas poser de problème pour avoir accès aux dossiers utilisateurs.


*************
Suite de mes soucis sous ubuntu...
En suivant les conseils des liens ci dessus, j'ai procédé à la réinstallation de HAL, mais rien n'y fait, mon système plante toujours autant.
J'ai l'impression qu'il n'y a pas de solution, le formatage et réinstallation complète est envisagé.

Dernière modification par leseb (Le 06/04/2006, à 23:27)

Hors ligne

#7 Le 20/12/2006, à 12:01

miq75

Re : Ouverture de session redémarre à la saisie du mot de passe

J'avais le même problème un démarrage sur deux, les manips suivantes semblent avoir résolue le problème chez moi :

1ere manip : (tout droit sortie de ma tête)
démarrer en mode de secours au besoin, ou sinon en console avec les droits root (sudo -s en console)
apt-get remove hal, puis refuser la commande (n à la question). Noter les paquets qu'il aurait retiré.
apt-get install --purge --reinstall (la liste des paquets qu'on vient de noter)
redémarrer

Chez moi, cela à provoqué une erreur systématique au démarrage, au lieu d'une erreur une fois sur deux. Cependant, en mode de secours, gdm fonctionnait toujours, avec le message suivant au lors de la connection: "Failed to initialize Hal"


2ème manip : (trouvée sur http://ubuntuforums.org/showthread.php?t=24146)
mettre un cd et booter. Le boot se passe normalement.
une fois démarré, réinstaller hal:
sudo apt-get install --purge --reinstall hal (ou par synaptic)
retirer le cd et rebooter.

Chez moi, maintenant ca semble fonctionner correctement (3 reboots de test -> aucun problème)
un conseil : Testez directement la seconde manip, si ça ne suffit pas, refaire les 2.


- j'ai un problème avec mon ordinateur
- on va voir ça
- j'ai Windows
- oui je ne suis pas sourd, vous m'avez déjà dit que vous aviez un problème !

Hors ligne