Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/10/2006, à 17:12

krokodil

[Résolu] Probleme de "locale"

Salut,

Quelqu'un a t'il deja eu ce message d'erreur lorsqu'on cherche a changer de locale :

root@ubuntu:/# dpkg-reconfigure locale                                                                                                                     
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR",
        LC_ALL = (unset),
        LANG = "fr_FR@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Package `locale' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: locale is not installed

On pourrait croire que le package des locale n'est pas installé, mais non ce n'est pas le cas !!

root@ubuntu:/# dpkg -l |grep locale
ii  belocs-locales-bin                2.3.5-5ubuntu7                         tools for compiling locale data files
ii  liblocale-gettext-perl            1.05-1                                 Using libc functions for internationalizatio
ii  localeconf                        0.9.4.1                                debconf interface to locale configuration
ri  locales                           2.3.18                                 common files for locale support
ii  mozilla-firefox-locale-fr-fr      1.5.0.1ubuntu6-2                       Mozilla Firefox French language/region packa
ii  thunderbird-locale-fr             1.5.0.2ubuntu1-3                       Thunderbird French language/region package

Et meme en le supprimant pour le reinstaller j'ai le meme probleme !
J'ai essayé pas mal de trucs mais rien n'y fait pour le moment.... sad
Une idée ?

Dernière modification par krokodil (Le 08/01/2007, à 20:22)


http://www.tem-la-firme.com/?card=40634

Hors ligne

#2 Le 18/10/2006, à 19:48

bertrand0

Re : [Résolu] Probleme de "locale"

Essaie plutôt
sudo dpkg-reconfigure locales

Dernière modification par bertrand0 (Le 18/10/2006, à 19:49)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#3 Le 19/10/2006, à 09:16

krokodil

Re : [Résolu] Probleme de "locale"

Idem, juste une faute de frappe pour le copier coller :-)

root@ubuntu:~# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR",
        LC_ALL = (unset),
        LANG = "fr_FR@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
  en_US.UTF-8... up-to-date
  fr_BE.UTF-8... up-to-date
  fr_CA.UTF-8... up-to-date
  fr_CH.UTF-8... up-to-date
  fr_FR.UTF-8... up-to-date
  fr_LU.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Europe/Paris'.
Local time is now:      Thu Oct 19 09:14:30 CEST 2006.
Universal Time is now:  Thu Oct 19 07:14:30 UTC 2006.
Run 'tzconfig' if you wish to change it.

http://www.tem-la-firme.com/?card=40634

Hors ligne

#4 Le 19/10/2006, à 10:54

bertrand0

Re : [Résolu] Probleme de "locale"

Mets "LANG=fr_FR.UTF-8" dans /etc/environment
à la place de "LANG=fr_FR@euro"

Tu peux aussi le faire via debconf avec
sudo dpkg-reconfigure localeconf


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#5 Le 19/10/2006, à 11:07

krokodil

Re : [Résolu] Probleme de "locale"

root@ubuntu:~# dpkg-reconfigure locales
Generating locales...
  en_US.UTF-8... up-to-date
  fr_BE.UTF-8... up-to-date
  fr_CA.UTF-8... up-to-date
  fr_CH.UTF-8... up-to-date
  fr_FR.UTF-8... up-to-date
  fr_LU.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Europe/Paris'.
Local time is now:      jeudi 19 octobre 2006, 11:05:24 (UTC+0200).
Universal Time is now:  jeudi 19 octobre 2006, 09:05:24 (UTC+0000).
Run 'tzconfig' if you wish to change it.

Niquel !! ca marche, merci pour ton aide. tongue

Tu sais pourquoi ca ne marche pas avec le fr_FR@euro ?


http://www.tem-la-firme.com/?card=40634

Hors ligne

#6 Le 19/10/2006, à 14:53

bertrand0

Re : [Résolu] Probleme de "locale"

Oui, il me semble que fr_FR@euro est un alias pour fr_FR.ISO8859-15
or seules les locales utf8 sont générées par défaut.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#7 Le 08/01/2007, à 20:20

krokodil

Re : [Résolu] Probleme de "locale"

Resolu


http://www.tem-la-firme.com/?card=40634

Hors ligne

#8 Le 31/05/2008, à 21:37

cacolac

Re : [Résolu] Probleme de "locale"

Bonjour,

quelqu'un sait (sous hardy) où d'autre peut être défini la valeur LANG
car j'ai ce message :

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "fr_FR@euro"
    are supported and installed on your system.

alors que mon /etc/environnement est bien réglé

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games"
LANG="fr_FR.UTF-8"

J'avais résolu ce problème lors de la précédente migration (vers la 7.10), et là re la même chose.
le menu "support linguistique" indique bien français par défaut, seule case cochée. J'ai réinstallé tous les paquets language-pack. Je ne vois pas

merci

Hors ligne

#9 Le 02/06/2008, à 14:28

bertrand0

Re : [Résolu] Probleme de "locale"

Le fichier /etc/default/locale a priorité sur /etc/environment dans le fichier de startup de gdm, et dans un certain nombre d'autres fichiers de config (pam notamment).

Dernière modification par bertrand0 (Le 02/06/2008, à 14:31)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#10 Le 14/06/2008, à 09:19

cacolac

Re : [Résolu] Probleme de "locale"

Voila mon fichier ...

cat /etc/default/locale
LANG="fr_FR.UTF-8"


je reinstalle avec un cd dans le weekend. depuis la version 6 j arrivais a m en sortir par mise a jour mais la il y a trop de choses qui marchent pas , la moitie des menus en anglaism keyboard en qwerty , j ai l impression que SCIM pose pb , driver proprietaire nvidia qui ne veut pas etre reconnu, erreur HAL a chaque demarrage etc. sad

Hors ligne

#11 Le 14/06/2008, à 16:29

cacolac

Re : [Résolu] Probleme de "locale"

J'ai réinstallé ubuntu ce matin pour voir que grub n'était pas bien configuré, embêtant pour booter, dès qu'il y a plus d'un hdd il se perd le pauvre ubuntu

La solution à ce pb de locale (je l'avais noté dans un coin...)

sudo locale-gen fr_FR@euro

C'est magique.

Hors ligne

#12 Le 14/08/2008, à 13:07

®om

Re : [Résolu] Probleme de "locale"

Enfin, il vaut mieux fr_FR.utf8 que @euro !

Hors ligne

#13 Le 23/03/2009, à 18:20

barbsbou

Re : [Résolu] Probleme de "locale"

bonjour je suis sous intrepid et j'ai le meme probleme :

root@nemo:/home/morgan# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR:fr:en_GB:en",
        LC_ALL = "fr_FR",
        LC_MESSAGES = "fr_FR",
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...


[...]

pourtant

 cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANGUAGE="fr_FR:fr"
LANG=fr_FR.UTF-8

et

root@nemo:/home/morgan# cat /etc/default/locale 
LANG="fr_FR.UTF-8"
LANGUAGE="fr_FR:fr:en_GB:en"

Petite aide SVP.... hmm

Merci par avance

Hors ligne

#14 Le 23/03/2009, à 18:51

bertrand0

Re : [Résolu] Probleme de "locale"

Manifestement, il manque les paquets de locale française, ou bien ils sont endommagés. Allez dans le menu "Système/Administration/Prise en charge linguistique" et assurez vous que "Français" est bien coché (il ne doit pas être seulement grisé, car cela signifie installé partiellement). Puis faites Appliquer.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#15 Le 24/03/2009, à 11:56

barbsbou

Re : [Résolu] Probleme de "locale"

Merci pour ta réponse bertrand0,

mais je utilise Kubuntu avec e17, qui avec une mise à jour (avec ecomorph) m'a dégagé KDE donc plus d'outil pour gérer mais paquet, alors j'ai fait une recherche avec apt-cache search locale | grep fr
j'ai installé tous les paquets dans la liste qui peuvent me correspondre... et j'ai refait un locale-gen!! Pas de changement!!

Petite précision
quand je fait locale-gen je n'ai pas de message d'erreur, mais quand je fais dpkg-reconfigure locales j'ai les fameuses erreurs de locales....

Si quelqu'un peut m'aider...

Merci

Dernière modification par barbsbou (Le 24/03/2009, à 11:56)

Hors ligne

#16 Le 24/03/2009, à 21:40

bertrand0

Re : [Résolu] Probleme de "locale"

Essaie de taper la commande suivante dans un terminal, pour réinstaller les paquets de locale français déjà installés sur le système:

sudo aptitude reinstall '~i~n(-fr$|-fr-)!~o'

Et celle-ci, pour installer les paquets manquant peut-être (les plus importants...):

sudo aptitude --without-recommends install '~n^language-pack(-|-gnome-|-kde-)fr$' language-support-fr

Dernière modification par bertrand0 (Le 24/03/2009, à 21:45)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#17 Le 25/03/2009, à 13:48

barbsbou

Re : [Résolu] Probleme de "locale"

Merci bertrand0 pour ta réponse
j'ai fait ce que tu m'as conseillé... mais toujours le même problème... je ne vois vraiment pas où est le problème...

Dernière modification par barbsbou (Le 25/03/2009, à 13:50)

Hors ligne

#18 Le 25/03/2009, à 14:26

barbsbou

Re : [Résolu] Probleme de "locale"

Bon j'ai trouvé une façon assez bourrin de résoudre mon problème à l'adresse suivante
http://forum.topflood.com/hebergement/p … -4291.html

Hors ligne

#19 Le 02/08/2010, à 10:00

Doin

Re : [Résolu] Probleme de "locale"

Je cite Agone dans un autre sujet :

Agone a écrit :
sudo apt-get install --reinstall language-pack-fr

et apres si t'as toujours rien :

cd /usr/lib/locale
sudo ln -s fr_FR.utf8 fr_FR

La première commande m'a suffit.

(Le paquet localeconf n'existe plus)

Hors ligne

#20 Le 05/03/2015, à 21:32

pdany4

Re : [Résolu] Probleme de "locale"

Après un :

sudo update-initramfs -u

pour mise à jour de mon RAID pour le démarrage
[sudo] password for toto:
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
Warning: No support for locale: fr_FR.utf8

J'ai trouvé la solution pour réparer cette erreur sur un forum Mint Anglais

sudo locale-gen --purge --no-archive

Et l'erreur disparaît tongue


Serveur Debian Squeeze 64 Bits avec C2D e6550 OC (FSB 400), 4Go de DDR2 Corsair C5, 1 SSD 60Go = OS, HDD : 1x160Go = fichier temporaires 2 x Samsung Spinpoint F2 de 1,5 To @ 5400rpm en RAID1 et  2 x Western Digital Green de 2 To @ 5400rpm en RAID1 avec mdadm + 1 PC Q9450 et 8Gb de RAM sous Linux Mint 13 (Mate) 64 bits et 1 PC Windows 7 en 32 bits, Core2quad avec 2Gb de RAM (applis radio oblige)

Hors ligne