Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/12/2011, à 22:57

hgus

Disque dur externe USB qui ne se monte pas tout seul

Bonjour,

Problème rencontré sous  Ubuntu 10.10 -  Maverick Meerkat - GNOME version 2.32.0

Avec un Disque dur externe USB EMTEC Movie Cube Q120E

Ce disque dur a eu fonctionné correctement, et d'un coup un beau jour plus rien.

J'ai tenté des solutions proposées dans le forum en modifiant /etc/fstab en rajoutant ces lignes :

# /dev/sdb1
UUID=386F-804D /media/ddusb     ntfs    defaults,umask=007,gid=46 0       1

L'UUID étant celui que je pense être le bon, récupérer dans Device Manager qui au passage voit le disque comme un Hitachi.
Je ne sais pas ce que vaut cette solution, mais sans succès, au redémarrage du système il plante en essayant de le monter.
D'ailleurs ce n'est pas ce que je souhaite, qu'il le cherche au démarrage, mais qu'il se monte lorsque je le branche, comme un clé !

J'ai donc laissé tombé, et monté manuellement le dd, en ligne de commande.
De cette façon il apparait sur le bureau, mais donc pas automatiquement.
Et avec cette solution je ne peux créer de dossier, de fichier, rien, aucun droit.
Idem pas les droits pour le démonter.

Donc solution de secours, 3 lanceurs sur le bureau qui lancent 3 scripts dans un terminal pour :
monter
démonter
et ouvrir nautilus en root pour avoir les droits.

Est-ce qu'il y aurait une solution pour revenir à un fonctionnement normal :
-> au branchement du dd usb externe, qu'il se monte automatiquement avec les droits en écriture et lecture ?

Je désespère !

Merci de votre aide !

ugo

Hors ligne

#2 Le 07/12/2011, à 10:54

serdar_villa

Re : Disque dur externe USB qui ne se monte pas tout seul

les options de montage, qui donnent certaines qualifications à votre partition:

    L'option rw indique que vous souhaitez accéder à cette partition en lecture et en écriture (read/write). Si vous ne souhaitez accéder à votre partition qu'en lecture seule, vous pourriez préférer ro (read only).
    user (ou users)1) permet à n'importe quel utilisateur de monter ou démonter cette partition, donc pas seulement les administrateurs de l'ordinateur. Vous pouvez l'omettre si vous ne désirez pas ce comportement.
    auto est l'option indiquant que la partition doit être montée automatiquement au démarrage d'Ubuntu (l'utilisateur qui effectue montage devient alors root). Utiliser noauto pour demander le contraire.
    exec est une option qui permet l'exécution de programmes installés dans cette partition. Sans elle, une erreur vous est affichée lorsque vous essayez d'exécuter un programme installé dans cette partition (« Permission non accordée »).
    gid=100 assignera l'ensemble des fichiers au groupe dont le gid (pour group id, identifiant de groupe) est 100. Sous Ubuntu, le gid 100 correspond au groupe users, auquel tous les utilisateurs font normalement partie. Vous pouvez retrouver une liste de tous les groupes existants sur votre machine avec leur gid dans le fichier /etc/group. Si vous omettez cette option, tous les fichiers seront assignés au groupe 0, soit root (le compte système).
    uid=1000 assignera l'ensemble des fichiers de la partition à l'utilisateur dont l'UID (pour User ID, identifiant d'utilisateur) est 1000. Sous Ubuntu, l'UID 1000 correspond au premier utilisateur, créé lors de l'installation de Ubuntu. Si vous omettez cette option, tous les fichiers seront assignés à l'utilisateur root (le compte système).
    L'option umask=002 donnera les droits d'accès, sur l'ensemble des répertoires et fichiers, en lecture et en exécution à tous, de même qu'en écriture au propriétaire et groupe du fichier. 2)
    Les options iocharset=utf8,codepage=850 permettent l'utilisation du jeu de caratère UTF-8 sur les partitions FAT32, ce qui corrige des erreurs dans l'affichage de noms de fichiers accentués.
    L'option shortname=mixed permet de faire en sorte que les noms de fichiers de moins de 8 caractères conservent leur casse. Pour des raisons de rétro-compatibilité, les noms de fichiers de moins de 8 caractères sont automatiquement mis en majuscules, à moins que cette option soit précisée.


Pour ajouter une partition dont le système de fichiers est le NTFS (voir plus haut pour les partitions de type FAT32) et y accéder en lecture et écriture, vous devez disposer du pilote ntfs-3g3). Si vous êtes sous Ubuntu 7.10 ou version ultérieure, ce pilote est installé de base. Sinon, vous devrez l'installer en suivant le tutoriel d'installation de ntfs-3g.

Lorsque vous disposez de ntfs-3g, il vous suffit d'ajouter une instruction à la fin de votre fichier /etc/fstab, sous la forme suivante :

# Partitions Windows - NTFS
périphérique    point de montage    ntfs-3g     rw,user,auto,gid=100,uid=1000,nls=utf8,umask=002    0    0


source: http://doc.ubuntu-fr.org/tutoriel/comme … ns_windows

Hors ligne

#3 Le 07/12/2011, à 13:17

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Bonjour,

Merci de la réponse !

Mais ça traite de partitions Windows ? c'en est de même pour un disque dur externe usb ou clé usb ?

Il est dit dans la doc ubuntu : Dans une installation standard, un service du système assure le montage automatique des systèmes de fichier dès qu'un périphérique externe en USB (par exemple) est détecté permettant d'afficher le contenu de cette nouvelle unité de stockage.

C'était le cas, ça ne l'ait plus.
Ce serait parce-que la ligne nécessaire aurait disparue ?

Pour assurer ce service il suffit juste de rajouter la bonne ligne dans le fstab, également pour que l'icone apparaisse sur le bureau ?
Faut-il redémarrer le PC après changement du fstab ?

Que de questions ...

Merci !


ugo

Hors ligne

#4 Le 07/12/2011, à 14:15

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

As-tu essayé avec windows ?
Je suspecte ton disque, formaté en ntfs semble-t-il, d'avoir le problème habituel qui se produit en débranchant le disque à la hussarde sans le démonter.

Ça n'a aucun rapport avec fstab ! En effet, fstab contient la liste des périphériques à monter automatiquement au démarrage du système. Or toi, ce que tu voudrais, c'est monter un disque au moment où tu le branches, donc après le démarrage de système.
En revanche, que donne :

sudo  mount  -t  ntfs-3g   /dev/sdb1  /mnt

Remplace évidemment sdb1 par ton disque. Si tu ne sais pas :

sudo   fdisk  -l         un "L" minuscule

En principe tu retrouves le contenu de ton disque en /mnt et tu devrais pouvoir lire et écrire...

Quand tu as fini de tester

sudo   umount  /mnt

Dernière modification par faustus (Le 07/12/2011, à 14:17)

#5 Le 07/12/2011, à 15:01

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Bonjour,

Faustus : avec Windows 7 il marche correctement.
J'ai lu par là que ça pouvait être du justement à un retrait sans sécurité.
J'ai donc remis le dd sur Windows, et l'ai retiré en toute sécurité.

Mais il ne se monte pas mieux sous Ubuntu.

En ligne de commande comme tu le préconises, c'est la solution de secours  que j'ai trouvé :
ça fonctionne, mais il faut 3 scripts !
1 sudo mount
1 sudo umount
1 sudo pour ouvrir nautilus en mode root et pouvoir écrire sur le disque

C'est fastidieux ! ... Existe-t-il un truc à donc paramétrer quelque-part pour ré-automatiser tout cela ?

Donc rien à voir avec fstab ?
fstab n'est pas appelé lors d'un branchement USB ?

Merci !

ugo

Hors ligne

#6 Le 07/12/2011, à 15:14

Korak

Re : Disque dur externe USB qui ne se monte pas tout seul

Bonjour,

Si tu branches un autre disque-dur externe, se monte-t-il correctement et automatiquement?

Juste pour info:

hgus a écrit :

EMTEC Movie Cube Q120E
.....
Device Manager qui au passage voit le disque comme un Hitachi.

EMTEC c'est la marque du boîtier. Et comme EMTEC ne fabrique pas de disque-dur, ils en prennent d'un constructeur de disque-dur. Dans ton cas, chez Hitachi. Il n'y a donc rien d'anormal (si tu n'es pas convaincu, ouvre le boîtier, tu verras la marque du disque-dur).

Dernière modification par Korak (Le 07/12/2011, à 15:24)


OS: Ubuntu 20.04.1 64 bits (avec Unity) + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 + R7   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#7 Le 07/12/2011, à 15:26

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

hgus a écrit :

Bonjour,

Faustus : avec Windows 7 il marche correctement.
J'ai lu par là que ça pouvait être du justement à un retrait sans sécurité.
J'ai donc remis le dd sur Windows, et l'ai retiré en toute sécurité.

Mais il ne se monte pas mieux sous Ubuntu.

En ligne de commande comme tu le préconises, c'est la solution de secours  que j'ai trouvé :
ça fonctionne, mais il faut 3 scripts !
1 sudo mount
1 sudo umount
1 sudo pour ouvrir nautilus en mode root et pouvoir écrire sur le disque

C'est fastidieux ! ... Existe-t-il un truc à donc paramétrer quelque-part pour ré-automatiser tout cela ?

Donc rien à voir avec fstab ?
fstab n'est pas appelé lors d'un branchement USB ?

Merci !

ugo

Non, rien à voir avec fstab.
En revanche, ça a à voir avec udev, hal, fuse, dbus et des trucs de ce genre. Bien sûr, je ne sais absolument pas comment remédier. C'est au coeur du système que ça se passe... Peut-être qu'il y a un daemon qui est normalement lancé et qui ne l'est plus ou qui a été mal configuré (suite à une mise à jour ?)...

#8 Le 07/12/2011, à 15:34

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

C'est pareil même problème avec un autre disque dur externe USB, et également avec des clés USB toutes simples.

???!!!

Hors ligne

#9 Le 07/12/2011, à 15:36

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Oui il y eu des mises à jour, mais du coup ... je crois bien que je suis dans l'impasse !
Réinstaller tout ? c'est ennuyeux quand même !

Hors ligne

#10 Le 07/12/2011, à 15:40

Korak

Re : Disque dur externe USB qui ne se monte pas tout seul

Un autre type de périphérique USB (clavier, souris) fonctionne correctement et automatiquement?


OS: Ubuntu 20.04.1 64 bits (avec Unity) + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 + R7   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#11 Le 07/12/2011, à 15:41

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Souris USB oui !

Hors ligne

#12 Le 07/12/2011, à 15:45

Korak

Re : Disque dur externe USB qui ne se monte pas tout seul

Donc, il n'y a que les périphériques de stockage USB qui posent problèmes.

Et là, désolé, je ne sais pas comment t'aider.


OS: Ubuntu 20.04.1 64 bits (avec Unity) + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 + R7   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#13 Le 07/12/2011, à 16:34

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Ok, donc si rien à voir avec fstab, et que c'est au coeur du noyau ... il n'y a pas d'autres solutions que de ... résintaller tout, non ?
On peut pas mettre à jour le noyau ou faire quelquechose pour qu'il soit bien ... renoyauté ?
Ou faut dénoyauter ?

Ca sent la confiture ... ou la déconfiture au choix ...

ugo

Hors ligne

#14 Le 07/12/2011, à 16:36

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

Essaye peut-être de créer un nouvel initrd. Parfois ça aide.

sudo   update-initramfs  -c

Après ça il faut redémarrer.

#15 Le 07/12/2011, à 16:49

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

Sinon, pose peut-être la question dans trucs, astuces, scripts utiles (en précisant que tu l'as déjà posée ailleurs sans obtenir de réponse convaincante).
Parce que bon, s'il ne veut pas monter ton disque tout seul au branchement, il y a peut-être moyen de faire ça par un script qui tournerait en tâche de fond, qui craquerait régulièrement un oeil sur les ports usb puis réagirait de manière adéquate au branchement d'un disque externe, et qui serait lancé au démarrage. Avec un autre script et un bouton (affiché à bon escient par le script précédent) pour démonter...
Ce n'est peut-être pas la bonne solution, mais dans les trucs et astuces il y a des intervenants qui connaissent linux comme leur poche et qui seraient plus à même de trouver la solution...
En fait ton problème n'est pas un problème de matériel mais de configuration de la gestion des ports usb.

Dernière modification par faustus (Le 07/12/2011, à 16:53)

#16 Le 07/12/2011, à 17:12

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Ok, je vais tenter dans les trucs et astuces ...

Par contre Faustus voici ce que me renvoie ta ligne de commande sudo   update-initramfs  -c :
sudo update-initramfs -c
Create mode requires a version argument

Usage: /usr/sbin/update-initramfs [OPTION]...

Options:
-k [version]    Specify kernel version or 'all'
-c        Create a new initramfs
-u        Update an existing initramfs
-d        Remove an existing initramfs
-t        Take over a custom initramfs with this one
-b        Set alternate boot directory
-v        Be verbose
-h        This message


Il manque un truc ... un option ? une version apparemment ...koual esse lakelle ? no lo se !
j'ai espoir que cette commande soit salvatrice ...

Dernière modification par hgus (Le 07/12/2011, à 17:15)

Hors ligne

#17 Le 07/12/2011, à 17:19

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

Oui, peut-être qu'il lui faut le noyau à utiliser...
Essaye ça :

sudo   update-initramfs  -c   -k   `uname -r`

les ` c'est alt droit -7

#18 Le 07/12/2011, à 17:23

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Ok,voici la réponse :
update-initramfs: Generating /boot/initrd.img-3.0.0-0300-generic

je reboot ...

Hors ligne

#19 Le 07/12/2011, à 17:30

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

après reboot toujours pas de montage auto d'une simple clé ...

tant pis !

merci à tous pour vos suggestions !

ugo

Hors ligne

#20 Le 07/12/2011, à 18:14

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

Que donne ça ?

ps   -ef   |   grep   volume

Parce que j'ai l'impression que ça pourrait venir de gnome volume manager (comme ici  : http://www.generation-nt.com/gnome-volu … 13651.html ). Je dis gnome volume manager, mais ça pourrait être ce qui en tient lieu (avec leur détestable manie de tout changer d'une version à l'autre).

Dernière modification par faustus (Le 07/12/2011, à 18:16)

#21 Le 07/12/2011, à 18:15

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

cela donne :

mazzy     1676  1656  0 18:15 pts/0    00:00:00 grep --color=auto volume

avec "volume" écrit en rouge

Dernière modification par hgus (Le 07/12/2011, à 18:16)

Hors ligne

#22 Le 07/12/2011, à 18:20

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

dans le liens que tu m'as passé, ils traitent de gpart ... il y a pas longtemps on a installé des paquets gpart, il me semble, on a tellement fait de trucs, mais toujours depuis des dépots officiels ...

Hors ligne

#23 Le 07/12/2011, à 18:28

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

Rien d'intéressant...
Mais j'ai trouvé ça, aussi : http://packages.debian.org/fr/sid/gnome-volume-manager
Ça a bien l'air de se passer par là, sauf qu'on n'en sait pas beaucoup plus sur la façon dont ça fonctionne ni où et comment ça se configure...

Dernière modification par faustus (Le 07/12/2011, à 18:28)

#24 Le 07/12/2011, à 18:38

hgus

Re : Disque dur externe USB qui ne se monte pas tout seul

Mais Debian kézako ce n'est pas ma configuration ?

Hors ligne

#25 Le 07/12/2011, à 18:48

compte supprimé

Re : Disque dur externe USB qui ne se monte pas tout seul

C'est tout comme ! En fait Ubuntu est une Debian modifiée...
Je viens encore de trouver quelque chose : gconf-editor (mais je ne peux pas tester chez moi : kde !).

sudo    gconf-editor

Si ça démarre (existe encore ?), il faut explorer et voir s'il n'y a pas quelque part un automount ou quelque chose de ce genre...

http://doc.ubuntu-fr.org/gconf

Ça doit pas être bon, la commande suggéré. Essaye celles qui sont dans la doc. Et si tu as gnome3 (sans doute pas encore, dans 10.10), c'est encore différent !

Dernière modification par faustus (Le 07/12/2011, à 18:53)