Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/01/2007, à 01:30

|-Corpse-|

Le point sur les codecs

Salut,

malgré la documentation abondante existant sur les codecs, je trouve qu'il manque un récapitulatif clair et concis de ce qu'il faut installer pour lire tous les formats libres ou non. Je me permets donc de poster le mien.

Il existe un très bon tuto sur les différents codecs/lecteurs, mais il est dépassé en ce qui concerne les paquets à installer ou certaines manipulations à faire. Il reste quand même très utile pour les explications générales sur les qualités des différents lecteurs, ainsi que pour avoir une explication détaillée (mais pas trop) des différents paquets.

1) Activer les dépots Universe, Multiverse et Medibuntu. Le plus simple, si vous ne vous y connaissez pas :

sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak
sudo gedit /etc/apt/sources.list

Effacez l'entièreté du fichier, et remplacez par :
Pour Ubuntu Dapper Drake

####Ubuntu officiels####
deb http://archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
#deb-src http://security.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

####Ubuntu commercial####
#deb http://archive.canonical.com/ubuntu dapper-commercial main

####Ubuntu officieux####
deb http://medibuntu.sos-sts.com/repo/ dapper free non-free
#deb-src http://medibuntu.sos-sts.com/repo/ dapper free non-free

Pour Ubuntu Edgy Eft (à vérifier)

####Ubuntu officiels####
deb http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
#deb-src http://security.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
#deb http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
#deb-src http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse

####Ubuntu commercial####
#deb http://archive.canonical.com/ubuntu edgy-commercial main

####Ubuntu officieux####
deb http://medibuntu.sos-sts.com/repo/ edgy free non-free
#deb-src http://medibuntu.sos-sts.com/repo/ edgy free non-free

Installez la clé pour les dépots Medibuntu :

wget -q http://medibuntu.sos-sts.com/repo/medibuntu-key.gpg -O- | sudo apt-key add -

Mettez à jour :

sudo apt-get update

2) Tapez la formule magique qui devrait installer tout ce dont vous avez besoin :

sudo apt-get install totem-xine gstreamer0.10-ffmpeg gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse w32codecs libxine-extracodecs libdvdread3 libdvdcss2 mozilla-mplayer

Une petite explication sur ce que vous venez d'installer :
totem-xine : une version de totem utilisant le moteur xine, qui offre une meilleure compatibilité avec les DVD.
gstreamer0.10-ffmpeg : différents codecs comme divx, xvid ou autres pour les lecteurs/utilitaires n'utilisant pas xine.
gstreamer0.10-plugins-good, gstreamer0.10-plugins-bad(-multiverse), gstreamer0.10-plugins-ugly(-multiverse) : différents codecs, notamment celui pour la lecture des mp3/mpc pour les lecteurs/utilitaires n'utilisant pas xine comme Rythmbox.
w32codecs : les codecs proprios, notamment pour le décodage du RealVideo 9-10
libxine-extracodecs : quelques codecs supplémentaires pour le moteur xine et non présents dans le paquet w32codecs.
libdvdread3 : pour la lecture des DVD.
libdvdcss2 : pour la lecture des DVD vidéos cryptés.
mozilla-mplayer : pour la lecture des vidéos sous firefox.

Remarques :
- lorsque vous effacez tout le contenu du fichier sources.list, prenez garde à ne pas effacer des dépots que vous auriez ajouté manuellement, comme les dépots pour wine ou xcfa. En cas de pépins, le backup est là pour vous sauver :

sudo mv /etc/apt/sources.list.bak /etc/apt/sources.list

- j'ai volontairement désactivé les backports et les dépots de sources car ils me semblent inutiles dans la plupart des cas.
- il faut vérifier les dépots pour Edgy, car perso j'utilise Dapper et je n'assure pas que les dépots marcheront.
- la version kubuntu devrait voir le jour, mais là j'aurai besoin d'un coup de main pour éviter les conneries.


Les avis/remarques sont les bienvenues. A moins d'avoir fait une grosse connerie, je pense que tout le « tuto » tient la route. Je n'ajouterai à mon avis rien dans les explications, car il y a déjà tout ce qu'il faut sur le wiki.

Dernière modification par |-Corpse-| (Le 26/01/2007, à 03:11)

Hors ligne

#2 Le 25/01/2007, à 01:49

xabilon

Re : Le point sur les codecs

Quelle utilité d'installer les gstreamers si on a totem-xine et mplayer ? ni Xine ni Mplayer n'utilisent Gstreamer.

Quelle utilité pour le dépôt Canonical ?

De plus, ceci est réservé à Ubuntu (Gnome)

Tu oublies aussi libdvdread.

J'ai tout dit, je crois ... wink


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 25/01/2007, à 01:57

|-Corpse-|

Re : Le point sur les codecs

xabilon a écrit :

Quelle utilité d'installer les gstreamers si on a totem-xine et mplayer ? ni Xine ni Mplayer n'utilisent Gstreamer.

Quelle utilité pour le dépôt Canonical ?

De plus, ceci est réservé à Ubuntu (Gnome)

Tu oublies aussi libdvdread.

J'ai tout dit, je crois ... wink

merci pour tes remarques. alors dans l'ordre :
1) pour pouvoir utiliser Rythmnbox, par exemple, qui est bien plus pratique pour lire la musique que totem ou mplayer. si mes souvenirs sont bons, ffmpeg qui sert à convertir des videos en .mpg utilise aussi gstreamer.
2) aucune en ce qui concerne les codecs, d'ailleurs j'aurais pu le commenter.
3) ben oui, on est bien sur ubuntu-fr et pas kubuntu-fr à ce que je sache tongue
4) d'après mes souvenirs, libdvdread3 est installé d'office sur ubuntu. mais je peux me tromper...

wink

Edit : voilà, j'ai fait les modifs

Dernière modification par |-Corpse-| (Le 25/01/2007, à 02:16)

Hors ligne

#4 Le 25/01/2007, à 02:16

xabilon

Re : Le point sur les codecs

|-Corpse-| a écrit :

3) ben oui, on est bien sur ubuntu-fr et pas kubuntu-fr à ce que je sache tongue

Ah bon ?
http://forum.kubuntu-fr.org/viewtopic.p … 72#p708972


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 25/01/2007, à 02:18

|-Corpse-|

Re : Le point sur les codecs

xabilon a écrit :
|-Corpse-| a écrit :

3) ben oui, on est bien sur ubuntu-fr et pas kubuntu-fr à ce que je sache tongue

Ah bon ?
http://forum.kubuntu-fr.org/viewtopic.p … 72#p708972

cool, j'avais jamais vraiment été sur kubuntu-fr, j'ai appris un truc aujourd'hui

Hors ligne

#6 Le 25/01/2007, à 19:11

waraba

Re : Le point sur les codecs

moi je lis presque tout avec mplayer et je m'en pleins pas.
En plus ce tape tout les trucs de gstreammer alors qu'avec un seul paquet et xine sa marche nikel.:/


Ubuntu 19.10 essaie de revenir sur le forum

Hors ligne

#7 Le 26/01/2007, à 00:49

|-Corpse-|

Re : Le point sur les codecs

waraba a écrit :

moi je lis presque tout avec mplayer et je m'en pleins pas.
En plus ce tape tout les trucs de gstreammer alors qu'avec un seul paquet et xine sa marche nikel.:/

Et avec VLC, c'est encore mieux, y'a tous les codecs intégrés.

On peut troller sur des pages et des pages sur quel lecteur utiliser, sur quel plugin à utiliser dans firefox, etc.
- Moi j'préfère VLC, c'est plus simple y'a tous les codecs intégrés
- Bouh, VLC c'est moche, je préfère totem xine c'est plus clair et plus joli
- Totem ca pue, vive mplayer parce que blablabla...
- Et pour lire la musique, tu peux mieux gérer tes playlist avec Rythmbox
Donc en gros, on n'a pas fini. Les paquets gstreamer (bad, ugly et ffmpeg, d'après mes souvenirs le good est installé d'office) doivent à tout casser prendre 5 mo, et grâce à eux tu peux lire « n'importe quel » format avec Rythmbox et convertir « n'importe quelle » vidéo flv en mpeg grâce à ffmpeg en 2 coups de cuillère à pot. Je crois que ca vaut le coup de les installer...

J'ai présenté ma méthode, qui me semble à priori la plus simple pour pouvoir utiliser à peu près n'importe quel format dans n'importe quel lecteur. J'ai pas dit que c'était la plus économique niveau place (quoique  5 mo de rab sur 2/3 Go d'install, c'est pas la mort), mais c'est à mon avis la plus pratique pour ne pas être emmerdé plus tard.

Hors ligne

#8 Le 26/01/2007, à 00:57

did

Re : Le point sur les codecs

Bonsoir,

Juste un truc, un détail :

totem-xine : une version améliorée de totem

Il ne s'agit pas d'une version améliorée, c'est simplement le moteur xine pour totem. Tu as le choix entre celui-ci et totem-gstreamer.
Ces deux paquets sont complémentaires du paquet totem qui s'installe par dépendance.

Et puis :

libxine-extracodecs : jamais compris à quoi il servait vraiment, toujours est-il que grâce à lui mes mkv avec h264+aac passent nickel

Ben c'est le pack de codec pour xine, justement. Je rajouterai libxine1 avec celui-ci.

Sinon, bonne initiative, manque que la version kubuntu wink

Dernière modification par did (Le 26/01/2007, à 01:51)

Hors ligne

#9 Le 26/01/2007, à 01:04

Blondin

Re : Le point sur les codecs

Et si on demandais au yekblog je pense que ça donnerais :
http://yeknan.free.fr/blog/index.php?2006/10/15/140-installation-de-ubuntu-610-02-premiers-soins-materiel-et-personnalisation

et

http://yeknan.free.fr/blog/index.php?2006/10/15/141-installation-de-ubuntu-610-03-logiciels

Sympas aussi comme point rapide, non ? big_smile


Qui troll un oeuf, troll un boeuf

Hors ligne

#10 Le 26/01/2007, à 02:02

|-Corpse-|

Re : Le point sur les codecs

did a écrit :

libxine-extracodecs : jamais compris à quoi il servait vraiment, toujours est-il que grâce à lui mes mkv avec h264+aac passent nickel

Ben c'est le pack de codec pour xine, justement. Je rajouterai libxine-main1 avec celui-ci.

Sinon, bonne initiative, manque que la version kubuntu wink

Si mes souvenirs sont bons, je n'avais pas eu à installer libxine-extracodecs sur la Breezy (le paquet existait-il d'ailleurs ?) et je n'avais aucun problème. Lors de mon passage à Dapper, ce paquet m'a été nécessaire pour lire certains de mes mkv, et je n'ai pas compris (cherché) pourquoi w32codecs ne suffisait plus.
Malheureusement, Breezy a été ma première install d'Ubuntu, et comme tout débutant j'ai installé plein de paquets sans trop savoir à quoi ils servaient. Alors peut-être que le paquet a été installé via une dépendance quelconque, je ne saurai plus dire.

Pour libxine-main1, il fait partie des dépendances de totem-xine.

Pour totem-xine, je savais mais j'ai peut-être voulu synthétiser un peu trop l'idée de ce paquet. Je pensais que dire « utilise le moteur xine à la place du moteur gstreamer », ca aurait amené la question évidente « pourquoi utiliser xine si on utilise quand même gstreamer pour d'autres applications ? »
J'ai voulu rendre le topic le plus clair et concis possible, sans commencer à rentrer dans plein de détails techniques.
Je voulais faire une explication synthétique, mais sans non plus tomber dans l'excès en donnant une suite de commandes à taper sans rien savoir de ce qu'on installe. C'était, de mon point de vue, le meilleur rapport commandes/explications. Tout au moins, c'est celui qui me satisfait le mieux quand je dois expliquer l'utilité d'un paquet à quelqu'un.
En même temps, en faisant ça, je savais que je filais le tube de vaseline à tous ceux qui sont pointilleux ou qui ne veulent pas expliquer les choses à moitié. Ce n'est pas un reproche hein ! Mais c'est juste que quand un débutant arrive sous Ubuntu et qu'il a un problème, certains donnent simplement les commandes magiques, du style « Que te donne la commande prout ? » « Ha, ben suffit de taper sudo ertgffd --fredsdf @@ --dsfsd || ## ddifzonf %~ et ca va marcher », que d'autres envoient sur des posts tellement détaillés que finalement, on ne lit que les commandes à taper pour voir si ca résoud le problème.

Pour la version kubuntu, je verrai à compléter par la suite...


@ Blondin : pas mal du tout ton lien , direct dans mes favoris.

Hors ligne

#11 Le 26/01/2007, à 02:20

did

Re : Le point sur les codecs

et je n'ai pas compris (cherché) pourquoi w32codecs ne suffisait plus.

Je ne crois pas que xine utilise w32codecs, mais à vérifier.

Pour libxine-main1, il fait partie des dépendances de totem-xine.

Exact,  plus précisement libxine-main1 est un paquet de transition vers libxine1 dont est dépendant totem-xine. L'ajouter n'a donc effectivement pas de sens.

J'ai voulu rendre le topic le plus clair et concis possible, sans commencer à rentrer dans plein de détails techniques.

Bah, trop simplifier n'est pas forcement rendre service au débutant, sans parler de rentrer dans les détails. Il faut toujours mieux expliquer les choses comme elles sont.

Je pensais que dire « utilise le moteur xine à la place du moteur gstreamer », ca aurait amené la question évidente « pourquoi utiliser xine si on utilise quand même gstreamer pour d'autres applications ? »

Tiens d'ailleurs, intéressante cette question, une réponse?

Enfin, je ne veux surtout pas avoir l'air de dénigrer ton travail, c'est simplement pour essayer d'être constructif. Encore merci pour ton travail.

Hors ligne

#12 Le 26/01/2007, à 02:44

|-Corpse-|

Re : Le point sur les codecs

Je ne crois pas que xine utilise w32codecs, mais à vérifier.

Un petit test rapide avec une vidéo encodée en RV10 me fait dire que oui. En effet j'utilise totem-xine, et la vidéo passe sans problèmes avec w32codecs, mais ne passe pas sans. Cependant, je ne sais pas dans quelle mesure quel filtre a la priorité sur un autre.

Bah, trop simplifier n'est pas forcement rendre service au débutant, sans parler de rentrer dans les détails. Il faut toujours mieux expliquer les choses comme elles sont.

Tout à fait d'accord, mais ce n'est pas évident de se remettre au niveau débutant quand tu as même un peu d'expérience.

Tiens d'ailleurs, intéressante cette question, une réponse?

La compatibilité DVD ? (source, au point 4.1.1)

Enfin, je ne veux surtout pas avoir l'air de dénigrer ton travail, c'est simplement pour essayer d'être constructif. Encore merci pour ton travail.

Y'a pas de soucis, j'aime autant qu'on fasse des remarques qui apportent quelque chose que pas de remarques et laisser le « tuto » tomber dans l'oubli car il est bourré d'erreurs. Par contre, le truc que je n'aime pas, c'est qu'on vienne en disant que la moitié des paquets ne sert à rien parce qu'on a une utilisation différente qui ne les nécessite pas forcément.

Hors ligne

#13 Le 29/01/2007, à 19:56

hugobosscool

Re : Le point sur les codecs

Ta commande ne fonctionne pas avec ma version amd64, Aucune version du paquet w32codecs n'est disponible!


Une idée?

#14 Le 29/01/2007, à 23:36

GrInDcOrE

Re : Le point sur les codecs

Bonsoir,

Merci beaucoup pour avoir pris le temps de faire ce petit point |-Corpse-|, tu m'as permis de gagner un temps précieux smile

hugobosscool a écrit :

Ta commande ne fonctionne pas avec ma version amd64, Aucune version du paquet w32codecs n'est disponible!


Une idée?

hugobosscool : as-tu bien activé les dépôts Medibuntu?

Hors ligne

#15 Le 29/01/2007, à 23:44

|-Corpse-|

Re : Le point sur les codecs

hugobosscool a écrit :

Ta commande ne fonctionne pas avec ma version amd64, Aucune version du paquet w32codecs n'est disponible!


Une idée?

Malheureusement, le paquet w32codecs n'est pas disponible en 64 bits. Il faudra faire sans...

GrInDcOrE a écrit :

Bonsoir,

Merci beaucoup pour avoir pris le temps de faire ce petit point |-Corpse-|, tu m'as permis de gagner un temps précieux smile

De rien wink

Dernière modification par |-Corpse-| (Le 29/01/2007, à 23:44)

Hors ligne