Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/06/2012, à 14:13

Doremon

[RESOLU] Activation wlan0 et eth0

Bonjour à tous,

J'ai une installation Ubuntu en 12.04 hébergeant une machine virtuelle Windows (XP64) via Virtualbox (4.1.12).
Au niveau du travail nous avons un réseau intranet "professionnel" filaire ainsi qu'un réseau "public" en WIFI ( je capte aussi les réseaux libres genre FreeWIFI ).

Je voudrais dédier l'interface eth0 à la VM Windows (ça marche sans problème) pour l'activité professionnelle et utiliser l'interface wlan0 pour l'activité réseau Internet avec Ubuntu.

Je cherche donc à activer simultanément les interfaces réseaux wlan0 et eth0.

Actuellement, mon problème réside dans le fait que l'activation de l'interface eth0 (i.e. branchement d'un câble réseau), coupe automatiquement l'interface WIFI.

Peut-on modifier ce comportement ?

Merci de votre aide.

Dernière modification par Doremon (Le 09/07/2012, à 20:34)

Hors ligne

#2 Le 26/06/2012, à 17:22

Haleth

Re : [RESOLU] Activation wlan0 et eth0

Ca coupe l'autre interface ?
Je gage plutôt que les deux interfaces sont activées, mais que les connexions utilisent une seule interface

Tu peux vérifier avec la commande ifconfig, j'imagine que les deux interfaces possèdent une adresse IP

Pour ton problème, je pense qu'il s'agit d'une histoire de route: les paquets prennent une certaine route, qui passe par la dernière interface configurée fonctionnel, ici eth0
Tu peux regarder la table de routage avec la commande route:

route -a

Tu peux aussi la modifier, toujours avec la commande route, pour les paquets passent toujours par wlan0 (sauf ceux de virtualbox, qui eu sont forcés vers eth0)

J'pense que ca marche, à vrai dire j'ai pas test

A propos, pourquoi cette ségrégation ?


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#3 Le 27/06/2012, à 12:46

Doremon

Re : [RESOLU] Activation wlan0 et eth0

L'interface est bien coupée.
Lors du branchement de câble Ethernet, j'ai bien une indication (dans la zone de notification de Unity) de déconnexion du WIFI avant d'avoir une nouvelle indication de la connexion du réseau filaire.

Sur tes indications j'ai tout de même vérifié avec ifconfig, et le verdict est le même.

J'ai l'impression que NetworkManager est responsable de cette bascule, mais je n'arrive pas à trouver d'indications sur le sujet : j'ai l'impression d'être le seul à vouloir faire ça...

Pour les motivations de cette "ségrégation" c'est assez simple :
- Mon entreprise nous fournit des PC avec Windows installé et fourré d'un antivirus/firewall développé par des glands : en gros mon Portable (core i5, 8go de Ram et Vertex 4) surconsomme du CPU, tous mes softs rament et/ou sont bloqués par le firewall (ex: 1 minute pour démarrer soapui) et les seules choses qui fonctionnent correctement sont powerpoint et les virus...
- Nous avons Outlook, Lync et MS Office donc impossible de travailler sous Linux.
- Le règlement informatique de l'entreprise nous interdit de connecter du matériel personnel, ou un autre OS que celui fourni, sur le réseau Intranet.

Donc pour rester dans le respect stricte de ce règlement informatique et dans le soucis de rester productif (c'est vrai qu'à l'origine c'était ça l'objectif), j'ai :
1. Transformé l'OS de mon portable en machine virtuelle (P2V avec l'utilitaire VirtualBox).
2. Configuré cette image dans Virtualbox avec une limitation drastique du CPU pour qu'il me reste assez de ressources pour travailler.
3. Autorisé cette image à accéder au réseau Intranet pour lire mon courrier + lecture/édition de documents Office + Lync (i.e. vitualbox sur eth0)
4. Installé tous mes softs de travail sous Ubuntu (soapui, eclipse, db2, websphere, etc...)
5. Activé le WIFI pour qu'il puisse accéder à l'Internet (nécessaire pour mon activité)
6. Bridé Ubuntu pour qu'il ne puisse pas accéder au réseau Intranet

En gros, je bloque sur la 5ème étape.

Hors ligne

#4 Le 27/06/2012, à 12:55

Haleth

Re : [RESOLU] Activation wlan0 et eth0

Ca à l'air interessant
Je rend gloire à ton esprit d'initiative: personnellement, j'aurais juste branché mon Linux sur l'intranet, et hop, c'est fait big_smile

Que se passe-t-il si, ton cable Ethernet étant branché et l'interface eth0 up, tu actives ton wifi ?
As-tu essayé de te passer de network-manager pour l'ethernet ? Je veut dire: démarrer eth0 sans lui
La configuration d'une interface ethernet est simple, regarde le fichier /etc/network/interfaces

Bref, essaye de faire ca:
- Branchement Ethernet
- Branchement wifi (ici, si j'ai bien compris, eth0 down et wlan0 up)
- relancer eth0 à la main (ifconfig eth0 up) avec peut-etre une configuration de l'interface manuelle (fichier /etc/network/interfaces) si requit


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#5 Le 28/06/2012, à 14:59

Doremon

Re : [RESOLU] Activation wlan0 et eth0

J'ai vérifié avec ifconfig et l'interface wlan0 perd son adresse IP lorsque que je branche le câble ethernet.

J'ai aussi essayé de redémarrer l'interface à la main avec un ifconfig wlan0 up et là ça devient intéressant. J'ai un retour indiquant que l'interface ne peut pas être redémarré à cause de RF-KILL.

SIOCSIFFLAGS: Opération impossible du fait de RF-kill

Du coup, j'ai fait des recherches sur RF-KILL et j'ai lancé la commande rfkill list avec le résultat suivant :

1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
6: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

En gros il indique que l'interface wlan0 est coupé physiquement.

Après plusieurs tests, il s'avère que :
- Si je branche le câble réseau, l'interface wlan0 est coupée Hard blocked: yes
- Si je débranche le câble réseau, l'interface wlan0 est réactivée : Hard blocked: no
- Si je coupe le wifi à partir du bouton de contrôle sur mon portable, l'interface wlan0 est coupée Hard blocked: yes
- Si j'active le wifi à partir du bouton de contrôle, l'interface wlan0 est réactivée : Hard blocked: no

En résumé, brancher le câble revient à forcer la désactivation du wifi. Il me reste donc à trouver qui est le petit malin qui associe le branchement d'un câble avec la coupure de l'interface wifi (le bios, network-manager, etc.).

Hors ligne

#6 Le 09/07/2012, à 20:33

Doremon

Re : [RESOLU] Activation wlan0 et eth0

C'est bon, j'ai finalement trouvé, la réponse était dans mon précédent post : ça venait du bios.

J'ai fini par passer en revu tous les réglages du BIOS et je suis tombé sur une option qui ne m'avait jamais parlé auparavant au sujet d'un "switch WLAN/LAN".

En désactivant cette option, j'ai pu activer simultanément les réseaux filaires et WIFI.

Pour information, il s'agit d'une option que se trouverait sur tous les portables HP EliteBook.

Hors ligne