Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/02/2007, à 16:37

jeffcom

problèmes d'accents que dans quantaplus

hello les gens

j'utilise quantaplus sous gnome, et depuis peu (après installation du nouveau noyau et soucis graphiques inhérents) lorsque je tape un caractère accentué, il apparâit comme mal encodé le "é" deviens "é"... et ce seulement dans quantaplus... j'ai tout paramétré quanta pour encoder en utf-8 mais rien n'y fait...

une idée ?

Hors ligne

#2 Le 21/02/2007, à 17:19

voitats6

Re : problèmes d'accents que dans quantaplus

Bonjour !

Pour ma part, je ne laisse pas d'accents dans quanta+.

J'applique à mes fichiers un petit script comme ceci:

#!/bin/bash
sed -e 's/à/\à/g' -e 's/â/\â/g'  -e 's/é/\é/g' -e 's/è/\&egr
ave;/g' -e 's/ê/\ê/g' -e 's/ô/\ô/g' -e 's/ù/\ù/g' -e 's/û/\&u
circ;/g'  -e 's/euro/\€/g'

On peut le développer, modifier les codes, etc... et l'appliquer via le menu  configuration/configurer les actions...

Bonne chance !

Hors ligne

#3 Le 21/02/2007, à 17:44

jeffcom

Re : problèmes d'accents que dans quantaplus

c'est pas qu'il ne lit pas les accents comme il faut, mais c'est lors de la saisie ! lorsque je veux saisir "é" il me l'encode mal ! on dirait qu'il cherche à afficher en iso au lieu d'unicode... et puis pour le web, j'utilise le paramètre de quanta qui transforme automatiquement les caractères accentués en entité html...

et puis on peut faire autre chose que du web avec quanta... smile mais merci quand même smile

Hors ligne

#4 Le 02/03/2007, à 23:09

voitats6

Re : problèmes d'accents que dans quantaplus

Je ne comprends pas très bien ce qui se passe...

De mon côté, j'ai beaucoup cherché comment éviter que les le "é" deviennent "é" (mais c'est en passant du web sur mon écran, je n'ai pas ce problème entre le clavier et l'écran.).

J'ai fini par trouver iconf():
$fichier = iconv("ISO-8859-1", "UTF-8", $fichier);
qui m'a rendu de grands services.

Si jamais...


Bonne chance!

Hors ligne

#5 Le 03/03/2007, à 12:18

jeffcom

Re : problèmes d'accents que dans quantaplus

oué iconv, mais le truc que je comprends pas c'est qu'avant tout allait bien et quand j'ai mis à jour je noyau ça c mis à merder... et seulement dans quanta ! et puis le truc c'est que j'utilise la conversion automatique des caractères : lorsque je tape "é" ça devrais me le transformer en à mais ça me mets ©Ã... si je fais un iconv ça va merder... ce que je ne comprends pas non plus c'est le fait que le puisse coller un caractère accentué sans que ça merde....

n'y aurait-il pas une config spéciale pour les logiciels kde sous gnome ? je connais mieux gnome que kde... donc je me dis qu'il ya peut être quelquechose à configurer du coté des librairies kde ...

si quelqu'un a une idée ...

Hors ligne

#6 Le 12/03/2007, à 19:49

jeffcom

Re : problèmes d'accents que dans quantaplus

up...

Hors ligne

#7 Le 14/03/2007, à 11:20

Olivier44

Re : problèmes d'accents que dans quantaplus

J'ai aussi le même problème et j'utilise Kedit pour modifier les fichiers avec des caractères accentués.

J'ai l'impression que Quanta+ sauvegarde mal les fichiers au format UTF8.

#8 Le 16/03/2007, à 12:30

Olivier44

Re : problèmes d'accents que dans quantaplus

Pour vérifier l'encodage des fichiers, j'ai utilisé enca (http://trific.ath.cx/software/enca/).

En ligne de commande : enca -L none *
Cela affiche l'encodage de tous les fichiers du dossier en cours.

J'ai constaté que les fichiers sauvegardés avec quanta au format UTF-8 n'ont pas ce format !!!!

Je n'ai pas encore trouvé la solution pour y remédier ...

#9 Le 12/06/2007, à 14:26

Dandelion Mood

Re : problèmes d'accents que dans quantaplus

Up big_smile, même problème que jeffcom depuis que je suis passé à XCFE hier soir ...
Je n'avais jamais eu ce pb sous gnome roll ^^


http://www.dandelionmood.com

Hors ligne

#10 Le 18/07/2007, à 11:22

Dandelion Mood

Re : problèmes d'accents que dans quantaplus

Re Up ! smile

Quanta + est le meilleur éditeur. Je le veux. big_smile

Je suis passé à KDE où j'avais plus de problème, avant de retourner finalement à Gnome où mon souci est de retour : mon analyse est la même que jeffcom -> problème de librairie ... manquante ? mal installée/configurée sous les autres environnements que Kde ?

Merci de votre aide !


http://www.dandelionmood.com

Hors ligne

#11 Le 18/07/2007, à 11:26

Dandelion Mood

Re : problèmes d'accents que dans quantaplus

Je viens de remarquer quelque chose qui apportera peut être un nouvel éclairage sur ce bug : lorsque je tape "ééé" dans gEdit et que je le colle dans Quanta, pas de problème, les accents sont conservés. Le problème se situe bien lors de la frappe.

Quelqu'un sait qui est responsable de l'analyse des caractères tapés (après X je pense) dans Kde ? Enfin on peut noter que Quanta propose une option pour convertir automatiquement les caractères accentués en entités type é ... Peut être que cette fonctionnalité a un problème ?


http://www.dandelionmood.com

Hors ligne

#12 Le 08/09/2007, à 22:18

voitats6

Re : problèmes d'accents que dans quantaplus

intéressante la remarque de Dandellon Mood:

Enfin on peut noter que Quanta propose une option pour convertir automatiquement les caractères accentués en entités type é ...

Cela se trouve où dans quanta+?

Hors ligne

#13 Le 21/02/2008, à 23:03

Klaquemuffe

Re : problèmes d'accents que dans quantaplus

voitats6 a écrit :

intéressante la remarque de Dandellon Mood:

Enfin on peut noter que Quanta propose une option pour convertir automatiquement les caractères accentués en entités type é ...

Cela se trouve où dans quanta+?

moi aussi, ça m'intéresserai pas mal de le savoir... winkroll


Les Quizzs de Raoul KLAQUEMUFFE sur http://klaquemuffe.com

Hors ligne

#14 Le 22/02/2008, à 06:51

voitats6

Re : problèmes d'accents que dans quantaplus

Bonjour !

On peut voir dans
Settings/Configure Quanta + Onglet "Style des balises", cocher "Remplacement automatiquement des caractères accentués".

Mais bon,  chez moi é devient é et non é j'ignore si c'est mieux ou pas !

Hors ligne

#15 Le 22/02/2009, à 14:46

bruno

Re : problèmes d'accents que dans quantaplus

Tout dépend du jeu de caractères utilisé dans le document HTML.
Quanta+ permet de préciser (dans les options du projet) avec quel jeu de caractère on désire travailler (charset par défaut pour les nouveaux documents HTML).
Si l'on utilise utf-8, ce qu je recommande fortement, avec donc dans l'en-tête :

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

les navigateurs sauront gérer correctement les caractères non-encodés sous formes d'entités dans le document. Autrement dit les é œ, Æ, « etc. s'afficheront correctement sur n'importe quel navigateur prenant en charge l'utf-8. En utf-8 l'encodage n'est pas obligatoire.

Si l'on utilise un autre jeu de caractères, par exemple iso8859-1 :

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

alors, il es OBLIGATOIRE d'encoder ces caractères sous formes d'entités pour être sûr que les navigateurs les restituent correctement. Autrement dit &eacute;, &oelig, etc.
Je considère cela comme une contrainte supplémentaire qui n'a plus lieu d'être avec la prise en charge d'utf-8 qui est maintenant quasi-universelle.

Il existe cependant des outils très pratique pour convertir les documents (HTML ou non) d'un encodage vers un autre. iconv est l'un de ces outils mais il est assez limité. recode (paquet du me nom) est bien plus puissant, puisqu'il permet par exemple de convertir les entités en caractères et vice-versa.
Par exemple, je récupère un document HTML4 ou XHTML truc.html en iso8859-1 que je veux passer en utf-8 :

recode h4..UTF-8 truc.html

toutes les entités (&agrave; ou &icirc;) seront converties en caractères (à ou î). Il suffit ensuite de modifier le « charset » du document pour travailler sereinement en UTF-8.

L'inverse est bien entendu possible, voir info recode pour les très nombreuses options de cet outil.


Le mensonge et la crédulité s'accouplent et engendrent l'opinion.

Hors ligne