Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/09/2013, à 18:51

Ben30400

Plus de son [Résolu]

Bonjour,

Depuis le passage à une mise à jour récente, mon système n'émet plus aucun son.
J'ai consulté les divers sujets similaires (installation ALSA, paquets nonfree), mais rien n'y a fait.
Totalement étranger au langage Ubuntu, comment puis-je faire pour vous donner plus de détail (utilisation du termional)?

Merci d'avance,

Dernière modification par Ben30400 (Le 15/09/2013, à 12:35)

Hors ligne

#2 Le 07/09/2013, à 19:04

Ben30400

Re : Plus de son [Résolu]

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.04
DISTRIB_CODENAME=raring
DISTRIB_DESCRIPTION="Ubuntu 13.04"

Hors ligne

#3 Le 07/09/2013, à 19:06

Ben30400

Re : Plus de son [Résolu]

00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 02)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
03:00.0 Network controller: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 02)

Hors ligne

#4 Le 08/09/2013, à 07:26

F50

Re : Plus de son [Résolu]

Salut,

Tape alsamixer dans un terminal pour voir si ce n'est pas sur "mute". Puis tape aussi gstreamer-properties et fait le test son pour voir quelle sortie est concluante.


Pourquoi acceptons-nous l’inacceptable ? https://vimeo.com/278811414
O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#5 Le 08/09/2013, à 09:28

Ben30400

Re : Plus de son [Résolu]

AlsaMixer v1.0.25 ──────────────────────────────┐
│    Carte: HDA Intel                                F1:  Aide                 │
│     Puce: Realtek ALC888                           F2:  Informations Système │
│      Vue: F3:[Lecture] F4: Capture  F5: Tout       F6:  Choisir la carte son │
│ Contrôle: Master [gain dB: -24,00]                 Esc: Quitter              │
│                                                                              │
│     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │  │     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                 │
│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │                                 │
│     ├──┤     ├──┤     ├──┤     ├──┤     └──┘     ┌──┐     ┌──┐   Enabled     │
│     │OO│     │OO│     │OO│     │MM│              │OO│     │OO│           


Ca semble enabled.


Après ça coince, aucun des 2 tests ne fonctionne.

(gstreamer-properties:2449): Gtk-WARNING **: Unknown property: GtkDialog.has-separator

(gstreamer-properties:2449): Gtk-WARNING **: Unknown property: GtkDialog.has-separator
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosrc'

Hors ligne

#6 Le 08/09/2013, à 09:40

Ben30400

Re : Plus de son [Résolu]

En modifiant les paramètres du test ouput qui était précedemment en autodetec, j'entends un son en plaçant "input", ALSA, analog.
Pour le input, rien ne se passe.

Hors ligne

#7 Le 08/09/2013, à 10:18

Ben30400

Re : Plus de son [Résolu]

SI je mets "test" en input, j'entends aussi un son.
Mais le test du réglage son est toujours négatif :-(

Hors ligne

#8 Le 08/09/2013, à 11:28

F50

Re : Plus de son [Résolu]


Pourquoi acceptons-nous l’inacceptable ? https://vimeo.com/278811414
O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#9 Le 08/09/2013, à 13:17

Ben30400

Re : Plus de son [Résolu]

Pas plus, je vais réinstaller Ubuntu.
Merci quand même ;-)

Hors ligne

#10 Le 08/09/2013, à 16:07

F50

Re : Plus de son [Résolu]

Où vire pulseaudio et reboot puis met tout sur Alsa et refait le test.


Pourquoi acceptons-nous l’inacceptable ? https://vimeo.com/278811414
O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#11 Le 08/09/2013, à 19:53

Ben30400

Re : Plus de son [Résolu]

Non, rien n'y fait et ça m'ennuie de tout réinstaller...

Hors ligne

#12 Le 08/09/2013, à 20:00

Madeba

Re : Plus de son [Résolu]

Peut etre un process qui bloque la carte :
que donne

fuser -v /dev/snd/*

Hors ligne

#13 Le 08/09/2013, à 20:03

Madeba

Re : Plus de son [Résolu]

fcn50 a écrit :

Où vire pulseaudio et reboot puis met tout sur Alsa et refait le test.

Au passage, pour la première fois depuis que Pulsaudio a été inclu dans les paquets (combien d'année? big_smile), j'ai réussi à avoir du son avec la dernière mise à jour (en Debian instable). Alléluia, après toute ces années, j'avais fini par croire que c'était un logiciel pour couper le son/rendre sourd l'utilisateur sur une distrib...:P

Hors ligne

#14 Le 08/09/2013, à 20:12

Ben30400

Re : Plus de son [Résolu]

chaupot@chaupot-B202:~$ fuser -v /dev/snd/*
                     UTIL.       PID ACCÈS  COMMANDE
/dev/snd/controlC0:  chaupot    1434 F.... pulseaudio
/dev/snd/controlC1:  chaupot    1434 F.... pulseaudio

Désolé mais je ne comprends pas votre private joke sur pulseaudio, suis newbee!

Hors ligne

#15 Le 08/09/2013, à 20:30

Madeba

Re : Plus de son [Résolu]

Ah, désolé, pour la blague d'initié smile
Disons qu'entre Pulseaudio, qui gère le son sur pas mal de distrib aujourdhui, et les utlisateurs Linux, c'est une longue histoire d'amour...

En tous cas c'est bien Pulseaudio qui "bloque" le son ici. Tu dois avoir un mixeur à zéro.
Essaye avec un outil genre pavucontrol ?
Il faudra peut être l'installer...

Hors ligne

#16 Le 08/09/2013, à 21:00

Ben30400

Re : Plus de son [Résolu]

Ah OK, je n'ai Ubuntu que depuis la V8, mais jamais de problème de son, avec le même PC!
Pavucontrol, j'ai configuré, rien de plus.
Je ne comprends pas cette soudaine panne...

Hors ligne

#17 Le 08/09/2013, à 23:08

Madeba

Re : Plus de son [Résolu]

Vérifie quand même dans ce machin que tes périf de lecture sont pas réglés sur une autre carte son (genre la sortie HDMI de la carte vidéo, plutôt que ta carte interne).
Après, je sais pas, désinstaller Pulseaudio ? tongue

Hors ligne

#18 Le 08/09/2013, à 23:32

F50

Re : Plus de son [Résolu]

Ben30400 a écrit :

e n'ai Ubuntu que depuis la V8

C'est laquelle la V8?

Ben30400 a écrit :

Désolé mais je ne comprends pas votre private joke sur pulseaudio, suis newbee!

Personne ne comprend pourquoi cette crotte est installée d'office... Sous buntu 12.04 LTS tu avais du son? Si oui, réinstalle celle-là, la 13.04 n'a aucun intérêt.

Donne quand même le retour de: aplay -l et de: cat /proc/asound/cards.

Dernière modification par fcn50 (Le 09/09/2013, à 06:35)


Pourquoi acceptons-nous l’inacceptable ? https://vimeo.com/278811414
O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#19 Le 09/09/2013, à 19:53

Ben30400

Re : Plus de son [Résolu]

J'ai pas de sortie HDMI, le PC est assez vieux (EEEbox)
JHe ne sais plus le nom d'ubuntu 8, désolé mais j'ai toujours eu du son...

**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: Intel [HDA Intel], périphérique 0: ALC888 Analog [ALC888 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: Intel [HDA Intel], périphérique 1: ALC888 Digital [ALC888 Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfeb38000 irq 44
1 [IM             ]: USB-Audio - VF0530 Live! Cam Chat IM
                      Creative Labs VF0530 Live! Cam Chat IM at usb-0000:00:1d.7-3, high speed

Hors ligne

#20 Le 11/09/2013, à 08:23

F50

Re : Plus de son [Résolu]

Pourtant ça semble reconnu! Essaye de supprimer pulseaudio puis de rebooter et essaye les différentes sorties et paramètre les logiciels sur Alsa.


Pourquoi acceptons-nous l’inacceptable ? https://vimeo.com/278811414
O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#21 Le 15/09/2013, à 12:28

Ben30400

Re : Plus de son [Résolu]

Je viens de désinstaller pulseaudio et CA MARCHE!
Merci mille fois!

Hors ligne

#22 Le 15/09/2013, à 14:17

Madeba

Re : Plus de son [Résolu]

Bon bin t'as désormais le droit de faire la blague d'initiés sur PA wink

Allez, j'en profite quand même pour signaler que quand il fonctionne, c'est quand même pratique (contrôle du son appli par appli ...).

Hors ligne

#23 Le 15/09/2013, à 14:23

Ben30400

Re : Plus de son [Résolu]

;-)

Hors ligne

#24 Le 16/09/2013, à 07:13

F50

Re : Plus de son [Résolu]

Parfait, tu as une crotte en moins sur ton système. cool


Pourquoi acceptons-nous l’inacceptable ? https://vimeo.com/278811414
O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne