Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/09/2013, à 16:49

zarchtrack

[Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

Bonjour,
depuis quelques jours - je ne sais plus si c'est à la suite d'une mise à jour... - j'ai ce message qui apparaît au boot « Le disque dur /dev/mapper/cryptswap1 n'est pas encore prêt ou présent. ».
J'ai cherché, mais n'ai trouvé aucune réponse...
Pourriez-vous m'aider ?
Merci.

Dernière modification par zarchtrack (Le 28/09/2013, à 15:31)

Hors ligne

#2 Le 26/09/2013, à 12:34

genma

Re : [Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

Si tu comprends l'anglais, tu as une solution ici
http://punygeek.blogspot.fr/2012/10/ubu … e-for.html.

Il est possible que ce soit lié à une mise à jour, un bug a été signalé en mars 2013.

Tu chiffres ton /home?


"Lorsque tu as découvert le libre, tu sais que tu ne pourras plus jamais revenir en arrière".
Utilisateur d'Ubuntu depuis la version 4.10 !
Mon blog ?      https://blog.genma.fr
Mon twitter?     http://twitter.com/genma

Hors ligne

#3 Le 26/09/2013, à 18:25

zarchtrack

Re : [Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

Merci de ta réponse.
Malheureusement, je ne comprends pas ce que je dois faire... hmm
Il serait possible que tu m'aides là-dessus ? smile

Pour le /home, je ne suis plus sûr, mais c'est possible... Cela joue ?

Hors ligne

#4 Le 27/09/2013, à 12:58

genma

Re : [Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

As tu activé le chiffrement? Car là c'est un problème de chifffrement du swap.

Tu as quel niveau en Linux? Pour t'aider, je reprends le code du lien et j'ajoute mes commentaires :Si tu comprends mieux en version française et c'est ce que tu fais, fais le. Sinon, attends quelqu'un d'autre apporte une solution plus simple :

sudo swapoff -a ; désactivation du swap

comment existing swap configuration in  : Dans le fichier /etc/crypttab, il faut commenter (ajouter un # en tout début de ligne) au niveau d'une ligne qui ressemble à  cryptswap1 /dev/sdb8 /dev/urandom swap,cipher=aes-cbc-essiv:sha256

comment existing swap configuration in /etc/fstab :
=> pareil, il faut faire # /dev/mapper/cryptswap1 none swap sw 0 0

re-format swap partition with gparted as linux-swap
=> ouvre gparted, formate la partition de swap en "swap"

sudo mkswap /dev/sdXX
=>creation d'un nouveau swap. XX est le numéro de la partition de SWAP.

Il faut garder la valeur de l'UUID car on aura besoin.
La commande doit te donner une ligne du type
Setting up swapspace version 1, size = 4208636 KiB
no label, UUID=06a9be15-d05b-466d-bfe3-a086bb9cdba0

Mets à jour le fichier /etc/initramfs-tools/conf.d/resume avec la nouvelle valeur d'UUID

ex.
RESUME=UUID=06a9be15-d05b-466d-bfe3-a086bb9cdba0

Puis il faut faire la commande
sudo update-initramfs -u
qui fait un update d'initramfs

Puis la commande qui remet le swap en utilisation :
sudo swapon /dev/sdXX
avec toujours le même numéro de partition swap


"Lorsque tu as découvert le libre, tu sais que tu ne pourras plus jamais revenir en arrière".
Utilisateur d'Ubuntu depuis la version 4.10 !
Mon blog ?      https://blog.genma.fr
Mon twitter?     http://twitter.com/genma

Hors ligne

#5 Le 28/09/2013, à 15:28

zarchtrack

Re : [Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

Je te remercie pour cette aide, et pour le temps que tu as consacrer à m'aider !
Je n'ai plus le message au démarrage d'ubuntu, il doit être réglé. smile
Mon niveau en Linux est par contre relativement bas, mais vu que tu as bien commenté ce qu'il fallait faire, je pense avoir réussi ! smile
Merci, et bonne journée.

Hors ligne

#6 Le 30/09/2013, à 13:35

genma

Re : [Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

De rien. Je pensais pas qu'on réussirait. Tant mieux si j'ai été utile.


"Lorsque tu as découvert le libre, tu sais que tu ne pourras plus jamais revenir en arrière".
Utilisateur d'Ubuntu depuis la version 4.10 !
Mon blog ?      https://blog.genma.fr
Mon twitter?     http://twitter.com/genma

Hors ligne

#7 Le 13/03/2015, à 05:03

PomponBuntu

Re : [Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

Salut genma, je suis nouveau avec Linux et j'ai le même problème que celui décrit dans ce post.
La ligne de commande : sudo swapoff -a
Je dois taper ça où?
Concernant la partition swap, j'aimerais savoir c'est laquelle? Voici mes partitions:
Partition         Système de fichiers       Point de montage       Taille             Utilisé        Inutilisé       Drapeaux
/dev/sda1       ext4                               /                                  295.15Gio    26.97Gio   268.19Gio   boot
/dev/sda2       extended                                                          2.94Gio         ---              ---
/dev/sda5 !     inconnu                                                            2.94Gio         ---              ---
Ensuite, pour la formater en swap, est-ce qu je dois prendre l'option "formater en linux-swap"?
Le numéro de la partition swap (XX)que je dois inscrire, il ressemble à quoi? est-ce que ce sera sda5? ou sda2?

Citation: "Il faut garder la valeur de l'UUID car on aura besoin." Est-ce que ce numéro sera généré lors de la création du nouveau swap?

Merci à l'avance!

Hors ligne

#8 Le 18/04/2015, à 17:42

jldr

Re : [Résolu ] "/dev/mapper/cryptswap1 n'est pas encore prêt ou présent."

genma a écrit :

As tu activé le chiffrement? Car là c'est un problème de chifffrement du swap.

Tu as quel niveau en Linux? Pour t'aider, je reprends le code du lien et j'ajoute mes commentaires :Si tu comprends mieux en version française et c'est ce que tu fais, fais le. Sinon, attends quelqu'un d'autre apporte une solution plus simple :

sudo swapoff -a ; désactivation du swap

comment existing swap configuration in  : Dans le fichier /etc/crypttab, il faut commenter (ajouter un # en tout début de ligne) au niveau d'une ligne qui ressemble à  cryptswap1 /dev/sdb8 /dev/urandom swap,cipher=aes-cbc-essiv:sha256

comment existing swap configuration in /etc/fstab :
=> pareil, il faut faire # /dev/mapper/cryptswap1 none swap sw 0 0

re-format swap partition with gparted as linux-swap
=> ouvre gparted, formate la partition de swap en "swap"

sudo mkswap /dev/sdXX
=>creation d'un nouveau swap. XX est le numéro de la partition de SWAP.

Il faut garder la valeur de l'UUID car on aura besoin.
La commande doit te donner une ligne du type
Setting up swapspace version 1, size = 4208636 KiB
no label, UUID=06a9be15-d05b-466d-bfe3-a086bb9cdba0

Mets à jour le fichier /etc/initramfs-tools/conf.d/resume avec la nouvelle valeur d'UUID

ex.
RESUME=UUID=06a9be15-d05b-466d-bfe3-a086bb9cdba0

Puis il faut faire la commande
sudo update-initramfs -u
qui fait un update d'initramfs

Puis la commande qui remet le swap en utilisation :
sudo swapon /dev/sdXX
avec toujours le même numéro de partition swap

====
bonjour
j'ai le même souci avec le swap et tente de réparer avec ton tuto.
Est-ce qu'il ne manque pas une ligne (selon le tuto en version anglaise) ?

sudo ecryptfs-setup-swap

J'ai tenté cette commande mais quelque chose se bloque :

jldr@steph-P5K:~$ sudo ecryptfs-setup-swap

WARNING:
An encrypted swap is required to help ensure that encrypted files are not leaked to disk in an unencrypted format.

HOWEVER, THE SWAP ENCRYPTION CONFIGURATION PRODUCED BY THIS PROGRAM WILL BREAK HIBERNATE/RESUME ON THIS SYSTEM!

NOTE: Your suspend/resume capabilities will not be affected.

Do you want to proceed with encrypting your swap? [y/N]: y

INFO: Setting up swap: [/dev/sda2]
cryptdisks stop/waiting

Que faire ensuite ?
Il semble que le souci est partagé : https://bugs.launchpad.net/ubuntu/+sour … ug/1409677
Merci d'avance
Jean-Luc

Hors ligne