Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/02/2008, à 23:47

Arkos971

[résolu]Connecté au wifi mais pas à internet

Bonjour à tous,

Mon problème se résume ainsi: Ma carte wifi est enregistrée sur ma livebox car je m'y connecte automatiquement et sans aucun problème. Je n'arrive pourtant pas à utiliser internet avec mon navigateur ou autre. Et je ne comprends pas pourquoi

J'ai fait le préalable demandé pour poster ici donc je vous donne tous les retours que j'ai eu des différentes commandes (c'est très long, je ne sais pas vraiment ce dont vous pourriez avoir besoin dsl):

arkos@ubuntumaster:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=7.10
DISTRIB_CODENAME=gutsy
DISTRIB_DESCRIPTION="Ubuntu 7.10"

arkos@ubuntumaster:~$ lsusb
Bus 007 Device 001: ID 0000:0000 
Bus 006 Device 001: ID 0000:0000 
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 001: ID 0000:0000 

arkos@ubuntumaster:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
04:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
0f:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0f:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
0f:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0f:06.3 Generic system peripheral [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller

arkos@ubuntumaster:~$ sudo lshw -C network           
       description: Ethernet interface
       product: NetLink BCM5787M Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: 02
       serial: 00:1d:72:09:44:96
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.77 firmware=5787m-v3.23 ip=192.168.1.151 latency=0 link=no module=tg3 multicast=yes port=twisted pair
  *-network
       description: Wireless interface
       product: AR5006E

Dernière modification par Arkos971 (Le 29/02/2008, à 22:01)


Bidouilleur mais pas sans peurs

Hors ligne

#2 Le 24/02/2008, à 23:55

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

UNe dernière chose: mon ordinateur est un Acer TravelMate 5320. Voila c'est bien tout^^


Bidouilleur mais pas sans peurs

Hors ligne

#3 Le 24/02/2008, à 23:57

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

Il faut savoir que networkmanger ne gère pas les IP fixe
soit tu passes par wicd (voir doc)
soit tu passes par l'édition du fichiers des interfaces

auto lo
iface lo inet loopback

# The primary network interface
auto eth1
iface eth1 inet static
address 192.168.1.151
netmask 255.255.255.0
gateway 192.168.1.1

#wifi
auto ath1
iface ath1 inet static
address 192.168.1.12
netmask 255.255.255.0
gateway 192.168.1.1
wireless-essid Livebox-a4f4
wireless-key la_clé_wep

puis

sudo ifdown eth1
sudo ifdown ath1
sudo ifup ath1

#4 Le 25/02/2008, à 00:18

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

Merci! Mais la ligne que tu as remplacé par iface eth1 inet static était un commentaire (avec un # devant, c'est bien ce que ça signifie?) donc je ne m'en préoccupe pas où alors t'as oublié le #?


Bidouilleur mais pas sans peurs

Hors ligne

#5 Le 25/02/2008, à 00:22

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

ah ok je comprends ce que tu as fait. ta supprimé tout un paragraphe et t'as fait remonter le premier.


Bidouilleur mais pas sans peurs

Hors ligne

#6 Le 25/02/2008, à 00:25

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

oui désolé j'ai remanié car
il y avait du eth0 et eth1 aussi

#7 Le 25/02/2008, à 00:31

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

petit problème: sudo ifdown eth1 OK
                     sudo ifdown ath1 donne ifddown: interface ath1 not configured
                     sudo ifup ath1 rien ne se passe.

Je dois juste ré-associer l'ordi et la livebox ou le problème est ailleurs?


Bidouilleur mais pas sans peurs

Hors ligne

#8 Le 25/02/2008, à 00:34

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

Tape
sudo ifdown eth1
retire le câble

et donne le retour de

sudo /etc/init.d/networking restart

#9 Le 25/02/2008, à 00:45

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

Attention je crois qu'il y a confusion. Dans mon premier poste j'ai dit que j'étais conecté mais en wifi, pas par cable. Actuellement je suis sous windows sur un autre ordi portable et j'ai en meme temps mon acer a coté.

sudo ifdown eth1 me donne interface eth1 not configured

sudo /etc/init.d/networking restart me donne command not found


Bidouilleur mais pas sans peurs

Hors ligne

#10 Le 25/02/2008, à 00:51

toutafai

Re : [résolu]Connecté au wifi mais pas à internet

oui, cette sulution est bonne, ton pb etant que tu est sur tu a 2 interfaces réseau sur le meme réseau 192.168.1.x.

j'suis dans le meme cas, perso j'utilse un petit batch qui m"activer l''une ou l'autre selon mes besoins.

oups le teps que je valide, y 'en a qu'on répondu..

Dernière modification par toutafai (Le 25/02/2008, à 00:55)


Tombé dans l'informatique étant petit, j'en ai fait mon métier. Utilisateur d'Ubuntu depuis novembre 2006, actuellement sous 20.04 x64 (Que d'évolution
depuis Dapper Drake ! Ça rajeunit pas ^^^).

Hors ligne

#11 Le 25/02/2008, à 00:55

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

De quelle solution parles-tu? celle de vista sous belga? Si c'est le seul moyen peux tu me donne le code du patch stp?


Bidouilleur mais pas sans peurs

Hors ligne

#12 Le 25/02/2008, à 00:58

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

Arkos971 a écrit :

sudo /etc/init.d/networking restart me donne command not found

pas normal cela vérifie la syntaxe????

Essaye wicd, il ne faut laisser que

auto lo
iface lo inet loopback

dans le fichier des interfaces

#13 Le 25/02/2008, à 00:59

toutafai

Re : [résolu]Connecté au wifi mais pas à internet

aynt pris ce post en cors, et de plus l'ayant lu en diagonale.

je parlais sous gusty quand on a 2 interface réseau configuré sur le meme réseau, il suffit de se faire un script pour activer l'une ou l'autre interface


Tombé dans l'informatique étant petit, j'en ai fait mon métier. Utilisateur d'Ubuntu depuis novembre 2006, actuellement sous 20.04 x64 (Que d'évolution
depuis Dapper Drake ! Ça rajeunit pas ^^^).

Hors ligne

#14 Le 25/02/2008, à 01:02

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

Ah d'accord je dois donc enlever les comentaires avant? Je vais corriger cela. Pour le networking install je suis allé vérifier dans le dossier il n'existe effectivement pas... je trouve juste un networking. Une possible mauvaise manip?


Bidouilleur mais pas sans peurs

Hors ligne

#15 Le 25/02/2008, à 01:04

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

que donne

ls /etc/init.d/ | grep networking

#16 Le 25/02/2008, à 01:18

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

vista sous belga a écrit :

puis

sudo ifdown eth1
sudo ifdown ath1
sudo ifup ath1

cette fois ci cela a l'air d'avoir fonctionné. j'ai pu down ath1 puis le upper par la suite sans message d'erreur. Je suis allé dans nm-applet et tous les paramètres ont l'air d'être OK pour la connexion sans fil. Par contre je ne capte toujours pas le réseau, il faut sans doute que je remette la livebox en association.

ls /etc/init.d | grep networking me donne networking

et en effet je n'ai pas de networking restart dans ce répertoire (je suis allé voir par l'interface graphique) S'il est nécessaire donne moi sa composition je créerai un fichier texte, je lui mettrai un suffixe sh, je cocherai "autoriser l'exécution du fichier comme un programme" dans propriété puis je ferai un sudo mv networking restart /etc/init.d/


Bidouilleur mais pas sans peurs

Hors ligne

#17 Le 25/02/2008, à 01:23

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

ls /etc/init.d | grep networking me donne networking

bon ok, il y est.

/etc/init.d/networking est une commande qui accepte
des options au même titre que mount, cp, mv, etc....


A ta place je passerai par wicd qui gère les ipfixes

#18 Le 25/02/2008, à 01:34

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

le problème est que je n'ai pas le cd d'ubuntu car j'ai reçu l'ordinateur avec Linux déjà installé (cadeau du conseil régional pour étudiants en classe préparatoire). Or dans le tuto de wicd il explique que si l'appli ne fonctionne pas il faut le cd pour réinstaller network manager... Je suis donc sans filet.

Ofait le sudo /etc/init.d/networking restart a l'air d'avoir fonctionné. Il m'a donné un rassurant * Reconfiguring networking interfaces...

Ta méthode était donc bonne c'est moi qui l'ai mal suivi, dsl... Mais toujours pas de Livebox en vue...


Bidouilleur mais pas sans peurs

Hors ligne

#19 Le 25/02/2008, à 01:40

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

J'ai l'impression qu'on ne se comprend pas.
Network-manager ne gère pas les IP fixe or tu
es en IP fixe.

Si tu veux passer par netw-manager:


Dans la page de config de la box,
place le en dhcp et non en ip fixe
puis
ne laisse que ceci pour le fichier des inetrfaces
auto lo
iface lo inet loopback

puis clique gauche sur les deux tv en haut à droite

#20 Le 25/02/2008, à 01:45

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

Mais dans ce cas a quoi a servi la modification deu fichier interfaces si le problème vient simplement de la box? Je croyais que c'était pour contourner le pb de gestion des IP fixes


Bidouilleur mais pas sans peurs

Hors ligne

#21 Le 25/02/2008, à 01:49

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

Arkos971 a écrit :

Mais dans ce cas a quoi a servi la modification deu fichier interfaces si le problème vient simplement de la box? Je croyais que c'était pour contourner le pb de gestion des IP fixes

lorsqu'on édite le fichier des interfaces on utilise plus d'outils
graphiques pour la connexion (ni wicd ni network-manager).

Ton problème je pense que c'est l'IP fixe. Passe en dhcp pour voir.

#22 Le 25/02/2008, à 02:06

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

OK maintenant je comprends. Le seul problème est que ça risque de modifier les configurations des autres ordis enregistrés sur la box non? Est-ce que, pour finir ce post, tu pourrais me dire ce que je peux faire en cas de plantage de wicd? Je pense à une image du CD Gutsy Gibbon par exemple. Et lorsque je passe à wicd je dois remodifier le fichier interface? Merci pour tout


Bidouilleur mais pas sans peurs

Hors ligne

#23 Le 25/02/2008, à 02:09

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

up: J'ai un nouveau problème: le DHCP est activé sur ma livebox, le prob ne vient donc pas de la....


Bidouilleur mais pas sans peurs

Hors ligne

#24 Le 25/02/2008, à 02:12

vista sous belga

Re : [résolu]Connecté au wifi mais pas à internet

Fais ceci alors

Pour une connexion avec l'applet Network-manager

modif du fichier interfaces

echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces

et connecte toi avec network-manager (2 tv en haut a droite à coté de l'heure)!

Ca donnes ça N-M
http://wlety.free.fr/images/N-M.gif

tu n'as pas besoin de faire une image ou autre
il suffit de réinstaller network-manager via les paquets .deb.
donne le retour de
uname -rm

#25 Le 25/02/2008, à 02:28

Arkos971

Re : [résolu]Connecté au wifi mais pas à internet

uname -rm me donne 2.6.22-14-generic i686

Et au fait... CA MARCHE!!!! Youpi! Alors vu que le fichier interface n'est pas le meme qu'avant ce tuto je déduis des modifications apportées que c'est le fait d'avoir mon ethernet sur la meme interface qui bloquait ma carte wifi, comme le disait toutafai...non? Et tu aurais une idée de ce que peux être le script dont il parlait?

Et encore merci


Bidouilleur mais pas sans peurs

Hors ligne