Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/04/2014, à 16:48

ytreza

[Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonjour !
Je possède un Dell XPS L702X avec une carte réseau Intel Centrino Wireless-N 1030. Je rencontre de gros problèmes avec le Wi-Fi sous Ubuntu 14.04 64bits (installation toute fraîche d'hier soir), que je ne rencontrais pas sous Ubuntu 12.04.
En effet, le Wi-Fi se déconnecte de façon intempestive et aléatoire. Parfois il tient 5 minutes, parfois 10 secondes... Bref, c'est insupportable. Ce problème est présent sur plusieurs réseaux Wi-Fi (testé sur une Livebox Orange à la maison et un AP TP-Link au travail) , j'en déduis donc que c'est ma machine qui ne fonctionne pas bien.
N'ayant trouvé aucun secours auprès de mon ami Google, je me tourne vers vous pour m'aider à découvrir et corriger le problème.
Merci d'avance smile

Quelques infos utiles récupérées grâce au script de Cracolinux (Merci !) :

>>    cat /etc/lsb-release 

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04 LTS"

>>    lsusb 

Bus 002 Device 004: ID 8086:0189 Intel Corp. 
Bus 002 Device 003: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0408:2fb1 Quanta Computer, Inc. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

>>    lspci -k -nn | grep -A 3 -i net 

03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34)
	Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN [8086:5325]
	Kernel driver in use: iwlwifi
04:00.0 USB controller [0c03]: NEC Corporation uPD720200 USB 3.0 Host Controller [1033:0194] (rev 04)
--
0a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
	Subsystem: Dell Device [1028:04b8]
	Kernel driver in use: r8169

>>    sudo lshw -C network 

  *-network
       description: Interface réseau sans fil
       produit: Centrino Wireless-N 1030 [Rainbow Peak]
       fabriquant: Intel Corporation
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       nom logique: wlan0
       version: 34
       numéro de série: xxxx
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-24-generic firmware=18.168.6.1 ip=192.168.1.13 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       ressources: irq:52 mémoire:f3b00000-f3b01fff
  *-network
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:0a:00.0
       nom logique: eth0
       version: 06
       numéro de série: xxxx
       taille: 10Mbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       ressources: irq:49 portE/S:2000(taille=256) mémoire:f3004000-f3004fff mémoire:f3000000-f3003fff

>>    lsmod 

Module                  Size  Used by
ctr                    13049  1 
ccm                    17773  1 
rfcomm                 69160  8 
bnep                   19624  2 
snd_hda_codec_hdmi     46207  1 
snd_hda_codec_realtek    61438  1 
uvcvideo               80885  0 
videobuf2_vmalloc      13216  1 uvcvideo
videobuf2_memops       13362  1 videobuf2_vmalloc
videobuf2_core         40664  1 uvcvideo
joydev                 17381  0 
videodev              134688  2 uvcvideo,videobuf2_core
intel_rapl             18773  0 
x86_pkg_temp_thermal    14205  0 
intel_powerclamp       14705  0 
coretemp               13435  0 
kvm_intel             143060  0 
kvm                   451511  1 kvm_intel
crct10dif_pclmul       14289  0 
crc32_pclmul           13113  0 
ghash_clmulni_intel    13259  0 
dell_laptop            18168  0 
dcdbas                 14928  1 dell_laptop
aesni_intel            55624  2 
arc4                   12608  2 
aes_x86_64             17131  1 aesni_intel
lrw                    13286  1 aesni_intel
gf128mul               14951  1 lrw
glue_helper            13990  1 aesni_intel
ablk_helper            13597  1 aesni_intel
cryptd                 20359  3 ghash_clmulni_intel,aesni_intel,ablk_helper
psmouse               102222  0 
iwldvm                232285  0 
serio_raw              13462  0 
mac80211              626489  1 iwldvm
snd_hda_intel          52355  3 
snd_hda_codec         192906  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm               102099  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  1 snd_seq_midi
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
dell_wmi               12761  0 
snd_timer              29482  2 snd_pcm,snd_seq
sparse_keymap          13948  1 dell_wmi
parport_pc             32701  0 
btusb                  32412  0 
bluetooth             395423  22 bnep,btusb,rfcomm
nouveau              1097199  1 
i915                  783485  3 
snd                    69238  17 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi
ppdev                  17671  0 
lpc_ich                21080  0 
iwlwifi               169932  1 iwldvm
lp                     17759  0 
parport                42348  3 lp,ppdev,parport_pc
cfg80211              484040  3 iwlwifi,mac80211,iwldvm
mxm_wmi                13021  1 nouveau
ttm                    85115  1 nouveau
drm_kms_helper         52758  2 i915,nouveau
drm                   302817  7 ttm,i915,drm_kms_helper,nouveau
mei_me                 18627  0 
soundcore              12680  1 snd
mei                    82274  1 mei_me
i2c_algo_bit           13413  2 i915,nouveau
wmi                    19177  3 dell_wmi,mxm_wmi,nouveau
video                  19476  2 i915,nouveau
mac_hid                13205  0 
hid_generic            12548  0 
usbhid                 52616  0 
hid                   106148  2 hid_generic,usbhid
ahci                   25819  4 
r8169                  67581  0 
libahci                32168  1 ahci
mii                    13934  1 r8169
>>    iwconfig 

wlan0     IEEE 802.11bgn  ESSID:"xxxx"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: xxxx 
          Bit Rate=65 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:101   Missed beacon:0


>>    ifconfig -a 

eth0      Link encap:Ethernet  HWaddr xxxx
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:585 erreurs:0 :0 overruns:0 frame:0
          TX packets:585 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:52297 (52.2 KB) Octets transmis:52297 (52.2 KB)

wlan0     Link encap:Ethernet  HWaddr xxxx
          inet adr:192.168.1.13  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::ae72:89ff:fefa:24b8/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:3043 erreurs:0 :0 overruns:0 frame:0
          TX packets:3221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:2109854 (2.1 MB) Octets transmis:475696 (475.6 KB)

>>    uname -r -m 

3.13.0-24-generic x86_64

>>    cat /etc/network/interfaces 

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

>>    nm-tool 


NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        xxxx

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0  [xxxx] ------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        xxxx

  Capabilities:
    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  IPv4 Settings:
    Address:         192.168.1.13
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1



>>    sudo rfkill list 

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Dernière modification par ytreza (Le 01/05/2014, à 18:37)

Hors ligne

#2 Le 18/04/2014, à 20:57

toutafai

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonsoir,

va dans l'interfaces d'administration de t alive box et change le chiffrement/cryptage pour soit que du wpa1 TKIP, soit que du WPA2 AES, enregistrer les modification et rebooter la box. Coté ubuntu déconnecté du reseau wifi via Network manager, puis une fois la box rebooté et prete, se re connecter.

Cela devrait etre plus stable


Ubuntu Server 14.04 x32 sur IBM ThinkCentre. - XP 32/ Seven ultimate 64 / Ubuntu 14.04 x64 sur Lenovo ThinkPad et sur HP EliteBook. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#3 Le 18/04/2014, à 23:52

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonsoir Toutafai !
Merci pour ta réponse smile
Je viens de tester ta solution, malheureusement, cela ne corrige pas mon problème, même si j'ai l'impression que les coupures sont un peu plus espacées qu'avant. J'ai remarqué que les coupures se faisaient le plus souvent lors de "gros" téléchargements. Par gros, je veux dire tout ce qui dépasse 1 Mo. D'autres idées ?

Hors ligne

#4 Le 19/04/2014, à 11:28

toutafai

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

redonne a nouveau le retour de

sudo iwlist scan

tu peux aussi essaye cela :

sudo gedit /etc/modprobe.d/iwlwifi.conf

une page blanche s'ouvre dedans tu met cette ligne

options iwlagn 11n_disable=1

enregistre, reboot et test si c'est mieux


Ubuntu Server 14.04 x32 sur IBM ThinkCentre. - XP 32/ Seven ultimate 64 / Ubuntu 14.04 x64 sur Lenovo ThinkPad et sur HP EliteBook. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#5 Le 20/04/2014, à 13:37

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonjour !
Désolé de répondre si tard, j'étais occupé toute la journée ^^.
Alors voici le retour de iwlist scan :

$ sudo iwlist scan
eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: xxxx
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=63/70  Signal level=-47 dBm  
                    Encryption key:on
                    ESSID:"xxxx"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000001f57fc6f7c
                    Extra: Last beacon: 0ms ago
                    IE: Unknown: 000C4C697665626F782D44453830
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 03010B
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101870003A4000027A4000042435E0062322F00
                    IE: Unknown: 2D1A4C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B080800000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010000000000
                    IE: Unknown: 0706465220010D14
                    IE: Unknown: DD920050F204104A0001101044000102103B00010310470010000000000000100000004C09B40CDE80102100035A54451023000F4C697665626F7820465454482076321024001A6164363833365F4144534C5F5048595F30783030303030303030104200074C4D5A313230361054000800060050F20400011011000D465446525341332E3639313632100800020086103C000101
          Cell 02 - Address: xxxx
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=29/70  Signal level=-81 dBm  
                    Encryption key:on
                    ESSID:"xxxx"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000006e58abce51
                    Extra: Last beacon: 0ms ago
                    IE: Unknown: 00094E4555465F45383134
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD840050F204104A00011010440001021041000100103B00010310470010D96C7EFC2F8938F1EFBD6E5148BFA812102100044E4555461023000A4E42342D4658432D72311024000A4E42342D4658432D72311042000C3030313733333541453831341054000800060050F2040001101100094E4555465F45383134100800020084103C000101
                    IE: Unknown: DD090010180202F02C0000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00

Par contre, quand j'édite le fichier /etc/modprobe.d/iwlwifi.conf, le fichier n'est pas vide, il contient déjà :

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Et je précise bien que les 3 dernières lignes ne sont pas en commentaire, ce n'est pas une faute de frappe ^^.

J'ai malgré tout ajouté l'option pour désactiver la norme n à la fin du fichier. Je vais rebooter, et advienne que pourra tongue

Dernière modification par ytreza (Le 01/05/2014, à 18:38)

Hors ligne

#6 Le 20/04/2014, à 14:23

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Les coupures son toujours là sad

Hors ligne

#7 Le 23/04/2014, à 09:52

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Personne ne peut m'aider ?

Hors ligne

#8 Le 24/04/2014, à 19:36

toutafai

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonsoir,

désolé pour le délais de réponse, je suis débordé en ce moment...

si tu as toujours la ligne que je t'ai fait ajouté et dans laquelle il y avait une erreur (désolé) supprime la. oui, c'est normal que le fichier ne soit plus vide, c'est une nouveauté depuis la 13.10 (la aussi désolé, etant resté sagement en 12.04, je l'ignorais). la seul autre solution que j'ai c'est de passer par ndiswrapper (voit la doc, c'est assez facile a installer)


Ubuntu Server 14.04 x32 sur IBM ThinkCentre. - XP 32/ Seven ultimate 64 / Ubuntu 14.04 x64 sur Lenovo ThinkPad et sur HP EliteBook. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#9 Le 28/04/2014, à 00:15

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonsoir !
Merci encore Toutafai !
J'ai passé ma journée à bidouiller dans l'espoir vain de corriger ce problème. J'ai tenté d'installer ndiswrapper. J'ai trouvé le fichier .inf du pilote windows, j'ai suivi à la lettre les infos de la doc, sans succès. Le pilote est bien reconnu par ndiswrapper, l'installation se passe bien, il reconnaît même le matériel qu'il prend en charge correctement. Malheureusement impossible de faire apparaître le wlan0 tant désiré.
En désespoir de cause, j'ai ouvert un thread sur le forum anglophone d'Ubuntu et j'attends impatiemment qu'on m'aide à nouveau.

Hors ligne

#10 Le 28/04/2014, à 12:58

toutafai

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

bonjour,

Oki, j'ai lu la réponse qu'on t'a fait sur les forum anglophone, oups, oui, la gestion de la desactivation du mode N a changé..fait comme il te dise sur le forum anglophone. si cela ne fonctionne toujours pas, on revient sur ndiswrapper et on check l'installation :

retour de

cd \laousontlesdriverswindows #remplace par le bon chemin && ls -la
sudo nidswrapper -l #c'est un petit L
lsmod
cat /etc/modules
cat /etc/modprobe.d/blacklist.conf
sudo lshw -C network

Ubuntu Server 14.04 x32 sur IBM ThinkCentre. - XP 32/ Seven ultimate 64 / Ubuntu 14.04 x64 sur Lenovo ThinkPad et sur HP EliteBook. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#11 Le 01/05/2014, à 18:32

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonjour !
Merci Toutafai !
J'ai enfin résolu le problème à l'aide de Varunendra sur le forum anglophone. Tu étais très proche de la solution, il fallait finalement remplacer le contenu du fichier (et pas ajouter à la fin comme je l'ai fait). Et il fallait aussi modifier un paramètre concernant l'utilisation simultanée du Wifi et du Bluetooth dans mon cas. Voici la manipulation exacte que j’ai utilisée :

echo "options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

A priori, le paramètre "swcrypto" ne semble avoir aucune incidence sur ma connexion, mais je le laisse par simple précaution.
Le détails des options est expliqué très clairement ici (en anglais) : http://ubuntuforums.org/showpost.php?p=12943350

Pour ce qui est de l'utilisation de Ndiswrapper, plusieurs personnes m'ont affirmé que mon échec était normal, car a priori, il ne serait pas adapté à ce type de matériel.

Merci encore pour toute ton aide ! smile

Hors ligne

#12 Le 01/05/2014, à 19:26

toutafai

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

oki, bravo a toi et merci pour le retour d'info


Ubuntu Server 14.04 x32 sur IBM ThinkCentre. - XP 32/ Seven ultimate 64 / Ubuntu 14.04 x64 sur Lenovo ThinkPad et sur HP EliteBook. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#13 Le 06/08/2014, à 14:19

Marqui

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Salut à vous !

Je viens d'installer Ubuntu 14 et j'ai exactement le même problème. Je suis allé sur le site, http://ubuntuforums.org/showpost.php?p=12943350. Mon anglais est suffisant mais je ne comprends absolument pas les commandes à utiliser et j'ai peur de tout foirer. Est-ce-que vous seriez assez sympas pour faire une récap en français, point par point, de la manip à utiliser pour régler ce problème. J'imagine que je ne suis pas le seul à être intéressé par une telle aide.

D'avance, merci pour votre effort.

Marqui

Dernière modification par Marqui (Le 06/08/2014, à 14:21)

Hors ligne

#14 Le 06/08/2014, à 21:19

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonsoir !
Je suis en train de traduire l'article dans la limite de mes connaissances ^^

Dernière modification par ytreza (Le 06/08/2014, à 21:21)

Hors ligne

#15 Le 06/08/2014, à 22:09

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Post de Varunendra

varunendra a écrit :

I thought you already knew the secret, since the "11n_disable=1" option seems to be already applied permanently. But probably you applied it following some post without understanding what it actually did and/or how.

So here's the long awaited Secret!

You simply create a .conf file in your /etc/modprobe.d directory, and put a line in it whose syntax should be exactly this -

options [driver's name] [parameter 1] [parameter2] .... [last parameter]

The name of the file doesn't matter, but its extension name should always be ".conf". Currently even that is not mandatory but in future releases it will be. And just for consistency, we always prefer to name the file same as the driver which it is for.

Now considering the above rules/conventions, here are the exact lines that can be placed in two .conf files to make the parameters permanent -

options iwlmvm power_scheme=1
options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1

You can simply use your text editor to create two new files (or edit existing one, as there seems to be one), but make sure to open the text editor with root access (e.g. "gksu gedit <file name>") to be able to write/edit file in /etc/modprobe.d directory.

We prefer the command line instead of GUI text editor, since commands are quick and universal. So here's my preferred way -

echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf
echo "options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

From your previous outputs, it seems you already have a file, most probably named "iwlwifi.conf", in you /etc/modprobe.d directory to enforce the 11n_disable parameter. If its name is indeed "iwlwifi.conf", it will be overwritten with the second command above which is perfectly okay. If it has a different name, you should manually delete it or use the same name in the second command above to overwrite it.


That being explained, I would strongly recommend (not necessary though, as long as everything is working nicely) to experiment with individual parameters and not use all of them at once. This will help determining which one(s) is/are helping and make only those permanent.

My personal understanding/assumption/interpretation of what each one we used does, to help you decide whether or not to do the experiments -

power_scheme=1 : Applicable to the "iwlmvm" driver; sets the power management scheme to "1", which is for "active" scheme as per its modinfo. The other two possible values are 2 (balanced) and 3 (low power). 2 was the default, we changed it to 1 (active).

bt_coex_active=N : Applicable to the "iwlwifi" driver; disables a 'Feature' that allows co-existence of bluetooth and wifi signals. The bluetooth signals operate within the same frequency range as wifi (2.4 GHz), and so may cause mutual interference when both are used simultaneously. This technology (bt-coexistence) modifies the transmission/reception of wifi in such a way that is supposed to avoid this kind of interference. Unfortunately, it doesn't always work as expected and sometimes causes more trouble than helping anything. In such cases, turning it off with above parameter helps.

swcrypto=1 : Applicable to the "iwlwifi" driver; shifts the task of packet encryption from hardware (wireless chip) to software (driver/OS). Helps when the hardware encryption can't keep up with the packet encryption for some reason (too fast traffic, inefficient encryption algorithm etc.).

11n_disable=1 : Applicable to the "iwlwifi" driver; disables N-channel, which means trading speed for stability by limiting yourself to g-speeds (54 Mbps max).

You can check the available parameters with any driver by using the "modinfo" command. For example, "modinfo iwlwifi".

To see ONLY the available parameters, not the other details : "modinfo -p iwlwifi" (btw, it loses formatting too, so the above one is better)

If you do the experiments, please let us know which one(s) help and which ones don't. Happy tweaking !

Traduit dans la limite de mes capacités (je suis pas traducteur pro hein, ni même bilingue tongue) :

Contexte :

Radek_Johanna a ouvert un thread sur Ubuntu Forums. Il rencontrait des problèmes de Wi-fi (gel de la connexion Wi-fi après 5-6 minutes de fonctionnement). Après voir essayé beaucoup de solutions à l'aveugle au gré des forums, Varunendra lui apporte son aide. Il dépose ce message pour expliquer comment créer des fichiers de configuration des drivers, et quels paramètres utiliser dans ces fichiers :

varunendra (traduit) a écrit :

Je pensais que tu connaissais le secret, vu que l'option "11n_disable=1" semble être déjà appliquée de façon permanente [dans ta configuration]. Mais tu l'as probablement appliquée en suivant un post sans comprendre ce qu'elle fait et/ou comment elle le fait.

Donc voici le secret tant attendu !

Créé simplement un fichier .conf dans ton répertoire /etc/modprobe.d, et mets-y une ligne dont la syntaxe est exactement celle-ci :

options [nom du driver] [paramètre 1] [paramètre 2] .... [dernier paramètre]

Le nom du fichier importe peu, mais l'extension du fichier doit toujours être ".conf". Actuellement, même ça ce n'est pas obligatoire, mais dans les versions futures ce le sera. Et juste pour la cohérence, nous préférons toujours donner au fichier le même nom que le pilote auquel il est dédié.

En considérant maintenant les règles/conventions ci-dessus, voici les lignes exactes qui peuvent être placées dans deux fichiers .conf pour rendre la configuration permanente :

options iwlmvm power_scheme=1
options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1

Tu peux simplement utiliser ton éditeur de texte pour créer deux nouveaux fichiers (ou éditer un fichier existant, comme il semble y en avoir un), mais assure-toi de bien ouvrir l'éditeur de texte avec les droits root (par exemple "gksu gedit <nom du fichier>")  pour pouvoir écrire/modifier le fichier dans le répertoire /etc/modprobe.d .

Je préfère la méthode en ligne de commande à l'interface graphique. En effet la ligne de commande est rapide et universelle.

echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf
echo "options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

En regardant tes retours de commande précédents, il semble que tu aies déjà un fichier, probablement nommé "iwlwifi.conf", dans ton répertoire /etc/modprobe.d pour forcer le paramètre 11n_disable. Si son nom est en effet "iwlwifi.conf", il sera écrasé par la seconde commande ci-dessus, ce qui serait parfait. S'il a un nom différent, tu dois le supprimer manuellement ou alors utiliser le même nom dans la seconde commande ci-dessus de façon a l'écraser.


Ceci étant expliqué, Je te recommande vivement (pas nécessairement, du moment que ça marche correctement) d’essayer avec diffèrents paramètres et de ne pas les utiliser en même temps. Cela permettra de déterminer lesquels sont utiles et de rendre uniquement ces paramètres permanents.

Voici ma connaissance/ma supposition/mon interprétation de chacun de ceux que nous avons utilisé, pour t'aider à choisir si oui ou non tu dois les tester :

power_scheme=1 : Applicable au driver "iwlmvm"; Définit le mode de gestion de l'alimentation à "1", qui correspond au mode "actif" de modinfo. Les deux autres valeurs possibles sont 2 (équilibré) et 3 (économie d'énergie). Le mode par défaut était 2, nous l'avons redéfinit à 1 (actif).

bt_coex_active=N : Applicable au driver "iwlwifi"; Désactive une "fonctionnalité" qui permet la coexistence des signaux Bluetooth et Wi-fi.
Les signaux Bluetooth utilisent la même gamme de fréquences que le Wi-fi (2.4GHZ), et donc il peut y avoir interférence mutuelle lorsque les deux sont utilisés simultanément. Cette technologie (bt-coexistence) modifie la transmision/réception du Wi-fi d'une façon qui est supposée empêcher ce genre d'interférences. Malheureusement, ça ne fonctionne pas toujours comme prévu et parfois ça cause plus de problèmes qu'autre chose. Dans ce cas, désactiver cette fonctionnalité avec ce paramètre peut être utile.

swcrypto=1 : Applicable au driver "iwlwifi"; bascule le mode de chiffrement des paquets de chiffrement matériel (wireless chip) à chiffrement logiciel (driver/OS). Utile quand le chiffrement matériel ne peut pas suivre le chiffrement des paquets pour une raison quelconque (trafique trop rapide, algorithme de cryptage inefficace, etc.).

11n_disable=1 : Applicable au driver "iwlwifi"; Désactive la norme Wi-fi N, Ce qui signifie sacrifier de la rapidité en échange de stabilité en se limitant sois-même à la vitesse de la norme G (54 Mbps max.)

Tu peux consulter la liste des paramètres disponibles avec n'importe quel driver en utilisant la commande "modinfo". Par exemple,  "modinfo iwlwifi".

Pour voir UNIQUEMENT  les paramètres disponibles, pas les autres détails : "modinfo -p iwlwifi" (mais la commande perd son formatage, par conséquent la commande précédente est meilleure)

Si tu fais les tests, s'il te plais dis nous lesquels aident et lesquels n'aident pas. Joyeux fignolage  !

Voili, voilou !
N'hésitez pas à me faire part de vos remarques concernant ma traduction. C'est la première fois que je traduis du texte, alors désolé si je suis mauvais big_smile

Dernière modification par ytreza (Le 06/08/2014, à 23:09)

Hors ligne

#16 Le 06/08/2014, à 22:27

tuxmarc

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

@ytreza : je n'aurais pas fait mieux smile
Bravo !!!!!!!!


Vive Richard Stalmann, Linus Torvalds, et tous les fondus de Linux.
De l'Ordinosaure fait à 90% de récup, à un portable LDLC, une tour, neufs sans système,un serveur et une carte mère sans boitier, tous libres !!
Parrain Linux sur www.parrain-linux.com et www.parrains.linux.free.fr

Hors ligne

#17 Le 06/08/2014, à 23:28

ytreza

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Merci Tuxmarc smile
Donc, maintenant que l'article est traduit (ça me démangeait, on manque cruellement de doc sur le sujet en français) la version courte pour Marqui :

Si ton PC souffre vraiment de ce problème, et dispose vraiment d'une des cartes réseau incriminées, et que tu es sous Ubuntu 14.04 copie-colle ça dans un terminal :

cp -r /etc/modprobe.d ~/modprob.d_sauvegarde #créer une copie de sauvegarde de la configuration
echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf
echo "options iwlwifi bt_coex_active=N swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

Redémarre ton PC et donne nous des nouvelles sur ta situation (si tu as encore accès à Internet roll), prévois au moins un câble Ethernet, on est jamais à l’abri d'une mauvaise surprise. big_smile

Hors ligne

#18 Le 07/08/2014, à 19:22

Marqui

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Grand merci pour ta réponse; Je fais un essai demain et je fais un CR.

Marqui

Hors ligne

#19 Le 08/08/2014, à 18:11

Marqui

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Salut à vous tous,

je viens de faire les manips préconisées par Ytreza. Pour l'instant ça fonctionne, mais je ne n'ai pas assez de recul pour dire que le prob est réglé. J'attends qques jours et je fais une réponse plus précise.

Merci encore.

Marqui

Hors ligne

#20 Le 14/08/2014, à 23:44

Marqui

Re : [Résolu] Wifi instable Ubuntu 14.04 Intel Wireless-N 1030

Bonjour, une semaine de fonctionnement et pour l'instant ça à l'air de fonctionner.

Merci encore

Hors ligne