Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/06/2015, à 15:44

AzhEv

[Résolu]Emergency mode

Bonjour à tous,

Hier soir j'ai décidé de résoudre un probléme que j'avais depuis un moment, je n'avais pas les droit d'écriture sur mon disque dur NTFS, j'ai instalé ntfs-config et j'ai réglé le probléme comme c'est indiqué dans la doc ici: http://doc.ubuntu-fr.org/tutoriel/ntfs

De plus j'ai fait qq mise à jour.

Ce matin, quand j'allume mon pc il me dis que je suis en emergency mode, je peut taper "jounalctl -xb" pour voir les log, sinon je peut redémarrer.

Ma parition linux est en 15.04, j'ai une parition windows 10, deux disque dur internet et un externe.

J'ai essayé de démarrer sur un live cd mais il me demande de démarrer sous windows et de taper "dskchk /r" pour réparer le disque et ensuite de relancer le live cd, je l'ai fait, mais il me remet le même message avec la même commande.

J'ai accés au mode recovery.

De plus, j'ai essayé de démarrer en débranchant mes disque dur de données, ca ne change rien au probléme.

Une idée?

Merci d'avance

Dernière modification par AzhEv (Le 21/06/2015, à 17:49)

Hors ligne

#2 Le 21/06/2015, à 17:07

malbo

Re : [Résolu]Emergency mode

Ce post de naroyce ressemble un peu à ton cas : http://ubuntuforums.org/showthread.php? … st13281247
On y voit qu'il avait des lignes de son fichier fstab qui étaient la cause de son passage en "emergency-mode". Du coup, comme tu dis que tu as utilisé ntfs-config et que ce dernier modifie le fichier fstab, j'imagine que certaines de ces lignes posent problème et que c'est ça qui te fait passer en "emergency-mode".
Je te prie de faire un Boot-Info depuis une session live de Ubuntu et de poster l'URL de ce Boot-Info dans ta réponse.

Dernière modification par malbo (Le 21/06/2015, à 17:09)

Hors ligne

#3 Le 21/06/2015, à 17:49

AzhEv

Re : [Résolu]Emergency mode

Bonjour,

Je vient de me rappeler que avant d'utiliser ntfs-config, j'avais suivi un tuto ou me demandais de modifié etc/fstab. J'avais fait un backup, j'ai remit l'ancien fstab et tout fonctionne comme avant. Merci beaucoup pour ton aide.

Hors ligne

#4 Le 22/06/2015, à 10:49

malbo

Re : [Résolu]Emergency mode

J'ai investigué un peu sur "Emergency mode" et je profite de cette discussion pour indiquer ce que j'ai trouvé. J'ai utilisé ntfs-config dans une installation où il y a Ubuntu 15.04 en dual-boot avec Windows 8. J'ai laissé faire ntfs-config qui m'a monté toutes les partitions NTFS en lecture et écriture au démarrage de l'ordi(*). Exprès, j'ai ouvert une session Windows 8 et je l'ai quitté par "Arrêter" afin de provoquer le passage en hibernation de la partition système de Windows 8 (c'est la fonctionnalité "démarrage rapide" de Win8), puis j'ai démarré l'ordi sur Ubuntu 15.04. Résultat : 

Welcome to emergency mode! After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to
try again to boot into default mode.

Pas la peine de s'emmerder à essayer de dépanner ça depuis la console (moi je ne sais pas faire en tout cas) : la bonne option, c'est de rebooter (taper "systemctl reboot" et valider par la touche Entrée) et l'ordi va redémarrer.
J'indique la solution : redémarrer l'ordi sur Windows 8 et quitter Windows 8 par "Redémarrer" (et non pas par "Arrêter" comme j'avais fait précédemment). Comme Win8 ne sera pas en hibernation, il n'y aura plus de souci au prochain démarrage sous Ubuntu.

(*) on n'est absolument pas obligé de laisser faire ntfs-config et moi je recommande de ne pas le laisser monter la partition système de Windows 8 au démarrage. Seulement le pékin de base qui utilise ntfs-config a déjà beaucoup de mal à comprendre ce qui se passe et en général, il laisse faire. C'est la raison pour laquelle j'ai pris cette option. j'ai rayé ça parce que le problème ne se pose pas seulement avec la partition système : toutes les partitions NTFS sont mises en hibernation quand la fonctionnalité "démarrage rapide" de Windows 8 est activée

EDIT 1 : pour le passant curieux, je signale que le souci qui a affecté AzhEv dans la présente discussion ainsi que le souci que je viens d'exposer n'existent pas avec les versions précédant 15.04 : dans ces versions, c'était upstart qui était à la manœuvre et lorsqu'une partition ne pouvait pas être montée, ça se passait beaucoup mieux à mon avis (un message sur l'écran "Continuer à attendre ou appuyer sur S pour ignorer le montage ou M pour la récupération manuelle" et même le plus benêt de la bande appuyait sur S et ça démarrait sans le montage qui bloquait). A présent, c'est systemd qui est utilisé avec la version 15.04 et c'est lui qui nous envoie en "emergency mode" dès qu'il y a un montage prévu au fstab qui ne peut pas se faire. Moi ça me parait souple comme un barreau de chaise ce systemd et son "emergency mode" de la mort qui tue mais c'est probablement parce que je ne connais pas la bonne façon de sortir de l'ornière.

EDIT 2 : quand on se retrouve dans l' "emergency mode", on peut trouver l'info en consultant le journal (log system ) comme c'est proposé mais il est assez intéressant de passer la commande suivante :

systemctl --failed

 
Chez moi, elle m'a retourné une ligne qui contenait "failed" et dont la description indiquait le point de montage qui posait problème (/media/OS_WIN). Au lieu de se peler tout le journal, on va directement à l'info.

EDIT 3 : astuce trouvée pour exporter en .txt le fichier log. Depuis "emergency mode", passer la commande suivante :

journalctl > journal.txt

Puis rebooter l'ordi sur une session live de Ubuntu (pas forcément une version 15.04) pour lire ce fichier. On peut monter la partition racine du Ubuntu malade avec le gestionnaire de disques, puis lancer nautilus avec pouvoir administrateur par la commande : "sudo nautilus". Le fichier journal.txt se trouve dans /media/ubuntu/point_de_montage_partition_racine/root
Il y a un bémol parce que la mise en forme n'est pas la même que ce qu'on voit quand on passe la commande "journalctl -xb" en emergency mode. Toutefois, une petite recherche sur "failed" dans le fichier .txt permet de trouver rapidement ce qui ne va pas.

EDIT 4 (le 23 juin 2015) : il est possible d'éviter le passage en " emergency mode " en ajoutant l'option nobootwait dans chacune des lignes de montage d'une partition NTFS du fichier fstab. Par exemple, pour la ligne de montage de ma partition système de Windows 8 dans le fstab :
Avant modif (passage en emergency mode au démarrage) :

UUID=8616053E160530AB	/media/OS_WIN	ntfs-3g	defaults,locale=fr_FR.UTF-8	0	0

Après modif (démarrage sans souci mais évidemment la partition n'est pas montée si elle est en hibernation) :

UUID=8616053E160530AB	/media/OS_WIN	ntfs-3g	defaults,locale=fr_FR.UTF-8,nobootwait	0	0

Dans le fichier /var/log/syslog, je trouve bien la mention "Failed to mount /media/OS_WIN" dans le cas où la partition n'a pas pu être montée parce qu'elle est en hibernation.

Dernière modification par malbo (Le 23/06/2015, à 10:14)

Hors ligne

#5 Le 23/06/2015, à 04:23

AzhEv

Re : [Résolu]Emergency mode

Merci pour tes explmications, le probléme avec windows 8 peut être réglé en désactivant le mode hiberantion directemetn dans windows 8. Ainsi tu peut choisir arréter ou redémarrer, dans les deux cas ubuntu bootera correctement.

Hors ligne

#6 Le 23/06/2015, à 06:22

malbo

Re : [Résolu]Emergency mode

AzhEv a écrit :

le problème avec windows 8 peut être réglé en désactivant le mode hibernation directement dans windows 8. Ainsi tu peut choisir arrêter ou redémarrer, dans les deux cas ubuntu bootera correctement.

Tu as raison : en désactivant complètement l'hibernation, on peut régler le pb. Mais ce qui est nécessaire et suffisant, c'est de désactiver le démarrage rapide de Windows 8 comme suggéré fort justement dans le paragraphe 4. Problème connu de la doc "Comment activer l'écriture sur les partitions NTFS ?"
Après ça, quand on quitte Windows 8 par "Arrêter", on n'a plus de problème de mise en hibernation des partitions NTFS.

Dernière modification par malbo (Le 23/06/2015, à 06:32)

Hors ligne

#7 Le 23/06/2015, à 06:32

Compte anonymisé

Re : [Résolu]Emergency mode

Bonjour, tiens, il m'est arrivé le même truc en modifiant (mal) le /etc/fstab, cependant, l'emergency mode m'a tout de soute connecté en root sans MDP demandé yikes .
Dangereux ça.

#8 Le 23/06/2015, à 07:17

malbo

Re : [Résolu]Emergency mode

J'ai fait un essai inspiré de celui du post #4 sur une autre installation de Ubuntu 15.04 en cohabitation avec Windows 10 Preview (hibernation activée volontairement par moi) pour voir ce que ça donnait. Dans ce cas, c'est encore plus vachard parce qu'au lieu de me retrouver avec le "Welcome to emergency mode!" et baratin associé (voir post #4), je me suis retrouvé devant un écran noir. Il a fallu que je fasse un Ctrl+Alt+F1 (résultat : apparition d'un tiret clignotant) suivi d'un Ctrl+Alt+F7 pour voir apparaître le message complet "Welcome to emergency mode!" (idem post #4) et l'invite de commande root.

Dernière modification par malbo (Le 23/06/2015, à 07:19)

Hors ligne

#9 Le 08/11/2016, à 00:40

denisgrugeon

Re : [Résolu]Emergency mode

Malbo, te remerciera-t-on un jour assez ? smile
En lisant tes notes 4 et 6, je résous deux problèmes à la fois !

Je partage mon expérience pour les amateurs (comme moi !) : j'ai rencontré cet "emergency mode" après avoir débranché des disques durs (mentionnés dans mon fstab).
Après avoir cherché longtemps et lu avec attention le post #4 ci-dessus de Malbo, j'ai "tout simplement" pu redémarrer en "Advanced options for Ubuntu" (2e élément dans Grub), puis en choisissant "upstart" sur la version la plus récente de linux.
C'est là que je me suis rendu compte que mes disques débranchés (qui ne sont pourtant que des disques de données) étaient la cause du switch en mode urgence.
Il est susceptible le pèpère Ubuntu quand même yikes)

Dernière modification par denisgrugeon (Le 08/11/2016, à 01:06)


Si vous ne pouvez expliquer un concept à un enfant de six ans, c’est que vous ne le comprenez pas complètement. – Albert Einstein

Hors ligne

#10 Le 30/01/2018, à 10:29

asroger

Re : [Résolu]Emergency mode

Bonjour! je sais que ce problème a été résolu un temps soit peu mais je doute fort qu'il réponde exactement de la même manière a mon problème. En effet j'ai installé ubuntu 17.04 ensuite j'ai effectué la mise à jour vers ubuntu 17.10. Tout était parfait jusqu'à ce que je décide d'installer Ext2 IFS sur windows en vue de partager mes données sur les 2 OS (j'ai en effet windows 7 et ubuntu 17.10 sur mon disque dur). bein!!! le problème a justement commencé à ce moment là! Quand je démarre ma machine on met quelque chose du genre you're in emergency mode... Est-ce le fait d'avoir voulu partager mon disque ou autre chose ??? je suis à votre écoute!

Hors ligne

#11 Le 30/01/2018, à 11:06

LeJediGris

Re : [Résolu]Emergency mode

asroger a écrit :

Bonjour! je sais que ce problème a été résolu un temps soit peu mais je doute fort qu'il réponde exactement de la même manière a mon problème. En effet j'ai installé ubuntu 17.04 ensuite j'ai effectué la mise à jour vers ubuntu 17.10. Tout était parfait jusqu'à ce que je décide d'installer Ext2 IFS sur windows en vue de partager mes données sur les 2 OS (j'ai en effet windows 7 et ubuntu 17.10 sur mon disque dur). bein!!! le problème a justement commencé à ce moment là! Quand je démarre ma machine on met quelque chose du genre you're in emergency mode... Est-ce le fait d'avoir voulu partager mon disque ou autre chose ??? je suis à votre écoute!

Salut,

SVP ouvre un sujet spécifique !! ce topic concerne un problème particulier et est marqué résolu, donc tu ne pourras pas avoir beau coup de réponses !!

A+


%NOINDEX%
Matos Asus Zenbook 3 Deluxe UX490
"Home Made" Monstro: core i7 2600+16Go de mémoire+SSD C300 128Go SATAIII+MoBo Asus P8P67 DeLuxe avec Mint 18.3
+ "Terminator", Pentium 4 avec velociraptor, A la niche, place au Core 2 2660 aussi sous Mint 18.3, Freebox Revolution

Hors ligne

#12 Le 30/01/2018, à 13:14

asroger

Re : [Résolu]Emergency mode

oui, en effet j'ai tout de suite compris cela!
Mais je l'explique dans quel contexte maintenant ??

Hors ligne

#13 Le 30/01/2018, à 14:01

LeJediGris

Re : [Résolu]Emergency mode

asroger a écrit :

oui, en effet j'ai tout de suite compris cela!
Mais je l'explique dans quel contexte maintenant ??

Fait un copié-collé de ton post dans un nouveau sujet !!

A+


%NOINDEX%
Matos Asus Zenbook 3 Deluxe UX490
"Home Made" Monstro: core i7 2600+16Go de mémoire+SSD C300 128Go SATAIII+MoBo Asus P8P67 DeLuxe avec Mint 18.3
+ "Terminator", Pentium 4 avec velociraptor, A la niche, place au Core 2 2660 aussi sous Mint 18.3, Freebox Revolution

Hors ligne

#14 Le 28/04/2018, à 11:19

TankG

Re : [Résolu]Emergency mode

Bonjour à touste,
Mon ordi c'est mise sur emergency mode sans qu j'ai installé de programme ou fait de mise a jour particulière.
Je suis sur ubuntu s: versions 2.02  beta2-36ubuntu3.17 (afficher lord de mon démarrage)

Voici ce que me dit l'emergency mode
"Welcome to emergency mode! After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or D to try again to boot into default mode. Press enter for maintenance (or press dontrol-D to continue) :
root@clement-E402SA: ~#

Je suis tres novice en informatique et sur ubuntu..

Merce de votre aide

Hors ligne

#15 Le 28/04/2018, à 11:33

malbo

Re : [Résolu]Emergency mode

@TankG : je te prie de créer une nouvelle discussion pour ton cas personnel. Pour ce faire, tu trouveras des indications dans le paragraphe 4.1 Initier une nouvelle discussion de l'Aide à l'utilisation du forum Ubuntu‑FR.

Hors ligne

#16 Le 28/04/2018, à 11:55

TankG

Re : [Résolu]Emergency mode

@Malbo Merci ! je viens de le faire.

Hors ligne

#17 Le 30/10/2018, à 02:32

longdivision

Re : [Résolu]Emergency mode

Malbo a écrit :

c'était upstart qui était à la manœuvre et lorsqu'une partition ne pouvait pas être montée, ça se passait beaucoup mieux à mon avis (un message sur l'écran "Continuer à attendre ou appuyer sur S pour ignorer le montage ou M pour la récupération manuelle" et même le plus benêt de la bande appuyait sur S et ça démarrait sans le montage qui bloquait)

C est vrai que ca avait le merite d'au moins envoyer un avertissement ...
desormais sous 18.04 exit le emergency  mode ou l averttissement de non montage .  Ca monte mais en mode eciture seulement .

Idealement un message du type : ''partition NTFS montée en mode lecture seule car hibernée par un autre OS'' pour les dual-bouteux novice ca eviterai bien des miseres ....

Hors ligne

#18 Le 30/10/2018, à 10:06

malbo

Re : [Résolu]Emergency mode

longdivision a écrit :

desormais sous 18.04 exit le emergency  mode ou l averttissement de non montage .  Ca monte mais en mode eciture seulement

Je pense que tu voulais écrire : "Ça monte mais en mode lecture seule"

Hors ligne