Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/08/2015, à 12:56

Myouf62

[Résolu] Passage de 14.04 LTS à 16.04 LTS

Bonjour tout le monde,

Je suis actuellement sous Ubuntu 14.04 LTS. J'aimerais savoir si en avril 2016, le gestionnaire de mises à jour m'informera automatiquement de la disponibilité d'Ubuntu 16.04 LTS et s'il sera possible de l'installer en préservant les logiciels, fichiers et préférences de mon système actuel? En gros est-ce que l'on sera obligé de faire une "clean install" en repartant de zéro ou non?

Merci de m'avoir lu.

Dernière modification par Myouf62 (Le 09/08/2015, à 12:24)

Hors ligne

#2 Le 08/08/2015, à 12:59

michel_04

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Bonjour,

Myouf62 a écrit :

Je suis actuellement sous Ubuntu 14.04 LTS. J'aimerais savoir si en avril 2016, le gestionnaire de mises à jour m'informera automatiquement de la disponibilité d'Ubuntu 16.04 LTS

Oui.

Myouf62 a écrit :

et s'il sera possible de l'installer en préservant les logiciels, fichiers et préférences de mon système actuel? En gros est-ce que l'on sera obligé de faire une "clean install" en repartant de zéro ou non?

Non.
Lorsqu'elle te sera proposée, tu lanceras la mise à niveau vers la version 16.04.

A+


:D
Comment Poser Les Questions De Manière Intelligente - Trouver de l'aide grâce au Groupe des Parrains Linux - Le Pacte des Gnous - l'Almanet doLys de nam1962 et ses amis
PCs sous Debian Stable & Debian Sid.

Hors ligne

#3 Le 08/08/2015, à 13:42

jplemoine

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Oui (pour les réponses données par michel_04) mais pour ma part, c'est plus long mais je conseille de faire :
- une sauvegarde des donnes personnelles
- un clean-install (avec les mises à jour et tout)
- rapatrier les fichiers nécessaires dans la sauvegarde
Et dans ce cas-là, il y a toujours un reliquat... 
(je pense que ce sont peut-être des fichiers de configuration d'ancien programme mais leur nom ne me dit souvent rien).


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#4 Le 08/08/2015, à 14:56

Myouf62

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Ok donc il vaut mieux faire une clean install avec un CD ou une clé USB, mais dans ce cas c'est compliqué de conserver les paramètres et logiciels?
Qu'est-ce qui n'est pas bon dans une simple mise à niveau? Des anciens fichiers système qui restent pour rien?

Hors ligne

#5 Le 08/08/2015, à 15:57

PizzaTux

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Myouf62 a écrit :

Ok donc il vaut mieux faire une clean install avec un CD ou une clé USB, mais dans ce cas c'est compliqué de conserver les paramètres et logiciels?
Qu'est-ce qui n'est pas bon dans une simple mise à niveau? Des anciens fichiers système qui restent pour rien?

nan si tu es débutant et que tu as du mal avec les installations, tu peux faire une mise a niveau normale, en général ça ne pose pas de problème si sur la version d'avant c'était pas le foutoir.

Sinon si tu sépares le home de la racine (c'est a dire dans 2 partitions différentes plutôt qu'une partition qui contient les 2), tu conserves alors tous tes paramètres de thunderbird, firefox etc.. il te suffit a la nouvelle installation de réutiliser la partition home et de ne pas la formater, seule la partition racine sera formaté..

Dernière modification par PizzaTux (Le 08/08/2015, à 15:57)


OS : Linux Mint 17.2/Cinnamon | Debian 8 Jessie/Mate | ArchLinux/Xfce

Hors ligne

#6 Le 08/08/2015, à 18:16

olivi4

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Est-ce que le plus gros risque lors d'une mise à niveau ne tient pas à un problème d'alimentation ou de connexion réseau qui coupe ?


La philosophie nous enseigne à douter de ce qui nous paraît évident. La propagande, au contraire, nous enseigne à accepter pour évident ce dont il serait raisonnable de douter. (Aldous Huxley)
"La plus grande partie de la souffrance humaine est inutile. On se l'inflige à soi-même aussi longtemps que, à son insu, on laisse le mental prendre le contrôle de sa vie". (E. Tolle)

Hors ligne

#7 Le 08/08/2015, à 18:39

erresse

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Bah, si tu as une coupure de courant pendant que tu fais une "fresh install", ça m'étonnerait que ça se passe mieux qu'avec une migration.
Pour moi, les migrations se passent généralement bien (à condition d'avoir taillé sa partition racine suffisamment grande pour la faire proprement), mais il est vrai que, à chaque nouvelle version, il y a des changements dans les applications de l'environnement :
Certaines ont été remplacées, d'autres ne sont plus acceptées dans la nouvelle version, etc...
Ça fait bien sûr des "cochonneries" qui traînent dans les répertoires du /home et on doit faire un brin de ménage pour nettoyer tout ça.
Mais, lorsque tu regardes ton /home séparé ou sauvé/restauré après ta "fresh install", tu t'aperçois que tu y trouves les mêmes "cochonneries" et qu'il te faut aussi faire un brin de ménage. Alors, migration ou "fresh install", pour moi, même combat !


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#8 Le 08/08/2015, à 18:48

michel_04

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Re,

erresse a écrit :

Alors, migration ou "fresh install", pour moi, même combat !

Ben voilà.

A+


:D
Comment Poser Les Questions De Manière Intelligente - Trouver de l'aide grâce au Groupe des Parrains Linux - Le Pacte des Gnous - l'Almanet doLys de nam1962 et ses amis
PCs sous Debian Stable & Debian Sid.

Hors ligne

#9 Le 08/08/2015, à 18:49

PizzaTux

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

olivi4 a écrit :

Est-ce que le plus gros risque lors d'une mise à niveau ne tient pas à un problème d'alimentation ou de connexion réseau qui coupe ?

Bah il vaut mieux éviter d'avoir une coupure de courant pile pendant la procédure de mise a niveau mais après ça dépend quand ça arrive, il y a plusieurs étape lors de la mise a niveau :

- téléchargement des paquets de la nouvelle LTS
- mise a jour avec les nouveaux paquets téléchargés
- configuration / paramétrage des paquets / système


- Si tu as une coupure de courant ou internet pendant la phase de téléchargement, je pense que ce n'est pas très grave car la mise a niveau n'aura pas encore commencé (rien n'est encore changé sur ton système de base), il suffira de relancer la mise a niveau (peut être même qu'il pourra reprendre le téléchargement là ou il est en ai je sais pas j'ai jamais testé l'expérience...)

- Si t'a une coupure internet après la phase de téléchargement ce n'est pas très grave car les paquets sont déjà téléchargé

- Si tu as une coupure de courant pendant l'installation des paquet ou la configuration du système, si tu redémarres il est possible que le système soit planté ou fonctionne mal (mais pas forcément) dans ce cas il suffit de faire une nouvelle installation direct de la version.


mais de toute façon ta question n'a pas vraiment de sens car ça c'est valable pour tout, même avec une nouvelle installation fraiche, ton système sera planté aussi si tu as une coupure de courant et il faudra recommencer l'installation depuis le début.


PS : par contre sans connexion internet, tu peux quand même faire une installation fraiche si tu as déjà le cd gravé ou clé usb, c'est juste qu'il manquera certains paquets facultatif qu'il faudra installer après (comme les langues pour mettre en français etc...)

Dernière modification par PizzaTux (Le 08/08/2015, à 18:53)


OS : Linux Mint 17.2/Cinnamon | Debian 8 Jessie/Mate | ArchLinux/Xfce

Hors ligne

#10 Le 08/08/2015, à 18:53

PPdM

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

michel_04 a écrit :

Re,

erresse a écrit :

Alors, migration ou "fresh install", pour moi, même combat !

Ben voilà.

A+

Je plussoie, la migration se passe bien dans 99% des cas si le système est propre, et dans 90% si le système est un peu encombré


Ma librairie en ligne https://www.recyclivre.com/https://lespiliersdebistrots.forumactif.com/ tenue correcte exigée.  Dell 15" reconditionnés core I5 8 GO de ram , SSD et Batteries neuf, MP si intéressés

Hors ligne

#11 Le 08/08/2015, à 19:02

alca94

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Bonjour
il faut quand même au préalable avoir configurer son "sources de logiciels" ---> onglet "Mises a jour"sur
Me prévenir uniquement pour les LTS ( ou une phrase du même genre)
mais avec cette méthode on est prévenu environ 3/4 mois après la date de sortie

EDIT= j'ajouterais quand même le problème lié au PPA qu'ils faut réactiver (quand ils existent encore sur la nouvelle version)

Dernière modification par alca94 (Le 08/08/2015, à 19:08)


POUR METTRE LES RETOURS DU "TERMINAL"  voir les explications sur ce post
https://forum.ubuntu-fr.org/viewtopic.p … #p17345641

Hors ligne

#12 Le 08/08/2015, à 22:02

Myouf62

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

alca94 a écrit :

il faut quand même au préalable avoir configurer son "sources de logiciels" ---> onglet "Mises a jour"sur
Me prévenir uniquement pour les LTS ( ou une phrase du même genre)
mais avec cette méthode on est prévenu environ 3/4 mois après la date de sortie

Qu'est-ce que tu entends par là ?

Hors ligne

#13 Le 08/08/2015, à 22:12

alca94

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Qu'est-ce que tu entends par là ?

Je ne sais pas ce que je dois précisé exactement donc en premier

il faut quand même au préalable avoir configurer son "sources de logiciels" ---> onglet "Mises a jour"sur

1439064437.png
Pour le reste la proposition de mise a niveau est proposé automatiquement (si le premier point est fait) environ a la sortie du premier correctif de la version soit 16.04 -1 vers le mois de Juillet ou Août ?  (Lorsque tous les Bugs de jeunesse sont corrigés entr'autres)
Voir la Doc a ce sujet si vous souhaitez faire la mise a niveau avant
https://doc.ubuntu-fr.org/migration#rec … rsions_lts


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Un hébergeur comme Toile Libre le permet).

Dernière modification par cqfd93 (Le 09/08/2015, à 03:27)


POUR METTRE LES RETOURS DU "TERMINAL"  voir les explications sur ce post
https://forum.ubuntu-fr.org/viewtopic.p … #p17345641

Hors ligne

#14 Le 09/08/2015, à 02:03

Myouf62

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Merci pour tes précisions alca94.
Donc dans l'idéal pour éviter les embêtements il faut procéder à une clean install quand la dernière LTS est débuguée.
Je pense que c'est ce que je ferai l'été prochain, merci à vous tous pour vos réponses rapides ! smile

Hors ligne

#15 Le 09/08/2015, à 10:17

alca94

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Je pense que c'est ce que je ferai l'été prochain, merci à vous tous pour vos réponses rapides ! smile

c'est le mieux effectivement smile

Si vous considérez votre problème réglé veuillez l'indiquer,en reprenant votre premier Message et en cliquant sur modifier (en bas a droite)
puis reprendre le titre et METTRE DEVANT =  [ RESOLU ] Passage de 14.04 LTS à 16.04 LTS
merci


POUR METTRE LES RETOURS DU "TERMINAL"  voir les explications sur ce post
https://forum.ubuntu-fr.org/viewtopic.p … #p17345641

Hors ligne

#16 Le 21/03/2016, à 10:57

malbo

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Comme signalé par alca94, la proposition officielle de mise à niveau 14.04 vers 16.04 devrait être faite à l'été 2016. Actuellement, la version 16.04 est encore en développement. Elle est quasiment au stade "Final Beta", à un mois de sa sortie (voir Calendrier des sorties). C'est donc très prématuré mais j'ai fait quelques essais - dans deux ordis différents - de mise à niveau 14.04 vers 16.04 par la commande "sudo do-release-upgrade --devel-release". Résultat : la mise à niveau plante systématiquement. Dans le meilleur des cas, j'ai pu achever la mise à niveau en procédant comme suit :
- démarrage en mode de dépannage sur le noyau le plus récent de la version 14.04 (le démarrage sur le noyau 16.04 ne fonctionnant pas --> plantage immédiat**) 
- choix "resume" dans le mode de dépannage. Puis, le mode graphique ne fonctionnant pas (écran noir), passage en console par CTRL + F1
- connexion de session (toujours en console : il faut taper le login puis le mot de passe), commande "sudo apt update" : ça affiche qu'il faut passer la commande "sudo dpkg --configure -a". Je tape donc la commande demandée qui va entraîner la poursuite et l'achèvement de la mise à niveau :

sudo dpkg --configure -a

Après cela (*), redémarrage par la commande "sudo reboot now". J'arrive alors à démarrer une session graphique sur le noyau de la 16.04 (4.4.0-x) et je pense que tout fonctionne normalement.
Ce que je viens de décrire en "meilleur des cas", c'est depuis une installation de la version de base 14.04 qui vient avec le noyau 3.13.0-x mais j'ai fait des essais de mise à niveau depuis une installation de la version 14.04.4 (noyau 4.2.0-x) vers 16.04 et là je n'ai pas su m'en sortir. J'ai lutté avec mes petits bras pour tenter d'obtenir une session graphique mais j'ai jeté l'éponge EDIT : j'ai refait la manip (en partant de la version 14.04.4 qui vient avec le noyau noyau 4.2.0-x) et cette fois ça a marché et suivant la procédure décrite plus haut. mais il reste des moignons de lts-wily que j'ai pu supprimer sans tout faire planter dans un des deux ordis par contre dans mon Acer Aspire M5100-5F7N (voir dans ma signature), la purge de ces moignons a été trop radicale - j'y suis allé comme un barbare avec "sudo apt-get remove --purge *-lts-wily" parce qu'il y en avait trop à virer - et j'ai dû passer la commande suivante pour réparer les "dégâts collatéraux" sur le mode graphique :

sudo apt-get install xserver-xorg-video-all

A noter que xserver-xorg-video-all est un méta-paquet qui entraîne l'installation de tout un tas de pilotes graphiques.

(*) attention, ça mouline longtemps dans le terminal suite à la commande donc le plantage de la mise à niveau ne s'est pas produit juste en fin de processus : il restait encore beaucoup à faire. EDIT le 24 mars 2016 : j'ai l'impression qu'il s'agit du bug #1555237

(**) ultérieurement, je constate que ce plantage immédiat est dû à l'absence du fichier /boot/initrd.img-4.4.0-xx-generic qui entraîne l'absence de la ligne "initrd    /boot/initrd.img-4.4.0-xx-generic" dans l'entrée correspondante du menu Grub. C'est seulement lors de la reprise de la mise à niveau - suite à la commande "sudo dpkg --configure -a" - que cette anomalie sera réparée.

Dernière modification par malbo (Le 24/03/2016, à 19:54)

En ligne

#17 Le 25/03/2016, à 13:49

malbo

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Pour faire suite à mon post précédent - qui commence à être encombré - je viens de constater que c'est devenu officiel que la mise à niveau 14.04 vers 16.04 est boguée. On voit ça dans les
ReleaseNotes de Xenial qui ont été actualisées ce matin même : c'est dans le paragraphe 14.04 LTS to 16.04 LTS Desktop Upgrade. On peut y lire :
-------------------------------------------------------------------------------
Upgrade

14.04 LTS to 16.04 LTS Desktop Upgrade

There is a known issue which prevents the upgrade of 14.04 LTS to 16.04 LTS. Please see this bug for more information.

At this time you should not attempt to upgrade a production desktop from 14.04 LTS to 16.04 LTS.
--------------------------------------------------------------------------------------------------------------------------------
Il s'agit bien du bug #1555237 comme je l'avais supposé dans le post précédent.

En ligne

#18 Le 27/03/2016, à 15:09

Ubuntu1988

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Pour apporter ma pierre à l’édifice : mise à niveau faite sur deux configurations identiques sur Trusty, une via l'interface graphique et la seconde en terminal. Résultat, si celle via le terminal s'est déroulée sans soucis, celle effectuée par l'interface graphique a fait freezer le système, les touches magiques étant inopérantes, en m'obligeant à redémarrer sauvagement.

Au redémarrage, je suis tombé sur un terminal mais j'ai pu tout arranger via

sudo dpkg --configure -a

Et la mise à niveau à pu se terminer

Dernière modification par Ubuntu1988 (Le 27/03/2016, à 15:10)


J'ai perdu ! :(

Hors ligne

#19 Le 27/03/2016, à 16:21

malbo

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Ubuntu1988 a écrit :

une via l'interface graphique et la seconde en terminal.

Peux-tu expliquer ce que c'est que la mise à niveau "via l'interface graphique" ? Ce que je veux dire, c'est que je ne connais que la mise à niveau obtenue en passant dans un terminal la commande "sudo do-release-upgrade --devel-release" comme je l'ai détaillé dans mon post #16. S'agissant d'une mise à niveau vers une version en développement, je ne connais pas d'autre procédure.

Dernière modification par malbo (Le 27/03/2016, à 16:28)

En ligne

#20 Le 31/03/2016, à 20:16

JLK

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Donc patientons qu'il y ait une certaine accalmie au niveau de la mise à jour.
D'ailleurs, je n'ai jamais compris pourquoi c'était aléatoire sous Ubuntu, alors que si j'en crois les utilisateurs de Debian, ça passe plutôt avec davantage de douceur.

Hors ligne

#21 Le 03/04/2016, à 15:08

malbo

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Les développeurs ont travaillé dur sur le bug #1555237 : la mise à niveau Ubuntu 14.04.4 64 bits vers Ubuntu 16.04 ne plante plus. Cela dit, je ne sais pas si c'est un bug réservé à cet ordi mais avec mon Acer Aspire M5100-5F7N, ça ne marche quand même pas au redémarrage qui suit la mise à niveau : je suis toujours obligé de passer la commande suivante (comme je l'avais signalé dans mon post #16) :

sudo apt-get install xserver-xorg-video-all

sinon, j'ai une session toute pourrie avec une définition d'écran inadaptée. Donc de gros efforts mais peut mieux faire.

EDIT le 4 avril 2016 : avec Clonezilla, j'ai restauré ma 14.04.4 d'origine sur mon ordi Acer et j'ai refait la mise à niveau vers 16.04. Je retrouve le souci au redémarrage (définition d'écran inadaptée) et au lieu de la commande précédente, je passe cette commande (ça doit revenir au même mais je trouve plus logique d'installer le paquet de plus haut niveau) :

sudo apt-get install xserver-xorg

Après cela, je n'ai plus de problème d'affichage.
Je retrouve ce qui a été fait suite à cette commande dans le fichier /var/log/apt/history.log :

Start-Date: 2016-04-04  16:02:03
Commandline: apt-get install xserver-xorg
Requested-By: malbo (1000)
Install: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3, automatic), xserver-xorg:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3, automatic), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2, automatic), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2, automatic), xserver-xorg-video-amdgpu:amd64 (1.0.1-1build2, automatic), xserver-xorg-core:amd64 (2:1.18.1-1ubuntu4, automatic), libglapi-mesa:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5, automatic), libxatracker2:amd64 (11.1.2-1ubuntu2, automatic), libegl1-mesa:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3, automatic), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2, automatic), libllvm3.8:amd64 (1:3.8-2ubuntu1, automatic), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160218-1ubuntu3, automatic), libwayland-egl1-mesa:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3, automatic), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2, automatic), xserver-xorg-video-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-video-ati:amd64 (1:7.6.1-1ubuntu2, automatic), libgl1-mesa-dri:amd64 (11.1.2-1ubuntu2, automatic), libgl1-mesa-glx:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-video-radeon:amd64 (1:7.6.1-1ubuntu2, automatic)
Upgrade: libgbm1:amd64 (10.1.3-0ubuntu0.6, 11.1.2-1ubuntu2)
Remove: libgbm1-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libegl1-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libgl1-mesa-glx-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), xserver-xorg-lts-wily:amd64 (1:7.7+7ubuntu4~trusty1), xserver-xorg-core-lts-wily:amd64 (2:1.17.2-1ubuntu9.1~trusty1), xserver-xorg-input-evdev-lts-wily:amd64 (1:2.9.2-1ubuntu1~trusty2), libwayland-egl1-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libgl1-mesa-dri-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libglapi-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1)
End-Date: 2016-04-04  16:02:59

Petit commentaire : ça sent bien le pâté parce qu'on peut voir qu'il restait beaucoup de paquet *lts-wily à enlever et c'est certainement ce qui a empêché la mise à niveau correcte de l'affichage.

Dernière modification par malbo (Le 04/04/2016, à 16:37)

En ligne

#22 Le 03/04/2016, à 15:22

Ubuntu1988

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

malbo a écrit :
Ubuntu1988 a écrit :

une via l'interface graphique et la seconde en terminal.

Peux-tu expliquer ce que c'est que la mise à niveau "via l'interface graphique" ? Ce que je veux dire, c'est que je ne connais que la mise à niveau obtenue en passant dans un terminal la commande "sudo do-release-upgrade --devel-release" comme je l'ai détaillé dans mon post #16. S'agissant d'une mise à niveau vers une version en développement, je ne connais pas d'autre procédure.

Via la commande

sudo update-manager -d

Ça lancera le gestionnaire de mise à jour en indiquant que Xenial est disponible malgré que je n'ai jamais eu vraiment confiance aux migrations via l'interface graphique vu les nombreux pépins que j'ai pu rencontrer mais là, c'était dans un but de test ... et ça n'a pas vraiment changé ma préférence pour la ligne de commande.

Dernière modification par Ubuntu1988 (Le 03/04/2016, à 15:22)


J'ai perdu ! :(

Hors ligne

#23 Le 03/04/2016, à 16:42

malbo

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

@Ubuntu1988 : merci pour l'info. Je viens de constater que cette commande est bien proposée dans le paragraphe 3.2 Méthode pour Ubuntu, Xubuntu et Edubuntu de la doc "Installation ou mise à jour vers une version d'ubuntu encore en développement (alpha/bêta/RC)". Je ne pense pas que j'utiliserai cette méthode parce que je ne passe jamais par le gestionnaire de mises à jour mais c'est bon de savoir que ça existe.

En ligne

#24 Le 04/04/2016, à 21:16

malbo

Re : [Résolu] Passage de 14.04 LTS à 16.04 LTS

Je confirme que ça merde en faisant un essai en machine virtuelle (avec VMware Player) de mise à niveau Ubuntu 14.04.4 vers 16.04.
Après mise à niveau, je repasse la commande du post #21 :

malbo@malbo-virtual-machine:~$ sudo apt-get install xserver-xorg
Mot de passe [sudo] pour malbo : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libllvm3.8 libwayland-egl1-mesa
  libxatracker2 xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom
  xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon
  xserver-xorg-video-vesa xserver-xorg-video-vmware
Paquets suggérés :
  xfonts-100dpi | xfonts-75dpi gpointing-device-settings touchfreeze firmware-amd-graphics
  xserver-xorg-video-r128 xserver-xorg-video-mach64
Les paquets suivants seront ENLEVÉS :
  libegl1-mesa-lts-wily libgbm1-lts-wily libgl1-mesa-dri-lts-wily libgl1-mesa-glx-lts-wily
  libglapi-mesa-lts-wily libwayland-egl1-mesa-lts-wily xserver-xorg-core-lts-wily
  xserver-xorg-input-evdev-lts-wily xserver-xorg-lts-wily
Les NOUVEAUX paquets suivants seront installés :
  libegl1-mesa libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libllvm3.8 libwayland-egl1-mesa
  libxatracker2 xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom
  xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon
  xserver-xorg-video-vesa xserver-xorg-video-vmware
Les paquets suivants seront mis à jour :
  libgbm1
1 mis à jour, 24 nouvellement installés, 9 à enlever et 2 non mis à jour.
Il est nécessaire de prendre 8 525 ko/18,8 Mo dans les archives.
Après cette opération, 142 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg amd64 1:7.7+13ubuntu3 [57,2 kB]
Réception de:2 http://archive.ubuntu.com/ubuntu xenial/main amd64 libwayland-egl1-mesa amd64 11.1.2-1ubuntu2 [5 796 B]
Réception de:3 http://archive.ubuntu.com/ubuntu xenial/main amd64 libegl1-mesa amd64 11.1.2-1ubuntu2 [70,3 kB]
Réception de:4 http://archive.ubuntu.com/ubuntu xenial/main amd64 libgl1-mesa-glx amd64 11.1.2-1ubuntu2 [127 kB]
Réception de:5 http://archive.ubuntu.com/ubuntu xenial/main amd64 libgbm1 amd64 11.1.2-1ubuntu2 [22,8 kB]
Réception de:6 http://archive.ubuntu.com/ubuntu xenial/main amd64 libgl1-mesa-dri amd64 11.1.2-1ubuntu2 [4 516 kB]
Réception de:7 http://archive.ubuntu.com/ubuntu xenial/main amd64 libglapi-mesa amd64 11.1.2-1ubuntu2 [22,9 kB]
Réception de:8 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-core amd64 2:1.18.1-1ubuntu4 [1 342 kB]
Réception de:9 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-input-evdev amd64 1:2.10.1-1ubuntu2 [31,3 kB]
Réception de:10 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-input-synaptics amd64 1.8.2-1ubuntu3 [63,3 kB]
Réception de:11 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-input-vmmouse amd64 1:13.1.0-1ubuntu2 [14,1 kB]
Réception de:12 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-input-wacom amd64 1:0.32.0-0ubuntu3 [84,7 kB]
Réception de:13 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-input-all amd64 1:7.7+13ubuntu3 [4 398 B]
Réception de:14 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxatracker2 amd64 11.1.2-1ubuntu2 [996 kB]
Réception de:15 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-amdgpu amd64 1.0.1-1build2 [49,9 kB]
Réception de:16 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-radeon amd64 1:7.6.1-1ubuntu2 [136 kB]
Réception de:17 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-ati amd64 1:7.6.1-1ubuntu2 [6 798 B]
Réception de:18 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-fbdev amd64 1:0.4.4-1build5 [11,6 kB]
Réception de:19 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-nouveau amd64 1:1.0.12-1build2 [84,9 kB]
Réception de:20 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-vesa amd64 1:2.3.4-1build2 [14,7 kB]
Réception de:21 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-vmware amd64 1:13.1.0-2ubuntu3 [67,7 kB]
Réception de:22 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-all amd64 1:7.7+13ubuntu3 [4 440 B]
Réception de:23 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-intel amd64 2:2.99.917+git20160218-1ubuntu3 [713 kB]
Réception de:24 http://archive.ubuntu.com/ubuntu xenial/main amd64 xserver-xorg-video-qxl amd64 0.1.4-3ubuntu3 [79,9 kB]
8 525 ko réceptionnés en 15s (567 ko/s)                                                                 
dpkg: xserver-xorg-lts-wily : problème de dépendance, mais suppression comme demandé :
 xorg dépend de xserver-xorg (>= 1:7.7+1ubuntu8.1) | xserver-xorg-renamed ; cependant :
  Le paquet xserver-xorg n'est pas installé.
  Le paquet xserver-xorg-lts-wily qui fournit xserver-xorg doit être supprimé.
  Le paquet xserver-xorg-renamed n'est pas installé.
  Le paquet xserver-xorg-lts-wily qui fournit xserver-xorg-renamed doit être supprimé.
 xorg dépend de xserver-xorg (>= 1:7.7+1ubuntu8.1) | xserver-xorg-renamed ; cependant :
  Le paquet xserver-xorg n'est pas installé.
  Le paquet xserver-xorg-lts-wily qui fournit xserver-xorg doit être supprimé.
  Le paquet xserver-xorg-renamed n'est pas installé.
  Le paquet xserver-xorg-lts-wily qui fournit xserver-xorg-renamed doit être supprimé.

(Lecture de la base de données... 194179 fichiers et répertoires déjà installés.)
Suppression de xserver-xorg-lts-wily (1:7.7+7ubuntu4~trusty1) ...
Sélection du paquet xserver-xorg précédemment désélectionné.
(Lecture de la base de données... 194170 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../xserver-xorg_1%3a7.7+13ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg (1:7.7+13ubuntu3) ...
dpkg: libwayland-egl1-mesa-lts-wily:amd64 : problème de dépendance, mais suppression comme demandé :
 libgtk-3-0:amd64 dépend de libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1 ; cependant :
  Le paquet libwayland-egl1-mesa n'est pas installé.
  Le paquet libwayland-egl1-mesa-lts-wily:amd64 qui fournit libwayland-egl1-mesa doit être supprimé.
  Le paquet libwayland-egl1 n'est pas installé.
  Le paquet libwayland-egl1-mesa-lts-wily:amd64 qui fournit libwayland-egl1 doit être supprimé.
 libwebkit2gtk-4.0-37-gtk2:amd64 dépend de libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1 ; cependant :
  Le paquet libwayland-egl1-mesa n'est pas installé.
  Le paquet libwayland-egl1-mesa-lts-wily:amd64 qui fournit libwayland-egl1-mesa doit être supprimé.
  Le paquet libwayland-egl1 n'est pas installé.
  Le paquet libwayland-egl1-mesa-lts-wily:amd64 qui fournit libwayland-egl1 doit être supprimé.
 libwebkit2gtk-4.0-37:amd64 dépend de libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1 ; cependant :
  
(Lecture de la base de données... 194213 fichiers et répertoires déjà installés.)
Suppression de libwayland-egl1-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1) ...
dpkg: xserver-xorg-input-evdev-lts-wily : problème de dépendance, mais suppression comme demandé :
 xserver-xorg dépend de xserver-xorg-input-all | xorg-driver-input ; cependant :
  Le paquet xserver-xorg-input-all n'est pas installé.
  Le paquet xorg-driver-input n'est pas installé.
  Le paquet xserver-xorg-input-evdev-lts-wily qui fournit xorg-driver-input doit être supprimé.

Suppression de xserver-xorg-input-evdev-lts-wily (1:2.9.2-1ubuntu1~trusty2) ...
dpkg: xserver-xorg-core-lts-wily : problème de dépendance, mais suppression comme demandé :
 xserver-xorg dépend de xserver-xorg-core (>= 2:1.17.2-2) ; cependant :
  Le paquet xserver-xorg-core n'est pas installé.
  Le paquet xserver-xorg-core-lts-wily qui fournit xserver-xorg-core doit être supprimé.

Suppression de xserver-xorg-core-lts-wily (2:1.17.2-1ubuntu9.1~trusty1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Sélection du paquet libwayland-egl1-mesa:amd64 précédemment désélectionné.
(Lecture de la base de données... 194158 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libwayland-egl1-mesa_11.1.2-1ubuntu2_amd64.deb ...
Dépaquetage de libwayland-egl1-mesa:amd64 (11.1.2-1ubuntu2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
dpkg: libegl1-mesa-lts-wily:amd64 : problème de dépendance, mais suppression comme demandé :
 libwayland-egl1-mesa:amd64 dépend de libegl1-mesa (= 11.1.2-1ubuntu2) ; cependant :
  Le paquet libegl1-mesa n'est pas installé.
  Le paquet libegl1-mesa-lts-wily:amd64 qui fournit libegl1-mesa doit être supprimé.
 libqt5gui5:amd64 dépend de libegl1-mesa (>= 7.8.1) | libegl1-x11 ; cependant :
  Le paquet libegl1-mesa n'est pas installé.
  Le paquet libegl1-mesa-lts-wily:amd64 qui fournit libegl1-mesa doit être supprimé.
  Le paquet libegl1-x11 n'est pas installé.
  Le paquet libegl1-mesa-lts-wily:amd64 qui fournit libegl1-x11 doit être supprimé.
 libwebkit2gtk-4.0-37-gtk2:amd64 dépend de libegl1-mesa (>= 7.8.1) | libegl1-x11 ; cependant :
  Le paquet libegl1-mesa n'est pas installé.
  Le paquet libegl1-mesa-lts-wily:amd64 qui fournit libegl1-mesa doit être supprimé.
  Le paquet libegl1-x11 n'est pas installé.
  Le paquet libegl1-mesa-lts-wily:amd64 qui fournit libegl1-x11 doit être supprimé.
 
(Lecture de la base de données... 194166 fichiers et répertoires déjà installés.)
Suppression de libegl1-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
Sélection du paquet libegl1-mesa:amd64 précédemment désélectionné.
(Lecture de la base de données... 194156 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libegl1-mesa_11.1.2-1ubuntu2_amd64.deb ...
Dépaquetage de libegl1-mesa:amd64 (11.1.2-1ubuntu2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
(Lecture de la base de données... 194166 fichiers et répertoires déjà installés.)
Suppression de libgbm1-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1) ...
Suppression de « détournement de /usr/lib/x86_64-linux-gnu/libgbm.so.1.0.0 en /usr/lib/x86_64-linux-gnu/old.libgbm.so.1.0.0 par libgbm1-lts-wily »
Suppression de « détournement de /usr/lib/x86_64-linux-gnu/libgbm.so.1 en /usr/lib/x86_64-linux-gnu/old.libgbm.so.1 par libgbm1-lts-wily »
Suppression de « détournement de /usr/lib/x86_64-linux-gnu/gbm/gbm_gallium_drm.so en /usr/lib/x86_64-linux-gnu/gbm/old.gbm_gallium_drm.so par libgbm1-lts-wily »
dpkg: libgl1-mesa-glx-lts-wily:amd64 : problème de dépendance, mais suppression comme demandé :
 libqtwebkit4:amd64 dépend de libgl1-mesa-glx | libgl1 ; cependant :
  Le paquet libgl1-mesa-glx n'est pas installé.
  Le paquet libgl1-mesa-glx-lts-wily:amd64 qui fournit libgl1-mesa-glx doit être supprimé.
  Le paquet libgl1 n'est pas installé.
  Le paquet libgl1-mesa-glx-lts-wily:amd64 qui fournit libgl1 doit être supprimé.
 xorg dépend de libgl1-mesa-glx | libgl1 ; cependant :
  Le paquet libgl1-mesa-glx n'est pas installé.
  Le paquet libgl1-mesa-glx-lts-wily:amd64 qui fournit libgl1-mesa-glx doit être supprimé.
  Le paquet libgl1 n'est pas installé.
  Le paquet libgl1-mesa-glx-lts-wily:amd64 qui fournit libgl1 doit être supprimé.
 gnome-session-bin dépend de libgl1-mesa-glx | libgl1 ; cependant :
  Le paquet libgl1-mesa-glx n'est pas installé.
  Le paquet libgl1-mesa-glx-lts-wily:amd64 qui fournit libgl1-mesa-glx doit être supprimé.
  Le paquet libgl1 n'est pas installé.
  Le paquet l
Suppression de libgl1-mesa-glx-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
Sélection du paquet libgl1-mesa-glx:amd64 précédemment désélectionné.
(Lecture de la base de données... 194145 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libgl1-mesa-glx_11.1.2-1ubuntu2_amd64.deb ...
Dépaquetage de libgl1-mesa-glx:amd64 (11.1.2-1ubuntu2) ...
Préparation du dépaquetage de .../libgbm1_11.1.2-1ubuntu2_amd64.deb ...
Dépaquetage de libgbm1:amd64 (11.1.2-1ubuntu2) sur (10.1.3-0ubuntu0.6) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
dpkg: libgl1-mesa-dri-lts-wily:amd64 : problème de dépendance, mais suppression comme demandé :
 libegl1-mesa:amd64 dépend de libgl1-mesa-dri (= 11.1.2-1ubuntu2) ; cependant :
  Le paquet libgl1-mesa-dri n'est pas installé.
  Le paquet libgl1-mesa-dri-lts-wily:amd64 qui fournit libgl1-mesa-dri doit être supprimé.
 xorg dépend de libgl1-mesa-dri ; cependant :
  Le paquet libgl1-mesa-dri n'est pas installé.
  Le paquet libgl1-mesa-dri-lts-wily:amd64 qui fournit libgl1-mesa-dri doit être supprimé.
 libgl1-mesa-glx:amd64 dépend de libgl1-mesa-dri (>= 7.2) ; cependant :
  Le paquet libgl1-mesa-dri n'est pas installé.
  Le paquet libgl1-mesa-dri-lts-wily:amd64 qui fournit libgl1-mesa-dri doit être supprimé.
 libgbm1:amd64 dépend de libgl1-mesa-dri (= 11.1.2-1ubuntu2) ; cependant :
  Le paquet libgl1-mesa-dri n'est pas installé.
  Le paquet libgl1-mesa-dri-lts-wily:amd64 qui fournit libgl1-mesa-dri doit être supprimé.
 qml-module-qtquick2:amd64 dépend de libgl1-mesa-dri | libgl1 ; cependant
(Lecture de la base de données... 194156 fichiers et répertoires déjà installés.)
Suppression de libgl1-mesa-dri-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1) ...
Sélection du paquet libgl1-mesa-dri:amd64 précédemment désélectionné.
(Lecture de la base de données... 194137 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libgl1-mesa-dri_11.1.2-1ubuntu2_amd64.deb ...
Dépaquetage de libgl1-mesa-dri:amd64 (11.1.2-1ubuntu2) ...
dpkg: libglapi-mesa-lts-wily:amd64 : problème de dépendance, mais suppression comme demandé :
 libgl1-mesa-glx:amd64 dépend de libglapi-mesa (= 11.1.2-1ubuntu2) ; cependant :
  Le paquet libglapi-mesa n'est pas installé.
  Le paquet libglapi-mesa-lts-wily:amd64 qui fournit libglapi-mesa doit être supprimé.

(Lecture de la base de données... 194156 fichiers et répertoires déjà installés.)
Suppression de libglapi-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
Sélection du paquet libglapi-mesa:amd64 précédemment désélectionné.
(Lecture de la base de données... 194148 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libglapi-mesa_11.1.2-1ubuntu2_amd64.deb ...
Dépaquetage de libglapi-mesa:amd64 (11.1.2-1ubuntu2) ...
Sélection du paquet libllvm3.8:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libllvm3.8_1%3a3.8-2ubuntu1_amd64.deb ...
Dépaquetage de libllvm3.8:amd64 (1:3.8-2ubuntu1) ...
Sélection du paquet xserver-xorg-core précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-core_2%3a1.18.1-1ubuntu4_amd64.deb ...
Dépaquetage de xserver-xorg-core (2:1.18.1-1ubuntu4) ...
Sélection du paquet xserver-xorg-input-evdev précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-input-evdev_1%3a2.10.1-1ubuntu2_amd64.deb ...
Dépaquetage de xserver-xorg-input-evdev (1:2.10.1-1ubuntu2) ...
Sélection du paquet xserver-xorg-input-synaptics précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-input-synaptics_1.8.2-1ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg-input-synaptics (1.8.2-1ubuntu3) ...
Sélection du paquet xserver-xorg-input-vmmouse précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-input-vmmouse_1%3a13.1.0-1ubuntu2_amd64.deb ...
Dépaquetage de xserver-xorg-input-vmmouse (1:13.1.0-1ubuntu2) ...
Sélection du paquet xserver-xorg-input-wacom précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-input-wacom_1%3a0.32.0-0ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg-input-wacom (1:0.32.0-0ubuntu3) ...
Sélection du paquet xserver-xorg-input-all précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-input-all_1%3a7.7+13ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg-input-all (1:7.7+13ubuntu3) ...
Sélection du paquet libxatracker2:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libxatracker2_11.1.2-1ubuntu2_amd64.deb ...
Dépaquetage de libxatracker2:amd64 (11.1.2-1ubuntu2) ...
Sélection du paquet xserver-xorg-video-amdgpu précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-amdgpu_1.0.1-1build2_amd64.deb ...
Dépaquetage de xserver-xorg-video-amdgpu (1.0.1-1build2) ...
Sélection du paquet xserver-xorg-video-radeon précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-radeon_1%3a7.6.1-1ubuntu2_amd64.deb ...
Dépaquetage de xserver-xorg-video-radeon (1:7.6.1-1ubuntu2) ...
Sélection du paquet xserver-xorg-video-ati précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-ati_1%3a7.6.1-1ubuntu2_amd64.deb ...
Dépaquetage de xserver-xorg-video-ati (1:7.6.1-1ubuntu2) ...
Sélection du paquet xserver-xorg-video-fbdev précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-fbdev_1%3a0.4.4-1build5_amd64.deb ...
Dépaquetage de xserver-xorg-video-fbdev (1:0.4.4-1build5) ...
Sélection du paquet xserver-xorg-video-nouveau précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-nouveau_1%3a1.0.12-1build2_amd64.deb ...
Dépaquetage de xserver-xorg-video-nouveau (1:1.0.12-1build2) ...
Sélection du paquet xserver-xorg-video-vesa précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-vesa_1%3a2.3.4-1build2_amd64.deb ...
Dépaquetage de xserver-xorg-video-vesa (1:2.3.4-1build2) ...
Sélection du paquet xserver-xorg-video-vmware précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-vmware_1%3a13.1.0-2ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg-video-vmware (1:13.1.0-2ubuntu3) ...
Sélection du paquet xserver-xorg-video-all précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-all_1%3a7.7+13ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg-video-all (1:7.7+13ubuntu3) ...
Sélection du paquet xserver-xorg-video-intel précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-intel_2%3a2.99.917+git20160218-1ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg-video-intel (2:2.99.917+git20160218-1ubuntu3) ...
Sélection du paquet xserver-xorg-video-qxl précédemment désélectionné.
Préparation du dépaquetage de .../xserver-xorg-video-qxl_0.1.4-3ubuntu3_amd64.deb ...
Dépaquetage de xserver-xorg-video-qxl (0.1.4-3ubuntu3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de libllvm3.8:amd64 (1:3.8-2ubuntu1) ...
Paramétrage de libgl1-mesa-dri:amd64 (11.1.2-1ubuntu2) ...
Installation de la nouvelle version du fichier de configuration /etc/drirc ...
Paramétrage de libgbm1:amd64 (11.1.2-1ubuntu2) ...
Paramétrage de libegl1-mesa:amd64 (11.1.2-1ubuntu2) ...
update-alternatives: utilisation de « /usr/lib/x86_64-linux-gnu/mesa-egl/ld.so.conf » pour fournir « /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf » (x86_64-linux-gnu_egl_conf) en mode automatique
Paramétrage de libglapi-mesa:amd64 (11.1.2-1ubuntu2) ...
Paramétrage de libgl1-mesa-glx:amd64 (11.1.2-1ubuntu2) ...
update-alternatives: utilisation de « /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf » pour fournir « /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf » (x86_64-linux-gnu_gl_conf) en mode automatique
Paramétrage de xserver-xorg-core (2:1.18.1-1ubuntu4) ...
Paramétrage de xserver-xorg-input-evdev (1:2.10.1-1ubuntu2) ...
Paramétrage de xserver-xorg-input-synaptics (1.8.2-1ubuntu3) ...
Paramétrage de xserver-xorg-input-vmmouse (1:13.1.0-1ubuntu2) ...
Paramétrage de xserver-xorg-input-wacom (1:0.32.0-0ubuntu3) ...
Paramétrage de xserver-xorg-input-all (1:7.7+13ubuntu3) ...
Paramétrage de xserver-xorg (1:7.7+13ubuntu3) ...
Paramétrage de libwayland-egl1-mesa:amd64 (11.1.2-1ubuntu2) ...
Paramétrage de libxatracker2:amd64 (11.1.2-1ubuntu2) ...
Paramétrage de xserver-xorg-video-amdgpu (1.0.1-1build2) ...
Paramétrage de xserver-xorg-video-radeon (1:7.6.1-1ubuntu2) ...
Paramétrage de xserver-xorg-video-ati (1:7.6.1-1ubuntu2) ...
Paramétrage de xserver-xorg-video-fbdev (1:0.4.4-1build5) ...
Paramétrage de xserver-xorg-video-nouveau (1:1.0.12-1build2) ...
Paramétrage de xserver-xorg-video-vesa (1:2.3.4-1build2) ...
Paramétrage de xserver-xorg-video-vmware (1:13.1.0-2ubuntu3) ...
Paramétrage de xserver-xorg-video-all (1:7.7+13ubuntu3) ...
Paramétrage de xserver-xorg-video-intel (2:2.99.917+git20160218-1ubuntu3) ...
Paramétrage de xserver-xorg-video-qxl (0.1.4-3ubuntu3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu2) ...
malbo@malbo-virtual-machine:~$ 

Pour comparaison avec ce que j'ai trouvé dans le post #21, je colle ce que je trouve dans /var/log/apt/history.log pour cette opération :

Start-Date: 2016-04-04  21:00:57
Commandline: apt-get install xserver-xorg
Requested-By: malbo (1000)
Install: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3, automatic), xserver-xorg:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3, automatic), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2, automatic), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2, automatic), xserver-xorg-video-amdgpu:amd64 (1.0.1-1build2, automatic), xserver-xorg-core:amd64 (2:1.18.1-1ubuntu4, automatic), libglapi-mesa:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5, automatic), libxatracker2:amd64 (11.1.2-1ubuntu2, automatic), libegl1-mesa:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3, automatic), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2, automatic), libllvm3.8:amd64 (1:3.8-2ubuntu1, automatic), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160218-1ubuntu3, automatic), libwayland-egl1-mesa:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3, automatic), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2, automatic), xserver-xorg-video-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-video-ati:amd64 (1:7.6.1-1ubuntu2, automatic), libgl1-mesa-dri:amd64 (11.1.2-1ubuntu2, automatic), libgl1-mesa-glx:amd64 (11.1.2-1ubuntu2, automatic), xserver-xorg-video-radeon:amd64 (1:7.6.1-1ubuntu2, automatic)
Upgrade: libgbm1:amd64 (10.1.3-0ubuntu0.6, 11.1.2-1ubuntu2)
Remove: libgbm1-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libegl1-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libgl1-mesa-glx-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), xserver-xorg-lts-wily:amd64 (1:7.7+7ubuntu4~trusty1), xserver-xorg-core-lts-wily:amd64 (2:1.17.2-1ubuntu9.1~trusty1), xserver-xorg-input-evdev-lts-wily:amd64 (1:2.9.2-1ubuntu1~trusty2), libwayland-egl1-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libgl1-mesa-dri-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1), libglapi-mesa-lts-wily:amd64 (11.0.2-1ubuntu4~trusty1)
End-Date: 2016-04-04  21:01:25

C'est identique à ce que j'ai trouvé dans le post #21 donc ce que je croyais être un bug limité à mon ordi Acer doit être vrai pour n'importe quel ordi, à savoir que la mise à niveau n'arrive pas à se débarrasser des paquets *lts-wily qui sont des traces de la version 14.04.4 et du coup, cette mise à niveau est incomplète. Dans le cas de l'essai en machine virtuelle, ce bug ne donne pas un affichage pourri au redémarrage après mise à niveau contrairement à ce que j'ai signalé plus haut pour la mise à niveau dans mon ordi Acer.

Remarque : en faisant une simple mise à jour après avoir passé la commande "sudo apt-get install xserver-xorg", je constate que xorg passe de la version 1:7.7+1ubuntu8.1 à la version 1:7.7+13ubuntu3, c'est à dire qu'il passe à la même version que les paquets xserver-xorg, xserver-xorg-video-all et xserver-xorg-input-all. A noter que le paquet x11-common est passé à cette version 1:7.7+13ubuntu3 lors de la mise à niveau (je l'ai vérifié en consultant le fichier /var/log/dist-upgrade/history.log).

Dernière modification par malbo (Le 05/04/2016, à 08:21)

En ligne