Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/06/2016, à 00:06

Pierre_K

[alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Bonjour smile
Depuis quelque temps il semble impossible de mettre à jour le "pepperflashplugin-nonfree" avec la commande suivante:

sudo update-pepperflashplugin-nonfree --install 

Son retour me donne ceci:

sudo update-pepperflashplugin-nonfree --install
[sudo] Mot de passe de pierre_k : 
WARNING: W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)
W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 3B068FB4789ABE4AEFA3BB491397BC53640DB551 uses weak digest algorithm (SHA1)

J'ai fait beaucoup de recherches et trouvé plusieurs solutions qui ne fonctionnent pas du tout (solutions peut-être plus adaptées pour la version 14.04?). Est-ce qu'il existe une solution à cette "Signature by key" que l'on rencontre sur Voyager 16.04 (Xubuntu 16.04) ?

Voici un lien qui propose une solution qui fonctionnait sur Voyager 14.04, mais visiblement pas sur Voyager 16.04: http://unix.stackexchange.com/questions … on-from-go

Est-ce qu'il existe un PPA pour mettre ce plugin à jour sous la version 16.04 ? Personnellement, j'ai toujours utilisé la commande ci-haut pour la mettre à jour.

Merci smile

Dernière modification par Pierre_K (Le 04/06/2016, à 10:34)


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#2 Le 01/06/2016, à 01:58

Coeur Noir

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Peut-être l'installation de https://doc.ubuntu-fr.org/yppamanager aiderait, via sa fonction d'import de clés manquantes (Import all missing GPG keys, Fix GPG BADSIG errors).

Une autre solution consiste à ne pas utiliser pepperflashplugin-non free mais uniquement adobe-flashplugin accesible depuis le dépôt partner canonical, qui sera mis à jour automatiquement, lui. https://doc.ubuntu-fr.org/flashplayer#d … _officiels et surtout cette remarque https://doc.ubuntu-fr.org/flashplayer#pour_firefox Pour supprimer :

update-pepperflashplugin-nonfree --uninstall

puis

sudo apt purge pepperflashplugin-nonfree

À savoir que depuis la 16.04 freshplayerplugin (pour utiliser le flash ppapi dans firefox) est devenu browser-plugin-freshplayer-peperflash accessible depuis les dépôts (plus besoin du ppa nilarimogard) attention cependant car il installe par défaut pepperflashplugin-nonfree alors qu'il n'y en a pas besoin si adobe-flashplugin est déjà installé.

Dernière modification par Coeur Noir (Le 01/06/2016, à 02:00)

Hors ligne

#3 Le 01/06/2016, à 02:21

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Bonjour coeur noir,

Merci de ta réponse. smile J'ai lu sommairement tes liens (que je vais lire plus attentivement ce soir) et si je comprends bien en supprimant et purgeant pepperflashplugin-nonfree et en le remplaçant par adobe-flashplugin j'aurai la toute dernière version de flash (présentement la 21.0.0.242) et les mises à jours ultérieures pour les navigateurs Vivaldi, Opera et Firefox (en ayant pour ce dernier "browser-plugin-freshplayer-peperflash" qui est déjà installé et fonctionnel) ?

En ce moment j'ai pepperflashplugin-nonfree et  adobe-flashplugin que j'ai installé hier suite à mes recherches. Donc si tu confirmes que j'ai bien compris je purgerai définitivement le pepperflashplugin-nonfree.

Encore merci smile

Dernière modification par Pierre_K (Le 01/06/2016, à 02:23)


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#4 Le 01/06/2016, à 02:42

Coeur Noir

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

C'est bien l'idée ! Mais adobe-flashplugin ne concerne que Chromium et Firefox, à priori.

Pour Vivaldi et Opera je ne sais pas.

Mais puisqu'adobe-flashplugin installe le flash player ppapi de google dans chromium, doit y a avoir moyen de faire pointer Opera et Vivaldi vers lui - à tester / investiguer… n'utilisant pas ces navigateurs "propriétaires" ce n'est qu'une supposition.

Hors ligne

#5 Le 01/06/2016, à 03:13

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Effectivement, ça ne fonctionne pas avec Vivaldi... C'est bien dommage ! Je ne sais pas si on peut pointer vers cette nouvelle solution. Si quelqu'un connait une astuce, je suis preneur smile. De mon côté, je continue mes recherches.

Merci smile


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#6 Le 01/06/2016, à 05:19

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Après la purge de pepperflashplugin-nonfree et l'installation de adobe-flashplugin Vivaldi n'a plus accès au plugin flash, mais Opera dernière version oui. Peut-être qu'il est impacté ou peut-être qu'il utilise tout simplement la version d'adobe-flashplugin.

Ce que j'aimerais savoir c'est si il est possible d'installer ce plugin à Vivaldi considérant que l'adresse utilisé par Opera est:  /usr/lib/adobe-flashplugin/libpepflashplayer.so ?

En espérant ne pas être trop confus smile


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#7 Le 01/06/2016, à 12:51

Coeur Noir

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Ah ! Étonnant que Vivaldi réagisse différemment d'Opéra.

Il faudrait trouver dans Vivaldi où est habituellement "rangé" le plugin flash et créer de là un lien pointant vers libpepflashplayer.so - encore une fois c'est une idée non testée chez moi, car je n'utilise pas les navigateurs non-libres.

Hors ligne

#8 Le 01/06/2016, à 12:53

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Bonne idée, je vais vérifier.


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#9 Le 01/06/2016, à 13:07

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

L'emplacement habituelle du plugin flash de Vivaldi se situe ici: /usr/lib/PepperFlash/libpepflashplayer.so. Je ne sais absolument pas créer un lien qui pointerait vers /usr/lib/adobe-flashplugin/libpepflashplayer.so ? Tu as une idée de la procédure ? Copier le fichier libpepflashplayer.so de /usr/lib/adobe-flashplugin/ vers /usr/lib/PepperFlash/ ?

Pierre

Dernière modification par Pierre_K (Le 01/06/2016, à 13:08)


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#10 Le 01/06/2016, à 13:24

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Ok ça fonctionne... J'ai recréé le dossier PepperFlash dans /usr/lib/ en y copiant le fichier libpepflashplayer.so. Ce qui est dommage c'est que je devrai répéter la manoeuvre à chaque mise à jour du plugin. C'est quand même un bon compromis dans les circonstances.

Voilà ! Une meilleure idée ?

Merci beaucoup de ton aide Coeur Noir.


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#11 Le 01/06/2016, à 14:41

littlejohn75

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Pierre_K a écrit :

J'ai recréé le dossier PepperFlash dans /usr/lib/ en y copiant le fichier libpepflashplayer.so.

Pierre_K a écrit :

Une meilleure idée ?

Utiliser un lien symbolique ( ln -s ) au lieu d'une copie ?

Cordialement,
Regards,
Mit freundlichen Grüssen,
ﻢﻋ  ﺖﺤﻳﺎﺘﻳ ﺎﻠﺧﺎﻠﺻﺓ
---
F. Petitjean
« Celui qui, parti de rien, n'est arrivé nulle part n'a de merci à dire à personne !! »
       Pierre Dac

Hors ligne

#12 Le 01/06/2016, à 15:55

Coeur Noir

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Oui c'est tout à fait çà littlejohn75 !

Ça devrait ressembler à :

sudo ln -s /usr/lib/adobe-flashplugin/libpepflashplayer.so /usr/lib/PepperFlash/libpepflashplayer.so

Hors ligne

#13 Le 01/06/2016, à 22:58

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Merci, je vais essayer ce soir (heure du Québec). smile


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#14 Le 02/06/2016, à 00:38

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Bonsoir,

La commande à très bien marché. Merci !! En théorie lorsque cette version de flash aura une mise à jour le lien symbolique la prendra en compte sans aucune intervention de ma part ?

Merci à tous les deux de votre aide précieuse smile


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne

#15 Le 02/06/2016, à 00:47

Coeur Noir

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

C'est ça : la mise à jour modifiera le fichier libpepflashplayer.so situé dans /usr/lib/adobe-flashplugin/ auquel le lien /usr/lib/PepperFlash/libpepflashplayer.so continuera de renvoyer.

Supprimer le lien ne supprime pas le fichier cible. Supprimer le fichier cible ne supprime pas le lien mais le lien est alors cassé (cible un fichier qui n'existe plus).

Hors ligne

#16 Le 02/06/2016, à 00:50

Pierre_K

Re : [alternative] Impossibilité de mettre à jour pepperflashplugin-nonfree

Génial !! C'est exactement ce que je voulais.

Encore merci !


Cordialement, Pierre_K
Desktop: Carte graphique: Nvidia Geforce GTX 760, RAM: 32 go, Carte mère: Gigabyte Z170-HD3: Core i7Intel 4 GHZ, Voyager 16.04 64 bits. Portable :Lenovo Think Pad E520, Carte graphique intégré intel HD 3000,RAM: 4 go, Proc. Intel core i5,Système d'exploitation: Voyager 14.04 64 bits.

Hors ligne