Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/07/2016, à 13:02

jdt37b

[Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Bonjour,
Avec le matériel ci-dessous, tout était OK en version Xubuntu 14.04 mais passant à la 16.04.1, problème :
1) Au boot et reboot, la recherche du Wifi de ma box n'aboutit pas.
2) Si je coupe la recherche par "Se déconnecter" puis tentative de connexion à un des autres réseaux visibles, puis nouvel arrêt de cette recherche et enfin nouvelle tentative sur le wifi de ma box NB6 , cette fois la connexion aboutit.
3) Si connecté au wifi, déconnection de l'utilisateur puis reconnexion, la connexion wifi se fait bien.
Pour compléter : sécurité "Wpa et Wpa2 personnel", code réseau wls1 (et non wlan0), linux-firmware 1.157.2
Merci de votre aide.

lspci | grep -i net
03:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 Ethernet controller: Qualcomm Atheros AR8131 Gigabit Ethernet (rev c0)

iwconfig
lo        no wireless extensions.
wls1      IEEE 802.11bgn  ESSID:"XXXXXXXX"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: xx:xx:xx:xx:xx:xx   
          Bit Rate=39 Mb/s   Tx-Power=14 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-34 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:74   Missed beacon:0
ens5      no wireless extensions.

lspci -nnk | grep -iA2 net
03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
	Subsystem: AzureWave AW-NE785 / AW-NE785H 802.11bgn Wireless Full or Half-size Mini PCIe Card [1a3b:1089]
	Kernel driver in use: ath9k
--
04:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8131 Gigabit Ethernet [1969:1063] (rev c0)
	Subsystem: ASUSTeK Computer Inc. AR8131 Gigabit Ethernet [1043:1820]
	Kernel driver in use: atl1c
	Kernel modules: atl1c

Dernière modification par jdt37b (Le 28/07/2016, à 17:58)


Acer Aspire XC330 - AMD A9-9420 - 4Go - HDD 1To - AMD Radeon R5 - Xubuntu 20.04 LTS - 64 bits
Asus VivoBook X515JA - Intel Core i3-1005G1 - 8Go - SSD 0,5To - Intel driver i915 - Xubuntu 20.04 LTS - 64 bits.

Hors ligne

#2 Le 26/07/2016, à 16:44

xubu1957

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Bonjour,

Le secure boot est il désactivé ? 

Procédure recommandée avec les noyaux 4.4. (EDIT et certaines cartes Wi-Fi, voir  § 2 et début du § 3 (documentation) > [Tuto] Pas de Wi-fi ? Eléments importants à vérifier)

Documentation : desactiver_secure_boot

Dernière modification par xubu1957 (Le 20/11/2018, à 15:33)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 26/07/2016, à 21:00

jdt37b

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Bonsoir,
Pas de secure boot sur mon PC Asus X72J.
J'ai constaté que le problème a lieu si le signal est <= 60%  environ, en rapprochant mon PC de la box, c'est ok avec un signal de 90%.
Est-il possible de paramétrer la sensibilité du récepteur Wifi sur le PC ?   (si oui, je mettrai la même qu'en 14.04 où c'est Ok).
Merci.


Acer Aspire XC330 - AMD A9-9420 - 4Go - HDD 1To - AMD Radeon R5 - Xubuntu 20.04 LTS - 64 bits
Asus VivoBook X515JA - Intel Core i3-1005G1 - 8Go - SSD 0,5To - Intel driver i915 - Xubuntu 20.04 LTS - 64 bits.

Hors ligne

#4 Le 26/07/2016, à 21:26

xubu1957

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Dans la documentation : wifi_liste_carte

§ 2.2 Atheros a écrit :

Atheros AR9285     Reconnue par défaut.  En cas de lenteur, dans l'interface de configuration de votre routeur, vérifiez le canal utilisé : s'il est en mode "automatique", tentez d'attribuer un canal manuel inférieur à 10. ou essayez la commande :

echo "options ath9k nohwcrypt=1" | sudo tee -a /etc/modprobe.d/ath9k.conf

En cas de difficultés persistantes on peut essayer de faire charger le pilote au démarrage avec la commande :

echo ath9k | sudo tee -a /etc/modules

sudo echo ath9k » /etc/modules

(edit= commande actualisée)

Dernière modification par xubu1957 (Le 11/01/2018, à 20:10)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 27/07/2016, à 08:51

jdt37b

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Ok, la commande avec nohwcrypt=1 a réglé le problème.
Je profite de l'occasion : pour le réglage de la puissance du chipset, avec un débit maxi de 8M sur ma box, pour une distance PC-box de 10 m maxi, est-ce correct  :
Fichier  /etc/init.d/rc.local :
iwconfig wls1 rate 8M
iwconfig wls1 txpower 2mW
Re-merci !


Acer Aspire XC330 - AMD A9-9420 - 4Go - HDD 1To - AMD Radeon R5 - Xubuntu 20.04 LTS - 64 bits
Asus VivoBook X515JA - Intel Core i3-1005G1 - 8Go - SSD 0,5To - Intel driver i915 - Xubuntu 20.04 LTS - 64 bits.

Hors ligne

#6 Le 27/07/2016, à 17:23

xubu1957

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Attends d'autres avis que le mien, je ne me sers pas du Wifi, j'utilise du CPL à la maison , et je trimbale des câbles lorsque je vais à ma réunion de linux-azur.org/ !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 28/07/2016, à 17:58

jdt37b

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Bonjour Xubu1957,
Avec les 2 commandes en #4 le pb semblait réglé à 90%, encore quelques aléas, en changeant aussi le canal sur la box et les paramètres iwconfig, presque à 100%
Je n'avais eu aucun problème Wifi  en installant Xubuntu 14.04.1 mais avec la 16.04.1 la version de network-manager a apparemment régressé pour l'AR8285, ce fut plus compliqué ! Merci pour l'aide, je mets en "Résolu".


Acer Aspire XC330 - AMD A9-9420 - 4Go - HDD 1To - AMD Radeon R5 - Xubuntu 20.04 LTS - 64 bits
Asus VivoBook X515JA - Intel Core i3-1005G1 - 8Go - SSD 0,5To - Intel driver i915 - Xubuntu 20.04 LTS - 64 bits.

Hors ligne

#8 Le 28/07/2016, à 18:28

xubu1957

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Merci pour ton retour, la version 16.04.1 est jeune, et je l'espère , perfectible, même pour le wifi !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 20/09/2016, à 09:31

jdt37b

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

xubu1957,
Pour info, dans un environnement encombré (bluetooth, téléphone DECT, murs, parties métalliques, autres réseaux wifi, ...) et à 6m de distance d'une box à 8000 kbps maxi, après moult tests et plusieurs semaines d'utilisation :
Ce qui a fait nettement la différence pour obtenir une connexion correcte en temps et en débit, c'est de baisser le tx-power et le bitrate de la carte Wifi comme ça :
Dans le fichier  /etc/rc.local :

ifconfig wls1 up
iwconfig wls1 txpower 5mW
iwconfig wls1 rate 11.0M auto

Si ça peut être utile !


Acer Aspire XC330 - AMD A9-9420 - 4Go - HDD 1To - AMD Radeon R5 - Xubuntu 20.04 LTS - 64 bits
Asus VivoBook X515JA - Intel Core i3-1005G1 - 8Go - SSD 0,5To - Intel driver i915 - Xubuntu 20.04 LTS - 64 bits.

Hors ligne

#10 Le 20/09/2016, à 16:43

xubu1957

Re : [Résolu] Xubuntu 16.04 + Atheros AR9285 : wifi KO au (re)boot

Bonjour,

Le principe de notre forum d'entraide est aussi basé sur un partage d'information.

Merci d'avoir affiché cette possibilité ! smile


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne