Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/12/2016, à 16:34

chbic

[résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

Bonjour,
j'utilise un lecteur de carte vital qui est géré par un logiciel maison de mon fournisseur. Ce logiciel a bien fonctionné de la version 12.04 jusqu'à la version 14.04, mais au passage à la version 16.04 j'ai eu droit à ça:

E: Impossible de trouver le paquet libwxgtk2.8-0
E: Couldn't find any package by glob 'libwxgtk2.8-0'
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libwxgtk2.8-0 »

alors j'ai cherché à installer le paquet libwxgtk2.8-0_2.8.12.1-6ubuntu2_amd64.deb
Arrivé à ce niveau, il y avait des problèmes de dépendance, alors j'ai suivi les recommandation et fait:

tissot@asus-R900V:~/ubinect$ sudo apt-get -f install

et j'ai obtenu

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 linux-headers-4.4.0-51
  linux-headers-4.4.0-51-generic linux-image-4.4.0-51-generic
  linux-image-extra-4.4.0-51-generic ubuntu-core-launcher
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
The following additional packages will be installed:
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
Paquets suggérés :
  libvisual-0.4-plugins gstreamer0.10-tools gstreamer0.10-plugins-base
Les paquets suivants seront ENLEVÉS :
  libwxgtk2.8-0
Les NOUVEAUX paquets suivants seront installés :
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
0 mis à jour, 2 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 1 089 ko dans les archives.
Après cette opération, 6 014 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 

réponse o, puis:

Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 libgstreamer0.10-0 amd64 0.10.36-1.5ubuntu1 [646 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 libgstreamer-plugins-base0.10-0 amd64 0.10.36-2 [443 kB]
1 089 ko réceptionnés en 1s (910 ko/s)                   
(Lecture de la base de données... 272487 fichiers et répertoires déjà installés.)
Suppression de libwxgtk2.8-0:amd64 (2.8.12.1-6ubuntu2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
Sélection du paquet libgstreamer0.10-0:amd64 précédemment désélectionné.
(Lecture de la base de données... 272452 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb ...
Dépaquetage de libgstreamer0.10-0:amd64 (0.10.36-1.5ubuntu1) ...
Sélection du paquet libgstreamer-plugins-base0.10-0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb ...
Dépaquetage de libgstreamer-plugins-base0.10-0:amd64 (0.10.36-2) ...
Paramétrage de libgstreamer0.10-0:amd64 (0.10.36-1.5ubuntu1) ...
Paramétrage de libgstreamer-plugins-base0.10-0:amd64 (0.10.36-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...

Je me disais chouette ça a marché mais quand j'ai essayé le lecteur n'était toujours pas reconnu alors j'ai relancé l'installation du logiciel de gestion du lecteur de carte vital et j'ai obtenu:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libwxgtk2.8-0 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libwxgtk2.8-0 » n'a pas de version susceptible d'être installée

Voila, je suis un peu perdu. Pourriez-vous m'aider.
Par avance merci
Loïc.

Dernière modification par chbic (Le 22/12/2016, à 09:14)

Hors ligne

#2 Le 21/12/2016, à 17:00

cqfd93

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

Bonjour,

Apparemment, tu peux trouver ce paquet dans un ppa : voir là.


cqfd93

Hors ligne

#3 Le 21/12/2016, à 17:05

chbic

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

Je l'ai déjà fait avec un autre dépôt. Je vais ré-essayer avec ce liens et on verra bien.

Hors ligne

#4 Le 21/12/2016, à 17:13

chbic

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

J'ai téléchargé le paquet avec le liens qu tu m'as donné et voila ce que ça donne avec dpkg:

tissot@asus-R900V:~/Téléchargements$ sudo dpkg -i libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2+1~webupd8~xenial0_amd64.deb
Sélection du paquet libwxgtk2.8-0:amd64 précédemment désélectionné.
(Lecture de la base de données... 272511 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2+1~webupd8~xenial0_amd64.deb ...
Dépaquetage de libwxgtk2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2+1~webupd8~xenial0) ...
dpkg: des problèmes de dépendances empêchent la configuration de libwxgtk2.8-0:amd64 :
 libwxgtk2.8-0:amd64 dépend de libwxbase2.8-0 (>= 2.8.12.1+dfsg2) ; cependant :
  Le paquet libwxbase2.8-0 n'est pas installé.

dpkg: erreur de traitement du paquet libwxgtk2.8-0:amd64 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
Des erreurs ont été rencontrées pendant l'exécution :
 libwxgtk2.8-0:amd64

Hors ligne

#5 Le 21/12/2016, à 17:16

cqfd93

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

Pour régler le problème de dépendances :

sudo apt-get install -f

devrait le faire.

Ou peut-être que tu devras installer de la même façon : libwxbase2.8-0.

J'y pense : tu as installé le ppa ? Ça serait quand même mieux que d'aller pêcher les dépendances une à une…


cqfd93

Hors ligne

#6 Le 21/12/2016, à 17:25

chbic

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

voila ce qu'il me met

tissot@asus-R900V:~$ sudo apt-get install -f
[sudo] Mot de passe de tissot : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 linux-headers-4.4.0-51
  linux-headers-4.4.0-51-generic linux-image-4.4.0-51-generic
  linux-image-extra-4.4.0-51-generic ubuntu-core-launcher
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libwxgtk2.8-0
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 10,7 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 

Je l'ai déja fait précédemment et il va me désinstallé le paquet  libwxgtk2.8-0
mais bon allons jusqu'au bout je rentre o et j'obtiens:

(Lecture de la base de données... 272545 fichiers et répertoires déjà installés.)
Suppression de libwxgtk2.8-0:amd64 (2.8.12.1+dfsg2-2ubuntu2+1~webupd8~xenial0) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...

Voila retour à la case départ!

Hors ligne

#7 Le 21/12/2016, à 17:26

chbic

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

C'est quoi le ppa?

Hors ligne

#8 Le 21/12/2016, à 17:34

cqfd93

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

chbic a écrit :

voila ce qu'il me met

tissot@asus-R900V:~$ sudo apt-get install -f
…
Les paquets suivants seront ENLEVÉS :
  libwxgtk2.8-0
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 10,7 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 

Je l'ai déja fait précédemment et il va me désinstallé le paquet  libwxgtk2.8-0

Voila retour à la case départ!

Effectivement ! big_smile

C'est quoi le ppa?

Tu peux le trouver . Il faudra remplacer <package name> par libwxgtk2.8-0.


cqfd93

Hors ligne

#9 Le 21/12/2016, à 19:16

chbic

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

ok ça a marché, le lecteur est reconnu par le logiciel.
il y a juste le message suivant qui me laisse dubitatif:

Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
insserv: warning: script 'ubinect' missing LSB tags and overrides

mais je verrai à l'usage.

Un grand merci.

Hors ligne

#10 Le 21/12/2016, à 22:00

cqfd93

Re : [résolu] pb avec libwxgtk2.8-0 migration vers Ubuntu 16.04 LTS

chbic a écrit :

ok ça a marché, le lecteur est reconnu par le logiciel.

Super, contente pour toi !

il y a juste le message suivant qui me laisse dubitatif:

Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
insserv: warning: script 'ubinect' missing LSB tags and overrides

mais je verrai à l'usage.

Ce genre de messages ne me parle pas du tout smile

Un grand merci.

De rien ! Pense à marquer ton sujet comme résolu en modifiant le titre depuis le premier message.


cqfd93

Hors ligne