Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/08/2017, à 22:02

Pcerrip

[Résolu] Un navigateur qui me convient

Bonjour,

Je sais que ce sujet a déjà était abordè, mais je n'ai jusqu'ici pas trouvé de reponse me correspondant.
Etant débutant sur Ubuntu je suis à la recherche d'un navigateur web compatible, rapide, sécurisé (pas chrome), et qui prennent en charge la plupart des sites.
En plus clair j'aimerai trouve un navigateur qui m'offre une experience professionel des plus simple, et qui reste sécurisé.
Je me répète mais si je devais résumé le navigateur que je recherche en trois mots se serait : simple, rapide, sécurisé.

Merci d'avance.

Dernière modification par Pcerrip (Le 23/08/2017, à 00:32)

Hors ligne

#2 Le 14/08/2017, à 22:12

JBF

Re : [Résolu] Un navigateur qui me convient

Déjà tu devrais donner la liste de ceux que tu as essayés, qui ne te conviennent pas et pourquoi ils ne te conviennent pas.


LibreOffice : https://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#3 Le 14/08/2017, à 22:17

GammaDraconis

Re : [Résolu] Un navigateur qui me convient

Pcerrip a écrit :

en trois mots se serait : simple, rapide, sécurisé.

Bah Firefox tout simplement.


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#4 Le 14/08/2017, à 23:12

Roschan

Re : [Résolu] Un navigateur qui me convient

Firefox ? Chromium ?

Hors ligne

#5 Le 15/08/2017, à 18:39

Brice Jeunieaux

Re : [Résolu] Un navigateur qui me convient

Bonjour Pcerrip,

Si tu recherches des informations quand aux différents navigateurs utilisables, je trouve cette page particulièrement utile :
https://doc.ubuntu-fr.org/navigateur

Personnellement, j'utilise généralement Chromium, que j'ai installé, mais j'ai également Firefox, par défaut, qui reste très rapide aussi. smile

Hors ligne

#6 Le 16/08/2017, à 16:45

legrand98

Re : [Résolu] Un navigateur qui me convient

BRAVE est bien aussi et sans PUB gênante.

Hors ligne

#7 Le 16/08/2017, à 17:22

nam1962

Re : [Résolu] Un navigateur qui me convient

A priori un Firefox correctement sécurisé fait le boulot.
Maintenant chacun a ses coquetteries et il existe une tripotée d'autres navigateurs plus ou moins utilisables (de Min ou Netsurt à Brave, déjà cité, en passant par Opera, Qupzilla, Midori, voire w3m pour avoir un navigateur dans le terminal...)
Le seul moyen est de les tester !
J 'ai [url=[modéré : pas d’auto-pub, merci]-le-bon-navigateur-avec-les-bonnes-extensions/]testé quelques navigateurs sous Linux[/url] , perso, je reviens invariablement à Firefox avec Qupzilla en navigateur de secours


[ Modéré ]

Hors ligne

#8 Le 16/08/2017, à 19:53

erresse

Re : [Résolu] Un navigateur qui me convient

Salut nam,
Après une mise à jour de Firefox, j'ai eu la surprise de trouver toutes les extensions notée "Obsolète"...
Un message de Mozilla informe qu'un nouveau format va être mis en place pour le développement des extensions, et que la version 57 de FF ne supportera plus les extensions qui n'ont pas été développées avec le nouveau format. sad
Est-ce que tu as vu ça aussi ? Sais-tu si une reprise des différentes extensions est prévue ?
Parce-que là, ni µbloc origin, ni better privacy, etc... ne seront plus disponibles du coup !


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#9 Le 16/08/2017, à 20:06

nam1962

Re : [Résolu] Un navigateur qui me convient

Effectivement, il y a un petit suspense dans la perspective du changement de standard des extensions FF

1502906456.png

Cela dit, webextensions ne sera exclusif qu'en novembre, en attendant, les devs discutent : https://blog.mozilla.org/addons/2017/07 … irefox-56/

A ce stade je ne suis pas trop inquiet : des extensions comme ublock origin qui tournent déjà sous Chrome ou Safari passeront certainement sans soucis.

J'ai déjà vu une ou deux fois l'une de mes préférées (TabMixPlus) ne pas réussir un passage de version, puis finalement être adaptée.


[ Modéré ]

Hors ligne

#10 Le 16/08/2017, à 21:40

J5012

Re : [Résolu] Un navigateur qui me convient

oui ce sont les reglementations de developpement pour les xpi qui seront desormais plus rigoureuses pour eviter les bugs instables qui perduraient à cause de la paresse "securitaire" de certains dev ... mozilla a pris le taureau wink

mozilla demande seulement à ces devs d'ecrire correctement les entetes xpi et certains trucs d'acces et permissions explicites ... corrections de sources pas bien compliquées ...

Hors ligne

#11 Le 16/08/2017, à 22:34

JBF

Re : [Résolu] Un navigateur qui me convient

Je crois que c'est un peu plus complexe que ça : https://blog.mozilla.org/addons/2017/08 … ions-apis/


LibreOffice : https://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#12 Le 17/08/2017, à 11:56

J5012

Re : [Résolu] Un navigateur qui me convient

hahah ... le lien que tu cites jbf demontre par lui-meme que noscripts s'est laissé emporter ...alors que si ils avaient suivi les recommendations de mozilla dev des le depart ? ils n'auraient pas eu tout ces trucs à faire ...

Hors ligne

#13 Le 17/08/2017, à 12:26

JBF

Re : [Résolu] Un navigateur qui me convient

J5012 a écrit :

hahah ... le lien que tu cites jbf demontre par lui-meme que noscripts s'est laissé emporter ...alors que si ils avaient suivi les recommendations de mozilla dev des le depart ? ils n'auraient pas eu tout ces trucs à faire ...

Tu peux détailler ?


LibreOffice : https://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#14 Le 17/08/2017, à 12:39

J5012

Re : [Résolu] Un navigateur qui me convient

JBF a écrit :
J5012 a écrit :

hahah ... le lien que tu cites jbf demontre par lui-meme que noscripts s'est laissé emporter ...alors que si ils avaient suivi les recommendations de mozilla dev des le depart ? ils n'auraient pas eu tout ces trucs à faire ...

Tu peux détailler ?

as-tu au moins lu en details la page que tu as cité ?

Hors ligne

#15 Le 17/08/2017, à 13:12

JBF

Re : [Résolu] Un navigateur qui me convient

Ben oui, mais je n'ai pas du comprendre la même chose que toi.


LibreOffice : https://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#16 Le 20/08/2017, à 14:41

J5012

Re : [Résolu] Un navigateur qui me convient

Originally released in 2005, NoScript was developed to address security vulnerabilities in browsers by pre-emptively blocking scripts from untrusted websites. Over the time it grew into a security suite including many additional and often unique countermeasures against various web-based threats ...

→ no script a evolué en un ensemble plus complexe et sophistiqué : le programme est devenu un gros mammouth difficile à maintenir sad

The so-called “legacy” add-on technology which NoScript has been built with is going to be banned very soon; therefore, like too often in real life, it’s either migrate or die. Many people rely on NoScript for being safer on the Web and in some cases for their physical security too, making this transition, although quite painful, an ethical obligation not to leave them in the cold.

→ le programme etant devenu plus complexe, il ne suivait plus les recommendations dev de mozilla : bien avant que les techno dites legacy soient interdites ... : elles ont ete interdites pour la raison que beaucoup de dev de plugin ne suivaient pas les recommendations dev de mozilla qui incluaient le fait de ne pas les utiliser !

For a long time, I strove to maintain as much backwards compatibility as possible, in order to offer some protection to those users stuck for various reasons with older, inherently less safe, versions of Firefox. For this reason, the legacy version of NoScript contains a lot of code for working around bugs that Firefox has since fixed: this cruft can safely go away during the migration. The plan is to have a lean and mean version of NoScript available as soon as Firefox 57 is released. Some of the APIs required for full parity with the legacy version won’t land until Firefox 57

→ un gros blabla pour s'excuser de resoudre les bugs de firefox ... : mozilla fournit depuis longtemps le compartimentage des versions et sous-versions de firefox en relatiion avec les extensions ...

le reste du discours est de l'autopub ...

https://developer.mozilla.org/en-US/Add … Extensions
la revolution a commencé en firefox v51 ...
elle se termine en firefox v57 où tous les plugins doivent avoir ete migrés ... mais cette version 57 n'est pas encore sortie ...

https://developer.mozilla.org/en-US/Add … cy_add_ons

l'erreur des dev de noscripts est l'erreur de beaucoup de dev : developper plein de fonctionnalités sans regarder à la complexité ...

Hors ligne

#17 Le 21/08/2017, à 13:48

Pcerrip

Re : [Résolu] Un navigateur qui me convient

Merci pour toute vos réponse smile

Hors ligne

#18 Le 21/08/2017, à 20:49

Martial34

Re : [Résolu] Un navigateur qui me convient

On peut déjà utiliser des WebExtensions. Il suffit de cliquer sur l’étiquette verte, à droite.

Hors ligne

#19 Le 21/08/2017, à 21:49

nam1962

Re : [Résolu] Un navigateur qui me convient

Uhhh, pas cliquable chez moi !


[ Modéré ]

Hors ligne

#20 Le 15/09/2017, à 14:09

Pimprelune

Re : [Résolu] Un navigateur qui me convient

Hello le Forum, coucou les Ubunteros !

Heureusement que je lis les recherches (un peu plus et je faisais - encore - un doublon), mais novembre, c'est bientôt et j'ai des applications (recommandées par vous et les membres de l'Axul) qui cafouillent : seront-elles "reconduites" ?

1505497446.png

Martial34 a écrit :

On peut déjà utiliser des WebExtensions. Il suffit de cliquer sur l’étiquette verte, à droite.

Et tout pareil que nam1962, pas cliquables (les liens verts tout à droite de la liste) pour moi non plus sad . Le numéros (en vert) au milieu, oui...

Donc - en bonne MQI - je balise dur en pensant à mon moteur de recherches - QWant - que j'adooore, ainsi qu'à Mes pense-bêtes (pour la tête en l'air de service, c'est incontournable !).

Je ne sais ce qu'il adviendra de BetterPrivacy, donc faut-il que j'ouvre un sujet spécialement pour demander une alternative à ce module en particulier ?

Mais si j'ai bien suivi, jusqu'à fin octobre, les "Obsolete" fonctionnent normalement ?


Merci d'avance pour vos réponses, bonne journée, tout le monde tongue !

Dernière modification par Pimprelune (Le 15/09/2017, à 19:44)


Ne vous trompez pas entre ma personnalité et mon attitude. Ma personnalité est "qui je suis", mon attitude dépend de "qui vous êtes"...
YES
Clics ici et
Aïe !

Hors ligne

#21 Le 15/09/2017, à 14:20

nam1962

Re : [Résolu] Un navigateur qui me convient

En fait Betterprivacy est devenu inutile, il suffit d'aller dans [Édition] - [Préférences] - [Vie privée] et de mettre ces réglages :

1505477985.png


[ Modéré ]

Hors ligne

#22 Le 15/09/2017, à 14:23

JBF

Re : [Résolu] Un navigateur qui me convient

Pas besoin d'extension pour utiliser Qwant et en faire son moteur de recherche par défaut.


LibreOffice : https://fr.libreoffice.org/ (téléchargement, documentation, FAQ, assistance, contribuer, ...)
Aide pour LibreOffice par la communauté francophone : https://ask.libreoffice.org/fr/

Hors ligne

#23 Le 15/09/2017, à 14:40

Martial34

Re : [Résolu] Un navigateur qui me convient

Oups ! Je m’aperçois que j’ai été quelque peu dyslexique : ce n’est pas à droite qu’il faut cliquer, c’est évidemment à gauche, quand le lien est cliquable.
Avant d’activer la protection contre le pistage, il faut savoir qu’elle est gérée par Google, qui a une conception très personnelle du pistage. Il est beaucoup plus prudent d’attendre que BetterPrivacy passe en WebExtension, comme cela est prévu.

Hors ligne

#24 Le 15/09/2017, à 14:41

Pimprelune

Re : [Résolu] Un navigateur qui me convient

Merci pour vos promptes réponses à tous les deux, nam1962 et JFB (dont le pseudo fait plus que me parler, mais c'est anecdotique wink...) !

@nam1962 : j'ai déjà l'onglet (pour le pistage) configuré comme sur ta capture, par contre, ça ne fait rien si j'ai de décoché les "Conservations" de l'historique de navigation et celui des recherches et des formulaires ?

@JFB : comment ça, pas besoin d'extension ? Il faudrait donc que je "l'installe" différemment, pour que ce soit mon moteur de recherches par défaut ?

Mais dans mes Préférences, il y est déjà !?! --> 1505478773.png

J'ai cafouillé quelque part dans ma configuration personnelle, récemment (ce qui expliqueraient mon énorme bug actuel ?) ?

[HS](Surtout que j'ai un truc bizarre -

Bureau a écrit :

Old firefox Data

- dans Nautilus qui apparaît tou.jours !)[/]HS]

Dernière modification par Pimprelune (Le 15/09/2017, à 14:56)


Ne vous trompez pas entre ma personnalité et mon attitude. Ma personnalité est "qui je suis", mon attitude dépend de "qui vous êtes"...
YES
Clics ici et
Aïe !

Hors ligne

#25 Le 15/09/2017, à 14:52

Pimprelune

Re : [Résolu] Un navigateur qui me convient

Aaaaaaah merci, Martial34 !

Mais tu es sûr que BetterPrivacy va updater/upgrader ?

Non, car en cliquant sur le Plus de ce module dans mon Gestionnaire de Modules Complémentaires, la page sur laquelle j'aboutis ne le laisse pas présumer -->

IKRG a écrit :

This add-on has been removed by its author.


Ne vous trompez pas entre ma personnalité et mon attitude. Ma personnalité est "qui je suis", mon attitude dépend de "qui vous êtes"...
YES
Clics ici et
Aïe !

Hors ligne