Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/04/2018, à 08:40

Antoinexten

[résolu] problème d'affichage Processeur I7 8700

Bonjour,

Je suis nouveau sur KUBUNTU ...

J'essaye d'ajouter une définition d'affichage en suivant le tuto très bien fait ...
J'ai l'erreur suivante :
oem@HAURRENDAKO:~$ xrandr --newmode "3840x2160_60"  712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync
xrandr: Failed to get size of gamma for output default

La commande xrandr renvoie quant à elle :
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00*
  3840x2160_60 (0x30f) 712.750MHz -HSync +VSync
        h: width  3840 start 4160 end 4576 total 5312 skew    0 clock 134.18KHz
        v: height 2160 start 2163 end 2168 total 2237           clock  59.98Hz

Mon écran est un 4K LG
Carte mère ASUS Z370
Processeur I7 8700
(pas de carte graphique)
KUBUNTU 16.04.4 LTS

Merci pour votre aide !

Antoinexten.

[edit modo] : scindé du topic ./viewtopic.php?pid=21896625#p21896625. Pour la lisibilité du forum, c’est mieux d’ouvrir un nouveau topic par problème. smile

Dernière modification par Sir Na Kraïou (Le 01/04/2018, à 21:32)


Ubuntu 18.04.1 LTS - CM ASUS Z370 TUF GAMING PLUS - INTEL I 7 8700 - écran LG 24UD58B (4K) - GNOME 3.28.2 - Intel® HD Graphics (Coffeelake 3x8 GT2) - 8Go RAM

Hors ligne

#2 Le 01/04/2018, à 08:51

xubu1957

Re : [résolu] problème d'affichage Processeur I7 8700

@ Antoinexten

Bonjour,

Pour ajouter toi-même les balises code à ton précédent message #6 :

  • Cliquer sur  le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

1485703524.png

comme indiqué dans le : Retour utilisable de commande


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 01/04/2018, à 09:15

youssoufB

Re : [résolu] problème d'affichage Processeur I7 8700

ton serveur X est certainement mal configuré.
essaye de jeter un oeuil sur les log /var/log/Xorg.0.log
sous kubuntu tu peut faire Applications->Système->KSystemLog->journal de X.org
recherche en premier lieu les (EE)
en mode console.

cat /var/log/Xorg.0.log | grep "(EE)"

pour trouver les erreurs qui sont survenue pandant la mise en place du serveur graphique.

fait aussi un:

lspci | grep "VGA"

pour savoir quel est le contrôleur.

normalement avec une configuration récente tu ne devrais pas avoir à changer le mode d'affichage ton écran est certainement plug&play il fournis les info au système.

Dernière modification par youssoufB (Le 01/04/2018, à 09:30)


mail et moteur de recherche: Lilo

Hors ligne

#4 Le 01/04/2018, à 11:50

Antoinexten

Re : [résolu] problème d'affichage Processeur I7 8700

@youssoufB

Bonjour !

Merci pour ton retour !

J'ai lancé la commande que tu as citée :

oem@HAURRENDAKO:/var/log$ cat /var/log/Xorg.0.log | grep "(EE)"

Il y a effectivement quelques erreurs sad

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     5.450] (EE) open /dev/dri/card0: No such file or directory
[     5.450] (EE) open /dev/dri/card0: No such file or directory
[     5.450] (EE) Screen 0 deleted because of no matching config section.
[     5.464] (EE) AIGLX: reverting to software rendering

Et la commande :

oem@HAURRENDAKO:/var/log$ lspci | grep "VGA"

Donne :

00:02.0 VGA compatible controller: Intel Corporation Device 3e92

Est-ce le bon contrôleur sachant que sur la carte mère ASUS c'est un Integrated Processor Intel HD Graphics support avec un port DVI et un port HDMI (l'écran est branché sur le port HDMi) ?

Merci.

Anoinexten.


Ubuntu 18.04.1 LTS - CM ASUS Z370 TUF GAMING PLUS - INTEL I 7 8700 - écran LG 24UD58B (4K) - GNOME 3.28.2 - Intel® HD Graphics (Coffeelake 3x8 GT2) - 8Go RAM

Hors ligne

#5 Le 01/04/2018, à 12:25

youssoufB

Re : [résolu] problème d'affichage Processeur I7 8700

le problème c'est que /dev/dri/card0 n'existe pas
voila ce qu'est le DRI

il faudrait essayer de réinstaller le serveur cela corrigerais l'erreur

j'ai vue ça aussi:

Problem: /dev/dri/card0 is missing
The /dev/dri/card0 device file is provided by the Linux kernel. If the file is missing, it prevents hardware acceleration from working. See if reloading the kernel module makes it work:
# Save your work first!
$ sudo rmmod i915
$ sudo modprobe i915
$ lsmod | grep i915
i915 65412 1
drm 96424 2 i915
$ sudo pkill X

ici


mail et moteur de recherche: Lilo

Hors ligne

#6 Le 01/04/2018, à 12:57

Antoinexten

Re : [résolu] problème d'affichage Processeur I7 8700

Merci bcp !
J'ai fait la réinstall mais j'ai toujours l'erreur :

oem@HAURRENDAKO:/var/log$ sudo apt-get install --reinstall xserver-xorg-video-intel xserver-xorg-core

Qui donne :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libxfont2 xserver-xorg-legacy-hwe-16.04
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 2 réinstallés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/2 060 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 200468 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../xserver-xorg-core_2%3a1.18.4-0ubuntu0.7_amd64.deb ...
Dépaquetage de xserver-xorg-core (2:1.18.4-0ubuntu0.7) sur (2:1.18.4-0ubuntu0.7) ...
Préparation du dépaquetage de .../xserver-xorg-video-intel_2%3a2.99.917+git20160325-1ubuntu1.2_amd64.deb ...
Dépaquetage de xserver-xorg-video-intel (2:2.99.917+git20160325-1ubuntu1.2) sur (2:2.99.917+git20160325-1ubuntu1.2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...
Paramétrage de xserver-xorg-core (2:1.18.4-0ubuntu0.7) ...
Paramétrage de xserver-xorg-video-intel (2:2.99.917+git20160325-1ubuntu1.2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...

J'ai ensuite cherché à nouveau les erreurs :

oem@HAURRENDAKO:/var/log$ cat /var/log/Xorg.0.log | grep "(EE)"

Et j'obtiens à nouveau :

 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     5.450] (EE) open /dev/dri/card0: No such file or directory
[     5.450] (EE) open /dev/dri/card0: No such file or directory
[     5.450] (EE) Screen 0 deleted because of no matching config section.
[     5.464] (EE) AIGLX: reverting to software rendering

Je tente l'autre solution ...

Merci encore pour votre aide.


Ubuntu 18.04.1 LTS - CM ASUS Z370 TUF GAMING PLUS - INTEL I 7 8700 - écran LG 24UD58B (4K) - GNOME 3.28.2 - Intel® HD Graphics (Coffeelake 3x8 GT2) - 8Go RAM

Hors ligne

#7 Le 01/04/2018, à 13:43

youssoufB

Re : [résolu] problème d'affichage Processeur I7 8700

voila plus la solution.
ta machine est trop récente pour les paramètre classique des distribution.
voila une autre solution , je pense que c'est de coté la que tu doit cherché.

C'est pour ça que je t'est parlé d'update. si  ça fonctionne pas il va falloir que tu voie du coté de ton noyau peut être faire une compilation d'un 4.15 ou plus récent.
pour connaître ta version:

uname -mr

normalement tu devrais avoir une 4.13 donc le post plus haut devrais fonctionné.

En lisant ce poste j'ai vue qu'on peut tapez:

grep (EE) /var/log/Xorg.0.log

à la place de:

cat /var/log/Xorg.0.log| grep (EE)

comme quoi ça sert d'aidé on apprend.

Dernière modification par youssoufB (Le 01/04/2018, à 13:54)


mail et moteur de recherche: Lilo

Hors ligne

#8 Le 01/04/2018, à 15:44

Antoinexten

Re : [résolu] problème d'affichage Processeur I7 8700

Alors, j'ai essayé l'autre solution ...
Mais la dernière commande a tout mis parterre (sudo -pkill X) ...
Bref , j'ai tout réinstallé  x !
Et là , miracle - à moitié - la pleine et entière définition est bien prise en compte (3840x2160) ... mais ... l'affichage se fait en mode "balayage" : à chaque fois que je bouge une fenêtre, et bien un balayage se produit sur l'écran ... l'image est nickelle , mais ça balaye ....

homesweethome@HAURRENDAKO:~$ uname -mr

donne

4.13.0-36-generic x86_64

Et maintenant en faisant :

homesweethome@HAURRENDAKO:~$ grep "EE" /var/log/Xorg.0.log

J'obtiens
     

  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     4.333] (EE) open /dev/dri/card0: No such file or directory
[     4.333] (EE) open /dev/dri/card0: No such file or directory
[     4.334] (EE) Screen 0 deleted because of no matching config section.
[     4.340] (EE) AIGLX: reverting to software rendering

Bref, j'y suis pas encore ....
En revanche , je ne comprends pas bien le post de la solution :
you need to boot the kernel with

i915.alpha_support=1

You can do this by editing the kernel command line manually during the boot, or by editing /etc/default/grub’s GRUB_CMDLINE_LINUX_DEFAULT. In the latter case, run update-grub before rebooting.

Je vais chercher.
Merci.


Ubuntu 18.04.1 LTS - CM ASUS Z370 TUF GAMING PLUS - INTEL I 7 8700 - écran LG 24UD58B (4K) - GNOME 3.28.2 - Intel® HD Graphics (Coffeelake 3x8 GT2) - 8Go RAM

Hors ligne

#9 Le 01/04/2018, à 15:56

Antoinexten

Re : [résolu] problème d'affichage Processeur I7 8700

Mon fichier grub a cette tete :

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Faut que je rajoute une ligne ?
Merci.


Ubuntu 18.04.1 LTS - CM ASUS Z370 TUF GAMING PLUS - INTEL I 7 8700 - écran LG 24UD58B (4K) - GNOME 3.28.2 - Intel® HD Graphics (Coffeelake 3x8 GT2) - 8Go RAM

Hors ligne

#10 Le 01/04/2018, à 16:25

youssoufB

Re : [résolu] problème d'affichage Processeur I7 8700

Il me semble que c'est la ligne:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

qu'il faut écrire:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.alpha_support=1"

fait quand même une sauvegarde de ton fichier en ajoutant un .original par exemple avant de changer.

sudo cp /etc/default/grub /etc/default/grub.original

ensuite:

sudo nano  /etc/default/grub

tu fait le changement et tu sort CTRL+x ->o->o

cat  /etc/default/grub

pour vérifier ton changement

update-grub 

dans la console avant de redémarré.

Dernière modification par youssoufB (Le 01/04/2018, à 16:30)


mail et moteur de recherche: Lilo

Hors ligne

#11 Le 01/04/2018, à 16:48

youssoufB

Re : [résolu] problème d'affichage Processeur I7 8700

Pour info ton :

sudo -pkill X

à stopper le serveur X du coup tu devais plus avoir d'affichage.
tu peut alors change de tty avec CTRL+ALT+F1à6 le 7 étant le tty utilisé par sddm pour le mode graphique.
ensuite tu te log et tu tape un

service sddm start

ou

service sddm restart

il va te redemandé une identification.
évite le

sudo service sddm start

personnellement j'ai eut des problème en passant direct en sudo.
c'est une Kubuntu les Ubuntu c'est lightdm au lieu de sddm.

de toute façons je ne pense pas que la bonne piste soit la. Mais pour info.


mail et moteur de recherche: Lilo

Hors ligne

#12 Le 01/04/2018, à 16:50

Antoinexten

Re : [résolu] problème d'affichage Processeur I7 8700

homesweethome@HAURRENDAKO:/etc/default$ sudo update-grub
Création du fichier de configuration GRUB…
Attention : Définir GRUB_TIMEOUT à une valeur non nulle si GRUB_HIDDEN_TIMEOUT est définie n’est plus possible.
Image Linux trouvée : /boot/vmlinuz-4.13.0-36-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.13.0-36-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
fait

A suivre  ....(je redémarre)


Ubuntu 18.04.1 LTS - CM ASUS Z370 TUF GAMING PLUS - INTEL I 7 8700 - écran LG 24UD58B (4K) - GNOME 3.28.2 - Intel® HD Graphics (Coffeelake 3x8 GT2) - 8Go RAM

Hors ligne

#13 Le 01/04/2018, à 17:14

Antoinexten

Re : [résolu] problème d'affichage Processeur I7 8700

UN TRES GRAND MERCI !
Cela fonctionne à merveille .

Bonne fin de WE !


Ubuntu 18.04.1 LTS - CM ASUS Z370 TUF GAMING PLUS - INTEL I 7 8700 - écran LG 24UD58B (4K) - GNOME 3.28.2 - Intel® HD Graphics (Coffeelake 3x8 GT2) - 8Go RAM

Hors ligne