Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/04/2018, à 11:07

elcastor

Accès à PhpMyAdmin [RESOLU]

Bonjour à tous,

j'ai développé il y a trois ans un petit questionnaire avec php / mysql pour tester les stagiaires dans mon entreprise. Et puis je l'ai laissé de côté.
Le tout sur une machine dédiée sous Ubuntu 12.04. Qui n'est pas connectée au net et qui ne bouge pas.

Là je reviens dessus pour modifier certaines données contenues dans ma base. Le plus simple serait d'utiliser Phpmyadmin, me dis-je, or, étrangement, il m'est impossible de m'y connecter !

J'ai bien la page d'authentification. Mais phpmyadmin se comporte comme si le mot de passe était erroné. J'essaie depuis 2 jours, avec l'utilisateur Lambda  (qui a TOUS les privilèges) , avec l'utilisateur root (de mysql) et rien n'y fait.

POURTANT, en ssh, pas de problème, je me connecte à mes bases, fais tous les sélect que je veux.

J'ai essayé de comprendre le contenu que devait avoir le fichier /etc/phpmyadmin/config-db.php et je n'ai pas très bien compris hélas.

Par ailleurs, je ne vois pas de "table" phpmyadmin dans la BDD. Est-ce normal ?
Bref, je ne sais même plus où chercher sad

J'ai essayé de comprendre les erreurs de connections dans les logs d'apache, et je n'ai rien de significatif, à par "Could not determine the server's fully qualified domaine name"
Please, help me sad

Dernière modification par elcastor (Le 17/04/2018, à 09:11)

Hors ligne

#2 Le 13/04/2018, à 13:39

bruno

Re : Accès à PhpMyAdmin [RESOLU]

elcastor a écrit :

Par ailleurs, je ne vois pas de "table" phpmyadmin dans la BDD. Est-ce normal ?

Bonjour,

Non ce n'est pas normal.
Le plus simple est sans doute de tenter une reconfiguration (en répondant oui aux questions concernant la re-création de la base phpmyadmin) :

sudo dpkg-reconfigure phpmyadmin

Dernière modification par bruno (Le 13/04/2018, à 13:40)

Hors ligne

#3 Le 13/04/2018, à 14:45

elcastor

Re : Accès à PhpMyAdmin [RESOLU]

alors je l'ai fait avant de poster, j'ai vu que ça a réécrit le fameux fichier /config-db.php, mais ça ne m'a pas créé de table phpmyadmin pour autant.
Voici les options que j'ai choisi :

Réinstaller la base de données : OUI
Méthode de connexion : socket Unix
Administrateur BDD: root
Mdp : le mot de passe du root BDD
Identifiant Mysql pour phpmyadmin : c'est là que j'ai un doute. J'ai mis Lambda,  un utilisateur (fonctionnel) de l'une des bases, à qui j'ai donné tous les privilèges
Un nom pour la base de données : phpmyadmin
Serveur web à reconfigurer : Apache2
Configuration de phpmyadmin => "une nouvelle version du fichier de configuration config-db.php est disponible mais la version actuellement utilisée a été modifiée localement."
Acion souhaitée :
     Installer la version du responsable du paquet
*  Garder la version actuellement installée
      Montrer les différences entre les deux versions
... etc
J'ai essayé les deux premiers

Puis un "service apache2 reload".

et puis pas mieux




Pourtant j'ai bien choisi Apache

Hors ligne

#4 Le 13/04/2018, à 16:25

bruno

Re : Accès à PhpMyAdmin [RESOLU]

elcastor a écrit :

Réinstaller la base de données : OUI
Méthode de connexion : socket Unix
Administrateur BDD: root
Mdp : le mot de passe du root BDD

Ok.

elcastor a écrit :

Identifiant Mysql pour phpmyadmin : c'est là que j'ai un doute. J'ai mis Lambda,  un utilisateur (fonctionnel) de l'une des bases, à qui j'ai donné tous les privilèges

Non, il vaut mieux laisser la valeur par défaut : phpmyadmin (cela va créer un utilisateur phpmyadmin qui a les droits sur la base phpmyadmin


elcastor a écrit :

Un nom pour la base de données : phpmyadmin
Serveur web à reconfigurer : Apache2

Ok.

elcastor a écrit :

Configuration de phpmyadmin => "une nouvelle version du fichier de configuration config-db.php est disponible mais la version actuellement utilisée a été modifiée localement."
Acion souhaitée :
     Installer la version du responsable du paquet
*  Garder la version actuellement installée
      Montrer les différences entre les deux versions
... etc

Il faut choisir d'installer la version du responsable du paquet.

Si tu n'y arrives toujours pas, purge le paquet (en répondant oui aux questions) :

sudo apt purge phpmyadmin

et reinstalle.

Hors ligne

#5 Le 13/04/2018, à 17:07

elcastor

Re : Accès à PhpMyAdmin [RESOLU]

J'ai reconfiguré => rien.

J'ai purgé puis réinstallé : on voit bien les tables, la base. Mais toujours pas possible de s'y  connecter.
C'est à n'y rien comprendre.

phpmyadmin.png

Hors ligne

#6 Le 13/04/2018, à 17:16

bruno

Re : Accès à PhpMyAdmin [RESOLU]

C'est pas normal…
Tu es sûr qu'après avoir purgé le paquet phpmyadmin le dossier /etc/phpmyadmin n'existait plus ?

Hors ligne

#7 Le 16/04/2018, à 17:32

elcastor

Re : Accès à PhpMyAdmin [RESOLU]

C'est vraiment fou.

J'ai tout recommencé :
apt-get purge phpmyadmin (en choisissant d'effacer la base)

Après coup, plus de fichiers dans /etc/phpmyadmin
MAIS un utilisateur phpmyadmin était toujours présent dans la base mysql. Par précaution, j'ai fait un
mysql => DROP 'phpmyadmin'@'localhost';

Après ça, plus d'utilisateur, plus de fichiers, plus de base.

Je réinstalle, en prenant mon temps, en choisissant les mêmes paramètres que ci dessus.
Aucune erreur lors de l'installation. Je choisis un mot de passe pour l'utilisateur phpmyadmin (de la base du même nom), je VERIFIE cette données en éditant /etc/phpmyadmin/config-db.php

Le mot de passe est bien là écrit en clair.

Je tente la connection via l'interface web => IMPOSSIBLE. Je me connecte en ligne de commande avec "mysql -u phpmyadmin -p" -> puis mon mot de passe : OK !

Je ne sais absolument pas quoi faire. C'est hallucinant. Pour info, la version de Mysql est 5.5.31
La version de PHP  est 5.3.10
Est-ce que ce serait pas là le noeud du problème ?

Hors ligne

#8 Le 16/04/2018, à 18:56

bruno

Re : Accès à PhpMyAdmin [RESOLU]

Tu as tout bien fait. Je ne comprends donc pas pourquoi cela ne fonctionne pas.
Tes versions sont anciennes et la 12.04 ne bénéficie plus d'aucune mise à jour, mais cela devrait fonctionner.

Hors ligne

#9 Le 16/04/2018, à 20:35

krodelabestiole

Re : Accès à PhpMyAdmin [RESOLU]

à défaut tu peux essayer adminer : https://www.adminer.org/

c'est un simple fichier php qui propose les fonctionnalités les plus courantes de phpmyadmin sans nécessiter un utilisateur mysql spécifique.

En ligne

#10 Le 17/04/2018, à 02:32

white_mike

Re : Accès à PhpMyAdmin [RESOLU]

krodelabestiole a écrit :

à défaut tu peux essayer adminer : https://www.adminer.org/

c'est un simple fichier php qui propose les fonctionnalités les plus courantes de phpmyadmin sans nécessiter un utilisateur mysql spécifique.

Je connaissais pas merci pour la découverte !

Hors ligne

#11 Le 17/04/2018, à 09:11

elcastor

Re : Accès à PhpMyAdmin [RESOLU]

yes c'est trop bien. Evidemment ça fonctionne direct. Aucun souci.
Merci tout plein !     -_-

Alors ça contourne le problème plutôt que ça ne le résoud. Je vais utiliser Adminer ; mais je me demandais tout de même s'il n'y avait pas un mode débug ou des logs pour Phpmyadmin. C'est fou de n'avoir aucune trace de ce qu'il se passe.

Hors ligne

#12 Le 17/04/2018, à 12:13

krodelabestiole

Re : Accès à PhpMyAdmin [RESOLU]

ça serait bien qu'on ait exactement le message d'erreur que tu rencontres avec phpmyadmin.

sinon les logs de mysql sont dans /var/log/mysql/ par défaut.
il faut aussi activer l'option general_log dans la section [mysqld] de la config de mysql : https://dev.mysql.com/doc/refman/5.7/en/query-log.html

par ex. je viens de créer un fichier /etc/mysql/conf.d/mysqld.cnf qui contient ça :

[mysqld]
general_log=1
general_log_file=/var/log/mysql/mysql.log

et je récupère les dernières infos de connexion avec la commande :

sudo tail /var/log/mysql/mysql.log

ça marche avec mariadb, je pense que ça devrait le faire aussi avec mysql.

Dernière modification par krodelabestiole (Le 17/04/2018, à 12:31)

En ligne