Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 04/06/2018, à 14:08

pater

[Résolu] dell lattitude 5590 aucune version ne fonctionne

Bonjour à tous,

J'ai acheté pour mon boulot un dell lattitude 5590 (je sais... mais au boulot on n'a pas le choix!) avec ubuntu 16.04.

Comme je préfère Mint, j'ai lancé une install. Qui a planté. J'ai essayé lubuntu, ubuntu-studio, re-mint, puis pour finir encore ubuntu 16.04. mais quelle que soit la version, ça plante.

J'ai essayé en uefi mode, en legacy mode... Je suis sur qu'il y a un problème de ce côté là mais je ne connais pas assez pour trouver le souci, et à fortiori la solution!

Si quelqu'un a une idée de ce que je peux tester pour faire en sorte d'avoir une version qui tourne, ce serait super! ça fait 2 jours qu'on tourne en rond et qu'on arrive à rien sad

Merci!

Dernière modification par pater (Le 07/06/2018, à 12:08)

Hors ligne

#2 Le 04/06/2018, à 15:01

??

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Bonjour
Je pense que si tu lis le guide indiqué dans ma signature, tu en diras un peu plus.

Mon conseil pour que cela fonctionne, il faut du courant électrique fournit soit par EDF soit par une batterie.

Je ne sais même pas quel est ton support d'installation n'y d'où vient l'ISO que tu veux essayer ni avec quoi tu as fabriqué le support,
Ni si l'écran a fait un petit clin d'oeil. Ni si la version ubuntu pré-installée fonctionne.


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#3 Le 04/06/2018, à 15:30

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

J'ai allumé le disjoncteur, branché la batterie, et ça a fonctionné!!! Trop merci!!! Non... ces aspects là, je les maîtrise à peu près...

les isos utilisés c'est Ubuntu 16.04, 18.04 officiels, ubuntu-studio18.04 officiel, mint cinnamon 18.03, lubuntu 17.10.

Tout sur clé live CD, faites avec unetbootin, mais aussi avec le créateur de clé de démarrage linux.

La version ubuntu 16.04 installée à la livraison fonctionnait, mais la première install semblant marcher parfaitement, j'ai eu la mauvaise idée d'effacer le disque, donc le ubuntu de départ n'existe plus.

L'écran a fait quelques clins d'oeil, toutes les tentatives d'install ont planté, chacune à un endroit différent avec des messages d'erreur différents...

D'où mon message, ça sent l'erreur uefi, en tout cas un truc mal paramétré du fait de mon ignorance.

Exemple d'erreur : sur mint, on lance l'install, et très vite : Method parse/execution failed ([\PSM._STA] (node ffff92......), AE_NOT_FOUND

Ah oui une des rares version qui est allée au bout en livecd (essayer sans installer) est ubuntu studio 18.04, mais sans réussir à faire fonctionner les cartes réseau, donc pas internet. Et à l'install ça plante vers la fin (copie des fichiers ok, erreur de type "grub-install fail"). Ce qui rend difficile la solution refind, sans internet...

Dernière modification par pater (Le 04/06/2018, à 15:41)

Hors ligne

#4 Le 04/06/2018, à 16:00

lucmars

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Y-a-t-il au moins une version, sinon toutes, qui fonctionne en mode essayer ?

Hors ligne

#5 Le 04/06/2018, à 16:03

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Ubuntu studio 18.04 a fonctionné une fois en mode Essayer, depuis, impossible d'accéder à ce mode, quelle que soit la version de Linux testée...

Hors ligne

#6 Le 04/06/2018, à 16:36

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Salut,

Il y a un chipset graphique Intel et une carte Nvidia sur ce PC. Il faut donc démarrer avec l'option nomodeset.

Après l'installation, il faudra, dans un 1er temps, démarrer avec la même option. Ensuite, il faut installer le pilote nvidia et probablement Prime. Mais sur ce dernier point, je ne connais pas bien et laisse d'autres intervenants expliquer la méthode.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#7 Le 04/06/2018, à 17:33

??

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

pater a écrit :

J'ai allumé le disjoncteur, branché la batterie, et ça a fonctionné!!! Trop merci!!! Non... ces aspects là, je les maîtrise à peu près...
D'où mon message, ça sent l'erreur uefi, en tout cas un truc mal paramétré du fait de mon ignorance.
Exemple d'erreur : sur mint, on lance l'install, et très vite : Method parse/execution failed ([\PSM._STA] (node ffff92......), AE_NOT_FOUND
.

Je vois que pour le courant, tu en avais entendu parler. Enfin tu as donné un message d'erreur C'est merveilleux, on va pouvoir faire appel à GOOGLE (Connais-tu?)

https://www.google.com/search?as_q=&as_ … as_rights=

La réponse est que cela n'a rien a voir avec EFI   mais avec ACPI

Donc, tu bootes aussi avec l'option ACPI=OFF https://doc.ubuntu-fr.org/kernel#modifi … ssion-live
car nomodeset sera nécessaire

Dernière modification par ?? (Le 04/06/2018, à 17:34)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#8 Le 05/06/2018, à 15:50

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

inbox a écrit :

Salut,

Il y a un chipset graphique Intel et une carte Nvidia sur ce PC. Il faut donc démarrer avec l'option nomodeset.

Re bonjour,

J'ai finalement pu installer un ubuntu 16.04 avec nomodeset dans le grub, merci pour l'info et le lien.

(Rien à voir, donc, avec l'ACPI.)

Mais il reste un problème : lorsque je branche mon deuxième écran sur le laptop, le pc ne le reconnaît pas. La section "affichage" des paramètres système montre seulement l'écran d'origine. D'après la fiche technique de DELL pour ce pc, la carte intégrée est une Intel HD 620. Les paramètres système disent seulement que c'est une carte "llvmpipe (LLVM 5.0, 256 bits)". (Je me doute bien que nomodeset a quelque chose à voir là-dedans, et j'ai aussi essayé de démarrer avec nouveau.modeset=0, mais cela me fait retourner au point de départ de ce post.)

J'ai cherché un pilote mais je n'ai rien trouvé d'autre que 'le pilote linux suffit'...... avez-vous d'autres idées ?

Hors ligne

#9 Le 05/06/2018, à 16:11

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Le retour de cette commande indiquera s'il y a bien deux composants graphiques :

lspci

S'il y a bien une Intel et une nvidia, voir la documentation du forum sur Prime.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#10 Le 05/06/2018, à 16:33

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

inbox a écrit :

Le retour de cette commande indiquera s'il y a bien deux composants graphiques :

lspci

S'il y a bien une Intel et une nvidia, voir la documentation du forum sur Prime.

Voici le retour de cette commande :

00:00.0 Host bridge: Intel Corporation Device 5914 (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Device 5917 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Device 9d12 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d4e (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (4) I219-LM (rev 21)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
02:00.0 Network controller: Intel Corporation Device 24fd (rev 78)
03:00.0 Non-Volatile memory controller: Toshiba America Info Systems Device 0116

Je ne vois pas de nvidia... ?
Sinon, j'ai pensé à tenter de mettre ubuntu 18.04 (maintenant qu'on a vu que le nomodeset fonctionnait), peut-être qu'un noyau plus récent prendra en compte ce matos là. Qu'en pensez-vous ?

Hors ligne

#11 Le 05/06/2018, à 16:34

moko138

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Pour la wifi
  Tu ouvriras un fil dans la section wifi.
  En général, les Dell ont une carte wifi Broadcom qui demande classiquement l'installation d'un pilote propriétaire.
AJOUT :
Raté ! Tu as une

02:00.0 Network controller: Intel Corporation Device 24fd (rev 78)

Donc tu montreras

lspci -nnk | grep -A3 24fd

(dans ton fil wifi).      FIN d'ajout

  - -

pater a écrit :

avez-vous d'autres idées ?

Oui :

?? a écrit :
pater a écrit :

Exemple d'erreur : sur mint, on lance l'install, et très vite : Method parse/execution failed ([\PSM._STA] (node ffff92......), AE_NOT_FOUND

tu as donné un message d'erreur, on va pouvoir faire appel à GOOGLE
https://www.google.com/search?as_q=&as_ … as_rights=
La réponse est que cela n'a rien a voir avec EFI   mais avec ACPI

Donc, tu bootes aussi avec l'option ACPI=OFF

Dernière modification par moko138 (Le 05/06/2018, à 16:39)


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#12 Le 05/06/2018, à 16:44

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Effectivement, ce modèle n'a pas de carte nvidia, seulement une Intel.

Comme c'est un modèle récent, tu devrais essayer d'installer plutôt une 18.04, toujours avec l'option nomodeset.

Après avoir installé les mises à jour, essaye de démarrer sans l'option nomodeset.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#13 Le 06/06/2018, à 11:08

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Re bonjour, voilà où nous en sommes aujourd'hui :

Pas de problème avec le wifi, aucun changement en utilisant ACPI=OFF, on est passés à ubuntu 18.04.

Le dual screen ne fonctionne toujours pas (l'écran branché en VGA n'est même pas détecté !) et malgré toutes les mises à jour faites, le pc refuse toujours de démarrer sans nomodeset.

J'ai regardé ce tuto : https://doc.ubuntu-fr.org/intel_graphic … des_utiles
Voici ce que donne lsmod | egrep 'i915' :

i915                 1617920  0
i2c_algo_bit           16384  1 i915
drm_kms_helper        167936  1 i915
drm                   401408  2 i915,drm_kms_helper
video                  40960  3 dell_wmi,dell_laptop,i915

Autre chose, d'après le tuto ci-dessus, la commande grep rendering /var/log/Xorg.0.log devrait retourner

[    21.396] (II) intel(0): direct rendering: DRI2 Enabled

mais chez moi elle retourne

[     4.748] (EE) AIGLX: reverting to software rendering

Que suis-je censé faire de cette info ??

Enfin, toujours selon le même tuto, en tapant grep -A29 Chipsets /var/log/Xorg.0.log je devrais voir ma carte, or la commande ne renvoie rien.

Je comprends bien que cette carte n'est pas reconnue ou pas fonctionnelle ou que sais-je, mais je ne sais pas quoi faire des indices à ma disposition pour réparer ça. Des idées ? Merci d'avance.

Dernière modification par pater (Le 06/06/2018, à 16:03)

Hors ligne

#14 Le 06/06/2018, à 12:19

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Tu devrais consulter la documentation Dell au sujet de l'installation d'Ubuntu. Il faut aussi que tu télécharges l'iso modifiée par Dell pour ses PC.

Support Dell a écrit :

Si vous avez acheté votre système Dell avec Ubuntu pré-installé, vous disposez d’images de récupération sur votre système. Si vous souhaitez utiliser un nouveau disque dur, vous pouvez télécharger une image d’installation à partir du site Web du support technique de Dell, en saisissant l’identification ou le code de service express de votre système, puis en sélectionnant les pilotes et téléchargements souhaités.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#15 Le 06/06/2018, à 12:28

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

inbox a écrit :

Tu devrais consulter la documentation Dell au sujet de l'installation d'Ubuntu. Il faut aussi que tu télécharges l'iso modifiée par Dell pour ses PC.

Support Dell a écrit :

Si vous avez acheté votre système Dell avec Ubuntu pré-installé, vous disposez d’images de récupération sur votre système. Si vous souhaitez utiliser un nouveau disque dur, vous pouvez télécharger une image d’installation à partir du site Web du support technique de Dell, en saisissant l’identification ou le code de service express de votre système, puis en sélectionnant les pilotes et téléchargements souhaités.

C'est ce que j'ai fait avant de poster sur ce forum... résultat :
- la page de récupération de l'OS renvoie une 404
- le service client, joint par téléphone, nous a finalement dit "je ne sais pas quoi faire".

Pendant le coup de fil au service client, on a quand même signalé la 404, on verra bien s'ils rectifient le lien (pour l'instant il est toujours mort.)...

Voilà voilà roll

Hors ligne

#16 Le 06/06/2018, à 12:41

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#17 Le 06/06/2018, à 14:06

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Merci pour le lien smile Malheureusement il s'agit de celui que j'avais essayé, et qui coince au moment de télécharger l'image de récupération sad

Hors ligne

#18 Le 06/06/2018, à 16:40

??

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Bonjour
Parles-t-on bien de cet ordinateur ? https://certification.ubuntu.com/hardware/201709
donc certainement https://www.dell.com/community/Linux-Ge … -p/6084667

Je crois que ton problème nomodeset peut être lié à ce bug https://bugs.launchpad.net/ubuntu/+sour … ug/1764194

Igor Shuvalov (i-s-shuvalov) wrote 19 hours ago: 	#22

bionic-proposed (4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux) is OK on my Latitude 5590.

As-tu pensé à faire

sudo apt update
sudo apt upgrade

Dernière modification par ?? (Le 06/06/2018, à 16:51)


Utiliser REFIND au lieu du GRUB https://doc.ubuntu-fr.org/refind . Aidez à vous faire dépanner en suivant le guide et en utilisant les outils de diagnostic J'ai perdu ma gomme. Désolé pour les fautes d'orthographes non corrigées.

Hors ligne

#19 Le 06/06/2018, à 16:59

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Dans les commentaires du bug, on peut lire qu'un des utilisateurs (message #14) a réglé le problème en mettant son bios (UEFI ?) à jour à la version 1.2.3.
Un autre dit que le noyau 4.15.0-23-generic correctif disponible dans le dépôt "proposed" fonctionne. Attention, il ne faut pas laisser le dépôt proposed activé, par la suite.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#20 Le 06/06/2018, à 17:29

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Alors là je dis chapeau bas... merci pour ces infos ! J'ai installé la modif portant sur le noyau (4.15.0-23-generic #25-Ubuntu SMP) et maintenant je peux utiliser le PC sans nomodeset !
Mais le dual screen n'est toujours pas pris en charge...
Lorsque j'ai coché la case pour les MAJ -proposed dans le gestionnaire de mises à jour, il m'en a proposé toute une liste, par mesure de prudence je n'ai installé que "4.15.0-23-generic #25-Ubuntu SMP" et celle qui a été auto-sélectionnée avec elle. Pensez-vous que j'aurais aussi du installer toutes les autres MAJ proposées ? Peut-être n'ai-je résolu qu'une (grosse, très grosse !!) partie du problème en n'installant pas tout ?

Hors ligne

#21 Le 06/06/2018, à 17:49

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Si tu veux un avis sur ce qui peut être installé venant de "proposed" (dépôt activé), donne le retour de la commande suivante en simulation :

sudo apt-get dist-upgrade --simulate

Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#22 Le 07/06/2018, à 09:49

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Bonjour,

Voici le retour de la commande sudo apt-get dist-upgrade --simulate :

Les NOUVEAUX paquets suivants seront installés :
  amd64-microcode intel-microcode iucode-tool linux-headers-4.15.0-23
  linux-headers-4.15.0-23-generic
Les paquets suivants seront mis à jour :
  apport apport-gtk binutils binutils-common binutils-x86-64-linux-gnu bolt
  command-not-found command-not-found-data cups-pk-helper desktop-file-utils
  gdm3 gir1.2-gdm-1.0 gir1.2-gnomedesktop-3.0 gir1.2-vte-2.91 gnome-calendar
  gnome-control-center gnome-control-center-data gnome-control-center-faces
  gnome-desktop3-data gnome-initial-setup gnome-software gnome-software-common
  gnome-software-plugin-snap gnome-terminal gnome-terminal-data libbinutils
  libegl-mesa0 libegl1-mesa libgbm1 libgdm1 libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libglx-mesa0 libgnome-desktop-3-17 libgtop-2.0-11
  libgtop2-common liblouis-data liblouis14 libnss-myhostname libnss-systemd
  libpam-systemd libsystemd0 libudev1 libvte-2.91-0 libvte-2.91-common
  libwayland-egl1-mesa libxatracker2 linux-generic linux-headers-generic
  linux-image-generic linux-libc-dev linux-signed-generic mesa-va-drivers
  mesa-vdpau-drivers nautilus-extension-gnome-terminal netplan.io nplan
  python3-apport python3-commandnotfound python3-distupgrade python3-louis
  python3-problem-report python3-update-manager systemd systemd-sysv
  ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk ubuntu-software
  udev update-manager update-manager-core wireless-regdb
73 mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.

Avec tout un tas de lignes commençant par Inst ou Conf. Qu'en pensez-vous ?

Hors ligne

#23 Le 07/06/2018, à 10:32

moko138

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Qu'en pensez-vous ?

Attends inbox ! qui a dit fort justement :

Attention, il ne faut pas laisser le dépôt proposed activé, par la suite.


%NOINDEX%
Un utilitaire précieux : ncdu
Photo, mini-tutoriel :  À la découverte de dcraw

Hors ligne

#24 Le 07/06/2018, à 11:11

inbox

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Tu peux passer cette commande :

sudo apt-get install linux-headers-4.15.0-23  linux-headers-4.15.0-23-generic linux-generic linux-headers-generic linux-image-generic --reinstall

J'ai ajouté "--reinstall" au cas ou. Si un paquet est déjà présent, le système ne râlera pas.

Une fois les paquets installés, désactive le dépôt "proposed".

Ce devrait être OK.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#25 Le 07/06/2018, à 12:01

pater

Re : [Résolu] dell lattitude 5590 aucune version ne fonctionne

Bien reçu !

Eeeet le dual screen marche... !

Merci à tous smile

Hors ligne