Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/05/2018, à 22:07

autrebord

[Résolu] Sortie de veille : perte réseau

Bonjour, je rencontre le même souci (en filaire car ordi de bureau sans wifi) sous ubuntu 18.04. La commande

sudo service network-manager restart

ne règle rien. Dans les paramètres réseau, la connexion filaire est indiquée comme cable débranché.
Quelqu'un aurait une idée ?

Dernière modification par autrebord (Le 01/06/2018, à 22:41)

Hors ligne

#2 Le 30/05/2018, à 22:14

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Bonjour,

@ autrebord

Le 29/01/2014, toutafai a écrit :

Salut,

...quel modèle de freebox as-tu ?
as-tu essayé sur une autre prise coté freebox et avec un autre câble ?
que donne le retour de :

cat /etc/network/interfaces
sudo lshw -C network
lspci -nn
ifconfig -a
nm-tool

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 30/05/2018, à 23:58

autrebord

Re : [Résolu] Sortie de veille : perte réseau

Bonjour xubu1957,
J'ai la freebox v5. Difficile de changer de cable, toutes les pièces de l'appart sont équipées de prises murales rj45 qui renvoient vers la freebox plaquée dans un placard difficilement accessible. Mais le problème semble plutôt venir de l'ordi étant donné que dès que je redémarre, ça fonctionne. C'est juste en sortie de veille qu'il n'y a plus de réseau (même le logo en haut à droite a disparu jusqu'à ce que je redémarre). Le retour des commandes me donne :

autrebord@autrebord-bureau:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
autrebord@autrebord-bureau:~$ sudo lshw -C network
  *-network                 
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       nom logique: enp1s0
       version: 02
       numéro de série: 00:23:54:37:6d:58
       taille: 1Gbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.10 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       ressources: irq:24 portE/S:c800(taille=256) mémoire:fe9ff000-fe9fffff mémoire:fdef0000-fdefffff mémoire:fe9c0000-fe9dffff
autrebord@autrebord-bureau:~$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 4 Series Chipset DRAM Controller [8086:2e20] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e22] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e23] (rev 03)
00:1a.0 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4 [8086:3a37]
00:1a.1 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5 [8086:3a38]
00:1a.2 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6 [8086:3a39]
00:1a.7 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2 [8086:3a3c]
00:1b.0 Audio device [0403]: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller [8086:3a3e]
00:1c.0 PCI bridge [0604]: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1 [8086:3a40]
00:1c.4 PCI bridge [0604]: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5 [8086:3a48]
00:1c.5 PCI bridge [0604]: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6 [8086:3a4a]
00:1d.0 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1 [8086:3a34]
00:1d.1 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2 [8086:3a35]
00:1d.2 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3 [8086:3a36]
00:1d.7 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1 [8086:3a3a]
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 90)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller [8086:3a16]
00:1f.2 IDE interface [0101]: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1 [8086:3a20]
00:1f.3 SMBus [0c05]: Intel Corporation 82801JI (ICH10 Family) SMBus Controller [8086:3a30]
00:1f.5 IDE interface [0101]: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2 [8086:3a26]
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 02)
02:00.0 IDE interface [0101]: Marvell Technology Group Ltd. 88SE6101/6102 single-port PATA133 interface [11ab:6101] (rev b2)
04:00.0 Serial controller [0700]: WCH.CN CH352 PCI Serial and Parallel Port Controller [4348:5053] (rev 10)
04:03.0 FireWire (IEEE 1394) [0c00]: LSI Corporation FW322/323 [TrueFire] 1394a Controller [11c1:5811] (rev 70)
autrebord@autrebord-bureau:~$ ifconfig -a
enp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.10  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::5fa3:f2aa:a0b8:6a11  prefixlen 64  scopeid 0x20<link>
        ether 00:23:54:37:6d:58  txqueuelen 1000  (Ethernet)
        RX packets 1339028  bytes 2022254710 (2.0 GB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 698498  bytes 47062134 (47.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 552  bytes 44147 (44.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 552  bytes 44147 (44.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

autrebord@autrebord-bureau:~$ nm-tool

La commande « nm-tool » n'a pas été trouvée, voulez-vous dire :

  commande « dm-tool » du deb lightdm

Essayez : sudo apt install <nom du deb>

autrebord@autrebord-bureau:~$ 

Ces infos données quand le réseau fonctionne. Faut-il que je le refasse après une sortie de veille ?

Dernière modification par autrebord (Le 30/05/2018, à 23:59)

Hors ligne

#4 Le 31/05/2018, à 06:23

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Bonjour,

Regarde cette Doc > la_connexion_reseau_ne_se_reactive_pas_en_sortie_de_veille_ou_d_hibernation

_ _ _

Fournis le noyau actif :

uname -a

Dernière modification par xubu1957 (Le 31/05/2018, à 06:32)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 31/05/2018, à 18:53

autrebord

Re : [Résolu] Sortie de veille : perte réseau

Merci xubu1957.
J'ai regardé la doc, les commandes

lshw -class network

et

lsmod

me renvoient :

autrebord@autrebord-bureau:~$ lshw -class network
ATTENTION: ce programme devrait être lancé en tant que super-utilisateur.
  *-network                 
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       nom logique: enp1s0
       version: 02
       numéro de série: 00:23:54:37:6d:58
       taille: 1Gbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.10 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       ressources: irq:24 portE/S:c800(taille=256) mémoire:fe9ff000-fe9fffff mémoire:fdef0000-fdefffff mémoire:fe9c0000-fe9dffff
ATTENTION: les informations sont potentiellement incomplètes ou erronées, vous devriez lancer ce programme en tant que super-utilisateur.
autrebord@autrebord-bureau:~$ lsmod
Module                  Size  Used by
msr                    16384  0
snd_usb_audio         196608  2
joydev                 24576  0
uvcvideo               86016  0
snd_usbmidi_lib        32768  1 snd_usb_audio
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         24576  1 uvcvideo
videobuf2_core         40960  2 uvcvideo,videobuf2_v4l2
input_leds             16384  0
videodev              184320  3 uvcvideo,videobuf2_core,videobuf2_v4l2
media                  40960  2 uvcvideo,videodev
coretemp               16384  0
kvm_intel             204800  0
kvm                   593920  1 kvm_intel
irqbypass              16384  1 kvm
snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek   102400  1
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          40960  6
serio_raw              16384  0
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              20480  2 snd_hda_codec,snd_usb_audio
snd_pcm                98304  5 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core,snd_hda_codec_hdmi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  2 snd_seq_midi,snd_usbmidi_lib
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    81920  29 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_hda_codec_realtek,snd_pcm
parport_serial         20480  0
lpc_ich                24576  0
asus_atk0110           20480  0
soundcore              16384  1 snd
shpchp                 36864  0
mac_hid                16384  0
sch_fq_codel           20480  2
parport_pc             36864  2 parport_serial
ppdev                  20480  0
lp                     20480  0
parport                49152  3 lp,parport_pc,ppdev
ip_tables              28672  0
x_tables               40960  1 ip_tables
autofs4                40960  2
hid_generic            16384  0
usbhid                 49152  0
hid                   118784  2 hid_generic,usbhid
i915                 1617920  25
video                  40960  1 i915
i2c_algo_bit           16384  1 i915
drm_kms_helper        167936  1 i915
uas                    24576  0
syscopyarea            16384  1 drm_kms_helper
firewire_ohci          40960  0
sysfillrect            16384  1 drm_kms_helper
psmouse               147456  0
sysimgblt              16384  1 drm_kms_helper
pata_acpi              16384  0
firewire_core          65536  1 firewire_ohci
r8169                  86016  0
crc_itu_t              16384  1 firewire_core
pata_marvell           16384  0
mii                    16384  1 r8169
usb_storage            69632  1 uas
fb_sys_fops            16384  1 drm_kms_helper
drm                   401408  16 i915,drm_kms_helper
floppy                 77824  0

Mais je n'arrive pas à identifier le n° du driver en question (désolé je débute).
Par ailleurs, la commande

uname -a

me renvoie

autrebord@autrebord-bureau:~$ uname -a
Linux autrebord-bureau 4.15.0-22-generic #24-Ubuntu SMP Wed May 16 12:15:17 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Si tu peux éclairer ma lanterne...

Hors ligne

#6 Le 31/05/2018, à 19:00

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Tu peux donner :

lsb_release -d ; printenv GDMSESSION ; uname -mrs

et les noyaux présents :

dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t

?

Tu n'utilises pas le Wifi, il ne ressort pas de pilote.

_ _ _
Essaye les commandes :

sudo ifconfig enp1s0 down
sudo ifconfig enp1s0 up
sudo dhclient enp1s0

pour activer la connexion filaire.

Dernière modification par xubu1957 (Le 31/05/2018, à 19:11)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 31/05/2018, à 22:37

autrebord

Re : [Résolu] Sortie de veille : perte réseau

Salut,
Voilà :

autrebord@autrebord-bureau:~$ lsb_release -d ; printenv GDMSESSION ; uname -mrs
Description:	Ubuntu 18.04 LTS
ubuntu
Linux 4.15.0-22-generic x86_64
autrebord@autrebord-bureau:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)" | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3 | column -s" " -t
ii  binutils-x86-64-linux-gnu        2.30-15ubuntu1
ii  linux-headers-4.15.0-20          4.15.0-20.21
ii  linux-headers-4.15.0-20-generic  4.15.0-20.21
ii  linux-image-4.15.0-20-generic    4.15.0-20.21
ii  linux-generic                    4.15.0.22.23
ii  linux-headers-generic            4.15.0.22.23
ii  linux-image-generic              4.15.0.22.23
ii  linux-tools-virtual              4.15.0.22.23
ii  linux-headers-4.15.0-22          4.15.0-22.24
ii  linux-tools-common               4.15.0-22.24
ii  linux-headers-4.15.0-22-generic  4.15.0-22.24
ii  linux-tools-4.15.0-22            4.15.0-22.24
ii  linux-tools-4.15.0-22-generic    4.15.0-22.24
ii  linux-image-4.15.0-22-generic    4.15.0-22.24
autrebord@autrebord-bureau:~$ 

Sinon, par rapport aux commandes proposées :

sudo ifconfig enp1s0 down
sudo ifconfig enp1s0 up
sudo dhclient enp1s0

les deux premières ne donnent rien et la troisième mouline sans résultat (testé en sortie de veille, donc sans réseau

Hors ligne

#8 Le 31/05/2018, à 22:42

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Il n'y a pas un dual-boot avec Windows ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 31/05/2018, à 22:49

autrebord

Re : [Résolu] Sortie de veille : perte réseau

Non aucun sur cette machine qui tourne sous ubuntu exclusivement depuis la 14.04 et n'a jamais eu ce problème.
Je viens par ailleurs d'essayer avec le live cd : même problème, plus de réseau ni d'icône réseau en haut à droite en sortie de veille.

Hors ligne

#10 Le 31/05/2018, à 22:53

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Tente :

Le 30/04/2016, Adelin a écrit :

Re,

Encore mieux, problème résolu:

http://askubuntu.com/questions/622470/d … untu-14-04

sudo rm /etc/resolv.conf
sudo ln -s ../run/resolvconf/resolv.conf /etc/resolv.conf
sudo resolvconf -u

Les deux portables marchent maintenant sur le câble en wifi et ethernet.
Merci à toutes les communautés GNU-LINUX d'exister,

Je me suis inspiré des réponses postés sur les forums divers, et ça m'a beaucoup aidé/ appris.

> [RESOLU] Network-Manager pas de connexion câble kubuntu16.04


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#11 Le 31/05/2018, à 22:55

ylag

Re : [Résolu] Sortie de veille : perte réseau

Bonsoir,

J'ai quelquefois ce problème en sortie de veille sous Ubuntu 18.04, et la seule façon de rétablir ma connexion ethernet semble être de décharger / recharger le module r8169 par les commandes:

sudo modprobe -r r8169

...suivi de:

sudo modprobe r8169

A+

Dernière modification par ylag (Le 31/05/2018, à 23:10)

En ligne

#12 Le 31/05/2018, à 23:34

autrebord

Re : [Résolu] Sortie de veille : perte réseau

Salut,
La bonne nouvelle c'est que les commandes de yagl

sudo modprobe -r r8169
...suivi de:
sudo modprobe r8169

relancent la connexion à la sortie de veille

La mauvaise c'est que j'ai tenté celles de xubu1957 :

sudo rm /etc/resolv.conf
sudo ln -s ../run/resolvconf/resolv.conf /etc/resolv.conf
sudo resolvconf -u

Les deux premières ont bien été acceptées, la troisième m'a répondu "commande introuvable" et maintenant je ne peux plus accéder au net du tout, même après redémarrage. Au lieu de m'afficher une page, chromium m'indique dns probe finished bad config.
Du coup deux questions :
- est-ce que je peux revenir en arrière par rapport aux commandes proposées par xubu1957 ?
- est que je peux automatiser, à la sortie de veille celles de ylag ?

Hors ligne

#13 Le 01/06/2018, à 00:05

ylag

Re : [Résolu] Sortie de veille : perte réseau

Salut,

J'ai l'impression que ton système n'est pas à jour ?
Si c'est le cas, vérifie que ton problème ne serait pas réglé avec les mises à jour.

A+

Dernière modification par ylag (Le 01/06/2018, à 00:06)

En ligne

#14 Le 01/06/2018, à 06:44

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Bonjour,

As-tu essayé avec Firefox ?

Tu peux accéder à la Box avec 192.168.1.1 ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#15 Le 01/06/2018, à 12:53

ylag

Re : [Résolu] Sortie de veille : perte réseau

Bonjour,

autrebord a écrit :

...est que je peux automatiser, à la sortie de veille...

J'ai tenté ceci (pris sur le forum anglophone): https://ubuntuforums.org/showthread.php … st13555828 qui semble fonctionner ?

Il semblerait qu'il faille parfois quand même refaire les commandes à la main après la réouverture de la session.

En gros, il faut créer le fichier /lib/systemd/system-sleep/suspend-modules dans lequel on met ce contenu:

#!/bin/bash

# Put into /lib/systemd/system-sleep/suspend-modules
# chmod a+x /lib/systemd/system-sleep/suspend-modules

# Create /etc/suspend-modules.conf
# with one module per line

# credits to:
# https://bbs.archlinux.org/viewtopic.php?pid=1540125#p1540125
# More info:
# https://ubuntuforums.org/showthread.php?t=2314905&p=13555828#post13555828

case $1 in
    pre)
        for mod in $(</etc/suspend-modules.conf); do
            rmmod $mod
        done
    ;;
    post)
        for mod in $(</etc/suspend-modules.conf); do
            modprobe $mod
        done
    ;;
esac

Rendre ensuite le fichier exécutable:

sudo chmod a+x /lib/systemd/system-sleep/suspend-modules

Créer un second fichier nommé /etc/suspend-modules.conf dans lequel tu entres le nom du ou des modules à relancer en sortie de veille, un par ligne. Dans ton cas ce sera r8169.

C'est sous toute réserve, je ne saurai dire si cette manip pourrait engendrer des instabilités sur ton système, à toi de voir...

Comme suggéré par @xubu1957 au #4, voir la doc du forum à ce sujet: https://doc.ubuntu-fr.org/veille_et_hib … ibernation

A+

Dernière modification par ylag (Le 01/06/2018, à 13:36)

En ligne

#16 Le 01/06/2018, à 17:18

ylag

Re : [Résolu] Sortie de veille : perte réseau

@xubu1957:

Bonjour,

Concernant ton commentaire #10: Chez-moi en Ubuntu 18.04, /etc/resolv.conf est un lien symbolique vers /run/systemd/resolve/stub-resolv.conf:

yvan@yvan-maison:~$ ls -l /etc/resolv.conf
lrwxrwxrwx 1 root root 39 avr 24 08:17 /etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf
yvan@yvan-maison:~$
yvan@yvan-maison:~$ ls -l /run/systemd/resolve/stub-resolv.conf
-rw-r--r-- 1 systemd-resolve systemd-resolve 701 jun  1 10:52 /run/systemd/resolve/stub-resolv.conf
yvan@yvan-maison:~$

Il y aurait eu une modif pour la 18.04 ?

Ma config réseau passe par NetworkManager et je suis connecté à un "router" en éthernet.

A+

Dernière modification par ylag (Le 01/06/2018, à 22:43)

En ligne

#17 Le 01/06/2018, à 17:34

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Bonjour,

@ ylag

Depuis la 17.04, c'est tordu :

Un des changements importants apportés par cette nouvelle version est que systemd-resolved est maintenant utilisé comme résolveur DNS par défaut

> blog-libre.org/2017/04/20/essuyer-les-platres-dns-sur-ubuntu/


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#18 Le 01/06/2018, à 18:20

ylag

Re : [Résolu] Sortie de veille : perte réseau

Salut,

Oui, je vois ceci chez-moi:

yvan@yvan-maison:~$ systemctl status systemd-resolved.service --no-pager -l
● systemd-resolved.service - Network Name Resolution
   Loaded: loaded (/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2018-06-01 05:22:26 EDT; 6h ago
     Docs: man:systemd-resolved.service(8)
           https://www.freedesktop.org/wiki/Software/systemd/resolved
           https://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
           https://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
 Main PID: 345 (systemd-resolve)
   Status: "Processing requests..."
    Tasks: 1 (limit: 4664)
   CGroup: /system.slice/systemd-resolved.service
           └─345 /lib/systemd/systemd-resolved
...
yvan@yvan-maison:~$ 

Je me demande si @autrebord ne devrait pas tenter de recréer le lien symbolique avec le nouveau nom de fichier, s'il n'a pas déjà réussi à rétablir sa connexion...?

A+

En ligne

#19 Le 01/06/2018, à 18:22

xubu1957

Re : [Résolu] Sortie de veille : perte réseau

Et redémarrer sa box ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#20 Le 01/06/2018, à 22:38

autrebord

Re : [Résolu] Sortie de veille : perte réseau

Désolé pour le temps de réponse j'ai du réinstaller ubuntu pour retrouver la connexion que j'avais définitivement perdu.

Concernant cette perte de connexion à la sortie de veille uniquement (que je ne retrouve qu'en redémarrant), la procédure indiquée par ylag au post #15 ci-dessus fonctionne. J'avoue l'avoir appliquée sans compredre, mais ça y est je retrouve ma connexion à la sortie de veille.
Je passe en résolu.
Un grand merci à vous deux et longue vie à ce forum !

Dernière modification par autrebord (Le 01/06/2018, à 22:39)

Hors ligne

#21 Le 17/06/2018, à 12:59

Arzon

Re : [Résolu] Sortie de veille : perte réseau

Merci !
J'avais le même problème avec carte ethernet Marvell, pilote sky2.

Hors ligne

#22 Le 25/07/2018, à 13:34

geo82

Re : [Résolu] Sortie de veille : perte réseau

Même probleme en ce moment avec ubuntu 18.04 bionic j’espère que c'est un bug et qu'il sera corrigé car ça devient lourd de devoir redémarrer l'ordinateur à chaque veille.
Surtout que j'ai le réflexe de mettre en veille à chaque fois que je quitte l'ordinateur un court instant.


Ubuntu 17.04 / Zalman ZM-T2 Plus / GIGABYTE GA-H110M-DS2 DDR3 /Intel Core i5-6500 3.2GHz/ Radeon HD 7770, 8 GB Ram
geekOfLinux

Hors ligne

#23 Le 25/07/2018, à 16:57

ylag

Re : [Résolu] Sortie de veille : perte réseau

@geo82:

Salut,

Regarge la page "man" de systemd-sleep:

man systemd-sleep

Pour faire un test, détermine quel est le module du pilote utilisé et fait, lors d'une sortie de veille avec le réseau désactivé:

sudo modprobe -r mon-module-réseau

...suivi de:

sudo modprobe mon-module-réseau

Ces deux commandes déchargent puis rechargent le module du réseau que tu auras spécifié. Si ça te redonnes le réseau, inspire-toi du commentaire #15 pour automatiser la manip.
ATTENTION: Si tu suis la piste du #15, assure-toi de recopier entièrement le contenu du fichier à créer: La dernière ligne en est:

esac

Pour déterminer quel est le bon module:

lspci -nn -k |grep -i net -A3

...ou:

lshw -C network

...devrait te donner la réponse.

Note: Il semblerait que la manip du lien cité par @xubu1957 au commentaire #4 s'appliquerait aux systèmes n'utilisant pas systemd, tel la 14.04...?

A+

Dernière modification par ylag (Le 25/07/2018, à 18:13)

En ligne