Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/08/2018, à 21:04

Timothée123

Config OpenVPN Via NAS Synology

Bonjour,

J'ai la version d'Ubuntu 18.04 LTS. J'essaye de me connecter en VPN sur mon NAS via OpenVPN mais en vain ...

J'ai exporté le fichier de configuration, j'ai ouvert le port sur mon routeur ...

Je vais dans Wired Settings, j'ajoute un VPN (j'appuie sur le "+") , "import from file", je choisis le fichier .ovpn .

Dans la boite de dialogue, j'ai en dessous du champ "Name" : "(Unable to load VPN connection editor)" .

J'appuie sur add et bien entendu rien ne se passe.

Quelqu'un pourrait-il me filer un coup de main svp ?

Hors ligne

#2 Le 17/08/2018, à 17:29

Fredouillemugen

Re : Config OpenVPN Via NAS Synology

Salut,
Essaie de bien suivre les indications du point 1.1 et 2.3 de ce lien :
https://doc.ubuntu-fr.org/openvpn
Ton VPN, il est géré par ton routeur (si oui quelle marque?) ou ton Syno ?
Pour ma part avec un VPN (openvpn) géré par routeur Netgear et accès sur NAS Qnap depuis extérieur, avec la 18.04, ça fonctionne, donc pas de soucis au niveau de la gestion avec le système.


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne

#3 Le 18/08/2018, à 22:28

Timothée123

Re : Config OpenVPN Via NAS Synology

Hello,

Le VPN est géré par le Synology.

Merci, je vais regarder ça et je vous tiens au courant ! smile

Hors ligne

#4 Le 18/08/2018, à 23:59

Timothée123

Re : Config OpenVPN Via NAS Synology

Fredouillemugen a écrit :

Salut,
Essaie de bien suivre les indications du point 1.1 et 2.3 de ce lien :
https://doc.ubuntu-fr.org/openvpn
Ton VPN, il est géré par ton routeur (si oui quelle marque?) ou ton Syno ?
Pour ma part avec un VPN (openvpn) géré par routeur Netgear et accès sur NAS Qnap depuis extérieur, avec la 18.04, ça fonctionne, donc pas de soucis au niveau de la gestion avec le système.

Après vérification, à l'étape 2.3, contrairement à ce qui est montré à la 4ième image, je n'ai pas d'onglet VPN.

C'est bizarre ...

Hors ligne

#5 Le 19/08/2018, à 00:20

Timothée123

Re : Config OpenVPN Via NAS Synology

J'ai résolu une partie de mon problème, à présent je peux insérer le Gateway, log-in et mot de passe.

J'ai trouvé la solution ici .

Mais quand j'essaye d'activier la connection, (passer du bouton OFF à ON, il se remet direct sur OFF) ça ne marche pas sad.

Hors ligne

#6 Le 19/08/2018, à 17:21

Timothée123

Re : Config OpenVPN Via NAS Synology

Up !
Je n'avais pas édité le fichier .ovpn, je ne savais pas qu'il fallait le faire ^^".

Ce matin ça fonctionnait bien, j'ai également connecté en vpn un windows, une tablette Ios et mon téléphone android.

Mais cette après-midi, j'essaye à nouveau de me connecter sur Ubuntu, je vois qu'il essaye pendant 1 minute environ puis j'ai un message d'erreur.
En fait, j'ai eu ça quand j'ai tenté de me connecter en cliquant sur le petit "cadenat" à droite de l'icone de connection dans la barre de menu.

Là, je viens de tester via l'icone de connection et ça a l'air de fonctionner.

Est-ce que le fait de cliquer sur l'icône de droite c'est comme s'il s'agissait d'un réseau (virtuel) dans le réseau actuel et donc vouloir crééer un vpn dan sun vpn qui n'est pas encore connecté ? Serait-ce pour cela que ça ne fonctionnait pas ?

Hors ligne

#7 Le 23/08/2018, à 22:53

Timothée123

Re : Config OpenVPN Via NAS Synology

Petit up,

Si jamais quelqu'un pourrait répondre à cette question :
J'ai toujours besoin de tenter de me connecter deux fois avant que cela ne fonctionne.

La première fois, il essaye de se connecter environ 1 minute, puis je réessaye et ça fonctionne directement.

Aurai-je mal configuré quelque chose ?

Hors ligne

#8 Le 14/09/2018, à 19:30

Fredouillemugen

Re : Config OpenVPN Via NAS Synology

Salut désolé de pas être réactif, période chargée.
As-tu bien déposé et laissé le fichier .ovpn et ces certificats dans un dossier fixe ? Sans les effacer ensuite ?
Avec mon netgear, j'avais un soucis similaire, car j'importais le fichier, puis l'effaçait ensuite, erreur à ne pas commettre.
Si tu effaces les fichiers, le VPN ne se lancera pas, car tu n'importe pas le fichier au network-manager-ovpn, tu lui indiques où il est ! Pour exemple, au début de mes essais, je gardais les fichiers dans “téléchargements”, j'importais, puis ça marchait ! Par contre ensuite je vidais le dossier “téléchargements”, et du coups ça ne marchait plus !!! C'est bête, mais j'ai cherché un moment à l'époque.


La raison a ses raisons que la raison ne connait pas...
---
Chérie apportes-moi une bière, stp ! Non lèves-toi...
Sudo Chérie apporte moi une bière stp ! ...

Hors ligne