Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/06/2019, à 14:01

manup31

[RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Bonjour, je reposte ici une question posée dans le forum Geckozone, sans réponse jusqu'à présent.

Il m'y est conseillé de la poser ici, des fois que ce soit lié à Ubuntu, ce dont je doute plutôt enclin à penser à un pb de profil Thunderbird (TB).

Ubuntu 18.04.2, Thunderbird 60.6.1 (64 bits) et Firefox 67.0 (64 bits)

Je lance TB avec les options --no-remote -P pour choisir un profil au démarrage (perso ou pro) et lorsque sur un profil j'ai un mail avec un lien/URL sur lequel je clique, alors que Firefox est déjà lancé (pas de profils sur FF, il n'y a que default), j'ai l'erreur :

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

Si FF n'est pas lancé au moment où je clique dans le lien du mail, il se lance et un nouvel onglet affiche la page correspondante à l'URL. OK.

J'ai touché les paramètres de TB pour être en mesure de choisir le navigateur pour des liens http(s), et lorsque je choisis Brave : pas de pb, un nouvel onglet est ouvert qui affiche la page demandée dans Brave.

Seul FF me pose ce soucis. Comment le corriger ? Merci.

J'ai déjà essayé de désactiver les 3 extensions actives de FF pour le même résultat.

Merci.

Dernière modification par manup31 (Le 03/06/2019, à 19:30)


manu'

Hors ligne

#2 Le 03/06/2019, à 15:01

rogn...

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Ce n'est lié à aucune extension, par contre, peux-tu montrer ton profiles.ini de Firefox ?

cat $(find ~/.mozilla/ -name "profiles.ini")

#3 Le 03/06/2019, à 15:24

manup31

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Merci @rogn...

[Install4F96D1932A9F858E]
Default=8qs6lvca.default-1404403210443-1501186888107

[Profile0]
Name=default
IsRelative=1
Path=8qs6lvca.default-1404403210443-1501186888107
Default=1

[General]
StartWithLastProfile=1
Version=2

manu'

Hors ligne

#4 Le 03/06/2019, à 15:29

rogn...

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Wew neutral
Que donne

ls -lR ~/.mozilla/

#5 Le 03/06/2019, à 16:10

manup31

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

OK, l'output de ce ls -lR fait 10 000 lignes, peut-être que tu as pas besoin de tout ce qui est sous .../storage ?


manu'

Hors ligne

#6 Le 03/06/2019, à 16:12

rogn...

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Zut, le R était peut être en trop. roll

ls -l ~/.mozilla/

#7 Le 03/06/2019, à 16:24

manup31

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

big_smile

manu@8570w:~$ ls -l ~/.mozilla/
total 20
drwx------ 3 manu manu 4096 nov.  23  2011 eclipse
drwx------ 2 manu manu 4096 sept. 13  2012 extensions
drwx------ 5 manu manu 4096 mai   22 08:52 firefox
drwxrwxrwx 2 manu manu 4096 août  21  2015 plugins
drwx------ 2 manu manu 4096 nov.  16  2017 systemextensionsdev

manu'

Hors ligne

#8 Le 03/06/2019, à 16:28

rogn...

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Ok, maintenant

ls -l ~/.mozilla/firefox/

Dernière modification par rogn... (Le 03/06/2019, à 16:28)

#9 Le 03/06/2019, à 16:29

manup31

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

manu@8570w:~$ ls -l ~/.mozilla/firefox/
total 44
drwx------ 18 manu manu  4096 juin   3 16:29  8qs6lvca.default-1404403210443-1501186888107
drwx------  5 manu manu 12288 mai   22 08:52 'Crash Reports'
-rw-rw-rw-  1 manu manu    73 mai   28 21:20  installs.ini
drwx------  2 manu manu  4096 déc.   4 08:53 'Pending Pings'
-rw-rw-rw-  1 manu manu   222 mai   28 21:20  profiles.ini
-rw-r--r--  1 manu manu 13649 avril  8  2013  usagefinder_results.xml

manu'

Hors ligne

#10 Le 03/06/2019, à 18:16

kamaris

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Je peux reproduire le problème chez moi, avec deux profils de TB lancés en parallèle en utilisant --no-remote. Ça ressemble à un bug, non ?
Car l'option --no-remote ne semble plus être nécessaire dans TB 60.7 pour lancer deux profils différents en parallèle, dans deux process distincts (comme d'ailleurs elle ne semble plus l'être non plus dans FF 67, probablement à cause de la nouvelle possibilité d'exécuter différentes releases en parallèle).
Perso, si je lance mes deux profils TB sans l'option --no-remote, ils tournent bien en parallèle dans deux process distincts, et je n'ai plus ce soucis avec l'ouverture des liens dans FF.

EDIT : @manup31 : je viens de voir que tu es en 60.6.1 au niveau de TB, il faudra probablement que tu te mettes à jour vers 60.7 pour avoir la même chose que moi.

Dernière modification par kamaris (Le 03/06/2019, à 18:21)

Hors ligne

#11 Le 03/06/2019, à 19:04

manup31

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Rhââ !!! tonguelol

Merci @kamaris, effectivement sans --no-remote, donc juste "thunderbird -P" TB ouvre ensuite correctement les liens dans FF, sans le message d'erreur et comme avec Brave.

J'ai bien la 60.7 après le dernier apt update.

La raison d'utiliser --no-remote est que ça permet d'avoir le favori TB (lanceur) qui ouvre la fenêtre de sélection de profil quand tu choisis "Nouvelle fenêtre", ce qui ne fonctionne pas sans --no-remote où il ne se passe rien. Tu dois pouvoir reproduire.

Disons que pour l'instant, je peux m'en sortir en n'utilisant qu'un TB à la fois, ou (ce que je n'ai pas encore trouvé) en créant deux favoris TB, un pour chaque profil et intégrer ça proprement dans les favoris GNOME (les lanceurs) ce qui est une autre histoire...


manu'

Hors ligne

#12 Le 03/06/2019, à 19:12

nam1962

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Et si tu lances avec -new-instance au lieu de -no-remote ?


[ Modéré ]

Hors ligne

#13 Le 03/06/2019, à 19:17

kamaris

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

@manup31 : oui, effectivement : si TB est ouvert avec un certain profil, et que je fais thunderbird -P, ça me renvoie vers le TB déjà ouvert.
Par contre, si je fais thunderbird -P autre-profil, ça ouvre bien TB avec cet autre profil en parallèle. Donc oui, tu dois pouvoir t'en sortir avec deux lanceurs, ou bien en lançant depuis un terminal, ou bien un script en début de session, etc.

Hors ligne

#14 Le 03/06/2019, à 19:29

manup31

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

Voilà, merci à tous, je n'ai pas essayé la nouvelle option -new-instance, mais créé deux lanceurs pour les deux profils, puis bricolé un tiroir dans les favoris en pompant celui de mes Navigateurs et tout roule. J'ouvre donc les deux TB en // et d'un côté comme de l'autre les liens dans les mails sont bien ouverts dans FF.


manu'

Hors ligne

#15 Le 04/06/2019, à 11:30

kamaris

Re : [RÉSOLU] Erreur ouverture de lien dans Firefox à p. de Thunderbird

En voulant faire un rapport de bug pour cette histoire de --no-remote, le moteur de Bugzilla m'a trouvé comme rapport similaire celui-ci : « -no-remote interferes with other Gecko based applications (e.g. Firefox launching Thunderbird via mailto or TB launching FF via click on link) »
Rapporté le… 30 mai 2007 yikes
Donc pas sûr que ce soit corrigé demain… j'ai mentionné que l'option --new-instance produit le même effet au niveau du « click on link ».

Hors ligne