Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/09/2019, à 14:35

furet12330

Openproject HS

Bonjour,

Je suis en train de configurer un serveur OpenProject sur Ubuntu Server 18.04 mais cela ne se passe pas comme je le souhaiterais.
J'ai pu installer le serveur openproject grâce à la doc ici : https://www.openproject.org/download-and-installation/
Tout fonctionnait bien, jusqu'au reboot du serveur. Je ne peux plus accéder à openproject depuis mon navigateur :

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Apache/2.4.29 (Ubuntu) Server at 10.10.1.22 Port 443

J'ai tenté de faire un reconfigure de openproject avec la commande sudo openproject reconfigure et voici le message d'erreur obtenu :

Bundler could not find compatible versions for gem "rails":
  In Gemfile:
    openproject-bim_seeder was resolved to 1.0.0, which depends on
      openproject-bcf was resolved to 1.0.0, which depends on
        rails (~> 5)

    openproject-emoji was resolved to 5.0.0, which depends on
      rails (~> 4.2.4)

J'ai tenter de tout désinstaller puis de réinstaller openproject, sans succès.

j'ai fait un bundle update, mais j'obtiens maintenant le message d'erreur :

Your Ruby version is 2.5.1, but your Gemfile specified ~> 2.6.1

Je modifie alors le fichier GemFile pour lui indiquer que la version de Ruby est en 2.5.1

ruby '~> 2.5.1'

Ce coup-ci la commande sudo bundle update fait plein de Fetching et Installing pendant plusieurs minutes puis le message d'erreur suivant apparaît :

An error occurred while installing pg (1.1.4), and Bundler cannot continue.
Make sure that `gem install pg -v '1.1.4'` succeeds before bundling.

Je fais un sudo gem install pg -v '1.1.4' mais erreur :

ERROR:  Error installing pg:
        ERROR: Failed to build gem native extension.
[...]
    current directory: /var/lib/gems/2.5.0/gems/pg-1.1.4/ext
/usr/bin/ruby2.5 -r ./siteconf20190912-3532-1zl5mg.rb extconf.rb

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/pg-1.1.4/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.5.0/gems/pg-1.1.4 for inspection.
Results logged to /var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/pg-1.1.4/gem_make.out

J'ai pu trouve ce message d'erreur dans le log mkmf.log :

"gcc -E -I/usr/include/x86_64-linux-gnu/ruby-2.5.0 -I/usr/include/ruby-2.5.0/ruby/backward -I/usr/include/ruby-2.5.0 -I. -Wdate-time -D_FORTIFY_SOURCE=2   -g -O2 -fdebug-prefix-map=/build/ruby2.5-TdNoZ6/ruby2.5-2.5.1=. -fstack-protector$
conftest.c:3:10: fatal error: libpq-fe.h: No such file or directory

Dans le log gem_make.out, cela indique qu'il faut installer postgresql-server-dev-NN
Je fait donc un sudo apt-get install postgresql-server-dev-all

Je refais un sudo gemfile updtate mais maintenant il faut que j'installe libmysqlclient-dev ce que je fais.
Maintenant le gemfile update fini avec succès ! ouff!

Je retente de reconfigurer openproject mais me revoilà de nouveau bloqué :

Your Ruby version is 2.6.1, but your Gemfile specified ~> 2.5.1

Je modifié le fichier Gemfile pour indiquer que la version de Ruby est la 2.6.1 mais me revoilà avec l'erreur suivante :

[openproject] ./bin/postinstall
Fetching https://github.com/tessi/openproject-emoji.git
Fetching gem metadata from https://rubygems.org/......
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies........
Bundler could not find compatible versions for gem "rails":
  In snapshot (Gemfile.lock):
    rails (= 5.2.2.1)

  In Gemfile:
    openproject-emoji was resolved to 5.0.0, which depends on
      rails (~> 4.2.4)

    typed_dag (~> 2.0.2) was resolved to 2.0.2, which depends on
      rails (>= 5.0.4)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
project@127:/opt/openproject$


Je n'arrive pas à m'en sortir et je viens donc ici pour trouver un peu d'aide.
D'avance merci pour votre aide.

Dernière modification par furet12330 (Le 12/09/2019, à 14:52)

Hors ligne