Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/10/2019, à 13:36

Jayllyz

SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

Bonjour,
je rencontre un problème d'installation de Linux Ubuntu 19.4 en  Dual Boot sur mon Dell Inspiron 14 7000 (7490).
Le pc étant tout nouveau, présenté lors de l'IFA 2019, je n'ai pas pu trouver  d'informations sur les forums à propos de ce problème sur le même modèle que moi.

Je mets ma clé usb, l’installation se lance pour l’instant sans soucis mais une fois sur l’étape où il faut choisir sur quel disque on veut mettre notre Ubuntu et bien tout simplement je n’ai rien, l’installateur ne détecte aucun disque (j’ai 1 disque nvme de 1to déjà partitionné pour procéder à l’installation)

Alors j’ai tout d’abord essayé une autre version de Ubuntu, malheureusement toujours le même problème (je suis même bloqué au chargement sur une des versions)
Ensuite j’ai tenté le safe mode, de passer mon ssd en mode AHCI à la place de RAID mais l’option n’est pas présente dans mon bios. Alors, j’ai lancé windows en mode sans échec et effectué une commande pour l’activer, j’ai suivi la totalité des marches à suivre que j’ai trouvé sur des forums ou sur des sites de confiances.
Notamment une manipulation qui m'a paru être la bonne à première vu (ici) mais malheureusement cela n'a pas résolu le problème.

Ce n’est pas la première fois que j’installe Linux mais j'e n'ai jamais eu à faire à une t - elle situation  alors c'est pourquoi je viens demander de l'aide sur ce forum.
Merci d'avoir pris le temps de lire mon post, Jayllyz.

Dernière modification par Jayllyz (Le 06/10/2019, à 15:58)

Hors ligne

#2 Le 06/10/2019, à 16:05

geole

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

Bonjour
Je n'ai pas tout compris.
Le lien que tu indiques dit "Accédez à la catégorie SATA Operations et passez de AHCI à RAID"
Cela me semble un conseil erroné.


Si ton bios ne permet pas de passer du mode RAID au mode AHCI, c'est fichu pour faire une installation de ubuntu.

Si tu n'as pas besoin  de toutes les fonctionnalités de ubuntu, tu devrais essayer  d'installer ubuntu dans windows

Sinon,   il est possible que  fabriquer un dual boot en  installant  ubuntu dans windows  soit possible mais je ne sais pas du tout si le boot fonctionnera... Cependant si tu es tenté, regarde cette documentation.

Dernière modification par geole (Le 06/10/2019, à 16:09)


Les grilles de l'installateur https://doc.ubuntu-fr.org/tutoriel/inst … _subiquity
"gedit admin:///etc/fstab" est proscrit,  utilisez "pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY xdg-open /etc/fstab" Voir  https://doc.ubuntu-fr.org/gedit
Les partitions EXT4 des disques externes => https://forum.ubuntu-fr.org/viewtopic.p … #p22697248

En ligne

#3 Le 06/10/2019, à 16:13

Jayllyz

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

geole a écrit :

Bonjour
Je n'ai pas tout compris.
Le lien que tu indiques dit "Accédez à la catégorie SATA Operations et passez de AHCI à RAID"
Cela me semble un conseil erroné.


Si ton bios ne permet pas de passer du mode RAID au mode AHCI, c'est fichu pour faire une installation de ubuntu.

Si tu n'as pas besoin  de toutes les fonctionnalités de ubuntu, tu devrais essayer  d'installer ubuntu dans windows

Sinon,   il est possible que  fabriquer un dual boot en  installant  ubuntu dans windows  soit possible mais je ne sais pas du tout si le boot fonctionnera... Cependant si tu es tenté, regarde cette documentation.

Merci pour votre réponse, effectivement mon bios ne propose pas de passer le SSD en mode ACHI mais seulement de desactiver la comptatibilité RAID, si cela empeche totalement l'installation ca va vraiment me poser problème ..  Je vais me renseigner sur votre dernière manipulation, merci beaucoup.

Hors ligne

#4 Le 06/10/2019, à 16:16

geole

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

As-tu essayé de déactiver le RAIDS?

Il est possible qu'en déactivant le RAIDS, windows ne puisse plus booter mais si l'installateur de ubuntu  voit le NVME, c'est gagné car il suffit alors de réinstaller windows.

Dernière modification par geole (Le 06/10/2019, à 16:17)


Les grilles de l'installateur https://doc.ubuntu-fr.org/tutoriel/inst … _subiquity
"gedit admin:///etc/fstab" est proscrit,  utilisez "pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY xdg-open /etc/fstab" Voir  https://doc.ubuntu-fr.org/gedit
Les partitions EXT4 des disques externes => https://forum.ubuntu-fr.org/viewtopic.p … #p22697248

En ligne

#5 Le 06/10/2019, à 16:21

Jayllyz

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

geole a écrit :

As-tu essayé de déactiver le RAIDS?

Il est possible qu'en déactivant le RAIDS, windows ne puisse plus booter mais si l'installateur de ubuntu  voit le NVME, c'est gagné car il suffit alors de réinstaller windows.

J'ai déjà essayé mais malheureusement Ubuntu ne détecte toujours pas le ssd une fois cette option désactivé.

Hors ligne

#6 Le 06/10/2019, à 16:35

geole

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

As-tu essayé avec la version 19.10 ?
Sinon, je ne vois donc que  l'une des deux solutions de repli.

Dernière modification par geole (Le 06/10/2019, à 16:35)


Les grilles de l'installateur https://doc.ubuntu-fr.org/tutoriel/inst … _subiquity
"gedit admin:///etc/fstab" est proscrit,  utilisez "pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY xdg-open /etc/fstab" Voir  https://doc.ubuntu-fr.org/gedit
Les partitions EXT4 des disques externes => https://forum.ubuntu-fr.org/viewtopic.p … #p22697248

En ligne

#7 Le 06/10/2019, à 16:36

Jayllyz

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

geole a écrit :

As-tu essayé avec la version 19.10 ?
Sinon, je ne vois donc que  l'une des deux solutions de repli.

Je vais essayer
Cette version n'a pas fonctionné il y a eu un message d'erreur dans la console de boot, je peux vous le fournir j'ai pris une photo.

Dernière modification par Jayllyz (Le 06/10/2019, à 17:05)

Hors ligne

#8 Le 06/10/2019, à 17:19

Jayllyz

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

geole a écrit :

1570375126-20191006-170404.png

Hors ligne

#9 Le 06/10/2019, à 17:38

geole

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

La description de ton ordinateur  est certainement disponible ICI https://www.ldlc.com/fiche/PB00278988.html
Le message d'erreur semble indiquer que le processeur n'est pas reconnu.
https://github.com/torvalds/linux/blob/ … nnonlake.c
    PINCTRL_PIN(180, "SRCCLKREQB_7"),

https://www.google.com/search?as_q=&as_ … as_rights=
https://forum.touslesdrivers.com/repons … m=1&v_pr=1
Ce qui semble surprenant puisque la version 19.04 n'avait pas de problème.

Je ne sais pas aller plus loin dans ce problème de la version 19.10

Dernière modification par geole (Le 06/10/2019, à 17:52)


Les grilles de l'installateur https://doc.ubuntu-fr.org/tutoriel/inst … _subiquity
"gedit admin:///etc/fstab" est proscrit,  utilisez "pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY xdg-open /etc/fstab" Voir  https://doc.ubuntu-fr.org/gedit
Les partitions EXT4 des disques externes => https://forum.ubuntu-fr.org/viewtopic.p … #p22697248

En ligne

#10 Le 10/10/2019, à 15:00

krank35

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

Bonjour j'ai le même problème sur la nouvelle série Dell 5500 le disque n'est pas visible après le boot sur la clé USB Ubuntu

Hors ligne

#11 Le 10/10/2019, à 15:28

geole

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

Bonjour
As-tu pu accéder au bios et regarder le mode de connexion pour le modifier?
L'as-tu commandé avec un NVME ou un disque dur


Les grilles de l'installateur https://doc.ubuntu-fr.org/tutoriel/inst … _subiquity
"gedit admin:///etc/fstab" est proscrit,  utilisez "pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY xdg-open /etc/fstab" Voir  https://doc.ubuntu-fr.org/gedit
Les partitions EXT4 des disques externes => https://forum.ubuntu-fr.org/viewtopic.p … #p22697248

En ligne

#12 Le 10/10/2019, à 15:41

krank35

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

Le Laptop 5500 arrive avec un SSD


Quelques infos:
https://www.dell.com/support/article/fr … m2?lang=fr
http://manpages.ubuntu.com/manpages/cos … eebsd.html

Dernière modification par krank35 (Le 10/10/2019, à 15:45)

Hors ligne

#13 Le 10/10/2019, à 16:24

geole

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

Tu peux toujours essayer l'option proposée. Je découvre la façon de faire.
J'espère la comprendre. Si tu veux essayer.

http://manpages.ubuntu.com/manpages/cosmic/man4/nvme.4freebsd.html a écrit :

     To compile this driver into your kernel, place the following line in your kernel
     configuration file:

           device nvme

     Or, to load the driver as a module at boot, place the following line in loader.conf(5):

           nvme_load="YES"

ce qui nous envoie sur

http://manpages.ubuntu.com/manpages/cosmic/man5/loader.conf.5.html a écrit :

systemd-boot(7) will read /loader/loader.conf and any files with the ".conf" extension
       under /loader/loader.conf.d/ on the EFI system partition (ESP).

       Each configuration file must consist of an option name, followed by whitespace, and the
       option value.  "#" may be used to start a comment line. Empty and comment lines are
       ignored.

Grosso-modo, je comprend la chose suivante
  Il  faut que tu modifies le support d'installation de UBUNTU
Si tu regardes son contenu, tu verras qu'il y a un répertoire EFI
A l'intérieur de ce répertoire /EFI, il y a un répertoire BOOT

Je comprend qu'il y manque le répertoire   loader  qui héberge le fichier  loader.conf contenant  le  paramètre nvme_load="YES"

Je te laisse essayer autour  cette direction.

Si le live USB reconnaît alors le NVME, tu pourras faire l'installation.


Autre possibilité vue dans ton premier lien.
ajoute l'option nvme_load=YES    dans le grub au moment du démarrage de la live-usb
en utilisant la même méthode que l'ajout nomodeset
Voir paragraphe 7.2 de https://doc.ubuntu-fr.org/kernel#modifi … ssion-live.
Cependant, je l'ai déjà proposée sans succès dans une discussion.
Sinon, essaie d'installer la version 14.04 afin de savoir si ubuntu est en régression.

Bon courage.

Dernière modification par geole (Le 10/10/2019, à 16:45)


Les grilles de l'installateur https://doc.ubuntu-fr.org/tutoriel/inst … _subiquity
"gedit admin:///etc/fstab" est proscrit,  utilisez "pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY xdg-open /etc/fstab" Voir  https://doc.ubuntu-fr.org/gedit
Les partitions EXT4 des disques externes => https://forum.ubuntu-fr.org/viewtopic.p … #p22697248

En ligne

#14 Le 11/10/2019, à 11:04

krank35

Re : SSD NVME non reconnu lors de l'installation (DELL 7490) Ubuntu 19.4

J'ai testé au moment du Grub avec edition ça ne fonctionne pas je regarde pour le reste

Dans les dernières versions les fichiers sont dans

Boot > Grub ou il y a deux fichiers .cfg  (grub.cfg , loopback.cfg)

Dans les deux fichiers il y a les lignes comme ci-dessous:

menuentry "Try Ubuntu without installing (safe graphics)" {
    set gfxpayload=keep
    linux    /casper/vmlinuz  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash nomodeset ---
    initrd    /casper/initrd

Dernière modification par krank35 (Le 11/10/2019, à 11:09)

Hors ligne