Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/06/2020, à 07:07

Armanio

[Résolu] Problème de noyau Linux

Bonjour,

Je suis sur Ubuntu 20.04, et j'ai un problème avec les noyaux Linux récents : lorsque j'essaie de booter sur les versions 5.4.0-37 ou 5.4.0-33, le système ne démarre pas, et reste bloqué sur "Chargement du disque mémoire initial".
Heureusement, l'ordinateur arrive à booter sur 5.4.0-31...

La machine est un Dell Latitude 7400 récent (acheté en novembre 2019).

Merci d'avance de votre aide,

Armanio

Dernière modification par Armanio (Le 19/06/2020, à 09:06)

Hors ligne

#2 Le 16/06/2020, à 07:18

xubu1957

Re : [Résolu] Problème de noyau Linux

Bonjour,

Montre, en te servant du Retour utilisable de commande :

echo; dpkg -l | grep -Ei "linux-(g|h|i|lo|mo|si|t)" | grep -v ^rc | sort -k3 | awk '{print $1,$2,$3,$4}' | column -s" " -t ; echo ; uname -mr

Méthode détaillée :

cqfd93 a écrit :

Bonjour,

Entrer des commandes dans un terminal et donner le résultat - Voilà la marche à suivre :

  1. Ouvre le terminal avec ctrl-alt-t

  2. Sélectionne la commande voulue avec un triple clic (ça sélectionne toute la ligne, même la fin si on ne la voit pas)

  3. Colle-la dans le terminal avec un clic molette, valide avec Entrée

  4. Sélectionne et copie tout ce que te dit le terminal depuis la commande jusqu'à la dernière ligne incluse

  5. Clique sur le <> de l'éditeur de message

    1578079461.png

  6. Colle là où se trouve le curseur (entre le ] et le [)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 16/06/2020, à 07:45

Armanio

Re : [Résolu] Problème de noyau Linux

Bonjour,

Voici le retour :

raoux@montrachet:~$ echo; dpkg -l | grep -Ei "linux-(g|h|i|lo|mo|si|t)" | grep -v ^rc | sort -k3 | awk '{print $1,$2,$3,$4}' | column -s" " -t ; echo ; uname -mr

ii  binutils-x86-64-linux-gnu             2.34-6ubuntu1   amd64
ii  linux-headers-4.15.0-1079-oem         4.15.0-1079.89  amd64
ii  linux-modules-5.4.0-31-generic        5.4.0-31.35     amd64
ii  linux-modules-extra-5.4.0-31-generic  5.4.0-31.35     amd64
ii  linux-image-5.4.0-31-generic          5.4.0-31.35     amd64
ii  linux-headers-5.4.0-33                5.4.0-33.37     all
ii  linux-modules-5.4.0-33-generic        5.4.0-33.37     amd64
ii  linux-modules-extra-5.4.0-33-generic  5.4.0-33.37     amd64
ii  linux-headers-5.4.0-33-generic        5.4.0-33.37     amd64
ii  linux-image-5.4.0-33-generic          5.4.0-33.37     amd64
ii  linux-generic                         5.4.0.37.40     amd64
ii  linux-image-oem                       5.4.0.37.40     amd64
ii  linux-headers-generic                 5.4.0.37.40     amd64
ii  linux-image-generic                   5.4.0.37.40     amd64
ii  linux-headers-5.4.0-37                5.4.0-37.41     all
ii  linux-modules-5.4.0-37-generic        5.4.0-37.41     amd64
ii  linux-modules-extra-5.4.0-37-generic  5.4.0-37.41     amd64
ii  linux-headers-5.4.0-37-generic        5.4.0-37.41     amd64
ii  linux-image-5.4.0-37-generic          5.4.0-37.41     amd64

5.4.0-31-generic x86_64
raoux@montrachet:~$ 

Hors ligne

#4 Le 16/06/2020, à 08:13

xubu1957

Re : [Résolu] Problème de noyau Linux

Vu :

linux-image-oem   

Je ne sais pas gérer les noyaux oem de Dell.

Il faut des aidants experts.

Montre le sources.list :

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

Dernière modification par xubu1957 (Le 16/06/2020, à 08:13)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 16/06/2020, à 08:31

Armanio

Re : [Résolu] Problème de noyau Linux

Retour de Sources.list

raoux@montrachet:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list.d/bionic-oem.list

     1	# deb http://oem.archive.canonical.com/updates/ bionic-oem public # désactivé pour la mise à niveau vers focal
     2	# deb-src http://oem.archive.canonical.com/updates/ bionic-oem public

/etc/apt/sources.list.d/bionic-dell-merion.list

     1	# deb http://dell.archive.canonical.com/updates/ bionic-dell-merion public # désactivé pour la mise à niveau vers focal
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell-merion public

/etc/apt/sources.list.d/nextcloud-devs-ubuntu-client-bionic.list

     1	# deb http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal main # désactivé pour la mise à niveau vers focal
     2	# deb-src http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic main

/etc/apt/sources.list.d/bionic-dell-service.list

     1	# deb http://dell.archive.canonical.com/updates/ bionic-dell-service public # désactivé pour la mise à niveau vers focal
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell-service public

/etc/apt/sources.list.d/google-chrome.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	# deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main # désactivé pour la mise à niveau vers focal

/etc/apt/sources.list.d/samoilov-lex-ubuntu-aftl-stable-bionic.list

     1	# deb http://ppa.launchpad.net/samoilov-lex/aftl-stable/ubuntu focal main # désactivé pour la mise à niveau vers focal
     2	# deb-src http://ppa.launchpad.net/samoilov-lex/aftl-stable/ubuntu bionic main

/etc/apt/sources.list.d/bionic-dell.list

     1	# deb http://dell.archive.canonical.com/updates/ bionic-dell public # désactivé pour la mise à niveau vers focal
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell public

/etc/apt/sources.list

     1	# deb cdrom:[Ubuntu 18.04 _Bionic_ - Build amd64 LIVE Binary 20180608-09:38]/ bionic main
     2	
     3	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4	# newer versions of the distribution.
     5	deb http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
     6	# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted
     7	
     8	## Major bug fix updates produced after the final release of the
     9	## distribution.
    10	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    11	# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
    12	
    13	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14	## team. Also, please note that software in universe WILL NOT receive any
    15	## review or updates from the Ubuntu security team.
    16	deb http://fr.archive.ubuntu.com/ubuntu/ focal universe
    17	# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic universe
    18	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
    19	# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates universe
    20	
    21	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22	## team, and may not be under a free licence. Please satisfy yourself as to 
    23	## your rights to use the software. Also, please note that software in 
    24	## multiverse WILL NOT receive any review or updates from the Ubuntu
    25	## security team.
    26	deb http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
    27	# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic multiverse
    28	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    29	# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
    30	
    31	## N.B. software from this repository may not have been tested as
    32	## extensively as that contained in the main release, although it includes
    33	## newer versions of some applications which may provide useful features.
    34	## Also, please note that software in backports WILL NOT receive any review
    35	## or updates from the Ubuntu security team.
    36	deb http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    37	# deb-src http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
    38	
    39	## Uncomment the following two lines to add software from Canonical's
    40	## 'partner' repository.
    41	## This software is not part of Ubuntu, but is offered by Canonical and the
    42	## respective vendors as a service to Ubuntu users.
    43	deb http://archive.canonical.com/ubuntu focal partner
    44	# deb-src http://archive.canonical.com/ubuntu bionic partner
    45	
    46	deb http://security.ubuntu.com/ubuntu focal-security main restricted
    47	# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
    48	deb http://security.ubuntu.com/ubuntu focal-security universe
    49	# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
    50	deb http://security.ubuntu.com/ubuntu focal-security multiverse
    51	# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse
raoux@montrachet:~$ 

Hors ligne

#6 Le 16/06/2020, à 08:47

xubu1957

Re : [Résolu] Problème de noyau Linux

/etc/apt/sources.list.d/bionic-oem.list

     1	# deb http://oem.archive.canonical.com/updates/ bionic-oem public # désactivé pour la mise à niveau vers focal
     2	# deb-src http://oem.archive.canonical.com/updates/ bionic-oem public

/etc/apt/sources.list.d/bionic-dell-merion.list

     1	# deb http://dell.archive.canonical.com/updates/ bionic-dell-merion public # désactivé pour la mise à niveau vers focal
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell-merion public

/etc/apt/sources.list.d/nextcloud-devs-ubuntu-client-bionic.list

     1	# deb http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal main # désactivé pour la mise à niveau vers focal
     2	# deb-src http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic main

/etc/apt/sources.list.d/bionic-dell-service.list

     1	# deb http://dell.archive.canonical.com/updates/ bionic-dell-service public # désactivé pour la mise à niveau vers focal
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell-service public

En passant de la version 18.04 à la version 20.04, les sources concernant Dell ont été désactivées.

Je n'ai pas la capacité pour gérer cette situation.

Je vais prévenir des aidants experts.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 16/06/2020, à 09:05

Armanio

Re : [Résolu] Problème de noyau Linux

Ok, merci de ton retour rapide, et de ton suivi !

Hors ligne

#8 Le 16/06/2020, à 09:15

cqfd93

Re : [Résolu] Problème de noyau Linux

Bonjour,

On peut essayer de réactiver tous ces dépôts et on verra après.

  • Modification de sources.list :

    sudo sed -i 's/bionic/focal/' /etc/apt/sources.list
  • Modification des fichiers des ppa :

    cd /etc/apt/sources.list.d
    sudo sed -i 's/bionic/focal/' *.list*
    sudo sed -i 's/# deb /deb /' *.list*
  • Et après tout ça :

    sudo apt update
    sudo apt full-upgrade

(Donne tous les retours)


cqfd93

Hors ligne

#9 Le 16/06/2020, à 10:30

xubu1957

Re : [Résolu] Problème de noyau Linux

Pour ces paquets > dell.archive.canonical.com/dists/bionic-dell-merion, je n'ai pas trouvé d'information.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#10 Le 16/06/2020, à 10:52

Armanio

Re : [Résolu] Problème de noyau Linux

Bonjour !

Le retour pour jusqu'à l'update :

raoux@montrachet:~$ sudo sed -i 's/bionic/focal/' /etc/apt/sources.list
[sudo] Mot de passe de raoux : 
raoux@montrachet:~$ cd /etc/apt/sources.list.d
raoux@montrachet:/etc/apt/sources.list.d$ sudo sed -i 's/bionic/focal/' *.list*
raoux@montrachet:/etc/apt/sources.list.d$ sudo sed -i 's/# deb /deb /' *.list*
raoux@montrachet:/etc/apt/sources.list.d$ sudo apt update
Ign :1 http://dell.archive.canonical.com/updates focal-dell-merion InRelease
Réception de :2 http://oem.archive.canonical.com/updates focal-oem InRelease [4747 B]
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal InRelease                        
Atteint :4 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                
Atteint :5 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease              
Atteint :6 http://security.ubuntu.com/ubuntu focal-security InRelease                 
Ign :7 http://dell.archive.canonical.com/updates focal-dell-service InRelease         
Atteint :8 http://dl.google.com/linux/chrome/deb stable InRelease                     
Atteint :9 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal InRelease      
Réception de :10 http://dell.archive.canonical.com/updates focal-dell InRelease [4710 B]
Err :11 http://dell.archive.canonical.com/updates focal-dell-merion Release           
  404  Not Found [IP : 91.189.89.6 80]
Ign :12 http://ppa.launchpad.net/samoilov-lex/aftl-stable/ubuntu focal InRelease      
Err :13 http://dell.archive.canonical.com/updates focal-dell-service Release          
  404  Not Found [IP : 91.189.89.6 80]
Err :14 http://ppa.launchpad.net/samoilov-lex/aftl-stable/ubuntu focal Release        
  404  Not Found [IP : 91.189.95.83 80]
Atteint :15 http://archive.canonical.com/ubuntu focal InRelease                       
Réception de :16 http://oem.archive.canonical.com/updates focal-oem/public i386 Packages [412 B]
Réception de :17 http://oem.archive.canonical.com/updates focal-oem/public amd64 Packages [412 B]
Lecture des listes de paquets... Fait
E: Le dépôt http://dell.archive.canonical.com/updates focal-dell-merion Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://dell.archive.canonical.com/updates focal-dell-service Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://ppa.launchpad.net/samoilov-lex/aftl-stable/ubuntu focal Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

Merci

Hors ligne

#11 Le 16/06/2020, à 11:05

cqfd93

Re : [Résolu] Problème de noyau Linux

Bon, on va désactiver les 3 dépôts qui n'existent pas pour focal :

cd /etc/apt/sources.list.d
sudo sed -i 's/deb /# deb /' bionic-dell-merion.list bionic-dell-service.list samoilov-lex-ubuntu*

Et re-mises à jour :

sudo apt update
sudo apt full-upgrade

Et donne les retours complets. Un retour complet doit contenir toutes les lignes depuis celle de la commande jusqu'à la ligne attendant la commande suivante, exemple :

moi@lenovo:~$ uname -a
Linux moi-lenovo 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
moi@lenovo:~$ 

cqfd93

Hors ligne

#12 Le 16/06/2020, à 17:41

Armanio

Re : [Résolu] Problème de noyau Linux

Re,
Voici les retours. Après un test éteindre/démarrer, le problème reste le même.

raoux@montrachet:/etc/apt/sources.list.d$ sudo apt update
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                                                                             
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease                                                                           
Atteint :4 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                  
Atteint :5 http://archive.canonical.com/ubuntu focal InRelease                                                                                     
Atteint :6 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal InRelease                                             
Réception de :7 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]        
Atteint :8 http://dell.archive.canonical.com/updates focal-dell InRelease    
Réception de :9 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [21,2 kB]
Réception de :10 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [31,6 kB]
Atteint :11 http://oem.archive.canonical.com/updates focal-oem InRelease               
160 ko réceptionnés en 2s (85,4 ko/s)      
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.
raoux@montrachet:/etc/apt/sources.list.d$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  adium-theme-ubuntu dh-python diffstat enchant example-content fonts-noto-hinted fonts-noto-ui-core fonts-roboto-hinted gir1.2-gtksource-3.0
  gir1.2-mutter-2 gnome-software-common gnome-user-guide guile-2.0-libs libappindicator1 libappstream-glib8 libapt-pkg-perl libart-2.0-2
  libasync-mergepoint-perl libavresample3 libavutil55 libboost-date-time1.65.1 libboost-iostreams1.65.1 libboost-python1.65.1 libbrlapi0.6
  libbtparse1 libcapture-tiny-perl libcdio17 libcpanel-json-xs-perl libcrystalhd3 libdbusmenu-gtk4 libdevel-size-perl libdigest-bubblebabble-perl
  libdouble-conversion1 libdrm-dev libenchant1c2a libevent-2.1-6 libexiv2-14 libfcgi-perl libfile-copy-recursive-perl libfluidsynth1
  libfont-ttf-perl libfuture-perl libgail-3-0 libgfortran4 libgit2-26 libglade2-0 libgmime-3.0-0 libgnome-keyring-common libgnome-keyring0
  libgpm2:i386 libgtksourceview-3.0-1 libgtksourceview-3.0-common libgutenprint-common libgutenprint2 libgutenprint9 libgweather-3-15
  libhttp-parser2.7.1 libhunspell-1.6-0 libilmbase12 libimport-into-perl libindicator3-7 libinih1 libio-async-loop-epoll-perl libio-async-perl
  libio-pty-perl libio-string-perl libisl19 libjte1 liblinux-epoll-perl liblist-compare-perl liblivemedia62 liblouis14 liblouisutdml8 liblua5.1-0
  libluajit-5.1-2 libluajit-5.1-common liblvm2cmd2.02 libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3 libmicrodns0
  libminiupnpc10 libmysofa0 libmysqlclient20 libnet-domain-tld-perl libnet-ip-perl libnfs11 liboauth0 libokular5core8 libopenexr22 libopengl-dev
  libpath-tiny-perl libperl4-corelibs-perl libperlio-gzip-perl libplacebo4 libpodofo0.9.5 libpoppler73 libpostproc54 libprotobuf10 librarian0
  libraw16 libre2-4 libreoffice-avmedia-backend-gstreamer libreoffice-style-galaxy libstruct-dumb-perl libswresample2 libswscale4 libsynctex1
  libtagsoup-java libtest-refcount-perl libtexlua52 libtype-tiny-perl libtype-tiny-xs-perl libupnp6 libusbmuxd4 libvpx5 libwxgtk3.0-0v5
  libx265-146 libyaml-libyaml-perl libzeitgeist-2.0-0 libzip4 light-themes linux-image-5.4.0-31-generic linux-modules-5.4.0-31-generic
  linux-modules-extra-5.4.0-31-generic nodejs-doc patchutils pppconfig printer-driver-gutenprint python-asn1crypto python-attr python-automat
  python-cairo python-cffi-backend python-constantly python-enum34 python-gobject python-gobject-2 python-hamcrest python-hyperlink python-idna
  python-pam python-pyasn1 python-pygame python-sip python-talloc python-twisted-bin python-xdg python3-asn1crypto python3-ldb python3-oauth
  python3-tdb qpdf qt4-doc qtcore4-l10n rarian-compat ruby-did-you-mean ubuntu-artwork ubuntu-system-service x11proto-damage-dev
  x11proto-fixes-dev x11proto-xf86vidmode-dev zeitgeist-core
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
raoux@montrachet:/etc/apt/sources.list.d$ 

Merci de ton aide

Hors ligne

#13 Le 17/06/2020, à 08:31

legalloisd

Re : [Résolu] Problème de noyau Linux

Bonjour,

Si cela peut aider à trouver d'où vient ce problème, je rencontre un problème similaire, mais sur un Dell plus récent encore, acheté en avril 2020, installation d'entrée de jeu d'Ubuntu 20.04, donc sans upgrade depuis la 18.04. Jusqu'hier, pas de problème et désormais je suis obligé de choisir d'utiliser la version 5.4.0-26-generic pour démarrer car la 37 bloque au même endroit qu'Armanio: "Chargement du disque mémoire initial" (je n'ai pas essayé la 33).

Le retour des commandes est le suivant :

echo; dpkg -l | grep -Ei "linux-(g|h|i|lo|mo|si|t)" | grep -v ^rc | sort -k3 | awk '{print $1,$2,$3,$4}' | column -s" " -t ; echo ; uname -mr

ii  binutils-x86-64-linux-gnu             2.34-6ubuntu1  amd64
ii  linux-headers-5.4.0-26                5.4.0-26.30    all
ii  linux-modules-5.4.0-26-generic        5.4.0-26.30    amd64
ii  linux-modules-extra-5.4.0-26-generic  5.4.0-26.30    amd64
ii  linux-headers-5.4.0-26-generic        5.4.0-26.30    amd64
ii  linux-image-5.4.0-26-generic          5.4.0-26.30    amd64
ii  linux-headers-5.4.0-33                5.4.0-33.37    all
ii  linux-modules-5.4.0-33-generic        5.4.0-33.37    amd64
ii  linux-modules-extra-5.4.0-33-generic  5.4.0-33.37    amd64
ii  linux-headers-5.4.0-33-generic        5.4.0-33.37    amd64
ii  linux-image-5.4.0-33-generic          5.4.0-33.37    amd64
ii  linux-generic-hwe-20.04               5.4.0.37.40    amd64
ii  linux-headers-generic-hwe-20.04       5.4.0.37.40    amd64
ii  linux-image-generic-hwe-20.04         5.4.0.37.40    amd64
ii  linux-headers-5.4.0-37                5.4.0-37.41    all
ii  linux-modules-5.4.0-37-generic        5.4.0-37.41    amd64
ii  linux-modules-extra-5.4.0-37-generic  5.4.0-37.41    amd64
ii  linux-headers-5.4.0-37-generic        5.4.0-37.41    amd64
ii  linux-image-5.4.0-37-generic          5.4.0-37.41    amd64

5.4.0-26-generic x86_64

Et le sources list :

/etc/apt/sources.list

     1  #deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/ focal main restricted
     2
     3  # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4  # newer versions of the distribution.
     5  deb http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
     6  # deb-src http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
     7
     8  ## Major bug fix updates produced after the final release of the
     9  ## distribution.
    10  deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    11  # deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    12
    13  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14  ## team. Also, please note that software in universe WILL NOT receive any
    15  ## review or updates from the Ubuntu security team.
    16  deb http://fr.archive.ubuntu.com/ubuntu/ focal universe
    17  # deb-src http://fr.archive.ubuntu.com/ubuntu/ focal universe
    18  deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
    19  # deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
    20
    21  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22  ## team, and may not be under a free licence. Please satisfy yourself as to 
    23  ## your rights to use the software. Also, please note that software in 
    24  ## multiverse WILL NOT receive any review or updates from the Ubuntu
    25  ## security team.
    26  deb http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
    27  # deb-src http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
    28  deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    29  # deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    30
    31  ## N.B. software from this repository may not have been tested as
    32  ## extensively as that contained in the main release, although it includes
    33  ## newer versions of some applications which may provide useful features.
    34  ## Also, please note that software in backports WILL NOT receive any review
    35  ## or updates from the Ubuntu security team.
    36  deb http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    37  # deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    38
    39  ## Uncomment the following two lines to add software from Canonical's
    40  ## 'partner' repository.
    41  ## This software is not part of Ubuntu, but is offered by Canonical and the
    42  ## respective vendors as a service to Ubuntu users.
    43  # deb http://archive.canonical.com/ubuntu focal partner
    44  # deb-src http://archive.canonical.com/ubuntu focal partner
    45
    46  deb http://security.ubuntu.com/ubuntu focal-security main restricted
    47  # deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
    48  deb http://security.ubuntu.com/ubuntu focal-security universe
    49  # deb-src http://security.ubuntu.com/ubuntu focal-security universe
    50  deb http://security.ubuntu.com/ubuntu focal-security multiverse
    51  # deb-src http://security.ubuntu.com/ubuntu focal-security multiverse
    52
    53  # This system was installed using small removable media
    54  # (e.g. netinst, live or single CD). The matching "deb cdrom"
    55  # entries were disabled at the end of the installation process.
    56  # For information about how to configure apt package sources,
    57  # see the sources.list(5) manual.

Merci et bonne journée !

Dernière modification par legalloisd (Le 17/06/2020, à 08:32)

Hors ligne

#14 Le 17/06/2020, à 12:46

cqfd93

Re : [Résolu] Problème de noyau Linux

Bonjour,

Je ne vois vraiment pas d'où peut venir ton problème (sur aucun des deux ordinateurs). En tout cas, sur celui dont tu parles dans ton message 13, il y a une anomalie dans les méta-paquets qu'on voit dans le premier retour : les paquets *-hwe-20.04 ne devraient pas être installés sur une 20.04 puisque ce sont des paquets permettant à une 18.04 d'utiliser des noyaux de 20.04.

Donc je propose de les supprimer et d'installer les méta-paquets adaptés à ta version (donne les retours) :

sudo apt purge linux-generic-hwe-20.04 linux-headers-generic-hwe-20.04 linux-image-generic-hwe-20.04
sudo apt install linux-generic

cqfd93

Hors ligne

#15 Le 17/06/2020, à 14:12

ylag

Re : [Résolu] Problème de noyau Linux

Bonjour @cqfd93,

les paquets *-hwe-20.04 ne devraient pas être installés sur une 20.04 puisque ce sont des paquets permettant à une 18.04 d'utiliser des noyaux de 20.04.

Je croyais que sur la 20.04 linux-generic-hwe-20.04 servait à passer en mode «hwe» vers les noyaux 20.04.2, 20.04.3 et suivants, tandis qu'avec linux-generic, on resterait sur les noyaux de série 5.4.x-x de la 20.04 et 20.04.1 ?

A+

Dernière modification par ylag (Le 17/06/2020, à 14:14)

Hors ligne

#16 Le 17/06/2020, à 14:36

cqfd93

Re : [Résolu] Problème de noyau Linux

Salut ylag,

ylag a écrit :

Je croyais que sur la 20.04 linux-generic-hwe-20.04 servait à passer en mode «hwe» vers les noyaux 20.04.2, 20.04.3 et suivants, tandis qu'avec linux-generic, on resterait sur les noyaux de série 5.4.x-x de la 20.04 et 20.04.1 ?

Ah oui, tu as raison, mais puisque 20.04.1 n'est pas encore sortie, leur présence ne se justifie pas (et je ne sais même pas pourquoi ils sont déjà sortis)


cqfd93

Hors ligne

#17 Le 17/06/2020, à 14:42

ylag

Re : [Résolu] Problème de noyau Linux

Re,

cqfd93 a écrit :

puisque 20.04.1 n'est pas encore sortie, leur présence ne se justifie pas (et je ne sais même pas pourquoi ils sont déjà sortis)

Pour le moment, linux-generic-hwe-20.04 semble pointer vers la même version de noyau que linux-generic; ça fera probablement double-emploi jusqu'à la sortie de la 20.04.2; faudra revérifier à ce moment.

Il y aurait aussi probablement des paquets du serveur X en «hwe» à repasser aux versions de base si on remplace linux-generic-hwe-20.04 par linux-generic ?

A+

Dernière modification par ylag (Le 17/06/2020, à 14:46)

Hors ligne

#18 Le 17/06/2020, à 15:18

cqfd93

Re : [Résolu] Problème de noyau Linux

Peut-être tout simplement ne rien faire de ce que j'ai mis dans mon message 14 ?


cqfd93

Hors ligne

#19 Le 17/06/2020, à 21:36

legalloisd

Re : [Résolu] Problème de noyau Linux

Eh bien je l'avais fait en début d'après-midi et je viens de redémarrer... sans souci, en 5.4.0-37.

Je garderai cette discussion en mémoire le jour où l'heure de l'upgrade sera venue !

Merci encore à vous et particulièrement à cqfd93 ^^

Bonne soirée,
Damien

Hors ligne

#20 Le 18/06/2020, à 06:44

cqfd93

Re : [Résolu] Problème de noyau Linux

Bonjour,

Problème résolu pour celui dont tu parles dans le message 13 ou sur les deux ordinateurs ?


cqfd93

Hors ligne

#21 Le 18/06/2020, à 10:03

malbo

Re : [Résolu] Problème de noyau Linux

Bonjour à tous,
Si on examine le contenu du fichier ubuntu-20.04-desktop-amd64.manifest téléchargeable à cette adresse : http://releases.ubuntu.com/releases/foc … 4.manifest http://old-releases.ubuntu.com/releases … 4.manifest (modif de l'adresse suite au passage en "old-releases")
Et qu'on recherche hwe-20.04 dans ce fichier, on trouve :
linux-generic-hwe-20.04    5.4.0.26.32
linux-headers-generic-hwe-20.04    5.4.0.26.32
linux-image-generic-hwe-20.04    5.4.0.26.32
Ce qui signifie que dès la version initiale de Ubuntu 20.04, le LTSEnablementStack est activé. Cela ne s'est jamais fait sur les versions LTS précédentes 16.04 et 18.04. EDIT : c'est respectivement pour 16.04.2 (voir ici) et pour 18.04.2 (voir ) que LTSEnablementStack  a été activé.

Moi j'avais fait mon install avec la version beta de Focal et je viens de vérifier que cette version beta n'avait pas le LTSEnablementStack activé. Donc chez moi, je n'ai pas ces trois paquets "hwe-20.04". Je viens juste de découvrir cette vacherie grâce à cette discussion...

EDIT le 19 juin 2020 : je l'ai vérifié dans une machine virtuelle, si je fais la mise à niveau 18.04 vers 20.04 en passant par le Gestionnaire de mises à jour suivant la procédure que j'utilise dans ce post, je constate que le LTSEnablementStack n'est pas activé (*) dans Ubuntu 20.04 (il n'y a pas de paquets "hwe-20.04"). Selon moi, c'est normal que ce Ubuntu "migré" n'ait pas le LTSEnablementStack. Ce qui n'est pas normal, c'est que la version initiale de Ubuntu 20.04 qu'on utilise pour une install propre soit équipée de base de ce LTSEnablementStack.

EDIT le 20 juin 2020 : d'après ce doc Ubuntu kernel lifecycle and enablement stack, il semblerait que la politique pour 20.04 soit la même que pour les versions 16.04 et 18.04. C'est ce que laisse penser le graphique "Kernel support schedule" de cette doc.
D'autre part, j'ai vérifié qu'aucune des variantes officielles de Ubuntu 20.04 (Kubuntu 20.04, Xubuntu 20.04 , etc...) n'est équipée du LTSEnablementStack : il n'y a vraiment que Ubuntu 20.04 qui est concernée. Il faut mettre un bémol : je constate en sept 2021 que les versions 20.04.3 de toutes les variantes officielles de Ubuntu sont toutes équipées du LTSEnablementStack et viennent avec le noyau 5.11

EDIT le 24 août 2020 : c'est toujours vrai pour la version 20.04.1 : le LTSEnablementStack  est activé par défaut. Dans le fichier ubuntu-20.04.1-desktop-amd64.manifest (ici), on trouve :
linux-generic-hwe-20.04    5.4.0.42.46
linux-headers-generic-hwe-20.04    5.4.0.42.46
linux-image-generic-hwe-20.04    5.4.0.42.46

(*) j'ai vérifié cela y compris dans le cas d'une mise à niveau depuis une version 18.04.5 de Ubuntu. Cette version 18.04.5 est équipée du HWE de 18.04 mais la 20.04 obtenue après mise à niveau n'est pas équipée du HWE de 20.04. A noter cependant qu'après mise à niveau, apt suggère de faire du nettoyage avec "apt autoremove" mais ce nettoyage est trop énergique car il vire les paquets linux-generic et linux-headers-generic. Il suffit alors de réinstaller linux-generic (ça va entraîner la réinstallation de linux-headers-generic).

Dernière modification par malbo (Le 23/09/2021, à 05:19)

Hors ligne

#22 Le 18/06/2020, à 10:50

ylag

Re : [Résolu] Problème de noyau Linux

Bonjour,

malbo a écrit :

Moi j'avais fait mon install avec la version beta de Focal et je viens de vérifier que cette version beta n'avait pas le LTSEnablementStack activé. Donc chez moi, je n'ai pas ces trois paquets "hwe-20.04" ...

Peut-être un «bug» à signaler ?

Faudra bien vérifier lors de la sortie de l'iso de la 24.04.1 si ces trois paquets seront installés d'office.

A+

Dernière modification par ylag (Le 18/06/2020, à 10:51)

Hors ligne

#23 Le 18/06/2020, à 11:00

cqfd93

Re : [Résolu] Problème de noyau Linux

Ah oui, des hwe installés à l'insu de notre plein gré, c'est vache ! sad


cqfd93

Hors ligne

#24 Le 18/06/2020, à 11:08

ylag

Re : [Résolu] Problème de noyau Linux

Bonjour,

La suggestion de @cqfd93 au commentaire #14 pourrait s'avérer pertinente; le fichier ubuntu-20.04-desktop-amd64.manifest cité au #21 par @malbo ne semble pas installer de paquets «hwe» pour le serveur X, seulement les trois méta-paquets du noyau y sont présents.

A+

Dernière modification par ylag (Le 18/06/2020, à 11:26)

Hors ligne

#25 Le 18/06/2020, à 20:34

legalloisd

Re : [Résolu] Problème de noyau Linux

cqfd93 a écrit :

Bonjour,

Problème résolu pour celui dont tu parles dans le message 13 ou sur les deux ordinateurs ?

Bonjour tout le monde,

Cela a marché pour un démarrage sur mon ordinateur, je ne sais pas ce qu'il en est pour Armanio, le posteur initial de la discussion.

Et depuis, rebelote, le démarrage sur les noyaux 5.4.0.37 ou 5.4.0.33 plante dès le départ, toujours après la ligne "Chargement du disque mémoire initial", alors que j'ai effectué la désinstallation des paquets hwe selon vos conseils.

J'ai du choisir le 5.4.0.26 à nouveau pour pouvoir vous écrire smile

Bonne soirée à tous,
damien

Hors ligne