Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/09/2020, à 16:15

ashigaru

impossibilité d'installer WOEUSB

Bonjour à tous  big_smile ,

Je suis débutant sur Ubuntu et j'aimerais installer WoeUSB mais a chaque fois que je fait sudo apt install woeusb, j'ai ce message d'erreur.

Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
woeusb : Dépend: libwxgtk3.0-0v5 (>= 3.0.4+dfsg) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état »

Après divers tentative  de recherche sur internet j'ai rien trouver qui puisse m'apporter la solution
voici le script de sudo apt-get update:
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal InRelease
Réception de :3 https://brave-browser-apt-release.s3.brave.com stable InRelease [4317 B]
Err :3 https://brave-browser-apt-release.s3.brave.com stable InRelease     
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A8580BDC82D3DC6C
Lecture des listes de paquets... Fait
W: Erreur de GPG : https://brave-browser-apt-release.s3.brave.com stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A8580BDC82D3DC6C
E: Le dépôt https://brave-browser-apt-release.s3.brave.com stable InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

merci pour votre aide

Hors ligne

#2 Le 11/09/2020, à 16:29

xubu1957

Re : impossibilité d'installer WOEUSB

Bonjour,

Tente :

sudo apt install -f

vu > install WoeUSB - RESOLU

Pour ajouter toi-même les balises code à ton précédent message #1, comme demandé dans le premier message du tutoriel Retour utilisable de commande :

  • Cliquer sur  le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

moko138 a écrit :

1) Les balises-code sont les < > (crochets bleus) de la barre de mise en forme.

1578811399.jpg

En séparant bien les retours :

comme
cela.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
woeusb : Dépend: libwxgtk3.0-0v5 (>= 3.0.4+dfsg) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état »
 sudo apt-get update:
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal InRelease
Réception de :3 https://brave-browser-apt-release.s3.brave.com stable InRelease [4317 B]
Err :3 https://brave-browser-apt-release.s3.brave.com stable InRelease     
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A8580BDC82D3DC6C
Lecture des listes de paquets... Fait
W: Erreur de GPG : https://brave-browser-apt-release.s3.brave.com stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A8580BDC82D3DC6C
E: Le dépôt https://brave-browser-apt-release.s3.brave.com stable InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 11/09/2020, à 17:16

ashigaru

Re : impossibilité d'installer WOEUSB

Merci pour ton retour, après avoir essayer cette commande, pour supprimer et réinstaller les packages j'ai eu

Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libwxgtk3.0-0v5 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libwxgtk3.0-0v5 » n'a pas de version susceptible d'être installée

le apt-get install woeusb  donne toujour

oem@oem-HP-ENVY-15-Notebook-PC:~$ sudo apt install woeusb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 woeusb : Dépend: libwxgtk3.0-0v5 (>= 3.0.4+dfsg) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

sudo apt install f

oem@oem-HP-ENVY-15-Notebook-PC:~$ sudo apt install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Aucune solution similaire help:(

Dernière modification par ashigaru (Le 11/09/2020, à 17:25)

Hors ligne

#4 Le 11/09/2020, à 17:23

xubu1957

Re : impossibilité d'installer WOEUSB

Je retrouve ce fil > [RESOLU] Installation pcem, mais je n'avais pas tout compris ! sad


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 11/09/2020, à 17:41

ashigaru

Re : impossibilité d'installer WOEUSB

merci mais je bute toujour sur  sad

oem@oem-HP-ENVY-15-Notebook-PC:~$ sudo apt install libwxgtk3.0-gtk3-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libwxgtk3.0-gtk3-dev : Dépend: libgl1-mesa-dev mais ne sera pas installé ou
                                 libgl-dev mais ne sera pas installé
                        Dépend: xlibmesa-glu-dev ou
                                 libglu-dev
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

et a la commande sudo apt-add-repository "deb [arch=amd64] https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe"
j'ai

Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-proposed InRelease
Atteint :3 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal InRelease
Atteint :4 https://repos.codelite.org/wx3.1.3/ubuntu focal InRelease
Lecture des listes de paquets... Fait               
W: La cible Packages (universe/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Packages (universe/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Translations (universe/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Translations (universe/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Translations (universe/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11 (universe/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11 (universe/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11-icons-small (universe/dep11/icons-48x48.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11-icons (universe/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11-icons-hidpi (universe/dep11/icons-64x64@2.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible CNF (universe/cnf/Commands-amd64) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible CNF (universe/cnf/Commands-all) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
N: Le fichier configuré « universe/binary-i386/Packages » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.1.3/ubuntu focal InRelease » ne prend pas en charge l'architecture « i386 »
W: La cible Packages (universe/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Packages (universe/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Translations (universe/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Translations (universe/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible Translations (universe/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11 (universe/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11 (universe/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11-icons-small (universe/dep11/icons-48x48.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11-icons (universe/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible DEP-11-icons-hidpi (universe/dep11/icons-64x64@2.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible CNF (universe/cnf/Commands-amd64) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5
W: La cible CNF (universe/cnf/Commands-all) est spécifiée plusieurs fois dans /etc/apt/sources.list:3 et /etc/apt/sources.list:5

et a sudo apt install libwxgtk3.0-dev j'ai

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libwxgtk3.0-dev n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libwxgtk3.0-dev » n'a pas de version susceptible d'être installée

Dernière modification par ashigaru (Le 11/09/2020, à 17:44)

Hors ligne

#6 Le 11/09/2020, à 17:42

xubu1957

Re : impossibilité d'installer WOEUSB

Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-proposed InRelease

Je te laisse lire la Doc : depots#proposed

§ 2.3 a écrit :

Proposed
Les dépôts "proposed" contiennent des paquets proposés à fins de tests seulement ! Ils servent à tester des paquets ou des mises à jour avant qu'ils n'intègrent définitivement les dépôts principaux. Ils peuvent donc être à l'origine de plantage et de corruption de système ! N'ajoutez ces dépôts que si vous savez ce que vous faites !
Ces dépôts correspondent à la case à cocher "Mises à jour en préversion (proposed)" → onglet "Mises à jour" de l'application Logiciels & Mises à jour.

Montre le sources.list :

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;
cqfd93 a écrit :

Astuce pour copier / coller sans erreur :

  • triple clic gauche pour sélectionner et copier une ligne entière

  • clic molette pour coller dans le terminal


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#7 Le 11/09/2020, à 17:48

ashigaru

Re : impossibilité d'installer WOEUSB

oem@oem-HP-ENVY-15-Notebook-PC:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list

     1	deb http://fr.archive.ubuntu.com/ubuntu/ focal main universe restricted multiverse
     2	deb http://fr.archive.ubuntu.com/ubuntu/ focal-proposed main restricted universe multiverse
     3	deb [arch=amd64] https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe
     4	# deb-src [arch=amd64] https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe
     5	deb https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe
     6	# deb-src https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe

/etc/apt/sources.list.d/nilarimogard-ubuntu-webupd8-focal.list

     1	deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal main
     2	# deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal main
     3	# deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal main

/etc/apt/sources.list.d/brave-browser-release.list

     1	# deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main

/etc/apt/sources.list.d/crass-ubuntu-ufraw-focal.list

Hors ligne

#8 Le 11/09/2020, à 17:52

xubu1957

Re : impossibilité d'installer WOEUSB

Je vais essayer d'obtenir du renfort !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#9 Le 11/09/2020, à 18:31

ashigaru

Re : impossibilité d'installer WOEUSB

merci beaucoup pour votre aide j'ai installer supprimer les paquets rien a faire. toujours le mémé message d'erreur

oem@oem-HP-ENVY-15-Notebook-PC:~$ sudo apt install woeusb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 woeusb : Dépend: libwxgtk3.0-0v5 (>= 3.0.4+dfsg) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état »

et

oem@oem-HP-ENVY-15-Notebook-PC:~$ sudo apt install libwxgtk3.0-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libwxgtk3.0-dev n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libwxgtk3.0-dev » n'a pas de version susceptible d'être installée

Dernière modification par ashigaru (Le 11/09/2020, à 18:33)

Hors ligne

#10 Le 11/09/2020, à 18:42

inbox

Re : impossibilité d'installer WOEUSB

Salut,

Voir cette page qui indique le dépôt (pour la 20.04) à ajouter pour installer facilement Woeusb.

A+

[Edit] Et si tu as ajouté le dépôt "nilarimogard", enlève le. C'est un dépôt fourre tout qui risque de mettre à jour certains paquets sans que tu le veuilles.

Dernière modification par inbox (Le 11/09/2020, à 18:44)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#11 Le 11/09/2020, à 18:43

cqfd93

Re : impossibilité d'installer WOEUSB

Modération

Il manque toujours les balises code dans le message 1. À ajouter en suivant les indications du message 2.


cqfd93

Hors ligne

#12 Le 11/09/2020, à 18:48

cqfd93

Re : impossibilité d'installer WOEUSB

Bonjour,

Ton sources.list contient les dépôts proposed et en plus il est incomplet et il contient un doublon.

Pour refaire un fichier propre et complet, copie tout le bloc qui suit et colle le dans le terminal (et appuie sur Entrée)

sudo tee /etc/apt/sources.list <<EOF
#------------------------------------------------------------------------------#
#OFFICIAL UBUNTU REPOS #
#------------------------------------------------------------------------------#


###### Ubuntu Main Repos
deb http://fr.archive.ubuntu.com/ubuntu/ focal main restricted universe multiverse 

###### Ubuntu Update Repos
deb http://fr.archive.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse 
deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted universe multiverse 
deb http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse 

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu focal partner

deb [arch=amd64] https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe
EOF

Et fais les mises à jour (donne les retours complets) :

sudo apt update
sudo apt full-upgrade

cqfd93

Hors ligne

#13 Le 11/09/2020, à 18:50

nany

Re : impossibilité d'installer WOEUSB

Bonjour,


ashigaru a écrit :
oem@oem-HP-ENVY-15-Notebook-PC:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list

     1	deb http://fr.archive.ubuntu.com/ubuntu/ focal main universe restricted multiverse
     2	deb http://fr.archive.ubuntu.com/ubuntu/ focal-proposed main restricted universe multiverse
     3	deb [arch=amd64] https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe
     4	# deb-src [arch=amd64] https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe
     5	deb https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe
     6	# deb-src https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe

…

/etc/apt/sources.list.d/crass-ubuntu-ufraw-focal.list

 
Ce sources.list n’est ni fait ni à faire. On ne touche pas impunément aux fichiers système.

De plus, on ne sait pas si le retour de la commande est complet car on ne voit pas le retour du prompt.


Maintenant que les choses sont claires, je veux bien t’aider à remettre ton système d’aplomb mais sans garantie de résultat. Donc prépare-toi mentalement à une réinstallation propre d’Ubuntu.



Pour commencer, donne les retours de :

echo "# deb cdrom:"$(sed 's/^/\[/;s/\"/_/g;s/$/\]/' /var/log/installer/media-info)"/ "$(awk -F'"' '{sub(" .*","",$2); print tolower($2)}' /var/log/installer/media-info)" main restricted" | sudo tee /etc/apt/sources.list
tail +9 /snap/core/current/etc/cloud/templates/sources.list.ubuntu.tmpl | sed "s#{{mirror}}#http://fr.archive.ubuntu.com/ubuntu/#;s#{{codename}}#$(lsb_release -sc)#;s#{{security}}#http://security.ubuntu.com/ubuntu/#" | sudo tee -a /etc/apt/sources.list
sudo sed -i '/partner/s/^# deb http/deb http/' /etc/apt/sources.list && cat -n /etc/apt/sources.list

 

[edit]
Oups ! cqfd93 a été plus rapide que moi !
Ceci dit, cqfd93, je trouve ton sources.list moche. tongue
[/edit]

Dernière modification par nany (Le 11/09/2020, à 18:55)


Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#14 Le 11/09/2020, à 18:57

cqfd93

Re : impossibilité d'installer WOEUSB

nany a écrit :

[edit]
Oups ! cqfd93 a été plus rapide que moi !
Ceci dit, cqfd93, je trouve ton sources.list moche. tongue
[/edit]

À cause de

deb [arch=amd64] https://repos.codelite.org/wx3.1.3/ubuntu/ focal universe

qui ne fait pas partie des dépôts officiels je suppose ? C'est par pure flemme de faire créer un fichier distinct wink


cqfd93

Hors ligne

#15 Le 11/09/2020, à 19:05

nany

Re : impossibilité d'installer WOEUSB

Aussi. Mais surtout parce qu’il ne ressemble pas au sources.list officiel. tongue


Le mot de passe sudo ne s'affiche pas
Comment bien utiliser les balises BBcode
LIBRARIES ARE NOT BOOK-STORES! − Une souris, des souris. Un souci, des soucis. Une énigme résolue, un problème résolu.
J’ai forké le compteur-couche-tard.

Hors ligne

#16 Le 11/09/2020, à 19:12

cqfd93

Re : impossibilité d'installer WOEUSB

Mais il est quand même bien lisible et propre.


cqfd93

Hors ligne

#17 Le 12/09/2020, à 08:16

ashigaru

Re : impossibilité d'installer WOEUSB

merci pour vos retour big_smile,  rien n'a apporter de solution concluante, voici pour  le retour que ma demander nany

oem@oem-HP-ENVY-15-Notebook-PC:~$ echo "# deb cdrom:"$(sed 's/^/\[/;s/\"/_/g;s/$/\]/' /var/log/installer/media-info)"/ "$(awk -F'"' '{sub(" .*","",$2); print tolower($2)}' /var/log/installer/media-info)" main restricted" | sudo tee /etc/apt/sources.list
# deb cdrom:[Ubuntu 20.04.1 LTS _Focal Fossa_ - Release amd64 (20200731)]/ focal main restricted
oem@oem-HP-ENVY-15-Notebook-PC:~$ tail +9 /snap/core/current/etc/cloud/templates/sources.list.ubuntu.tmpl | sed "s#{{mirror}}#http://fr.archive.ubuntu.com/ubuntu/#;s#{{codename}}#$(lsb_release -sc)#;s#{{security}}#http://security.ubuntu.com/ubuntu/#" | sudo tee -a /etc/apt/sources.list
tail: impossible d'ouvrir '/snap/core/current/etc/cloud/templates/sources.list.ubuntu.tmpl' en lecture: Aucun fichier ou dossier de ce type
oem@oem-HP-ENVY-15-Notebook-PC:~$ sudo sed -i '/partner/s/^# deb http/deb http/' /etc/apt/sources.list && cat -n /etc/apt/sources.list
     1	# deb cdrom:[Ubuntu 20.04.1 LTS _Focal Fossa_ - Release amd64 (20200731)]/ focal main restricted

Hors ligne

#18 Le 12/09/2020, à 08:38

xubu1957

Re : impossibilité d'installer WOEUSB

Bonjour,

Comme demandé au #2, en mode espacé :

oem@oem-HP-ENVY-15-Notebook-PC:~$ echo "# deb cdrom:"$(sed 's/^/\[/;s/\"/_/g;s/$/\]/' /var/log/installer/media-info)"/ "$(awk -F'"' '{sub(" .*","",$2); print tolower($2)}' /var/log/installer/media-info)" main restricted" | sudo tee /etc/apt/sources.list
# deb cdrom:[Ubuntu 20.04.1 LTS _Focal Fossa_ - Release amd64 (20200731)]/ focal main restricted
oem@oem-HP-ENVY-15-Notebook-PC:~$ tail +9 /snap/core/current/etc/cloud/templates/sources.list.ubuntu.tmpl | sed "s#{{mirror}}#http://fr.archive.ubuntu.com/ubuntu/#;s#{{codename}}#$(lsb_release -sc)#;s#{{security}}#http://security.ubuntu.com/ubuntu/#" | sudo tee -a /etc/apt/sources.list
tail: impossible d'ouvrir '/snap/core/current/etc/cloud/templates/sources.list.ubuntu.tmpl' en lecture: Aucun fichier ou dossier de ce type
oem@oem-HP-ENVY-15-Notebook-PC:~$ sudo sed -i '/partner/s/^# deb http/deb http/' /etc/apt/sources.list && cat -n /etc/apt/sources.list
     1	# deb cdrom:[Ubuntu 20.04.1 LTS _Focal Fossa_ - Release amd64 (20200731)]/ focal main restricted

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#19 Le 12/09/2020, à 08:57

bluc

Re : impossibilité d'installer WOEUSB

Bonjour,

J'ai utilisé Ventoy pour installer W10 ,ça fonctionne tres bien


Clevo :  Ubuntu 20.04   ❖  Xubuntu 20.04  ❖ Ubuntu 20.04 Unity 
                      avec partition data commune

Hors ligne

#20 Le 12/09/2020, à 10:14

geole

Re : impossibilité d'installer WOEUSB

Bonjour
Mais woeusb est parfaitement adapté pour  fabriquer une clé USB de boot de windows. C'est juste un problème d'installation non lié à l'outil

Mais je confirme qu'en version 20.04, ce n'est pas possible de l'installer

a@a:~$ sudo apt install woeusb
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 woeusb : Dépend: libwxgtk3.0-0v5 (>= 3.0.4+dfsg) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Alors pourquoi ne pas utiliser un autre outil!

NOTA
cette commande pourrait être modifiée pour filtrer les lignes qui commencent par un commentaire ou des espaces et ne pas faire de numérotation.

a@a:~$ 
a@a:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list.d/yannubuntu-ubuntu-boot-repair-focal.list

     1	deb http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal main
     2	# deb-src http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal main

/etc/apt/sources.list.d/ancestris-ubuntu-ancestris-stable-focal.list

     1	deb http://ppa.launchpad.net/ancestris/ancestris-stable/ubuntu focal main
     2	# deb-src http://ppa.launchpad.net/ancestris/ancestris-stable/ubuntu focal main

/etc/apt/sources.list.d/nilarimogard-ubuntu-webupd8-focal.list

     1	deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal main
     2	# deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu focal main

/etc/apt/sources.list.d/nicotine-team-ubuntu-unstable-focal.list

     1	deb http://ppa.launchpad.net/nicotine-team/unstable/ubuntu focal main
     2	# deb-src http://ppa.launchpad.net/nicotine-team/unstable/ubuntu focal main

/etc/apt/sources.list

     1	# deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Beta amd64 (20200402)]/ focal main restricted
     2	
     3	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4	# newer versions of the distribution.
     5	deb http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
     6	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
     7	
     8	## Major bug fix updates produced after the final release of the
     9	## distribution.
    10	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    11	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    12	
    13	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14	## team. Also, please note that software in universe WILL NOT receive any
    15	## review or updates from the Ubuntu security team.
    16	deb http://fr.archive.ubuntu.com/ubuntu/ focal universe
    17	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal universe
    18	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
    19	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
    20	
    21	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22	## team, and may not be under a free licence. Please satisfy yourself as to 
    23	## your rights to use the software. Also, please note that software in 
    24	## multiverse WILL NOT receive any review or updates from the Ubuntu
    25	## security team.
    26	deb http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
    27	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
    28	deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    29	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    30	
    31	## N.B. software from this repository may not have been tested as
    32	## extensively as that contained in the main release, although it includes
    33	## newer versions of some applications which may provide useful features.
    34	## Also, please note that software in backports WILL NOT receive any review
    35	## or updates from the Ubuntu security team.
    36	deb http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    37	# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    38	
    39	## Uncomment the following two lines to add software from Canonical's
    40	## 'partner' repository.
    41	## This software is not part of Ubuntu, but is offered by Canonical and the
    42	## respective vendors as a service to Ubuntu users.
    43	# deb http://archive.canonical.com/ubuntu focal partner
    44	# deb-src http://archive.canonical.com/ubuntu focal partner
    45	
    46	deb http://security.ubuntu.com/ubuntu focal-security main restricted
    47	# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
    48	deb http://security.ubuntu.com/ubuntu focal-security universe
    49	# deb-src http://security.ubuntu.com/ubuntu focal-security universe
    50	deb http://security.ubuntu.com/ubuntu focal-security multiverse
    51	# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse
    52	
    53	# This system was installed using small removable media
    54	# (e.g. netinst, live or single CD). The matching "deb cdrom"
    55	# entries were disabled at the end of the installation process.
    56	# For information about how to configure apt package sources,
    57	# see the sources.list(5) manual.
a@a:~$ 

Dernière modification par geole (Le 12/09/2020, à 10:36)

En ligne

#21 Le 12/09/2020, à 10:26

ashigaru

Re : impossibilité d'installer WOEUSB

merci, à toi bluc :)j'ai réussi a réinstaller Ubuntu avec vento maintenant je vais faire sa de façon plus propre

Dernière modification par ashigaru (Le 12/09/2020, à 10:28)

Hors ligne

#22 Le 12/09/2020, à 11:53

inbox

Re : impossibilité d'installer WOEUSB

Ce que j'ai indiqué message #10 fonctionne parfaitement.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#23 Le 12/09/2020, à 13:06

geole

Re : impossibilité d'installer WOEUSB

Bonjour inbox
Veux-tu parler de ces commandes à exécuter dans un Ubuntu sans aucune modification ?

echo 'deb http://download.opensuse.org/repositories/home:/Provessor/xUbuntu_20.04/ /' | sudo tee /etc/apt/sources.list.d/home:Provessor.list
curl -fsSL https://download.opensuse.org/repositories/home:Provessor/xUbuntu_20.04/Release.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/home:Provessor.gpg > /dev/null
sudo apt update
sudo apt install woeusb

Il faudrait d'abord commencer à installer curl

Dernière modification par geole (Le 12/09/2020, à 13:08)

En ligne

#24 Le 12/09/2020, à 13:45

inbox

Re : impossibilité d'installer WOEUSB

Si besoin, oui. Mais sur mon installation, curl est déjà installé.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#25 Le 12/09/2020, à 14:39

geole

Re : impossibilité d'installer WOEUSB

inbox a écrit :

Salut,

Voir cette page qui indique le dépôt (pour la 20.04) à ajouter pour installer facilement Woeusb.

A+

[Edit] Et si tu as ajouté le dépôt "nilarimogard", enlève le. C'est un dépôt fourre tout qui risque de mettre à jour certains paquets sans que tu le veuilles.

C'est  une obligation de supprimer le dépôt , car autrement il reste prioritaire et empêche l'installation en provoquant le même incident.

En ligne