Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/11/2020, à 03:50

abecidofugy

[Résolu] WSL : premières difficultés

Salut salut,

Je viens d’installer WSL, et je tente de lancer ma première application graphique après l’avoir installée : gvim, comme dans la doc.

Je tape donc dans bash Ubuntu :

$ gvim ESSAI.txt
Authorization required, but no authorization protocol specified
E233: cannot open display
Press ENTER or type command to continue

E852: The child process failed to start the GUIAuthorization required, but no authorization protocol specified

Press ENTER or type command to continue

J’ai ouvert le port 6000 pour l’IP de mon PC, en UDP et TCP, et ouvert les connexions dans le firewall :
1605754466.png

Suis-je passé à côté de quelque chose ?

Merci.

//EDIT : à la fin de mon .bashrc, j’avais bien sûr rajouté ces lignes-là :

export DISPLAY=localhost:0.0
export DISPLAY=$(grep -oP "(?<=nameserver ).+" /etc/resolv.conf):0
export LIBGL_ALWAYS_INDIRECT=1

Mais je constate que dans la doc anglaise, ce n’est pas les mêmes lignes : https://wiki.ubuntu.com/WSL#line-1-31

--------------------------------------------------------------
Autre point, je n‘ai pas d‘affichage du répertoire Linux (point 4.7 et 4.6 du wiki)

Est parce que c’est une release preview ? J’avoue que ça serait superbe si on pouvait glisser des fichiers vers Ubuntu à partir de l‘explorer cool

//EDIT 2 : j’ai pu afficher les fichiers en tapant :

explorer.exe .

--------------------------------------------------------------

//EDIT 3 : j’ai une erreur également quand j’édite mon fichier avec vim :

$ vim .bashrc
Authorization required, but no authorization protocol specified

Dernière modification par abecidofugy (Le 19/11/2020, à 16:42)


[Soignons nos posts] comprendre que lorsqu’on fait une demande d’aide, ou apporte une aide, on la joue collectif et on œuvre pour l’humanité en quelque sorte.
Kubuntu et KDEneon en VM dans host W10 / KDEneon en double-boot avec W10 / Ubuntu 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print

Hors ligne

#2 Le 19/11/2020, à 16:41

abecidofugy

Re : [Résolu] WSL : premières difficultés

[Résolu]

Alors j’ai mis les trois lignes de la doc anglais, mais j’ai commenté la première (je la garde pour trace).

Et dans VcXsvr j’ai coché toutes les cases dans le derniers écran de config.

Par contre, c’est super lent, et j’ai du mal à retrouver le curseur de la souri.


[Soignons nos posts] comprendre que lorsqu’on fait une demande d’aide, ou apporte une aide, on la joue collectif et on œuvre pour l’humanité en quelque sorte.
Kubuntu et KDEneon en VM dans host W10 / KDEneon en double-boot avec W10 / Ubuntu 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print

Hors ligne

#3 Le 19/11/2020, à 16:45

abecidofugy

Re : [Résolu] WSL : premières difficultés

Houra ! Avec le mode mutifenêtrage, le curseur est fluide !

Trop d’la balle !


[Soignons nos posts] comprendre que lorsqu’on fait une demande d’aide, ou apporte une aide, on la joue collectif et on œuvre pour l’humanité en quelque sorte.
Kubuntu et KDEneon en VM dans host W10 / KDEneon en double-boot avec W10 / Ubuntu 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print

Hors ligne

#4 Le 19/11/2020, à 18:10

geole

Re : [Résolu] WSL : premières difficultés

abecidofugy a écrit :

[Résolu]

Et dans VcXsvr j’ai coché toutes les cases dans le derniers écran de config.

Bonjour
Est-ce bien la troisième grille?
J'avais eu ce problème.   Mais je n'avais pas su  si j'étais le seul...  Donc,  Je viens de mettre   une note dans la documentation.

En ligne

#5 Le 20/11/2020, à 18:34

abecidofugy

Re : [Résolu] WSL : premières difficultés

geole a écrit :
abecidofugy a écrit :

[Résolu]

Et dans VcXsvr j’ai coché toutes les cases dans le derniers écran de config.

Bonjour
Est-ce bien la troisième grille?
J'avais eu ce problème.   Mais je n'avais pas su  si j'étais le seul...  Donc,  Je viens de mettre   une note dans la documentation.

Ben selon mes tests, oui, il faut cocher les trois cases. Et je suis tombé sur un billet de blog qui disait pareil. Si tu veux, je peux te le chercher.


[Soignons nos posts] comprendre que lorsqu’on fait une demande d’aide, ou apporte une aide, on la joue collectif et on œuvre pour l’humanité en quelque sorte.
Kubuntu et KDEneon en VM dans host W10 / KDEneon en double-boot avec W10 / Ubuntu 20.04 serveur sur machines dédiées.
Agence de communication en Alsace · web · print

Hors ligne