Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/02/2021, à 21:49

hoc_dev

[Résolu] PC qui boot directement sur windows avec un dualboot

Bonjour à tous,

Je souhaitais découvrir le monde de linux, j'ai donc décidé d'installer un dualboot sur mon pc afin d'avoir windows et ubuntu.
Cela fait depuis environ une semaine que j'ai installé tout ça et jusqu'ici tout fonctionnait à merveille. Cependant, en début de soirée, je décide de rallumer mon pc sauf que ce dernier boot directement sur windows sans me proposer le grub. Je redémarre une nouvelle fois en me disant que c'était qu'un léger bug et il se passe la même chose, j'ai donc perdu l'accès à ubuntu.
Après quelques recherches sur internet, je décide d'installer HASLEO easyUEFI, et dans ce dernier je constate que le status d'ubuntu est en "hidden" contrairement à celui de windows qui lui est en "normal".
Je débute sous linux, je ne sais pas du comment m'y prendre pour récupérer le grub afin de ravoir accès à ubuntu.
Si quelqu'un pourrait m'aider, ça serait vraiment sympathique de sa part, d'autant plus que je possède quelques dossiers que j'ai seulement enregistrer sur ubuntu que je voudrais récupérer.

Merci d'avance wink

Dernière modification par hoc_dev (Le 09/02/2021, à 21:16)

Hors ligne

#2 Le 08/02/2021, à 21:59

malbo

Re : [Résolu] PC qui boot directement sur windows avec un dualboot

Bonjour,
Je te prie de préciser le nom complet du modèle de ton ordi et son fabricant.

Hors ligne

#3 Le 08/02/2021, à 22:53

hoc_dev

Re : [Résolu] PC qui boot directement sur windows avec un dualboot

Ah, je ne savais que ça pouvait influencer, alors mon ordi est un Asus et le modèle est le S533F.

Hors ligne

#4 Le 09/02/2021, à 07:40

malbo

Re : [Résolu] PC qui boot directement sur windows avec un dualboot

Bonjour,
Je te prie de faire un Boot-info depuis une session live (*) de Ubuntu et de donner l'URL de ce Boot-info dans ta réponse.

(*) session live = ordi démarré sur la liveUSB qui t'a servi pour installer Ubuntu, choix "Essayer Ubuntu"

Hors ligne

#5 Le 09/02/2021, à 18:51

hoc_dev

Re : [Résolu] PC qui boot directement sur windows avec un dualboot

Voici le lien du Boot-info que tu m'as demandé :
https://paste.ubuntu.com/p/whSsyRkVcd/
(désolé de répondre que maintenant j'étais en cours ^^)

Hors ligne

#6 Le 09/02/2021, à 20:27

malbo

Re : [Résolu] PC qui boot directement sur windows avec un dualboot

Je colle ton Boot-info ci-dessous :

boot-info-4ppa125                                              [20210209_1646]

============================== Boot Info Summary ===============================

 => Syslinux MBR (5.00 and higher) is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 6.04
    Boot sector info:  Syslinux looks at sector 32792 of /dev/sda1 for its 
                       second stage. The integrity check of Syslinux failed. 
                       No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /boot/grub/grub.cfg /syslinux.cfg 
                       /efi/BOOT/grubx64.efi /efi/BOOT/mmx64.efi /ldlinux.sys

md/imsm0: ______________________________________________________________________

    File system:       
    Boot sector type:  Unknown
    Boot sector info: 

md/imsm1: ______________________________________________________________________

    File system:       
    Boot sector type:  Unknown
    Boot sector info: 


================================ 1 OS detected =================================

OS#1:   Ubuntu 20.04.1 LTS on nvme0n1p5

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
Live-session OS is Ubuntu 64-bit (Ubuntu 20.04.1 LTS, focal, x86_64)


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0004,0003,0000
Boot0000* ubuntu	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003* Windows Boot Manager	HD(1,GPT,e154434c-46ac-4be9-a323-0134323c88a8,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0004* UEFI: SanDisk Cruzer Switch 1.27, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0xa8d000,0x800,0xee8400)..BO



============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

nvme0n1	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes
nvme1n1	: notGPT,	no-BIOSboot,	has-noESP, 	not-usb,	not-mmc, no-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

nvme0n1p1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
nvme0n1p3	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
nvme0n1p4	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
nvme0n1p5	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

nvme0n1p1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p3	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
nvme0n1p4	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	recovery-or-hidden,	no-bmgr,	notwinboot
nvme0n1p5	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

nvme0n1p1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p3	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p4	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1
nvme0n1p5	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	nvme0n1

fdisk -l (filtered): ___________________________________________________________

Disk nvme0n1: 476.96 GiB, 512110190592 bytes, 1000215216 sectors
Disk identifier: A5E2A7D1-3348-48BC-84FA-3EC430BCDD3C
              Start        End   Sectors   Size Type
nvme0n1p1      2048     534527    532480   260M EFI System
nvme0n1p2    534528     567295     32768    16M Microsoft reserved
nvme0n1p3    567296  854383139 853815844 407.1G Microsoft basic data
nvme0n1p4 997746688 1000204287   2457600   1.2G Windows recovery environment
nvme0n1p5 854384640  997746687 143362048  68.4G Linux filesystem
Partition table entries are not in disk order.
Disk nvme1n1: 27.26 GiB, 29260513280 bytes, 57149440 sectors
Disk sda: 7.47 GiB, 8004304896 bytes, 15633408 sectors
Disk identifier: 0x00a8d000
      Boot Start      End  Sectors  Size Id Type
sda1  *     2048 15633407 15631360  7.5G  c W95 FAT32 (LBA)

parted -lm (filtered): _________________________________________________________

sda:8004MB:scsi:512:512:msdos:SanDisk Cruzer Switch:;
1:1049kB:8004MB:8003MB:fat32::boot, lba;
nvme0n1:512GB:nvme:512:512:gpt:INTEL HBRPEKNX0202A:;
1:1049kB:274MB:273MB:fat32:EFI system partition:boot, esp;
2:274MB:290MB:16.8MB::Microsoft reserved partition:msftres;
3:290MB:437GB:437GB:ntfs:Basic data partition:msftdata;
5:437GB:511GB:73.4GB:ext4::;
4:511GB:512GB:1258MB:ntfs:Basic data partition:hidden, diag;
nvme1n1:29.3GB:nvme:512:512:unknown:INTEL HBRPEKNX0202AO:;

blkid (filtered): ______________________________________________________________

NAME        FSTYPE          UUID                                 PARTUUID                             LABEL       PARTLABEL
sda                                                                                                               
└─sda1      vfat            9A83-746C                            00a8d000-01                          UBUNTU 20_0 
nvme0n1     isw_raid_member                                                                                       
├─nvme0n1p1 vfat            0A76-1A6D                            e154434c-46ac-4be9-a323-0134323c88a8 SYSTEM      EFI system partition
├─nvme0n1p2                                                      84c2a9cd-2ce0-45d0-ae25-9e781efbd8a0             Microsoft reserved partition
├─nvme0n1p3 ntfs            224277E54277BC5B                     f986721a-f506-4b89-95f7-38413e856c1b OS          Basic data partition
├─nvme0n1p4 ntfs            02608F15608F0F1B                     e74b5294-6652-4dc0-a01d-47352e93ed74 RECOVERY    Basic data partition
└─nvme0n1p5 ext4            584cd607-2ca6-4c4b-b937-a4409de67369 8d3deb01-fe0d-43cd-a884-d26dd4a8ec7a             
nvme1n1     isw_raid_member                                                                                       

df (filtered): _________________________________________________________________

       Avail Use% Mounted on
sda1    4.9G  35% /cdrom

Mount options: __________________________________________________________________

sda1   ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro

====================== sda1/boot/grub/grub.cfg (filtered) ======================

Ubuntu
Ubuntu (safe graphics)
OEM install (for manufacturers)
Boot from next volume
UEFI Firmware Settings

========================= sda1/syslinux.cfg (filtered) =========================

DEFAULT loadconfig

LABEL loadconfig
  CONFIG /isolinux/isolinux.cfg
  APPEND /isolinux/

==================== sda1: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             boot/grub/grub.cfg                             1

================== sda1: Location of files loaded by Syslinux ==================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             syslinux.cfg                                   1
            ?? = ??             ldlinux.sys                                    1


======================== Unknown MBRs/Boot Sectors/etc =========================

Unknown BootLoader on md/imsm0


Unknown BootLoader on md/imsm1



=============================== StdErr Messages ================================

File descriptor 63 (pipe:[121720]) leaked on lvs invocation. Parent PID 25372: /bin/bash
mdadm: (IMSM): Unsupported attributes : 3000000
mdadm: Unsupported attributes in IMSM metadata.Arrays activation is blocked.
mdadm: Cannot activate member /md127/0 in /dev/md/imsm0.
mdadm: (IMSM): Unsupported attributes : 3000000
mdadm: Unsupported attributes in IMSM metadata.Arrays activation is blocked.
mdadm: Cannot activate member /md126/0 in /dev/md/imsm1.
mdadm: (IMSM): Unsupported attributes : 3000000
mdadm: Unsupported attributes in IMSM metadata.Arrays activation is blocked.
mdadm: Cannot activate member /md126/1 in /dev/md/imsm1.


=================== blkid (filtered) before raid activation: ===================
/dev/nvme0n1p1: LABEL="SYSTEM" UUID="0A76-1A6D" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e154434c-46ac-4be9-a323-0134323c88a8"
/dev/nvme0n1p3: LABEL="OS" UUID="224277E54277BC5B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="f986721a-f506-4b89-95f7-38413e856c1b"
/dev/nvme0n1p4: LABEL="RECOVERY" UUID="02608F15608F0F1B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e74b5294-6652-4dc0-a01d-47352e93ed74"
/dev/nvme0n1p5: UUID="584cd607-2ca6-4c4b-b937-a4409de67369" TYPE="ext4" PARTUUID="8d3deb01-fe0d-43cd-a884-d26dd4a8ec7a"
/dev/nvme1n1: TYPE="isw_raid_member"
/dev/sda1: LABEL="UBUNTU 20_0" UUID="9A83-746C" TYPE="vfat" PARTUUID="00a8d000-01"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="84c2a9cd-2ce0-45d0-ae25-9e781efbd8a0"
dmraid -si -c
no block devices found
dmraid -ay:
no block devices found
dmraid -sa -c:
no block devices found
mdadm --assemble --scan

mdadm --detail --scan
ARRAY /dev/md/imsm0 metadata=imsm UUID=e7181e38:95afcd78:b8ba15ca:fbfabe5e
ARRAY /dev/md/imsm1 metadata=imsm UUID=0dff7b48:7293db53:7764ac84:15650185
Error code 32
mount -r /dev/nvme0n1p1 /mnt/boot-sav/nvme0n1p1

mount -r /dev/nvme0n1p1 : Error code 32
Error code 21
mount -r /dev/nvme0n1p3 /mnt/boot-sav/nvme0n1p3

mount -r /dev/nvme0n1p3 : Error code 21
Error code 21
mount -r /dev/nvme0n1p4 /mnt/boot-sav/nvme0n1p4

mount -r /dev/nvme0n1p4 : Error code 21
Error code 32
mount -r /dev/nvme0n1p5 /mnt/boot-sav/nvme0n1p5

mount -r /dev/nvme0n1p5 : Error code 32
Error code 32
mount -r /dev/nvme0n1p1 /mnt/boot-sav/nvme0n1p1

mount -r /dev/nvme0n1p1 : Error code 32
Error code 21
mount -r /dev/nvme0n1p3 /mnt/boot-sav/nvme0n1p3

mount -r /dev/nvme0n1p3 : Error code 21
Error code 21
mount -r /dev/nvme0n1p4 /mnt/boot-sav/nvme0n1p4

mount -r /dev/nvme0n1p4 : Error code 21
Error code 32
mount -r /dev/nvme0n1p5 /mnt/boot-sav/nvme0n1p5

mount -r /dev/nvme0n1p5 : Error code 32
Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would not act on the boot.

On y voit que ton modèle d'ordi est équipé du système Optane H10 (*). Il va falloir que tu désactives Optane H10. Cela se fait depuis une session de ton Windows 10.
EDIT : des explications sur les manips à faire sont données par alexandre_caze dans ce post : https://forum.ubuntu-fr.org/viewtopic.p … #p22403411
A priori, tu n'as pas à changer ce qu'il y a actuellement dans le Bios. C'est à dire que le paramètre SATA Mode Selection est certainement sur [Intel RST Premium With Intel Optane System Acceleration] et il convient de le laisser comme ça.

(*) les symptômes de Optane H10 quand il est activé : la présence de md/imsm1 au début du Boot-info.

Dernière modification par malbo (Le 10/02/2021, à 07:53)

Hors ligne

#7 Le 09/02/2021, à 20:48

hoc_dev

Re : [Résolu] PC qui boot directement sur windows avec un dualboot

D'accord, donc il suffit seulement que je désactives Optane H10, c'est cela ?

UPDATE : Je t'écris depuis mon ubuntu réparer maintenant, je te remercie INFINIMENT !! Les héros ne portent donc pas tous des caps wink
Je passe de suite le sujet en résolu. Et encore merci beaucoup !!

Dernière modification par hoc_dev (Le 09/02/2021, à 21:14)

Hors ligne

#8 Le 10/02/2021, à 07:41

malbo

Re : [Résolu] PC qui boot directement sur windows avec un dualboot

Bonjour,
Je viens d'ajouter ton modèle Vivobook S533F dans la Liste des portables « Asus »
Ce serait utile que tu fasses un Boot-info depuis une session de ton Ubuntu installé (et non pas depuis une session live) et que tu donnes l'URL de ce Boot-info dans ta réponse. Cela donnerait un exemple d'un dual-boot réussi pour quelqu'un qui aurait le même modèle d'ordi ou un modèle proche.

EDIT le 13 févr 2021 : je voulais relancer par mail pour cette demande de boot-info mais c'est impossible car hoc_dev a supprimé E-mail de son profil...

Dernière modification par malbo (Le 13/02/2021, à 09:44)

Hors ligne