Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/02/2021, à 18:25

Zwank

Refus d'utiliser flatpak et snaps

Bonjour,

Pour essayer thunderbird 78, je suis parti du download de leur site qui m'a envoyé sur discover qui n'avais qu'un snap à me proposer.
Il fonctionnait bien à priori. Mais je l'ai viré car inutile pour moi.
Je me méfie des flatpak depuis une mauvaise expérience avec darktable qui plantait souvent, alors qu'en l'installant à partir de darktable.fr c'est nickel.
La réinstallation de libreoffice, c'est aussi folklorique pour l'avoir avec une version complète en français.
Alors qu'en partant de leur site, c'est impeccable.
Quand j'avais des flatpak (pour gimp et libreoffice), tous les jours j'avais des m.a.j pour gnome etc...36 et 38.
Pour les snap, il me rest  :

$ snap list --all
Name                             Version          Rev    Tracking       Publisher   Notes
core                             16-2.48.2.1      10823  latest/stable  canonical✓  core
core18                           20210128         1988   latest/stable  canonical✓  base
core20                           20201210         904    latest/stable  canonical✓  base
gnome-3-34-1804                  0+git.3556cb3    66     latest/stable  canonical✓  -
gtk-common-themes                0.1-50-gf7627e4  1514   latest/stable  canonical✓  -
gtk2-common-themes               0.1              13     latest/stable  canonical✓  -
kde-frameworks-5-qt-5-14-core18  5.68.0           4      latest/stable  kde✓        -

Toutes choses qui m'ont été imposées.
Reste que c'est un peu fouillis pour s'y retrouver

Système : KDE neon user edition


KDE neon user edition

Hors ligne

#2 Le 22/02/2021, à 19:15

bruno

Re : Refus d'utiliser flatpak et snaps

Zwank a écrit :

Toutes choses qui m'ont été imposées.

Rein ne t'oblige à utiliser cette bouse de snap. Surtout pour avoir une version de KDE Frameworks obsolète par rapport aux paquets de KDE neon


Si tu veux essayer Thunderbird 78, utilise des paquets deb :
https://launchpad.net/~mozillateam/+archive/ubuntu/ppa


Être radical c’est prendre les choses par la racine.

Hors ligne

#3 Le 22/02/2021, à 20:38

Coeur Noir

Re : Refus d'utiliser flatpak et snaps

…et de toute façon elle ne devrait plus tarder à arriver dans les dépôts officiels ( elle y est pour Groovy et Hirsute… elle est sans doute dans le canal proposed pour Focal - à éviter ).

C'est vrai que snap et KDE ( enfin Qt précisément ) c'est bof-bof.

Zwank ces paquets snap que tu montres sont le strict nécessaire de base, qui servent de « cadre » aux éventuels snaps que tu installerais ultérieurement.

Dernière modification par Coeur Noir (Le 22/02/2021, à 20:38)


DébuterDocBien rédigerRetour commandeInsérer image | mes albums <>

Hors ligne

#4 Le 22/02/2021, à 20:50

Zwank

Re : Refus d'utiliser flatpak et snaps

@ Bruno : je voulais dire que ce n'était pas moi qui avait installé manuellement ces snaps.
Je ne sais même pas ce que c'est.
Et encore moi mettre à jour le frameworks obsolète.


KDE neon user edition

Hors ligne

#5 Le 22/02/2021, à 21:01

Coeur Noir

Re : Refus d'utiliser flatpak et snaps

Je ne sais même pas ce que c'est → bah je viens de te donner la réponse big_smile et c'est installé par défaut dans Ubuntu.


DébuterDocBien rédigerRetour commandeInsérer image | mes albums <>

Hors ligne

#6 Le 23/02/2021, à 12:34

Zwank

Re : Refus d'utiliser flatpak et snaps

Merci pour les réponses !
Donc, je n'y touche pas, (790 Mio). Au cas où j'aurais besoin d'un snap.
Je faisais la comparaison avec les flatpak, puisque c'est le sujet de cette discussion.
Et sur ma flatpak list, je n'ai rien du tout. Nada.


KDE neon user edition

Hors ligne

#7 Le 23/02/2021, à 16:09

Coeur Noir

Re : Refus d'utiliser flatpak et snaps

Et pourtant il a bien fallu que tu installes le « cadre » flatpak… c'est exactement le même principe.

Sous Ubuntu à une époque il fallait d'abord activer un ppa, puis installer flatpak, et de là il devient possible d'utiliser des logiciels en flatpak.


DébuterDocBien rédigerRetour commandeInsérer image | mes albums <>

Hors ligne

#8 Le 23/02/2021, à 19:58

Zwank

Re : Refus d'utiliser flatpak et snaps

Je comprends bien. Mais je me suis mal exprimé. Vu que ni les snap, ni les flat ne font l'unanimité, ne serait-il pas possible d'avoir un système sans les uns et les autres ?


KDE neon user edition

Hors ligne

#9 Le 23/02/2021, à 20:37

Qid

Re : Refus d'utiliser flatpak et snaps

Zwank a écrit :

ne serait-il pas possible d'avoir un système sans les uns et les autres ?

Tu tournes en ronds là...


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#10 Le 23/02/2021, à 20:38

bruno

Re : Refus d'utiliser flatpak et snaps

Bine sûr que oui. Je n'ai ni snap, ni flatpak sur ma machine sous Kde Neon.


Être radical c’est prendre les choses par la racine.

Hors ligne