Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/03/2021, à 15:19

merauder

[ Résolu] Pourquoi le lecteur eid veut pas fonctionner !?

Salut à tous,
Faut-il faire quelque chose de particulier pour utiliser le lecteur eid sous Budgie ou pas ?
C'est la première fois sur Budgie, j'ai refait la démarche pour l'installer mais ça veut pas !
De plus le module eid de BOSA pour Firefox m'annonce "Le logiciel eid n'a pas été trouvé" quand je l'installe. Alors, que par la suite, il est présent dans mes modules !
Je pige pas.

Merci

Edit : Au secour !! Plus moyens d'installer les paquet eid !!!
C'est moi qui perd la tête ou c'est une réalité ?
Même le module firefox est obselète!

Si quelqu'un s'est connecté récement et qu'il passe par ici, aidez-moi s'il vous plait !
Dieu vous le ren...enfin j'en sais rien.

Merci !

Dernière modification par merauder (Le 27/03/2021, à 18:03)


HP ProBook-6570b - Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Ubuntu 20.04

Hors ligne

#2 Le 26/03/2021, à 18:01

fernand1

Re : [ Résolu] Pourquoi le lecteur eid veut pas fonctionner !?

Voilà comment je procède pour ubuntu,
je ne sais pas si sur Budgie c'est pareil !

Carte d’identité :
https://doc.ubuntu-fr.org/tutoriel/util … ique_belge
Aller sur :https://doc.ubuntu-fr.org/tutoriel/utiliser_carte_identite_electronique_belge

 Installez les paquets pcscd libccid libacsccid1.

Téléchargez le paquet eid-archive.deb fourni par l'État belge

Aller sur : https://eid.belgium.be/fr

revenir sur : https://doc.ubuntu-fr.org/tutoriel/util … ique_belge

les pilotes :'installez d’abord le paquet, eid-mw, puis eid-viewer.
S’ils ne s’installent pas
Dans ce cas, Faire une mise à jour des index : sudo  apt-get update, puis installez les 2 paquets

descendre sur la rubrique : Chrome / Chromium

 installant le paquet, libnss3-tools,

 Il faudra fermer Chrome , mais avant copier la ligne suivante :                                                                        modutil -dbdir sql:.pki/nssdb/ -add "Belgium eID" -libfile /usr/lib/x86_64-linux-gnu/libbeidpkcs11.so.0

fermez chrome, puis collez dans terminal la longue phrase.

Rebranchez chrome.
Lecteur CI branché avec CI insérée

Mettre dans terminal : modutil -dbdir sql:.pki/nssdb/ -list

On doit obtenir :

Listing of PKCS #11 Modules
-----------------------------------------------------------
  1. NSS Internal PKCS #11 Module
         slots: 2 slots attached
        status: loaded

         slot: NSS Internal Cryptographic Services
        token: NSS Generic Crypto Services

         slot: NSS User Private Key and Certificate Services
        token: NSS Certificate DB

  2. Belgium eID
        library name: /usr/lib/libbeidpkcs11.so
         slots: 1 slot attached
        status: loaded

         slot: ACS ACR38U 00 00
        token: BELPIC

recherchez l’icone (CI) eiD Card Reader
Il faut peut-être redémarrer le pc

Sans redémarrage du PC, le logiciel de lecture apparaît bien dans le menu et il fonctionne, mais dès que vous essaierez de lire la carte d'identité électronique, si une "erreur inconnue" apparaît, redémarrer votre ordinateur. Vous pouvez utiliser la commande suivante pour éviter le redémarrage:
sudo /etc/init.d/pcscd restart

Hors ligne

#3 Le 26/03/2021, à 18:11

fernand1

Re : [ Résolu] Pourquoi le lecteur eid veut pas fonctionner !?

UTILISATION LECTEUR DE CARTES :
Uniquement avec chrome !  (chromium ne va pas)



Brancher le lecteur
insérer la carte
aller sur l’icone carte en bas de l’écran sur le lanceur (ça peut être à gauche de l'écran)
la carte doit être lue
clic sur certificat
clic sur belgium
la durée de validité du certificat doit s’afficher
fermer avec le X
aller sur tax on web
d’identifier avec la carte.

Hors ligne

#4 Le 26/03/2021, à 22:16

merauder

Re : [ Résolu] Pourquoi le lecteur eid veut pas fonctionner !?

Salut fernand1, merci pour le retour mais j'ai déjà effectué cette démarche. La Logithèque ne veut pas installer, pas pris en charge!
Je me rappel avoir fait fonctionner le lecteur il y a quelques temps mais je ne sais plus comment j'avais fais (j'étais sur Xubuntu). Avec Antix aussi ça se passait bien. Pourquoi Antix, Xubuntu et pas Budgie (qui est quand même basé sur Ubuntu non?)
Je vais encore fouiller demain.
Et puis si tu as une autre idée, ou si quelqu'un d'autre s'arrête avec une soluce...
On verra

Merci fernand1


HP ProBook-6570b - Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Ubuntu 20.04

Hors ligne

#5 Le 27/03/2021, à 18:26

merauder

Re : [ Résolu] Pourquoi le lecteur eid veut pas fonctionner !?

Voilà, résolu, le lecteur fonctionne.

Si ça peut aider certains, voici ma démarche :

Aller  ici
(pour ma part) A la section B) : Sans le logiciel du SPF STRATÉGIE ET APPUI
Téléchargez les paquets

  sudo apt-get install opensc opensc-pkcs11 pcscd libccid pcsc-tools

Vérifier que ça fonctionne :
(lecteur branché avec la carte)

pcsc_scan

Quitté le terminal malgré le "process still running" et y a plus qu'a utilisé

Dernière modification par merauder (Le 28/03/2021, à 17:39)


HP ProBook-6570b - Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Ubuntu 20.04

Hors ligne

#6 Le 28/03/2021, à 12:00

fernand1

Re : [ Résolu] Pourquoi le lecteur eid veut pas fonctionner !?

Bien,
J'ajoute cela dans ma bibliothèque
Bonne journée

Hors ligne

#7 Le 28/03/2021, à 17:40

merauder

Re : [ Résolu] Pourquoi le lecteur eid veut pas fonctionner !?

fernand1 a écrit :

Bien,
J'ajoute cela dans ma bibliothèque
Bonne journée

Tu fais bien wink
Belle soirée.


HP ProBook-6570b - Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Ubuntu 20.04

Hors ligne