Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/06/2021, à 21:30

oobov

Ubuntu Server 20.04.2 LTS - Problème pour exécuter .php sous Apache2

Bonjour,

Comme les fichiers php ne se lancent pas mais affichent leur source, j'ai fais quelques recherche et j'ai compris qu'il me manquait le module php.

Par contre, quand je fais sudo a2enmod php7.4 j'ai le droit à :

Considering dependency mpm_prefork for php7.4:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.4:
Enabling module php7.4.

Comme je ne peux toujours pas exécuter mes .php je pense que ce conflit est peut-être la raison.
Mais si je fais sudo a2dismod mpm_event cela me retourne qu'il est déjà disabled.

Je crois qu'en voulant résoudre mon problème initial j'ai installé de vieux modules en plus des récents, donc c'est tout sale dans mon répertoire et je ne sais pas comment retrouver mon répertoire de modules propre. Celui de l'installation.

Merci pour votre aide.

Dernière modification par oobov (Le 12/06/2021, à 21:31)

Hors ligne

#2 Le 13/06/2021, à 14:25

jplemoine

Re : Ubuntu Server 20.04.2 LTS - Problème pour exécuter .php sous Apache2

Je pense qu'il faut que tu installes libapache2-mod-php  et/ou libapache2-mod-php7.4.
De mémoire, c'est ça qui fait que apache exécute les php au lieu d’afficher le contenu
Après, il faut :
- désinstaller les php5
- "jouer" avec apt autoremove, apt autoclean,... pour nettoyer tous les anciens paquets.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#3 Le 13/06/2021, à 14:27

oobov

Re : Ubuntu Server 20.04.2 LTS - Problème pour exécuter .php sous Apache2

Ok merci, je vais regarder ça.

Hors ligne

#4 Le 13/06/2021, à 16:48

bruno

Re : Ubuntu Server 20.04.2 LTS - Problème pour exécuter .php sous Apache2

Bonjour,

D'après ton premier retour le module php7.4 d'apache est bien activé (et donc libapache2-mod-php est bien installé). Après avoir relancé apache2 cela devrait fonctionner.


Le mensonge et la crédulité s'accouplent et engendrent l'opinion.

Hors ligne