Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/08/2021, à 00:12

Crestey

[Résolu] Montage Nas en NFS systemd, pb timing au boot, (option AFTER)

Bonsoir à tous,
J'ai un NAS que j'essaie de monter en NFS avec systemd.
J'ai écrit ce fichier /etc/systemd/system/mnt-nas1.mount

[Unit]
Description=Mount nas1 volume at boot
After=network-online.target

[Mount]
What=192.168.0.20:/mnt/HD_a2
Where=/mnt/nas1
Options=user,rw,nfsvers=3,nolock,proto=tcp,mountproto=tcp
Type=nfs

[Install]
WantedBy=multi-user.target

Ensuite je lance : systemctl daemon-reload
Ça marche impeccable sur mon pc en wifi (même sans l'option "After"), mais sur mon pc en filaire, ça ne se lance pas tout seul après boot.
Je pense que c'est un pb de timing (que le réseau n'est pas là quand le fichier est lu)
Si je fais sudo systemctl start mnt-nas1.mount après le boot, là ça marche. Donc le fichier est correct à part la tempo.
L'option After est là normalement pour attendre que le réseau soit actif. Mais ça ne marche pas. J'ai vu pas mal de fil où différentes choses sont proposées mais ça ne marche pas.
Auriez-vous une idée SVP ?
Merci

EDIT : Là je viens d'ajouter la ligne Wants=network-online.target comme suggéré là , mais non, y a vraiment rien qui marche.

Dernière modification par Crestey (Le 06/08/2021, à 10:23)


Merci à tous.
Sous Ubuntu/XFCE depuis 2013. Ça fonctionne vraiment très bien.

Hors ligne

#2 Le 06/08/2021, à 08:50

bruno

Re : [Résolu] Montage Nas en NFS systemd, pb timing au boot, (option AFTER)

Bonjour,

Est-ce que tu as bien pensé à activer le montage :

sudio systemctl enable mnt-nas1.mount

pour vérifier :

systemctl is-enabled mnt-nas1.mount

Sinon sans garantie, tu peux essayer ceci :

Wants=network-online.target rpc-statd.service
After=network-online.target rpc-statd.service

Si rien ne fonctionne désactive le montage mnt-nas1.mount et utilise un automount mnt-nas1.automount (à activer) :

[Unit]
DefaultDependencies=no
After=remote-fs-pre.target
Wants=remote-fs-pre.target
Conflicts=umount.target
Before=umount.target

[Automount]
Where=/mnt/HD_a2
DirectoryMode=0755
TimeoutIdleSec=0

[Install]
WantedBy=multi-user.target

Le montage sera fait automatiquement lorsque l'utilisateur tente d’accéder au dossier /mnt/HD_a2.

Dernière modification par bruno (Le 06/08/2021, à 08:55)


Le mensonge et la crédulité s'accouplent et engendrent l'opinion.

Hors ligne

#3 Le 06/08/2021, à 09:36

Crestey

Re : [Résolu] Montage Nas en NFS systemd, pb timing au boot, (option AFTER)

Bonjour bruno,
1) Oui j'ai bien pensé à activer "sudio systemctl enable mnt-nas1.mount"
2) Rajouter rpc-statd.service ne change pas. Ça merdoit toujours
3) Pour l'automount je viens de faire un essai mais j'ai fait un mixte avec mon fichier parcequ'avec le tien je ne comprends pas comment le system peut comprendre d'aller chercher sur 192.168.0.20.
Mais ça merdoit aussi  (j'ai sans doute introduit des merdes, mais c'est sur qu'il faut 192.168.0.20 quelque part ) :

[Unit]
DefaultDependencies=no
After=remote-fs-pre.target
Wants=remote-fs-pre.target
Conflicts=umount.target
Before=umount.target

[Automount]
What=192.168.0.20:/mnt/HD_a2
Where=/mnt/nas1
Options=user,rw,nfsvers=3,nolock,proto=tcp,mountproto=tcp
Type=nfs
DirectoryMode=0755
TimeoutIdleSec=0

[Install]
WantedBy=multi-user.target

EDIT : Je précise que j'ai bien pensé à faire systemctl start mnt-nas1.automount. Mais qu'après le boot, il faut le refaire pour que ça soit monté. Donc le soucis est inchangé.

Dernière modification par Crestey (Le 06/08/2021, à 09:47)


Merci à tous.
Sous Ubuntu/XFCE depuis 2013. Ça fonctionne vraiment très bien.

Hors ligne

#4 Le 06/08/2021, à 10:05

bruno

Re : [Résolu] Montage Nas en NFS systemd, pb timing au boot, (option AFTER)

Je vois une erreur dans ta configuration : le nom des fichiers mount et automount doit impérativement être composé avec le nom du dossier de montage mnt-nas1.mount pour un montage sur /mnt/nas1
cf. https://www.freedesktop.org/software/sy … mount.html

Pour utiliser l'automount il faut :
1. arrêter le montage :

sudo systemctl stop mnt-nas1.mount

2. désactiver le montage

sudo systemctl disable mnt-nas1.mount

3. activer l'automount :

sudo systemctl enable mnt-nas1.automount

L'unité automount va chercher l'unité mount du même nom pour faire le montage. Ce que j'ai indiqué est suffisant.

Le montage sera effectué automatiquement à la première tentative d'accès à /mnt/nas1.


Vérification :

$ systemctl is-enabled mnt-nas1.mount 
static
$ systemctl is-enabled mnt-nas1.automount 
enable

Dernière modification par bruno (Le 06/08/2021, à 10:35)


Le mensonge et la crédulité s'accouplent et engendrent l'opinion.

Hors ligne

#5 Le 06/08/2021, à 10:23

Crestey

Re : [Résolu] Montage Nas en NFS systemd, pb timing au boot, (option AFTER)

Bonjour bruno,
Ça semble marcher ! Merci beaucoup cool (lunette de soleil pour faire venir l'été).
J'ai refait les commandes suggérées. J'avais omis sudo systemctl enable mnt-nas1.automount, sorry.

Par contre, je ne comprends pas ta remarque pour les noms de fichiers car ils sont corrects. D'ailleurs comme je disais en  #1, le montage se fait correctement sur mon pc en wifi. Le nom est donc forcément bon.
Et aussi j'ai une petite différence sans importance avec toi :

crestey@crestey-Pegatron:~$ systemctl is-enabled mnt-nas1.mount 
disabled
crestey@crestey-Pegatron:~$

au lieu de static
Merci encore, amicalement, Dominique


Merci à tous.
Sous Ubuntu/XFCE depuis 2013. Ça fonctionne vraiment très bien.

Hors ligne

#6 Le 06/08/2021, à 10:37

bruno

Re : [Résolu] Montage Nas en NFS systemd, pb timing au boot, (option AFTER)

Oui pardon c'est moi qui me suis trompé dans le fichier proposé en #2, la ligne aurait dû être :

Where=/mnt/nas1

Tes noms de fichiers sont parfaitement corrects.

Pour la dernière remarque, il devrait apparaître comme static après un redémarrage.


Le mensonge et la crédulité s'accouplent et engendrent l'opinion.

Hors ligne

#7 Le 06/08/2021, à 10:49

Crestey

Re : [Résolu] Montage Nas en NFS systemd, pb timing au boot, (option AFTER)

Bon alors d'abord, Pardon d'être aussi nul.
En effet, finalement le seul problème était l'oubli de l'indispensable commande enable : sudo systemctl enable mnt-nas1.mount
Du coup par curiosité, j'ai repris mon fichier en #1 (en virant la ligne after et sans ligne want), j'ai fait "disable" de  mnt-nas1.automount, et "enable" mnt-nas1.mount.
Et ça marche !
Le fichier juste suffisant est donc :

[Unit]
Description=Mount nas1 volume at boot

[Mount]
What=192.168.0.20:/mnt/HD_a2
Where=/mnt/nas1
Options=user,rw,nfsvers=3,nolock,proto=tcp,mountproto=tcp
Type=nfs

[Install]
WantedBy=multi-user.target

Il suffit de ne pas oublier de faire sudo systemctl enable mnt-nas1.mount roll
Merci encore de ton aide et du temps passé.
Amicalement, Dominique

Dernière modification par Crestey (Le 08/08/2021, à 15:05)


Merci à tous.
Sous Ubuntu/XFCE depuis 2013. Ça fonctionne vraiment très bien.

Hors ligne