Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/08/2021, à 08:20

wallace27

wsl2 - erreur ppa java lors du sudo update

Bonjour,

Lorsque je tape sudo apt update sur mon Ubuntu wsl je tome sur une erreur liée au sde/sdk java :

ubuntu@steg:~$ sudo apt update
[sudo] password for ubuntu:
Ign:1 http://ppa.launchpad.net/webupd8team/java/ubuntu focal InRelease
Hit:2 http://archive.ubuntu.com/ubuntu focal InRelease
Get:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:4 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Err:5 http://ppa.launchpad.net/webupd8team/java/ubuntu focal Release
  404  Not Found [IP: 91.189.95.85 80]
Get:6 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:7 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1132 kB]
Get:8 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [844 kB]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
ubuntu@steg:~$

Sauriez-vous m'aider à résoudre ?

Merci pour votre aide.

Hors ligne

#2 Le 08/08/2021, à 08:28

Qid

Re : wsl2 - erreur ppa java lors du sudo update

A vu de nez ce dépôt n'existe pas pour Focal... Je ne connais pas le fonctionnement de wsl mais tu dois bien avoir un sources.list quelquepart dans lequel il faut que tu désactives ce dépôt


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#3 Le 08/08/2021, à 08:45

xubu1957

Re : wsl2 - erreur ppa java lors du sudo update

Bonjour,

Pour webupd8team, l'avis de nam1962 était radical > forum.ubuntu-fr.org/viewtopic.php?pid=21873873#p21873873.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#4 Le 09/08/2021, à 09:19

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

Je vous remercie pour votre aide.

Pourriez-vous m'indiquer comment désinstaller/supprimer ce dépôt et comment installer le bon/conseillé dépôt à la place ?

Hors ligne

#5 Le 09/08/2021, à 09:29

xubu1957

Re : wsl2 - erreur ppa java lors du sudo update

Bonjour,

Montre le sources.list :

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;
cqfd93 a écrit :

Astuce pour copier / coller sans erreur :

  • triple clic gauche pour sélectionner et copier une ligne entière

  • clic molette pour coller dans le terminal

pour essayer de voir si la solution de nany est praticable


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#6 Le 09/08/2021, à 09:52

MicP

Re : wsl2 - erreur ppa java lors du sudo update

Bonjour

Pour rechercher le chemin et le nom du ou des fichiers .list
qui contiennent une ligne dans laquelle se trouve : webupd8team

awk '/webupd8team/{print FILENAME}' /etc/apt/sources.list{,.d/*.list}

Dernière modification par MicP (Le 09/08/2021, à 10:13)

Hors ligne

#7 Le 09/08/2021, à 10:18

Qid

Re : wsl2 - erreur ppa java lors du sudo update

Sur du wsl les chemins restent les mêmes ? En même dans l'architecture wine on a bien un c: alors pourquoi pas... Mais là vous allez me faire découvrir...


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#8 Le 09/08/2021, à 22:25

soshy

Re : wsl2 - erreur ppa java lors du sudo update

@Qid : wsl (v2) n'est rien de plus qu'une vm hyper-v. La seule différence vraiment notable que j'ai constaté c'est qu'ubuntu n'est pas démarré avec systemd et donc on a pas de systemctl etc.
Pour wsl v1, faut plutot voir ça comme une sorte de wine bundle avec un squashfs ubuntu. On lance bash dans le squashfs, et les partitions windows sont "montés" dans /mnt (en réalité les appels système sont translaté). Ici aussi, tout le layout du système reste identique à une installation normale.

Hors ligne

#9 Le 12/08/2021, à 08:11

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

ubuntu@steg:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list

     1  # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     2  # newer versions of the distribution.
     3  deb http://archive.ubuntu.com/ubuntu/ focal main restricted
     4  # deb-src http://archive.ubuntu.com/ubuntu/ focal main restricted
     5
     6  ## Major bug fix updates produced after the final release of the
     7  ## distribution.
     8  deb http://archive.ubuntu.com/ubuntu/ focal-updates main restricted
     9  # deb-src http://archive.ubuntu.com/ubuntu/ focal-updates main restricted
    10
    11  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    12  ## team. Also, please note that software in universe WILL NOT receive any
    13  ## review or updates from the Ubuntu security team.
    14  deb http://archive.ubuntu.com/ubuntu/ focal universe
    15  # deb-src http://archive.ubuntu.com/ubuntu/ focal universe
    16  deb http://archive.ubuntu.com/ubuntu/ focal-updates universe
    17  # deb-src http://archive.ubuntu.com/ubuntu/ focal-updates universe
    18
    19  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    20  ## team, and may not be under a free licence. Please satisfy yourself as to
    21  ## your rights to use the software. Also, please note that software in
    22  ## multiverse WILL NOT receive any review or updates from the Ubuntu
    23  ## security team.
    24  deb http://archive.ubuntu.com/ubuntu/ focal multiverse
    25  # deb-src http://archive.ubuntu.com/ubuntu/ focal multiverse
    26  deb http://archive.ubuntu.com/ubuntu/ focal-updates multiverse
    27  # deb-src http://archive.ubuntu.com/ubuntu/ focal-updates multiverse
    28
    29  ## N.B. software from this repository may not have been tested as
    30  ## extensively as that contained in the main release, although it includes
    31  ## newer versions of some applications which may provide useful features.
    32  ## Also, please note that software in backports WILL NOT receive any review
    33  ## or updates from the Ubuntu security team.
    34  deb http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    35  # deb-src http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    36
    37  ## Uncomment the following two lines to add software from Canonical's
    38  ## 'partner' repository.
    39  ## This software is not part of Ubuntu, but is offered by Canonical and the
    40  ## respective vendors as a service to Ubuntu users.
    41  # deb http://archive.canonical.com/ubuntu focal partner
    42  # deb-src http://archive.canonical.com/ubuntu focal partner
    43
    44  deb http://security.ubuntu.com/ubuntu/ focal-security main restricted
    45  # deb-src http://security.ubuntu.com/ubuntu/ focal-security main restricted
    46  deb http://security.ubuntu.com/ubuntu/ focal-security universe
    47  # deb-src http://security.ubuntu.com/ubuntu/ focal-security universe
    48  deb http://security.ubuntu.com/ubuntu/ focal-security multiverse
    49  # deb-src http://security.ubuntu.com/ubuntu/ focal-security multiverse

/etc/apt/sources.list.d/webupd8team-ubuntu-java-focal.list

     1  deb http://ppa.launchpad.net/webupd8team/java/ubuntu focal main
     2  # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu focal main
ubuntu@steg:~$
xubu1957 a écrit :

Bonjour,

Montre le sources.list :

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;
cqfd93 a écrit :

Astuce pour copier / coller sans erreur :

  • triple clic gauche pour sélectionner et copier une ligne entière

  • clic molette pour coller dans le terminal

pour essayer de voir si la solution de nany est praticable

Hors ligne

#10 Le 12/08/2021, à 08:12

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

ubuntu@steg:~$ awk '/webupd8team/{print FILENAME}' /etc/apt/sources.list{,.d/*.list}
/etc/apt/sources.list.d/webupd8team-ubuntu-java-focal.list
/etc/apt/sources.list.d/webupd8team-ubuntu-java-focal.list
ubuntu@steg:~$
MicP a écrit :

Bonjour

Pour rechercher le chemin et le nom du ou des fichiers .list
qui contiennent une ligne dans laquelle se trouve : webupd8team

awk '/webupd8team/{print FILENAME}' /etc/apt/sources.list{,.d/*.list}

Dernière modification par wallace27 (Le 12/08/2021, à 08:12)

Hors ligne

#11 Le 18/08/2021, à 13:44

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

et maintenant je fais quoi ? sad

Je suis toujours à la case départ :

ubuntu@steg:/mnt/c/Users/Steg$ sudo apt update
[sudo] password for ubuntu:
Ign:1 http://ppa.launchpad.net/webupd8team/java/ubuntu focal InRelease
Hit:2 http://archive.ubuntu.com/ubuntu focal InRelease
Err:3 http://ppa.launchpad.net/webupd8team/java/ubuntu focal Release
  404  Not Found [IP: 91.189.95.85 80]
Get:4 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:5 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:6 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:7 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1163 kB]
Get:8 http://archive.ubuntu.com/ubuntu focal-updates/main Translation-en [251 kB]
Get:9 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [13.9 kB]
Get:10 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [400 kB]
Get:11 http://archive.ubuntu.com/ubuntu focal-updates/restricted Translation-en [57.3 kB]
Get:12 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 c-n-f Metadata [480 B]
Get:13 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [845 kB]
Get:14 http://archive.ubuntu.com/ubuntu focal-updates/universe Translation-en [177 kB]
Get:15 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata [18.4 kB]
Get:16 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages [25.0 kB]
Get:17 http://archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en [6888 B]
Get:18 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata [652 B]
Get:19 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [822 kB]
Get:20 http://security.ubuntu.com/ubuntu focal-security/main Translation-en [161 kB]
Get:21 http://security.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [8440 B]
Get:22 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [364 kB]
Get:23 http://security.ubuntu.com/ubuntu focal-security/restricted Translation-en [52.1 kB]
Get:24 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata [484 B]
Get:25 http://security.ubuntu.com/ubuntu focal-security/universe amd64 Packages [637 kB]
Get:26 http://security.ubuntu.com/ubuntu focal-security/universe Translation-en [99.2 kB]
Get:27 http://security.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata [12.1 kB]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
ubuntu@steg:/mnt/c/Users/Steg$

Dernière modification par wallace27 (Le 18/08/2021, à 13:46)

Hors ligne

#12 Le 18/08/2021, à 13:50

Qid

Re : wsl2 - erreur ppa java lors du sudo update

wallace27 a écrit :

et maintenant je fais quoi ? sad

Je suis toujours à la case départ

en même temps si tu n'as toujours pas supprimé ou au moins commenté le dépôt en question c'est normal que les choses n'aient pas changées...


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#13 Le 18/08/2021, à 14:08

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

Pardon, je ne comprends justement pas comment supprimer le dépôt en question. Je dois taper quelle commande pour le supprimer ?

Hors ligne

#14 Le 18/08/2021, à 15:45

ylag

Re : wsl2 - erreur ppa java lors du sudo update

Bonjour,

Pour retirer le PPA webupd8team/java des sources, essayer :

sudo add-apt-repository --remove ppa:webupd8team/java

...ou dans «Logiciels & Mises à jour», onglet «Autres logiciels» => décocher ou supprimer la/les lignes concernant ce PPA.

La doc concernant Logiciels & Mises à jour

A+

Dernière modification par ylag (Le 18/08/2021, à 15:53)

Hors ligne

#15 Le 18/08/2021, à 19:43

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

ça semble avoir fonctionné merci !

ubuntu@steg:~$ sudo add-apt-repository --remove ppa:webupd8team/java
[sudo] password for ubuntu:
 The Oracle JDK License has changed for releases starting April 16, 2019.

The new Oracle Technology Network License Agreement for Oracle Java SE is substantially different from prior Oracle JDK licenses. The new license permits certain uses, such as personal use and development use, at no cost -- but other uses authorized under prior Oracle JDK licenses may no longer be available. Please review the terms carefully before downloading and using this product. An FAQ is available here: https://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html

Oracle Java downloads now require logging in to an Oracle account to download Java updates, like the latest Oracle Java 8u211 / Java SE 8u212. Because of this I cannot update the PPA with the latest Java (and the old links were broken by Oracle).

For this reason, THIS PPA IS DISCONTINUED.

For Oracle Java 11, see a different PPA -> https://www.linuxuprising.com/2019/06/new-oracle-java-11-installer-for-ubuntu.html

That same PPA also has Oracle Java 13 -> https://www.linuxuprising.com/2019/09/install-oracle-java-13-on-ubuntu-linux.html

and Oracle Java 14 ->
https://www.linuxuprising.com/2020/03/how-to-install-oracle-java-14-jdk14-on.html

Old description:

Oracle Java (JDK) Installer (automatically downloads and installs Oracle JDK8). There are no actual Java files in this PPA.

Important -> Why Oracle Java 7 And 6 Installers No Longer Work: http://www.webupd8.org/2017/06/why-oracle-java-7-and-6-installers-no.html

Update: Oracle Java 9 has reached end of life: http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html

The PPA supports Ubuntu 18.10, 18.04, 16.04, 14.04 and 12.04.

More info (and Ubuntu installation instructions):
- http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html

Debian installation instructions:
- Oracle Java 8: http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html
 More info: https://launchpad.net/~webupd8team/+archive/ubuntu/java
Press [ENTER] to continue or Ctrl-c to cancel removing it.

ubuntu@steg:~$

Maintenant, puis-je vous demander comment je dois procéder pour installer le bon dépôt je vous prie ? Je rappelle que j'utilise wsl2 sous Windows 10 et que j'aimerais que l'interpréteur java tourne sous linux.

Dernière modification par wallace27 (Le 18/08/2021, à 19:47)

Hors ligne

#16 Le 18/08/2021, à 20:28

Qid

Re : wsl2 - erreur ppa java lors du sudo update

Il y a plein de lecture en lien avec java dans la Doc ubuntu-fr... Et puis vu la situation je pense qu'il serait bon que tu expliques le contexte et le pourquoi de ce besoin parce-que déjà j'arrive pas trop à comprendre ce que tu fais sur wsl...

Rassurez moi les connaisseurs on est pas dans une situation proche de celle qu'on a pu avoir à l'époque de wubi ?


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#17 Le 18/08/2021, à 20:39

xubu1957

Re : wsl2 - erreur ppa java lors du sudo update

Bonjour,

@Qid

extraits de la Doc a écrit :

Le Windows Subsystem for Linux (WSL), en français "Sous-système Windows pour Linux", parfois grossièrement appelé "Bash sur Windows" est une couche de compatibilité permettant d'exécuter des fichiers ELF (binaires exécutables) pour Linux à partir d'un système Windows.
Le principe est le même que Wine, mais "dans l'autre sens".

Le but de cette distribution est de simplifier le travail des développeurs (en particulier dans le domaine du web) en rendant possible la mise en place d'une structure et d'outils Linux sous Windows, et ainsi d'harmoniser les environnements de développement Windows avec les environnements GNU/Linux qu'on trouve couramment sur les serveurs de production.
Cet outil n'est donc pas destiné au grand public et son intérêt n'est pas de déployer "nativement" un environnement de bureau GNU/Linux sous Windows, même si c'est techniquement envisageable.

> wsl


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#18 Le 18/08/2021, à 21:53

Qid

Re : wsl2 - erreur ppa java lors du sudo update

Ouais... Il y a plusieurs passages intéressant là-dedans... Surtout la partie que tu as mis en gras ainsi que la dernière phrase de ta citation... Et l'intervention de soshy était pas mal non plus mais ça ne fait pas vraiment avancer le bousin... Du coup je vous laisse gérer... wink


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#19 Le 20/08/2021, à 08:15

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

J'utilise Windows pour son ergonomie (qu'Ubuntu n'a pas) tout en ayant la possibilité d'utiliser un Linux en lignes de commandes en même temps (qui est un Linux natif avec les performances que ça implique). En d'autres termes j'ai les avantages de Windows et de Linux en même temps, ou si vous préférez j'utilise les deux OS simultanément profitant pleinement des avantages de l'un et de l'autre en même temps.

Hors ligne

#20 Le 22/08/2021, à 22:24

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

Maintenant que j'ai désinstallé webupd8team, que puis-je/dois-je installer à la place ?

Dernière modification par wallace27 (Le 22/08/2021, à 22:24)

Hors ligne

#21 Le 30/08/2021, à 20:42

wallace27

Re : wsl2 - erreur ppa java lors du sudo update

personne pour m'aider sad

Hors ligne

#22 Le 31/08/2021, à 18:57

Qid

Re : wsl2 - erreur ppa java lors du sudo update

wallace27 a écrit :

que puis-je/dois-je installer à la place ?

Oui ? C'est pour quoi ? T'as un truc qui ne marche plus !?


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne