Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 09/09/2021, à 15:35

Hada de la Luna

20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Bonjour,

Le service d'évaluation des adaptations au handicap auditif me propose d'utiliser Ava sur mon PC, mais ça donne ça lorsque j'essaie juste de le télécharger…

Capture-d-cran-de-2021-09-09-15-34-37.png

Donc, ça parait compromis…

Comment pourrais-je l'installer et l'utiliser?


Hada de la Luna :o)

Hors ligne

#2 Le 09/09/2021, à 16:21

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Bonjour
Es-tu sur que c'est disponible sur ubuntu?

J'ai juste trouvé ce document
https://webzine.okeenea.com/6-applicati … ants-2020/
qui dit
1. Ava

Une application de transcription instantanée qui transcrit les paroles d’un groupe de personnes en direct. Chaque participant installe l’application sur son smartphone et à l’aide du micro les échanges sont transcrits. Cela permet aux personnes sourdes ou malentendantes de suivre distinctement une conversation au sein d’un groupe sans devoir lire sur les lèvres.

Pratique pour les utilisateurs d’iPhone qui n’ont pas accès à la célèbre transcription instantanée de Google lors de vos réunions de concertation.

Disponible sur iOS et Android.

Hors ligne

#3 Le 09/09/2021, à 16:26

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Je suis certaine que non : ce n'est pas prévu pour s'installer sur Ubuntu.

Je souhaite savoir si le problème est contournable.


Hada de la Luna :o)

Hors ligne

#4 Le 09/09/2021, à 16:33

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Si tu n'as rien contre windows, cela devrait pouvoir se faire https://help.ava.me/fr/articles/4413669 … ac-windows

https://cc.ava.me/download


Windows peut s'installer après ubuntu pour fonctionner en dual boot. Il y a un échange de Malbo qui détaille bien. https://forum.ubuntu-fr.org/viewtopic.php?id=2061271

Dernière modification par geole (Le 09/09/2021, à 16:41)

Hors ligne

#5 Le 09/09/2021, à 16:36

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Je n'ai aucune licence Windows : est-il possible d'installer sans et d'interagir avec les logiciels de vidéo conférence ?


Hada de la Luna :o)

Hors ligne

#6 Le 09/09/2021, à 16:38

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Windows fonctionne sans licence sauf pour certaines applications qui vont aller vérifier si la licence a bien été payée. Pour celle-ci je ne sais pas

Hors ligne

#7 Le 09/09/2021, à 16:42

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Et je n'ai pas de PC où installer un Windows juste pour Ava (ce qui annulerait de toute façon l'intérêt d'avoir ce logiciel même si sponsorisé par la compensation handicap)


Hada de la Luna :o)

Hors ligne

#8 Le 09/09/2021, à 16:45

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Tu as bien un PC qui contient ubuntu. Il peut aussi contenir windows en technique dual boot
Il faut juste un peu de place disque
    => De temps en temps, tu bootes sur ubuntu
    => De temps en temps, tu bootes sur windows

Dernière modification par geole (Le 09/09/2021, à 16:46)

Hors ligne

#9 Le 09/09/2021, à 16:50

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Donc, il n'existe aucun moyen d'installer une version PC ou Android sur Ubuntu ?
Je dois répondre au service d'évaluation du handicap sur ça pour qu'ils examinent d'autres options.


Hada de la Luna :o)

Hors ligne

#10 Le 09/09/2021, à 16:56

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Il doit exister un émulateur androïd    Il y a un an il n'était pas tellement au point.
Je viens de voir qu'il y a maintenant un snap
https://korben.info/faire-tourner-appli … linux.html

sudo snap install --classic anbox-installer && anbox-installer

Je regarde s'il n'y pas mieux
https://doc.ubuntu-fr.org/anbox
Le même en installation  habituelle

sudo add-apt-repository ppa:morphis/anbox-support
sudo apt update
sudo apt install anbox-modules-dkms
sudo modprobe ashmem_linux
sudo modprobe binder_linux

Dernière modification par geole (Le 09/09/2021, à 17:13)

Hors ligne

#11 Le 09/09/2021, à 17:00

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Merci.
J'attends ta confirmation avant d'essayer Anbox


Hada de la Luna :o)

Hors ligne

#12 Le 09/09/2021, à 17:12

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Je ne peux rien te dire, J'avais utilisé la version deb il y a un an pour l'application doctorlib, et cela avait foiré
Tu peux  avoir la version deb et la version  snap et essayer
Dans l'ensemble la version snap est celle qui est la plus à jour.

sudo snap install --classic anbox-installer && anbox-installer
anbox-installer 1 par Simon Fels (morphis) installé
The anbox-installer is deprecated. Please find updated installation
instructions here https://github.com/anbox/anbox/blob/master/docs/install.md

For any further questions please ask on the #anbox IRC channel on the
FreeNode network or in the Anbox telegram group (https://t.me/anbox).
a@a:~$ 

Dernière modification par geole (Le 09/09/2021, à 17:18)

Hors ligne

#13 Le 09/09/2021, à 17:14

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Alors quelle installation vaut-elle mieux ?


Hada de la Luna :o)

Hors ligne

#14 Le 09/09/2021, à 17:22

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Je vois que cela se complique https://github.com/anbox/anbox/blob/mas … install.md

Je crois que je ne pourrais aller très loin

$ snap install --devmode --edge anbox
erreur : cannot perform the following tasks:
- Lancer l'installation du point d'accroche du snap "anbox" si existant (run hook "install": 
-----
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
The CPU of your computer (Intel(R) Celeron(R) CPU        E3400  @ 2.60GHz) does not support all
features Anbox requires.
It is missing support for the following features: SSE 4.1, SSE 4.2
You can for example find more information about SSE
here https://en.wikipedia.org/wiki/Streaming_SIMD_Extensions
-----)
a@a:~$ sudo add-apt-repository ppa:morphis/anbox-support
[sudo] Mot de passe de a : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de a : 
 
 Plus d’info : https://launchpad.net/~morphis/+archive/ubuntu/anbox-support
Appuyez sur [ENTRÉE] pour continuer ou sur Ctrl-c pour annuler l'ajout.

Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                     
Ign :3 http://ppa.launchpad.net/morphis/anbox-support/ubuntu focal InRelease                            
Atteint :4 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease                                
Réception de :5 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Err :6 http://ppa.launchpad.net/morphis/anbox-support/ubuntu focal Release
  404  Not Found [IP : 2001:67c:1560:8008::19 80]
Réception de :7 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [27,6 kB]
Réception de :8 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [61,2 kB]
Réception de :9 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2468 B]
Lecture des listes de paquets... Fait                                          
E: Le dépôt http://ppa.launchpad.net/morphis/anbox-support/ubuntu focal Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
a@a:~$

Dernière modification par geole (Le 09/09/2021, à 17:47)

Hors ligne

#15 Le 09/09/2021, à 17:49

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Il faut donc que tu te lances.
Commence par  la version deb. Si elle ne s'installe pas par absence de logiciel, tu pourras faire la version snap

Hors ligne

#16 Le 10/09/2021, à 12:04

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Finalement, non' j'ai un problème :

snap install --devmode --edge anbox
erreur : cannot perform the following tasks:
- Lancer l'installation du point d'accroche du snap "anbox" si existant (run hook "install": 
-----
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
realpath: '': No such file or directory
The CPU of your computer (Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz) does not support all
features Anbox requires.
It is missing support for the following features: SSE 4.2
You can for example find more information about SSE
here https://en.wikipedia.org/wiki/Streaming_SIMD_Extensions
-----)

Comment résoudre ce problème ?


Hada de la Luna :o)

Hors ligne

#17 Le 10/09/2021, à 16:44

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Bonjour.
Une documentation récente: https://www.moyens.net/android/comment- … vec-anbox/

Il y aurait des modules additionnels à installer.

Autre solution: En machine virtuelle https://thedroidguy.com/best-android-em … ux-1087692


Autre solution. Il existe un "concurrent" https://docs.waydro.id/usage/install-on-desktops
1) Identifier notre version afin de bien choisir la bonne ligne d'installation

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.3 LTS"

Et installer le paquet virtuel absent

sudo apt install lxc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  bridge-utils liblxc-common liblxc1 libpam-cgfs lxc-utils lxcfs uidmap
Paquets suggérés :
  ifupdown btrfs-tools lvm2 lxc-templates lxctl
Les NOUVEAUX paquets suivants seront installés :
  bridge-utils liblxc-common liblxc1 libpam-cgfs lxc lxc-utils lxcfs uidmap
0 mis à jour, 8 nouvellement installés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de prendre 2690 ko dans les archives.
Après cette opération, 22,5 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://fr.archive.ubuntu.com/ubuntu focal/universe amd64 lxcfs amd64 4.0.3-0ubuntu1 [65,3 kB]
Réception de :2 http://fr.archive.ubuntu.com/ubuntu focal/main amd64 bridge-utils amd64 1.6-2ubuntu1 [30,5 kB]
Réception de :3 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 liblxc1 amd64 1:4.0.6-0ubuntu1~20.04.1 [294 kB]
Réception de :4 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 liblxc-common amd64 1:4.0.6-0ubuntu1~20.04.1 [694 kB]
Réception de :5 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 libpam-cgfs amd64 1:4.0.6-0ubuntu1~20.04.1 [31,4 kB]
Réception de :6 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 lxc-utils amd64 1:4.0.6-0ubuntu1~20.04.1 [1547 kB]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 lxc all 1:4.0.6-0ubuntu1~20.04.1 [2976 B]
Réception de :8 http://fr.archive.ubuntu.com/ubuntu focal-updates/universe amd64 uidmap amd64 1:4.8.1-1ubuntu5.20.04.1 [26,3 kB]
2690 ko réceptionnés en 2s (1130 ko/s)
Sélection du paquet lxcfs précédemment désélectionné.
(Lecture de la base de données... 189892 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-lxcfs_4.0.3-0ubuntu1_amd64.deb ...
Dépaquetage de lxcfs (4.0.3-0ubuntu1) ...
Sélection du paquet bridge-utils précédemment désélectionné.
Préparation du dépaquetage de .../1-bridge-utils_1.6-2ubuntu1_amd64.deb ...
Dépaquetage de bridge-utils (1.6-2ubuntu1) ...
Sélection du paquet liblxc1 précédemment désélectionné.
Préparation du dépaquetage de .../2-liblxc1_1%3a4.0.6-0ubuntu1~20.04.1_amd64.deb ...
Dépaquetage de liblxc1 (1:4.0.6-0ubuntu1~20.04.1) ...
Sélection du paquet liblxc-common précédemment désélectionné.
Préparation du dépaquetage de .../3-liblxc-common_1%3a4.0.6-0ubuntu1~20.04.1_amd64.deb ...
Dépaquetage de liblxc-common (1:4.0.6-0ubuntu1~20.04.1) ...
Sélection du paquet libpam-cgfs précédemment désélectionné.
Préparation du dépaquetage de .../4-libpam-cgfs_1%3a4.0.6-0ubuntu1~20.04.1_amd64.deb ...
Dépaquetage de libpam-cgfs (1:4.0.6-0ubuntu1~20.04.1) ...
Sélection du paquet lxc-utils précédemment désélectionné.
Préparation du dépaquetage de .../5-lxc-utils_1%3a4.0.6-0ubuntu1~20.04.1_amd64.deb ...
Dépaquetage de lxc-utils (1:4.0.6-0ubuntu1~20.04.1) ...
Sélection du paquet lxc précédemment désélectionné.
Préparation du dépaquetage de .../6-lxc_1%3a4.0.6-0ubuntu1~20.04.1_all.deb ...
Dépaquetage de lxc (1:4.0.6-0ubuntu1~20.04.1) ...
Sélection du paquet uidmap précédemment désélectionné.
Préparation du dépaquetage de .../7-uidmap_1%3a4.8.1-1ubuntu5.20.04.1_amd64.deb ...
Dépaquetage de uidmap (1:4.8.1-1ubuntu5.20.04.1) ...
Paramétrage de libpam-cgfs (1:4.0.6-0ubuntu1~20.04.1) ...
Paramétrage de lxcfs (4.0.3-0ubuntu1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/lxcfs.service → /lib/systemd/system/lxcfs.service.
Paramétrage de uidmap (1:4.8.1-1ubuntu5.20.04.1) ...
Paramétrage de bridge-utils (1.6-2ubuntu1) ...
Paramétrage de liblxc1 (1:4.0.6-0ubuntu1~20.04.1) ...
Paramétrage de lxc-utils (1:4.0.6-0ubuntu1~20.04.1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/lxc-net.service → /lib/systemd/system/lxc-net.service.
Created symlink /etc/systemd/system/multi-user.target.wants/lxc.service → /lib/systemd/system/lxc.service.
Setting up lxc dnsmasq configuration.
Paramétrage de lxc (1:4.0.6-0ubuntu1~20.04.1) ...
Paramétrage de liblxc-common (1:4.0.6-0ubuntu1~20.04.1) ...
Traitement des actions différées (« triggers ») pour systemd (245.4-4ubuntu3.11) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9.2) ...

2) Faire connaître

wget 'https://static.mrcyjanek.net/abstruse/apt-repository/mrcyjanek-repo/mrcyjanek-repo_2.0-1_all.deb' -O cyjanrepo.deb
sudo apt install ./cyjanrepo.deb
sudo rm ./cyjanrepo.deb && sudo  rm -rf /etc/apt/sources.list.d/cyjan.list

(Ils ont oublié sudo dans leur commande)
Puis un raté pour la mise à jour

sudo sh -c 'echo deb [signedby=/usr/share/keyrings/mrcyjanek-archive-keyring.gpg] https://static.mrcyjanek.net/abstruse/apt-repository/  focal main > /etc/apt/sources.list.d/cyjan.list' 
sudo apt update

3) Installer
Ils ont encore oublié sudo

sudo apt install waydroid
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  libgbinder libglibutil python3-gbinder
Les NOUVEAUX paquets suivants seront installés :
  libgbinder libglibutil python3-gbinder waydroid
0 mis à jour, 4 nouvellement installés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de prendre 364 ko dans les archives.
Après cette opération, 893 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 [url]https://static.mrcyjanek.net/abstruse/apt-repository[/url] focal/main all libglibutil amd64 1.0.55ubuntu1 [24,4 kB]
Réception de :2 [url]https://static.mrcyjanek.net/abstruse/apt-repository[/url] focal/main all libgbinder amd64 1.1.9ubuntu1 [49,2 kB]
Réception de :3 [url]https://static.mrcyjanek.net/abstruse/apt-repository[/url] focal/main all python3-gbinder amd64 0.0.0+git.202109051230 [69,3 kB]
Réception de :4 [url]https://static.mrcyjanek.net/abstruse/apt-repository[/url] focal/main all waydroid all 1.0.0ubuntu1 [222 kB]
364 ko réceptionnés en 4s (83,3 ko/s)
Sélection du paquet libglibutil précédemment désélectionné.
(Lecture de la base de données... 189818 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libglibutil_1.0.55ubuntu1_amd64.deb ...
Dépaquetage de libglibutil (1.0.55ubuntu1) ...
Sélection du paquet libgbinder précédemment désélectionné.
Préparation du dépaquetage de .../libgbinder_1.1.9ubuntu1_amd64.deb ...
Dépaquetage de libgbinder (1.1.9ubuntu1) ...
Sélection du paquet python3-gbinder précédemment désélectionné.
Préparation du dépaquetage de .../python3-gbinder_0.0.0+git.202109051230_amd64.deb ...
Dépaquetage de python3-gbinder (0.0.0+git.202109051230) ...
Sélection du paquet waydroid précédemment désélectionné.
Préparation du dépaquetage de .../waydroid_1.0.0ubuntu1_all.deb ...
Dépaquetage de waydroid (1.0.0ubuntu1) ...
Paramétrage de libglibutil (1.0.55ubuntu1) ...
Paramétrage de libgbinder (1.1.9ubuntu1) ...
Paramétrage de python3-gbinder (0.0.0+git.202109051230) ...
Paramétrage de waydroid (1.0.0ubuntu1) ...
ERROR: WayDroid is not initialized, run "waydroid init"
Created symlink /etc/systemd/system/multi-user.target.wants/waydroid-container.service → /lib/systemd/system/waydroid-container.serv
ice.
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9.2) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) ...
 

4) Initialiser. Séquence très longue qui télécharge tout le logiciel.

sudo waydroid init
[19:29:20] Download https://sourceforge.net/projects/waydroid/files/images/system/lineage/waydroid_x86_64/lineage-17.1-20210909-VANILLA-waydroid_x86_64-system.zip/download
[19:39:12] Validating system image
[19:39:19] Extracting to /var/lib/waydroid/images
[19:39:50] Download https://sourceforge.net/projects/waydroid/files/images/vendor/waydroid_x86_64/lineage-17.1-20210909-MAINLINE-waydroid_x86_64-vendor.zip/download
[19:41:03] Validating vendor image
[19:41:04] Extracting to /var/lib/waydroid/images

5) Mettons en route

sudo systemctl start waydroid-container

et vérifions

sudo systemctl status waydroid-container
● waydroid-container.service - Waydroid Container
     Loaded: loaded (/lib/systemd/system/waydroid-container.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2021-09-10 19:43:00 CEST; 3min 45s ago
   Main PID: 3039 (waydroid)
      Tasks: 2 (limit: 4647)
     Memory: 15.4M
     CGroup: /system.slice/waydroid-container.service
             └─3039 /usr/bin/python3 /usr/bin/waydroid container start

6) Il ne reste plus qu'à installer ton application

waydroid app install xyz.apk

Pas de chance car la réponse est surprenante

a@a:~$ waydroid app install xyz.apk
[19:48:32] WayDroid session is stopped
a@a:~$ 

7) Est-on en session wayland?

echo $XDG_SESSION_TYPE 
x11

Dernière modification par geole (Le 11/09/2021, à 10:17)

Hors ligne

#18 Le 11/09/2021, à 07:45

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

SUITE
1) Quelle version

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=21.04
DISTRIB_CODENAME=hirsute
DISTRIB_DESCRIPTION="Ubuntu 21.04"

2 ) Préréquis

sudo apt install lxc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets supplémentaires suivants seront installés : 
  bridge-utils liblxc-common liblxc1 libpam-cgfs lxc-utils lxcfs uidmap
Paquets suggérés :
  ifupdown btrfs-tools lxc-templates lxctl
Les NOUVEAUX paquets suivants seront installés :
  bridge-utils liblxc-common liblxc1 libpam-cgfs lxc lxc-utils lxcfs uidmap
0 mis à jour, 8 nouvellement installés, 0 à enlever et 56 non mis à jour.
Il est nécessaire de prendre 2694 ko dans les archives.
Après cette opération, 22,2 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://fr.archive.ubuntu.com/ubuntu hirsute/universe amd64 lxcfs amd64 4.0.7-0ubuntu1 [66,2 kB]
Réception de :2 http://fr.archive.ubuntu.com/ubuntu hirsute/main amd64 bridge-utils amd64 1.6-5ubuntu1 [32,6 kB]
Réception de :3 http://fr.archive.ubuntu.com/ubuntu hirsute/universe amd64 liblxc1 amd64 1:4.0.6-0ubuntu1 [293 kB]
Réception de :4 http://fr.archive.ubuntu.com/ubuntu hirsute/universe amd64 liblxc-common amd64 1:4.0.6-0ubuntu1 [690 kB]
Réception de :5 http://fr.archive.ubuntu.com/ubuntu hirsute/universe amd64 libpam-cgfs amd64 1:4.0.6-0ubuntu1 [31,3 kB]
Réception de :6 http://fr.archive.ubuntu.com/ubuntu hirsute/universe amd64 lxc-utils amd64 1:4.0.6-0ubuntu1 [1560 kB]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu hirsute/universe amd64 lxc all 1:4.0.6-0ubuntu1 [2960 B]
Réception de :8 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 uidmap amd64 1:4.8.1-1ubuntu8.1 [18,6 kB]
2694 ko réceptionnés en 3s (1020 ko/s)
Sélection du paquet lxcfs précédemment désélectionné.
(Lecture de la base de données... 191981 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-lxcfs_4.0.7-0ubuntu1_amd64.deb ...
Dépaquetage de lxcfs (4.0.7-0ubuntu1) ...
Sélection du paquet bridge-utils précédemment désélectionné.
Préparation du dépaquetage de .../1-bridge-utils_1.6-5ubuntu1_amd64.deb ...
Dépaquetage de bridge-utils (1.6-5ubuntu1) ...
Sélection du paquet liblxc1 précédemment désélectionné.
Préparation du dépaquetage de .../2-liblxc1_1%3a4.0.6-0ubuntu1_amd64.deb ...
Dépaquetage de liblxc1 (1:4.0.6-0ubuntu1) ...
Sélection du paquet liblxc-common précédemment désélectionné.
Préparation du dépaquetage de .../3-liblxc-common_1%3a4.0.6-0ubuntu1_amd64.deb ...
Dépaquetage de liblxc-common (1:4.0.6-0ubuntu1) ...
Sélection du paquet libpam-cgfs précédemment désélectionné.
Préparation du dépaquetage de .../4-libpam-cgfs_1%3a4.0.6-0ubuntu1_amd64.deb ...
Dépaquetage de libpam-cgfs (1:4.0.6-0ubuntu1) ...
Sélection du paquet lxc-utils précédemment désélectionné.
Préparation du dépaquetage de .../5-lxc-utils_1%3a4.0.6-0ubuntu1_amd64.deb ...
Dépaquetage de lxc-utils (1:4.0.6-0ubuntu1) ...
Sélection du paquet lxc précédemment désélectionné.
Préparation du dépaquetage de .../6-lxc_1%3a4.0.6-0ubuntu1_all.deb ...
Dépaquetage de lxc (1:4.0.6-0ubuntu1) ...
Sélection du paquet uidmap précédemment désélectionné.
Préparation du dépaquetage de .../7-uidmap_1%3a4.8.1-1ubuntu8.1_amd64.deb ...
Dépaquetage de uidmap (1:4.8.1-1ubuntu8.1) ...
Paramétrage de libpam-cgfs (1:4.0.6-0ubuntu1) ...
Paramétrage de lxcfs (4.0.7-0ubuntu1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/lxcfs.service → /lib/systemd/system/lxcfs.service.
Paramétrage de uidmap (1:4.8.1-1ubuntu8.1) ...
Paramétrage de bridge-utils (1.6-5ubuntu1) ...
Paramétrage de liblxc1 (1:4.0.6-0ubuntu1) ...
Paramétrage de lxc-utils (1:4.0.6-0ubuntu1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/lxc-net.service → /lib/systemd/system/lxc-net.service.
Created symlink /etc/systemd/system/multi-user.target.wants/lxc.service → /lib/systemd/system/lxc.service.
Setting up lxc dnsmasq configuration.
Paramétrage de lxc (1:4.0.6-0ubuntu1) ...
Paramétrage de liblxc-common (1:4.0.6-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.4-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.33-0ubuntu5) .

.
3) Faire connaître

wget https://waydroid.ubuntu-web.org/waydroid.key && sudo apt-key add waydroid.key && rm -f waydroid.key && echo 'deb https://waydroid.ubuntu-web.org/waydroid unstable main' | sudo tee /etc/apt/sources.list.d/waydroid.list && sudo apt-get update
--2021-09-11 08:26:53--  https://waydroid.ubuntu-web.org/waydroid.key
Résolution de waydroid.ubuntu-web.org (waydroid.ubuntu-web.org)… 139.59.7.112
Connexion à waydroid.ubuntu-web.org (waydroid.ubuntu-web.org)|139.59.7.112|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 2419 (2,4K) [application/x-iwork-keynote-sffkey]
Enregistre : ‘waydroid.key’

waydroid.key                       100%[================================================================>]   2,36K  --.-KB/s    ds 0s      

2021-09-11 08:26:54 (12,4 MB/s) - ‘waydroid.key’ enregistré [2419/2419]

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
OK
deb https://waydroid.ubuntu-web.org/waydroid unstable main
Atteint :1 http://fr.archive.ubuntu.com/ubuntu hirsute InRelease
Réception de :2 http://fr.archive.ubuntu.com/ubuntu hirsute-updates InRelease [115 kB]                         
Atteint :3 http://security.ubuntu.com/ubuntu hirsute-security InRelease                                                     
Réception de :4 http://fr.archive.ubuntu.com/ubuntu hirsute-backports InRelease [101 kB]                                   
Réception de :5 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/main i386 Packages [188 kB]
Réception de :6 https://waydroid.ubuntu-web.org/waydroid unstable InRelease [2321 B]
Réception de :7 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/main amd64 Packages [356 kB]
Réception de :8 https://waydroid.ubuntu-web.org/waydroid unstable/main amd64 Packages [1502 B]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/main amd64 DEP-11 Metadata [93,8 kB]
Réception de :10 https://waydroid.ubuntu-web.org/waydroid unstable/main i386 Packages [416 B]         
Réception de :11 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/restricted amd64 Packages [174 kB]
Réception de :12 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/restricted i386 Packages [19,7 kB]
Réception de :13 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/universe i386 Packages [232 kB]
Réception de :14 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 Packages [288 kB]
Réception de :15 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 DEP-11 Metadata [55,2 kB]
Réception de :16 http://fr.archive.ubuntu.com/ubuntu hirsute-updates/multiverse amd64 DEP-11 Metadata [944 B]
Réception de :17 http://fr.archive.ubuntu.com/ubuntu hirsute-backports/universe amd64 DEP-11 Metadata [9348 B]
1637 ko réceptionnés en 2s (744 ko/s)            
Lecture des listes de paquets... Fait

Puis

 rm -f waydroid.key && echo 'deb https://waydroid.ubuntu-web.org/waydroid unstable main' | sudo tee /etc/apt/sources.list.d/waydroid.list && sudo apt-get update
deb https://waydroid.ubuntu-web.org/waydroid unstable main
Atteint :1 http://fr.archive.ubuntu.com/ubuntu hirsute InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu hirsute-updates InRelease                                       
Atteint :3 http://fr.archive.ubuntu.com/ubuntu hirsute-backports InRelease                                                  
Atteint :4 http://security.ubuntu.com/ubuntu hirsute-security InRelease                                                     
Atteint :5 https://waydroid.ubuntu-web.org/waydroid unstable InRelease                    
Lecture des listes de paquets... Fait

4) Installation

sudo apt install waydroid
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets supplémentaires suivants seront installés : 
  libgbinder libglibutil python3-gbinder
Les NOUVEAUX paquets suivants seront installés :
  libgbinder libglibutil python3-gbinder waydroid
0 mis à jour, 4 nouvellement installés, 0 à enlever et 49 non mis à jour.
Il est nécessaire de prendre 348 ko dans les archives.
Après cette opération, 836 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 https://waydroid.ubuntu-web.org/waydroid unstable/main amd64 libglibutil amd64 1.0.55-0ubuntu1 [23,9 kB]
Réception de :2 https://waydroid.ubuntu-web.org/waydroid unstable/main amd64 libgbinder amd64 1.1.9-0ubuntu1 [48,5 kB]
Réception de :3 https://waydroid.ubuntu-web.org/waydroid unstable/main amd64 python3-gbinder amd64 0.0.0+git.20210906T121300Z [54,7 kB]
Réception de :4 https://waydroid.ubuntu-web.org/waydroid unstable/main amd64 waydroid all 1.0.0-0git1 [221 kB]
348 ko réceptionnés en 2s (184 ko/s) 
Sélection du paquet libglibutil précédemment désélectionné.
(Lecture de la base de données... 192266 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libglibutil_1.0.55-0ubuntu1_amd64.deb ...
Dépaquetage de libglibutil (1.0.55-0ubuntu1) ...
Sélection du paquet libgbinder précédemment désélectionné.
Préparation du dépaquetage de .../libgbinder_1.1.9-0ubuntu1_amd64.deb ...
Dépaquetage de libgbinder (1.1.9-0ubuntu1) ...
Sélection du paquet python3-gbinder précédemment désélectionné.
Préparation du dépaquetage de .../python3-gbinder_0.0.0+git.20210906T121300Z_amd64.deb ...
Dépaquetage de python3-gbinder (0.0.0+git.20210906T121300Z) ...
Sélection du paquet waydroid précédemment désélectionné.
Préparation du dépaquetage de .../waydroid_1.0.0-0git1_all.deb ...
Dépaquetage de waydroid (1.0.0-0git1) ...
Paramétrage de libglibutil (1.0.55-0ubuntu1) ...
Paramétrage de libgbinder (1.1.9-0ubuntu1) ...
Paramétrage de python3-gbinder (0.0.0+git.20210906T121300Z) ...
Paramétrage de waydroid (1.0.0-0git1) ...
ERROR: WayDroid is not initialized, run "waydroid init"
Created symlink /etc/systemd/system/multi-user.target.wants/waydroid-container.service → /lib/systemd/system/waydroid-container.service.
Traitement des actions différées (« triggers ») pour libc-bin (2.33-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour mailcap (3.68ubuntu1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1ubuntu1) ...
Traitement 

5) initialisation

[08:46:27] Download https://sourceforge.net/projects/waydroid/files/images/system/lineage/waydroid_x86_64/lineage-17.1-20210909-VANILLA-waydroid_x86_64-system.zip/download
[08:56:18] Validating system image
[08:56:20] Extracting to /var/lib/waydroid/images
[08:56:37] Download https://sourceforge.net/projects/waydroid/files/images/vendor/waydroid_x86_64/lineage-17.1-20210909-MAINLINE-waydroid_x86_64-vendor.zip/download
[08:57:57] Validating vendor image
[08:57:57] Extracting to /var/lib/waydroid/images
 

6) Mise en route

sudo systemctl start waydroid-container

et contrôle

sudo systemctl status waydroid-container
● waydroid-container.service - Waydroid Container
     Loaded: loaded (/lib/systemd/system/waydroid-container.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-09-11 09:06:45 CEST; 1min 30s ago
   Main PID: 8637 (waydroid)
      Tasks: 2 (limit: 6907)
     Memory: 16.7M
     CGroup: /system.slice/waydroid-container.service
             └─8637 /usr/bin/python3 /usr/bin/waydroid container start

sept. 11 09:06:46 a sudo[8642]: pam_unix(sudo:session): session closed for user root
sept. 11 09:06:46 a sudo[8647]:     root : PWD=/ ; USER=root ; COMMAND=/usr/bin/chmod 666 -R /dev/anbox-binder
sept. 11 09:06:46 a sudo[8647]: pam_unix(sudo:session): session opened for user root by (uid=0)
sept. 11 09:06:46 a sudo[8647]: pam_unix(sudo:session): session closed for user root
sept. 11 09:06:46 a sudo[8649]:     root : PWD=/ ; USER=root ; COMMAND=/usr/bin/chmod 666 -R /dev/anbox-vndbinder
sept. 11 09:06:46 a sudo[8649]: pam_unix(sudo:session): session opened for user root by (uid=0)
sept. 11 09:06:46 a sudo[8649]: pam_unix(sudo:session): session closed for user root
sept. 11 09:06:46 a sudo[8651]:     root : PWD=/ ; USER=root ; COMMAND=/usr/bin/chmod 666 -R /dev/anbox-hwbinder
sept. 11 09:06:46 a sudo[8651]: pam_unix(sudo:session): session opened for user root by (uid=0)
sept. 11 09:06:46 a sudo[8651]: pam_unix(sudo:session): session closed for user root
a@a:~$

7) Installation du logiciel

a@a:~$ waydroid app install xyz.apk
[09:10:56] WayDroid session is stopped

8) Est-on en session wayland?

a@a:~/Téléchargements$ echo $XDG_SESSION_TYPE 
wayland
a@a:~/Téléchargements$

9) extraits de la trace

(008637) [11:19:51] New background process: pid=9528, output=background
lxc-start: waydroid: utils.c: open_devnull: 1338 No such file or directory - Can't open /dev/null
(008637) [11:19:52] Save session config: /var/lib/waydroid/session.cfg
(009436) [11:19:52] Failed to start Clipboard manager service, check logs
(009436) [11:20:39] Clipboard service is not even started

10) vu dans internet https://opensource.com/article/19/10/li … d-managers
à définir une extension firefox

Dernière modification par geole (Le 11/09/2021, à 10:35)

Hors ligne

#19 Le 11/09/2021, à 10:47

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Merci.
Je n'avais pas encore lu ton dernier message et j'ai essayé de lancer Anbox malgré tout :

anbox session-manager

Ça m'a répondu de faire ça avant :

sudo apt install anbox

Et au moins l'icône est apparue…
Je vais voir si je peux installer l'apk…

Ce n’est pas encore OK : la fenêtre crashe

j'ai aussi installé les fonctions Android:

sudo apt install android-tools-adb

La fenêtre crashe encore…

Du coup, réessayé via le terminal :

anbox session-manager
[ 2021-09-11 10:03:54] [session_manager.cpp:133@operator()] Failed to start as either binder or ashmem kernel drivers are not loaded

J'ai fait une recherche sur le problème et cela semble sans issue :
https://github.com/anbox/anbox/issues/1886
https://github.com/anbox/anbox/issues/1889

Avant de tester les alternatives, j'aimerais nettoyer mon système : peux-tu me « trier » les infos ? Car, à force, je ne sais plus trop où j'en suis…

Dernière modification par Hada de la Luna (Le 11/09/2021, à 11:37)


Hada de la Luna :o)

Hors ligne

#20 Le 11/09/2021, à 12:47

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Bonjour
Tant que tu n'as trouvé avec quelles briques cela peut fonctionner, il me semble prématuré d'en supprimer.
Mémorise  bien ce que tu installes pour faire un point final.
Si le paquet deb fonctionne tu pourras virer le paquet snap à moins que cela soit l'inverse.

Dernière modification par geole (Le 11/09/2021, à 12:47)

Hors ligne

#21 Le 11/09/2021, à 12:51

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Rien ne fonctionne : pourquoi garder?


Hada de la Luna :o)

Hors ligne

#22 Le 11/09/2021, à 14:26

geole

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

J'ai récupéré quelques unes de tes installations, pour supprimer

sudo apt purge android-tools-adb
sudo apt purge anbox

et

sudo snap remove anbox

Hors ligne

#23 Le 15/09/2021, à 13:32

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Bonjour,

Merci. C'est effacé…

geole a écrit :

Autre solution: En machine virtuelle https://thedroidguy.com/best-android-em … ux-1087692

En résumé, sur 20.04LTS:

  • Anbox ne fonctionne pas

  • Andro VM n'est plus en téléchargement

  • Android-x86 nécessite VMware ou équivalent

  • Andy OS ou Andyroid ne fonctionne que sur Windows ou Mac

  • Android SDK serait très gros

  • GenyMotion nécessite VirtualBox

  • waydroid ne fonctionne pas

  • Jar of Beans est «DISCONTINUED» selon son créateur

Je vais commencer par GenyMotion qui est plus petit et demande 400 Mo, car Android-x86 demande 4Go et si aucun ne vas je passerais à Android SDK car il me semble difficile à utiliser pour mon objectif…

Dernière modification par Hada de la Luna (Le 15/09/2021, à 17:20)


Hada de la Luna :o)

Hors ligne

#24 Le 15/09/2021, à 22:22

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

VirtualBox est directement installable depuis la bibliothèque de logiciels

Installation de Genymotion :

dmesg | grep -i vboxdrv
[ 1804.692634] vboxdrv: loading out-of-tree module taints kernel.
[ 1804.693013] vboxdrv: module verification failed: signature and/or required key missing - tainting kernel
[ 1804.703044] vboxdrv: Found 2 processor cores
[ 1804.704795] vboxdrv: fAsync=0 offMin=0x1c2 offMax=0x12cf
[ 1804.805082] vboxdrv: TSC mode is Synchronous, tentative frequency 2400100618 Hz
[ 1804.805084] vboxdrv: Successfully loaded version 6.1.26_Ubuntu r145957 (interface 0x00300000)
hada@hada-ThinkPad-X200:~$ ls
Bureau  Documents  hp-check.log  Images  MindMap  Modèles  Musique  OpenClassRooms-DevWeb  Public  snap  Téléchargements  Vidéos
hada@hada-ThinkPad-X200:~$ cd Téléchargements
hada@hada-ThinkPad-X200:~/Téléchargements$ chmod +x genymotion-3.2.1-linux_x64.bin 
hada@hada-ThinkPad-X200:~/Téléchargements$ ./genymotion-3.X.X-linux_x64.bin -d {Genymotion_install_path}
bash: ./genymotion-3.X.X-linux_x64.bin: Aucun fichier ou dossier de ce type
hada@hada-ThinkPad-X200:~/Téléchargements$ ./genymotion-3.2.1-linux_x64.bin -d {Genymotion_install_path}
Installing for current user only. To install for all users, restart this installer as root.

Installing to folder [/media/data/Téléchargements/{Genymotion_install_path}/genymotion]. Are you sure [y/n] ? y


- Trying to find VirtualBox toolset .................... OK (Valid version of VirtualBox found: 6.1.26_Ubuntur145957)
- Extracting files ..................................... OK (Extract into: [/media/data/Téléchargements/{Genymotion_install_path}/genymotion])
- Installing launcher icon ............................. OK

Installation done successfully.

You can now use these tools from [/media/data/Téléchargements/{Genymotion_install_path}/genymotion]:
 - genymotion
 - genymotion-shell
 - gmtool

Ayant validé  l'installation de genymotion par la création d'un compte « usage personnel » sur leur site, j'ai constaté que c'est limité à une unique installation, or je vais avoir besoin de 3 sur PC.

Je passe donc directement à l'essai d’Android-x86 et ne reviendrai sur genymotion que si pas le choix

Dernière modification par Hada de la Luna (Le 16/09/2021, à 21:05)


Hada de la Luna :o)

Hors ligne

#25 Le 18/09/2021, à 13:24

Hada de la Luna

Re : 20.04LTS : Ava Sourd et malentendant est il installable et utilisable?

Bonjour,

pour Android-x86, je suis le tuto suivant : Tuto Android-x86 dans VirtualBox en français.

Après questions auprès de la communauté LibreBoot, il semble que «les options de virtualisation sont activées dans le BIOS» nativement.

Bouton «Nouvelle»
Nom : Android
Dossier de la machine : /media/data/Android
Type : Linux
Version: Linux 2.6 / 3.x / 4.x (64-bit) car j'ai téléchargé l'iso «android-x86_64-8.1-r6.iso»
Suivant
taille de la mémoire : 2048MB
Suivant
Créer un disque virtuel maintenant
Créer
VDI (VirtualBox Disk Image
Suivant
Dynamiquement Allouée
Suivant
8 Go
Créer
Capture-d-cran-de-2021-09-18-14-16-44.png

Capture-d-cran-de-2021-09-18-14-20-11.png

Capture-d-cran-de-2021-09-18-14-20-51.png

Capture-d-cran-de-2021-09-18-14-21-09.png

Capture-d-cran-de-2021-09-18-14-21-36.png

Que faire ?


Hada de la Luna :o)

Hors ligne