Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/09/2021, à 18:30

Max_123

[Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Bonjour à tous,

Info système :
Ubuntu 18.04.5

Je me tourne vers le forum après de nombreux essai en vain.

J'essayer d'utiliser valgrind et je suis tombé sur l'erreur disant qu'il me manquait le paquet libc6-dbg

J'ai donc essayer de l'installer et j'ai obtenu :

$ sudo apt install -y libc6-dbg
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc6 : Casse: libc6:i386 (!= 2.27-3ubuntu1) mais 2.27-3ubuntu1.4 devra être installé
 libc6:i386 : Casse: libc6 (!= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 devra être installé
 libc6-dev : Dépend: libc6 (= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

J'ai donc essayé la solution proposé :

$ sudo apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc6 : Casse: libc6:i386 (!= 2.27-3ubuntu1) mais 2.27-3ubuntu1.4 est installé
 libc6:i386 : Casse: libc6 (!= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 est installé
 libc6-dev : Dépend: libc6 (= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 est installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances

J'ai essayé d'update et d'upgrade cela n'a rien résolu :

$ sudo apt-get update
Ign :1 http://oem.archive.canonical.com/updates bionic-oem InRelease
Atteint :2 http://archive.ubuntu.com/ubuntu trusty-security InRelease                               
Atteint :3 http://oem.archive.canonical.com/updates bionic-oem Release                              
Atteint :4 http://dl.google.com/linux/chrome/deb stable InRelease                                   
Atteint :5 http://archive.ubuntu.com/ubuntu trusty-updates InRelease                                
Atteint :6 http://archive.ubuntu.com/ubuntu trusty-proposed InRelease                               
Atteint :7 https://repo.steampowered.com/steam stable InRelease                                     
Atteint :8 https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/ InRelease                    
Atteint :9 http://archive.ubuntu.com/ubuntu trusty-backports InRelease                              
Atteint :10 http://archive.ubuntu.com/ubuntu bionic InRelease                                    
Ign :11 http://dell.archive.canonical.com/updates bionic-dell-beaver-osp1-bowen InRelease
Ign :12 http://dell.archive.canonical.com/updates bionic-dell-service InRelease
Atteint :13 http://dell.archive.canonical.com/updates bionic-dell InRelease
Atteint :14 http://dell.archive.canonical.com/updates bionic-dell-beaver-osp1-bowen Release
Atteint :15 http://dell.archive.canonical.com/updates bionic-dell-service Release
Lecture des listes de paquets... Fait
$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc6 : Casse: libc6:i386 (!= 2.27-3ubuntu1) mais 2.27-3ubuntu1.4 est installé
 libc6:i386 : Casse: libc6 (!= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 est installé
 libc6-dev : Dépend: libc6 (= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 est installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
$ cat /etc/apt/sources.list
deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/
deb http://archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic main universe

J'ai essayé d'installer d'autres paquets mais le même problème survient toujours.

Quand je clique sur l'application gestionnaire de paquets j'ai l'erreur suivante :

Un problème irrémédiable est survenu durant l'initialisation des informations du paquet.

Veuillez signaler ce bogue du paquet « update-manager » en y joignant le message d'erreur suivant :
E:Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Je n'ai vraiment pas d'idée

Merci d'avance pour votre aide

Cordialement

Dernière modification par Max_123 (Le 21/09/2021, à 22:51)

Hors ligne

#2 Le 21/09/2021, à 18:41

cqfd93

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Bonjour,

Avec des dépôts trusty (version obsolète), normal que tu aies des problèmes.

Pour faire un tour d'horizon de ton système donne les retours complets suivants :

  • version d'Ubuntu

    cat /etc/issue
    uname -a
    echo "${XDG_CURRENT_DESKTOP}"
  • Sources de logiciels

    find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

Un retour complet doit contenir toutes les lignes depuis celle de la commande jusqu'à la ligne attendant la commande suivante, exemple :

moi@lenovo:~$ uname -a
Linux moi-lenovo 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
moi@lenovo:~$

Astuce pour copier / coller sans erreur :

  • triple clic gauche pour sélectionner et copier une ligne entière

  • clic molette pour coller dans le terminal


cqfd93

Hors ligne

#3 Le 21/09/2021, à 18:48

Max_123

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Merci

Alors dans l'ordre :

$ cat /etc/issue
Ubuntu 18.04.5 LTS \n \l

$ uname -a
Linux moi-Precision-3551 5.4.0-70-generic #78~18.04.1-Ubuntu SMP Sat Mar 20 14:10:07 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
$ echo "${XDG_CURRENT_DESKTOP}"
ubuntu:GNOME
$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list

     1	deb https://cloud.r-project.org/bin/linux/ubuntu bionic-cran35/
     2	deb http://archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
     3	deb http://archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
     4	deb http://archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
     5	deb http://archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
     6	deb http://archive.ubuntu.com/ubuntu bionic main universe

/etc/apt/sources.list.d/bionic-oem.list

     1	deb http://oem.archive.canonical.com/updates/ bionic-oem public
     2	# deb-src http://oem.archive.canonical.com/updates/ bionic-oem public

/etc/apt/sources.list.d/nathan-renniewaldock-ubuntu-flux-bionic.list


/etc/apt/sources.list.d/bionic-dell.list

     1	deb http://dell.archive.canonical.com/updates/ bionic-dell public
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell public

/etc/apt/sources.list.d/bionic-dell-beaver-osp1-bowen.list

     1	deb http://dell.archive.canonical.com/updates/ bionic-dell-beaver-osp1-bowen public
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell-beaver-osp1-bowen public

/etc/apt/sources.list.d/steam.list

     1	deb [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
     2	deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
     3	
     4	# Uncomment these lines to try the beta version of the Steam launcher
     5	#deb [arch=amd64,i386] https://repo.steampowered.com/steam/ beta steam
     6	#deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ beta steam

/etc/apt/sources.list.d/bionic-dell-service.list

     1	deb http://dell.archive.canonical.com/updates/ bionic-dell-service public
     2	# deb-src http://dell.archive.canonical.com/updates/ bionic-dell-service public

/etc/apt/sources.list.d/google-chrome.list

     1	### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2	# You may comment out this entry, but any other modifications may be lost.
     3	deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Hors ligne

#4 Le 21/09/2021, à 18:58

cqfd93

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Bon tous ces dépôts trusty n'ont plus rien à faire dans sources.list. On va tout remplacer par le strict nécessaire.
Copie tout le bloc qui suit et colle-le en une seule fois dans le terminal (termine avec Entrée) :

sudo tee /etc/apt/sources.list <<EOF

deb http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse 

deb http://fr.archive.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse 
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse 
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse 

deb http://archive.canonical.com/ubuntu bionic partner
EOF

Ensuite, fais les mises à jour (donne les retours complets) :

sudo apt update
sudo apt full-upgrade

cqfd93

Hors ligne

#5 Le 21/09/2021, à 19:08

Max_123

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Voila
J'ai aussi lancé apt --fix-broken à la fin. Il y a une petite erreur à la fin je crois

$ cat /etc/apt/sources.list

deb http://fr.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse 

deb http://fr.archive.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse 
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse 
deb http://fr.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse 

deb http://archive.canonical.com/ubuntu bionic partner

$ sudo apt update
Réception de :1 http://fr.archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
Ign :2 http://dell.archive.canonical.com/updates bionic-dell-beaver-osp1-bowen InRelease                        
Réception de :3 http://archive.canonical.com/ubuntu bionic InRelease [10,2 kB]                                  
Ign :4 http://dell.archive.canonical.com/updates bionic-dell-service InRelease                                  
Ign :5 http://oem.archive.canonical.com/updates bionic-oem InRelease                                            
Atteint :6 http://dl.google.com/linux/chrome/deb stable InRelease                                               
Atteint :7 http://dell.archive.canonical.com/updates bionic-dell InRelease                                      
Atteint :8 http://oem.archive.canonical.com/updates bionic-oem Release                                          
Atteint :9 http://dell.archive.canonical.com/updates bionic-dell-beaver-osp1-bowen Release                      
Atteint :10 https://repo.steampowered.com/steam stable InRelease                                 
Réception de :11 http://fr.archive.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]         
Atteint :12 http://dell.archive.canonical.com/updates bionic-dell-service Release                 
Réception de :13 http://fr.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]            
Réception de :14 http://archive.canonical.com/ubuntu bionic/partner i386 Packages [1588 B]          
Réception de :15 http://fr.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]                       
Réception de :16 http://archive.canonical.com/ubuntu bionic/partner amd64 Packages [1592 B]        
Réception de :17 http://archive.canonical.com/ubuntu bionic/partner Translation-en [1004 B]
Réception de :19 http://fr.archive.ubuntu.com/ubuntu bionic/main i386 Packages [1007 kB]      
Réception de :21 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 Packages [1019 kB]
Réception de :23 http://fr.archive.ubuntu.com/ubuntu bionic/main Translation-fr [513 kB]     
Réception de :24 http://fr.archive.ubuntu.com/ubuntu bionic/main Translation-en [516 kB]      
Réception de :25 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 DEP-11 Metadata [477 kB]
Réception de :26 http://fr.archive.ubuntu.com/ubuntu bionic/main DEP-11 48x48 Icons [118 kB]
Réception de :27 http://fr.archive.ubuntu.com/ubuntu bionic/main DEP-11 64x64 Icons [245 kB]
Réception de :28 http://fr.archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages [9184 B]
Réception de :29 http://fr.archive.ubuntu.com/ubuntu bionic/restricted i386 Packages [9156 B]
Réception de :30 http://fr.archive.ubuntu.com/ubuntu bionic/restricted Translation-en [3584 B]
Réception de :31 http://fr.archive.ubuntu.com/ubuntu bionic/restricted Translation-fr [2380 B]
Réception de :32 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages [8570 kB]
Réception de :33 http://fr.archive.ubuntu.com/ubuntu bionic/universe i386 Packages [8531 kB]
Réception de :34 http://fr.archive.ubuntu.com/ubuntu bionic/universe Translation-fr [2972 kB]
Réception de :35 http://fr.archive.ubuntu.com/ubuntu bionic/universe Translation-en [4941 kB]
Réception de :36 http://fr.archive.ubuntu.com/ubuntu bionic/universe amd64 DEP-11 Metadata [3287 kB]
Réception de :37 http://fr.archive.ubuntu.com/ubuntu bionic/universe DEP-11 48x48 Icons [2151 kB]
Réception de :38 http://fr.archive.ubuntu.com/ubuntu bionic/universe DEP-11 64x64 Icons [8420 kB]
Réception de :39 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages [151 kB]
Réception de :40 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse i386 Packages [144 kB]
Réception de :41 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse Translation-en [108 kB]
Réception de :42 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse Translation-fr [109 kB]
Réception de :43 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse amd64 DEP-11 Metadata [49,7 kB]
Réception de :44 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse DEP-11 48x48 Icons [8931 B]
Réception de :45 http://fr.archive.ubuntu.com/ubuntu bionic/multiverse DEP-11 64x64 Icons [225 kB]
Réception de :46 http://fr.archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages [1871 kB]
Réception de :47 http://fr.archive.ubuntu.com/ubuntu bionic-security/main i386 Packages [1040 kB]
Réception de :48 http://fr.archive.ubuntu.com/ubuntu bionic-security/main Translation-en [341 kB]
Réception de :49 http://fr.archive.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [51,3 kB]
Réception de :50 http://fr.archive.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [28,4 kB]
Réception de :51 http://fr.archive.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [67,5 kB]
Réception de :52 http://fr.archive.ubuntu.com/ubuntu bionic-security/restricted i386 Packages [22,0 kB]
Réception de :53 http://fr.archive.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [438 kB]
Réception de :54 http://fr.archive.ubuntu.com/ubuntu bionic-security/restricted Translation-en [58,8 kB]
Réception de :55 http://fr.archive.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [1138 kB]
Réception de :56 http://fr.archive.ubuntu.com/ubuntu bionic-security/universe i386 Packages [987 kB]
Réception de :57 http://fr.archive.ubuntu.com/ubuntu bionic-security/universe Translation-en [259 kB]
Réception de :58 http://fr.archive.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [57,9 kB]   
Réception de :59 http://fr.archive.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [25,0 kB]      
Réception de :60 http://fr.archive.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [132 kB]       
Réception de :61 http://fr.archive.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [20,9 kB]        
Réception de :62 http://fr.archive.ubuntu.com/ubuntu bionic-security/multiverse i386 Packages [6480 B]         
Réception de :63 http://fr.archive.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [4732 B]        
Réception de :64 http://fr.archive.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2464 B] 
Réception de :65 http://fr.archive.ubuntu.com/ubuntu bionic-security/multiverse DEP-11 48x48 Icons [29 B]       
Réception de :66 http://fr.archive.ubuntu.com/ubuntu bionic-security/multiverse DEP-11 64x64 Icons [2638 B]    
Réception de :67 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [2217 kB]              
Réception de :68 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [1345 kB]               
Réception de :69 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [433 kB]                
Réception de :70 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [293 kB]         
Réception de :71 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [82,0 kB]           
Réception de :72 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [157 kB]            
Réception de :73 http://fr.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages [462 kB]          
Réception de :74 http://fr.archive.ubuntu.com/ubuntu bionic-updates/restricted i386 Packages [28,6 kB]          
Réception de :75 http://fr.archive.ubuntu.com/ubuntu bionic-updates/restricted Translation-en [62,5 kB]         
Réception de :76 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1749 kB]          
Réception de :77 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [1575 kB]           
Réception de :78 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [375 kB]            
Réception de :79 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [294 kB]     
Réception de :80 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [224 kB]        
Réception de :81 http://fr.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [502 kB]        
Réception de :82 http://fr.archive.ubuntu.com/ubuntu bionic-updates/multiverse i386 Packages [11,6 kB]          
Réception de :83 http://fr.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [27,3 kB]         
Réception de :84 http://fr.archive.ubuntu.com/ubuntu bionic-updates/multiverse Translation-en [6808 B]         
Réception de :85 http://fr.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2468 B]  
Réception de :86 http://fr.archive.ubuntu.com/ubuntu bionic-updates/multiverse DEP-11 48x48 Icons [29 B]        
Réception de :87 http://fr.archive.ubuntu.com/ubuntu bionic-updates/multiverse DEP-11 64x64 Icons [2638 B]     
Réception de :88 http://fr.archive.ubuntu.com/ubuntu bionic-backports/main amd64 Packages [10,0 kB]             
Réception de :89 http://fr.archive.ubuntu.com/ubuntu bionic-backports/main i386 Packages [10,0 kB]              
Réception de :90 http://fr.archive.ubuntu.com/ubuntu bionic-backports/main Translation-en [4764 B]             
Réception de :91 http://fr.archive.ubuntu.com/ubuntu bionic-backports/universe i386 Packages [10,3 kB]          
Réception de :92 http://fr.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 Packages [10,3 kB]         
Réception de :93 http://fr.archive.ubuntu.com/ubuntu bionic-backports/universe Translation-en [4588 B]         
Réception de :94 http://fr.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [9276 B]  
Réception de :95 http://fr.archive.ubuntu.com/ubuntu bionic-backports/universe DEP-11 48x48 Icons [2809 B]     
Réception de :96 http://fr.archive.ubuntu.com/ubuntu bionic-backports/universe DEP-11 64x64 Icons [3943 B]     
60,6 Mo réceptionnés en 11s (5681 ko/s)                                                                        
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
299 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.

$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libc6 : Casse: libc6:i386 (!= 2.27-3ubuntu1) mais 2.27-3ubuntu1.4 est installé
 libc6:i386 : Casse: libc6 (!= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 est installé
 libc6-dev : Dépend: libc6 (= 2.27-3ubuntu1.4) mais 2.27-3ubuntu1 est installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

$ sudo apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  cdbs dh-translations dmeventd intltool jq libasyncns0:i386 libdevmapper-event1.02.1 libflac8:i386
  libjack-jackd2-0:i386 libjq1 libllvm6.0:i386 liblvm2cmd2.02 libogg0:i386 libonig4 libreadline5
  libsamplerate0:i386 libspeexdsp1:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libxatracker2
  libxinerama1:i386 libxss1:i386 libxvmc1 python3-scour scour xserver-xorg-video-fbdev-hwe-18.04
  xserver-xorg-video-vesa-hwe-18.04
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libc6
Paquets suggérés :
  glibc-doc
Les paquets suivants seront mis à jour :
  libc6
1 mis à jour, 0 nouvellement installés, 0 à enlever et 298 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 2832 ko dans les archives.
Après cette opération, 8192 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
Réception de :1 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libc6 amd64 2.27-3ubuntu1.4 [2832 kB]
2832 ko réceptionnés en 0s (7493 ko/s)
Préconfiguration des paquets...
(Lecture de la base de données... 389680 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libc6_2.27-3ubuntu1.4_amd64.deb ...
Dépaquetage de libc6:amd64 (2.27-3ubuntu1.4) sur (2.27-3ubuntu1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libc6_2.27-3ubuntu1.4_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/doc/libc6/NEWS.gz », qui est différent d'autres instances du paquet libc6:amd64
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libc6_2.27-3ubuntu1.4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
$ 

Hors ligne

#6 Le 21/09/2021, à 19:17

cqfd93

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Oui, essaye ça (donne les retours) :

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.27-3ubuntu1.4_amd64.deb
sudo apt install -f

cqfd93

Hors ligne

#7 Le 21/09/2021, à 19:27

Max_123

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Et voici

$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.27-3ubuntu1.4_amd64.deb
(Lecture de la base de données... 389680 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libc6_2.27-3ubuntu1.4_amd64.deb ...
Dépaquetage de libc6:amd64 (2.27-3ubuntu1.4) sur (2.27-3ubuntu1) ...
dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: tentative de remplacement de « /usr/share/doc/libc6/NEWS.gz », qui est différent d'autres instances du paquet libc6:amd64
dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: tentative de remplacement de « /usr/share/doc/libc6/changelog.Debian.gz », qui est différent d'autres instances du paquet libc6:amd64
Paramétrage de libc6:amd64 (2.27-3ubuntu1.4) ...

$ sudo apt install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  cdbs dh-translations dmeventd intltool jq libasyncns0:i386 libdevmapper-event1.02.1 libflac8:i386
  libjack-jackd2-0:i386 libjq1 libllvm6.0:i386 liblvm2cmd2.02 libogg0:i386 libonig4 libreadline5
  libsamplerate0:i386 libspeexdsp1:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libxatracker2
  libxinerama1:i386 libxss1:i386 libxvmc1 python3-scour scour xserver-xorg-video-fbdev-hwe-18.04
  xserver-xorg-video-vesa-hwe-18.04
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 298 non mis à jour.
2 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Paramétrage de libc-bin (2.27-3ubuntu1) ...
Paramétrage de libc6:i386 (2.27-3ubuntu1.4) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
W: APT had planned for dpkg to do more than it reported back (5 vs 9).
   Affected packages: libc6:i386

Hors ligne

#8 Le 21/09/2021, à 19:30

cqfd93

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Juste un avertissement à la fin… Finis les mises à jour :

sudo apt full-upgrade

cqfd93

Hors ligne

#9 Le 21/09/2021, à 19:42

Max_123

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Ok super ça fonctionne! Merci big_smile

Donc le pb c'était des sources listes obsolètes

Hors ligne

#10 Le 21/09/2021, à 19:44

xubu1957

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Bonjour,

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#11 Le 21/09/2021, à 19:47

cqfd93

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

J'aurais bien aimé voir le retour des mises à jour.


cqfd93

Hors ligne

#12 Le 21/09/2021, à 20:07

Max_123

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Ah oui pardon.
Alors pour les paquets cassés :

$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                                         Architecture Description
+++-==========================================-===============================================-============-===================================================================================================
rc  bolt                                       0.5-0ubuntu0.18.04.1                            amd64        system daemon to manage thunderbolt 3 devices
rc  dell-recovery-bootloader                   1.61~somerville5                                all          Bootloader configuration for Dell's factory process
rc  dmraid                                     1.0.0.rc16-8ubuntu1                             amd64        Device-Mapper Software RAID support tool
rc  fluxgui                                    1:1.2.0~pre~20190501-g0548b6f-1~bionic          all          f.lux indicator applet is an indicator applet to control xflux, an
rc  kpartx-boot                                0.7.4-2ubuntu3                                  all          Provides kpartx during boot
rc  linux-image-5.0.0-1034-oem-osp1            5.0.0-1034.39                                   amd64        Signed kernel image oem-osp1
rc  linux-image-5.0.0-1071-oem-osp1            5.0.0-1071.77                                   amd64        Signed kernel image oem-osp1
rc  linux-image-5.4.0-60-generic               5.4.0-60.67~18.04.1                             amd64        Signed kernel image generic
rc  linux-image-5.4.0-62-generic               5.4.0-62.70~18.04.1                             amd64        Signed kernel image generic
rc  linux-image-5.4.0-64-generic               5.4.0-64.72~18.04.1                             amd64        Signed kernel image generic
rc  linux-image-5.4.0-65-generic               5.4.0-65.73~18.04.1                             amd64        Signed kernel image generic
rc  linux-modules-5.0.0-1034-oem-osp1          5.0.0-1034.39                                   amd64        Linux kernel extra modules for version 5.0.0 on 64 bit x86 SMP
rc  linux-modules-5.0.0-1071-oem-osp1          5.0.0-1071.77                                   amd64        Linux kernel extra modules for version 5.0.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-60-generic             5.4.0-60.67~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-62-generic             5.4.0-62.70~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-64-generic             5.4.0-64.72~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-65-generic             5.4.0-65.73~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-60-generic       5.4.0-60.67~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-62-generic       5.4.0-62.70~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-64-generic       5.4.0-64.72~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-65-generic       5.4.0-65.73~18.04.1                             amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  locale-support-plugin                      2.1~18.04timbuktu1                              all          Ubiquity plugin to conditionally install packages based on locale.
rc  lvm2                                       2.02.176-4.1ubuntu3.18.04.3                     amd64        Linux Logical Volume Manager
rc  oem-config                                 18.04.14.12timbuktu1                            all          Perform end-user configuration after initial OEM installation
rc  oem-config-gtk                             18.04.14.12timbuktu1                            all          GTK+ frontend for end-user post-OEM-install configuration
rc  oem-workaround-ubiquity-no-early-microcode 1.0~18.04timbuktu3                              all          Workaround package to disable early intel/amd64-microcode in initrd during installer (LP: #1772592)
rc  recutils                                   1.7-2                                           amd64        text-based databases called recfiles
rc  xserver-xorg-video-intel-hwe-18.04         2:2.99.917+git20171229-1ubuntu1~18.04.1         amd64        X.Org X server -- Intel i8xx, i9xx display driver

Hors ligne

#13 Le 21/09/2021, à 20:12

Max_123

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Par contre je n'ai plus l'historique du terminal, l'upgrade était très long et j'ai lancé d'autres choses depuis. J'ai juste cela si je le relance

$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  cdbs dh-translations dmeventd intltool jq libapt-inst1.5 libapt-pkg4.12 libasyncns0:i386 libdevmapper-event1.02.1 libflac8:i386 libjack-jackd2-0:i386 libjq1
  libllvm6.0 libllvm6.0:i386 liblvm2cmd2.02 libnvidia-cfg1-450 libnvidia-common-450 libnvidia-compute-450 libnvidia-compute-450:i386 libnvidia-decode-450
  libnvidia-decode-450:i386 libnvidia-encode-450 libnvidia-encode-450:i386 libnvidia-extra-450 libnvidia-fbc1-450 libnvidia-fbc1-450:i386 libnvidia-gl-450
  libnvidia-gl-450:i386 libnvidia-ifr1-450 libnvidia-ifr1-450:i386 libogg0:i386 libonig4 libreadline5 libsamplerate0:i386 libspeexdsp1:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwrap0:i386 libxatracker2 libxinerama1:i386 libxss1:i386 libxvmc1 linux-headers-5.4.0-67-generic linux-hwe-5.4-headers-5.4.0-67
  linux-image-5.4.0-67-generic linux-modules-5.4.0-67-generic linux-modules-extra-5.4.0-67-generic nvidia-compute-utils-450 nvidia-dkms-450 nvidia-kernel-common-450
  nvidia-kernel-source-450 nvidia-utils-450 shim xserver-xorg-video-fbdev-hwe-18.04 xserver-xorg-video-nvidia-450 xserver-xorg-video-vesa-hwe-18.04
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Hors ligne

#14 Le 21/09/2021, à 20:29

xubu1957

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Pour nettoyer :

Le 11/02/2017, moko138 a écrit :

Pour supprimer tous ces fichiers de configuration devenus sans objets et marqués "rc", et uniquement ces fichiers, exécute :

dpkg -l | awk '/^rc/{print $2}' | xargs -r sudo dpkg -P

Pour info, les précisions de nany, pour la commande de nettoyage et une possibilité d'automatisation.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#15 Le 21/09/2021, à 20:31

cqfd93

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

C'est pas grave, au moins ton système est à jour et il n'y a plus de paquets cassés.

Tu peux faire un peu de nettoyage :

sudo apt-get clean
sudo apt-get autoremove
dpkg -l | grep ^rc | cut -d' ' -f3 | xargs sudo dpkg --purge

Est-ce que maintenant tu peux utiliser valgrind ?


cqfd93

Hors ligne

#16 Le 21/09/2021, à 21:04

Max_123

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Ok j'ai fais du nettoyage ça s'est bien passé.

Oui valgrind fonctionne désormais, j'ai pu installer le paquet libc6-dbg

Hors ligne

#17 Le 21/09/2021, à 22:13

cqfd93

Re : [Résolu]Impossible d'installer de nouveau paquet car Casse: libc6:i386

Donc tu peux marquer ton sujet comme résolu en modifiant le titre depuis le premier message.


cqfd93

Hors ligne